123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674 |
- %define enable_native_atlas 0
- %define disable_CPU_throttling_probe 1
- Name: atlas
- Version: 3.8.4
- %if "%{?enable_native_atlas}" != "0"
- %define dist .native
- %endif
- Release: 5%{?_dist_release}
- Summary: Automatically Tuned Linear Algebra Software
- Summary(ja): 自動的にCPUに最適化する線形代数ソフトウェア
- Group: System Environment/Libraries
- License: BSD
- URL: http://math-atlas.sourceforge.net/
- Source0: http://downloads.sourceforge.net/math-atlas/%{name}%{version}.tar.bz2
- Source1: PPRO32.tgz
- Source2: K7323DNow.tgz
- Source3: README.Fedora
- Source4: USII64.tgz
- Source5: USII32.tgz
- Patch0: atlas-fedora_shared.patch
- Patch1: atlas-fedora-arm.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- BuildRequires: gcc-gfortran lapack-static
- %description
- The ATLAS (Automatically Tuned Linear Algebra Software) project is an
- ongoing research effort focusing on applying empirical techniques in
- order to provide portable performance. At present, it provides C and
- Fortran77 interfaces to a portably efficient BLAS implementation, as
- well as a few routines from LAPACK.
- The performance improvements in ATLAS are obtained largely via
- compile-time optimizations and tend to be specific to a given hardware
- configuration. In order to package ATLAS for Fedora some compromises
- are necessary so that good performance can be obtained on a variety
- of hardware. This set of ATLAS binary packages is therefore not
- necessarily optimal for any specific hardware configuration. However,
- the source package can be used to compile customized ATLAS packages;
- see the documentation for information.
- %package devel
- Summary: Development libraries for ATLAS
- Summary(ja): ATLAS を使ったプログラム開発に必要なヘッダファイル/ライブラリ
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Obsoletes: %name-header <= %version-%release
- Requires(posttrans): chkconfig
- Requires(preun): chkconfig
- Requires(post): /sbin/alternatives
- Requires(postun): /sbin/alternatives
- %description devel
- This package contains the libraries and headers for development
- with ATLAS (Automatically Tuned Linear Algebra Software).
- %define types base
- %if "%{?enable_native_atlas}" == "0"
- ############## Subpackages for architecture extensions #################
- #
- %ifarch x86_64
- %define types base sse3
- %package sse3
- Summary: ATLAS libraries for SSE3 extensions
- Summary(ja): SSE3命令セット拡張に最適化した ATLASライブラリ
- Group: System Environment/Libraries
- %description sse3
- This package contains the ATLAS (Automatically Tuned Linear Algebra
- Software) libraries compiled with optimizations for the SSE3
- extensions to the x86_64 architecture. The base ATLAS builds in Fedora for the
- x86_64 architecture are made for the SSE2 extensions.
- %package sse3-devel
- Summary: Development libraries for ATLAS with SSE3 extensions
- Summary(ja): ATLAS を使ったプログラム開発に必要な SSE3命令セット拡張に最適化したヘッダファイル/ライブラリ
- Group: Development/Libraries
- Requires: %{name}-sse3 = %{version}-%{release}
- Obsoletes: %name-header <= %version-%release
- Requires(posttrans): chkconfig
- Requires(preun): chkconfig
- Requires(post): /sbin/alternatives
- Requires(postun): /sbin/alternatives
- %description sse3-devel
- This package contains shared and static versions of the ATLAS
- (Automatically Tuned Linear Algebra Software) libraries compiled with
- optimizations for the SSE3 extensions to the x86_64 architecture.
- %endif
- %ifarch %{ix86}
- %define types base 3dnow sse sse2 sse3
- %package 3dnow
- Summary: ATLAS libraries for 3DNow extensions
- Summary(ja): 3DNow命令セット拡張に最適化した ATLASライブラリ
- Group: System Environment/Libraries
- %description 3dnow
- This package contains the ATLAS (Automatically Tuned Linear Algebra
- Software) libraries compiled with optimizations for the 3DNow extension
- to the ix86 architecture. Fedora also produces ATLAS build with SSE, SSE2
- and SSE3 extensions.
- %package 3dnow-devel
- Summary: Development libraries for ATLAS with 3DNow extensions
- Summary(ja): ATLAS を使ったプログラム開発に必要な 3DNow命令セット拡張に最適化したヘッダファイル/ライブラリ
- Group: Development/Libraries
- Requires: %{name}-3dnow = %{version}-%{release}
- Obsoletes: %name-header <= %version-%release
- Requires(posttrans): chkconfig
- Requires(preun): chkconfig
- %description 3dnow-devel
- This package contains headers and shared versions of the ATLAS
- (Automatically Tuned Linear Algebra Software) libraries compiled with
- optimizations for the 3DNow extensions to the ix86 architecture.
- %package sse
- Summary: ATLAS libraries for SSE extensions
- Summary(ja): SSE命令セット拡張に最適化した ATLASライブラリ
- Group: System Environment/Libraries
- %description sse
- This package contains the ATLAS (Automatically Tuned Linear Algebra
- Software) libraries compiled with optimizations for the SSE(1) extensions
- to the ix86 architecture. Fedora also produces ATLAS build with SSE2 and SSE3
- extensions.
- %package sse-devel
- Summary: Development libraries for ATLAS with SSE extensions
- Summary(ja): ATLAS を使ったプログラム開発に必要な SSE命令セット拡張に最適化したヘッダファイル/ライブラリ
- Group: Development/Libraries
- Requires: %{name}-sse = %{version}-%{release}
- Obsoletes: %name-header <= %version-%release
- Requires(posttrans): chkconfig
- Requires(preun): chkconfig
- %description sse-devel
- This package contains headers and shared versions of the ATLAS
- (Automatically Tuned Linear Algebra Software) libraries compiled with
- optimizations for the SSE(1) extensions to the ix86 architecture.
- %package sse2
- Summary: ATLAS libraries for SSE2 extensions
- Summary(ja): SSE2命令セット拡張に最適化した ATLASライブラリ
- Group: System Environment/Libraries
- %description sse2
- This package contains ATLAS (Automatically Tuned Linear Algebra Software)
- shared libraries compiled with optimizations for the SSE2
- extensions to the ix86 architecture. Fedora also produces ATLAS build with
- SSE(1) and SSE3 extensions.
- %package sse2-devel
- Summary: Development libraries for ATLAS with SSE2 extensions
- Summary(ja): ATLAS を使ったプログラム開発に必要な SSE2命令セット拡張に最適化したヘッダファイル/ライブラリ
- Group: Development/Libraries
- Requires: %{name}-sse2 = %{version}-%{release}
- Obsoletes: %name-header <= %version-%release
- Requires(posttrans): chkconfig
- Requires(preun): chkconfig
- %description sse2-devel
- This package contains ATLAS (Automatically Tuned Linear Algebra Software)
- shared libraries compiled with optimizations for the SSE2 extensions to the
- ix86 architecture.
- %package sse3
- Summary: ATLAS libraries for SSE3 extensions
- Summary(ja): SSE3命令セット拡張に最適化した ATLASライブラリ
- Group: System Environment/Libraries
- %description sse3
- This package contains the ATLAS (Automatically Tuned Linear Algebra
- Software) libraries compiled with optimizations for the SSE3.
- Fedora also produces ATLAS build with SSE(1) and SSE2 extensions.
- %package sse3-devel
- Summary: Development libraries for ATLAS with SSE3 extensions
- Summary(ja): ATLAS を使ったプログラム開発に必要な SSE3命令セット拡張に最適化したヘッダファイル/ライブラリ
- Group: Development/Libraries
- Requires: %{name}-sse3 = %{version}-%{release}
- Obsoletes: %name-header <= %version-%release
- Requires(posttrans): chkconfig
- Requires(preun): chkconfig
- %description sse3-devel
- This package contains ATLAS (Automatically Tuned Linear Algebra Software)
- shared libraries compiled with optimizations for the SSE3 extensions to the ix86 architecture.
- %endif
- %endif
- %global mode %{__isa_bits}
- %ifarch %{arm}
- %define arch_option -A 38
- %define threads_option -t 2
- %global mode ' '
- %endif
- %prep
- %setup -q -n ATLAS
- %patch0 -p0 -b .shared
- %ifarch %{arm}
- %patch1 -p0 -b .arm
- %endif
- cp %{SOURCE1} CONFIG/ARCHS/
- cp %{SOURCE2} CONFIG/ARCHS/
- cp %{SOURCE3} doc
- cp %{SOURCE4} CONFIG/ARCHS/
- cp %{SOURCE5} CONFIG/ARCHS/
- %build
- for type in %{types}; do
- if [ "$type" = "base" ]; then
- libname=atlas
- %define pr_base %(echo $((%{__isa_bits}+0)))
- else
- libname=atlas-${type}
- fi
- mkdir -p %{_arch}_${type}
- pushd %{_arch}_${type}
- ../configure -b %{mode} %{?threads_option} %{?arch_option} -D c -DWALL -Fa alg '-g -Wa,--noexecstack -fPIC'\
- --prefix=%{buildroot}%{_prefix} \
- --incdir=%{buildroot}%{_includedir} \
- --libdir=%{buildroot}%{_libdir}/${libname} \
- --with-netlib-lapack=%{_libdir}/liblapack_pic.a \
- %if %{disable_CPU_throttling_probe}
- -Si cputhrchk 0
- %endif
- %if "%{?enable_native_atlas}" == "0"
- %ifarch x86_64
- if [ "$type" = "base" ]; then
- sed -i 's#ARCH =.*#ARCH = HAMMER64SSE2#' Make.inc
- sed -i 's#-DATL_SSE3##' Make.inc
- sed -i 's#-msse3#-msse2#' Make.inc
- elif [ "$type" = "sse3" ]; then
- sed -i 's#ARCH =.*#ARCH = HAMMER64SSE3#' Make.inc
- %define pr_sse3 %(echo $((%{__isa_bits}+4)))
- fi
- %endif
- %ifarch %{ix86}
- if [ "$type" = "base" ]; then
- sed -i 's#ARCH =.*#ARCH = PPRO32#' Make.inc
- sed -i 's#-DATL_SSE3 -DATL_SSE2 -DATL_SSE1##' Make.inc
- sed -i 's#-mfpmath=sse -msse3#-mfpmath=387#' Make.inc
- elif [ "$type" = "3dnow" ]; then
- sed -i 's#ARCH =.*#ARCH = K7323DNow#' Make.inc
- sed -i 's#-DATL_SSE3 -DATL_SSE2 -DATL_SSE1##' Make.inc
- sed -i 's#-mfpmath=sse -msse3#-mfpmath=387#' Make.inc
- %define pr_3dnow %(echo $((%{__isa_bits}+1)))
- elif [ "$type" = "sse" ]; then
- sed -i 's#ARCH =.*#ARCH = PIII32SSE1#' Make.inc
- sed -i 's#-DATL_SSE3 -DATL_SSE2##' Make.inc
- sed -i 's#-msse3#-msse#' Make.inc
- %define pr_sse %(echo $((%{__isa_bits}+2)))
- elif [ "$type" = "sse2" ]; then
- sed -i 's#ARCH =.*#ARCH = P432SSE2#' Make.inc
- sed -i 's#-DATL_SSE3##' Make.inc
- sed -i 's#-msse3#-msse2#' Make.inc
- %define pr_sse2 %(echo $((%{__isa_bits}+3)))
- elif [ "$type" = "sse3" ]; then
- sed -i 's#ARCH =.*#ARCH = P4E32SSE3#' Make.inc
- %define pr_sse3 %(echo $((%{__isa_bits}+4)))
- fi
- %endif
- %endif
- make build
- cd lib
- make shared
- make ptshared
- popd
- done
- %install
- rm -rf %{buildroot}
- for type in %{types}; do
- pushd %{_arch}_${type}
- make DESTDIR=%{buildroot} install
- mv %{buildroot}%{_includedir}/atlas %{buildroot}%{_includedir}/atlas-%{_arch}-${type}
- if [ "$type" = "base" ]; then
- cp -pr lib/*.so* %{buildroot}%{_libdir}/atlas/
- rm -f %{buildroot}%{_libdir}/atlas/*.a
- else
- cp -pr lib/*.so* %{buildroot}%{_libdir}/atlas-${type}/
- rm -f %{buildroot}%{_libdir}/atlas-${type}/*.a
- fi
- popd
- mkdir -p %{buildroot}/etc/ld.so.conf.d
- if [ "$type" = "base" ]; then
- echo "%{_libdir}/atlas" \
- > %{buildroot}/etc/ld.so.conf.d/atlas-%{_arch}.conf
- else
- echo "%{_libdir}/atlas-${type}" \
- > %{buildroot}/etc/ld.so.conf.d/atlas-%{_arch}-${type}.conf
- fi
- done
- mkdir -p %{buildroot}%{_includedir}/atlas
- %clean
- rm -rf %{buildroot}
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %posttrans devel
- if [ $1 -eq 0 ] ; then
- /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
- %{_includedir}/atlas-%{_arch}-base %{pr_base}
- fi
- %preun devel
- if [ $1 -ge 0 ] ; then
- /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-base
- fi
- %if "%{?enable_native_atlas}" == "0"
- %ifarch x86_64
- %post -n atlas-sse3 -p /sbin/ldconfig
- %postun -n atlas-sse3 -p /sbin/ldconfig
- %posttrans sse3-devel
- if [ $1 -eq 0 ] ; then
- /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
- %{_includedir}/atlas-%{_arch}-sse3 %{pr_sse3}
- fi
- %preun sse3-devel
- if [ $1 -ge 0 ] ; then
- /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse3
- fi
- %endif
- %ifarch %{ix86}
- %post -n atlas-3dnow -p /sbin/ldconfig
- %postun -n atlas-3dnow -p /sbin/ldconfig
- %posttrans 3dnow-devel
- if [ $1 -eq 0 ] ; then
- /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
- %{_includedir}/atlas-%{_arch}-3dnow %{pr_3dnow}
- fi
- %preun 3dnow-devel
- if [ $1 -ge 0 ] ; then
- /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-3dnow
- fi
- %post -n atlas-sse -p /sbin/ldconfig
- %postun -n atlas-sse -p /sbin/ldconfig
- %posttrans sse-devel
- if [ $1 -eq 0 ] ; then
- /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
- %{_includedir}/atlas-%{_arch}-sse %{pr_sse}
- fi
- %preun sse-devel
- if [ $1 -ge 0 ] ; then
- /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse
- fi
- %post -n atlas-sse2 -p /sbin/ldconfig
- %postun -n atlas-sse2 -p /sbin/ldconfig
- %posttrans sse2-devel
- if [ $1 -eq 0 ] ; then
- /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
- %{_includedir}/atlas-%{_arch}-sse2 %{pr_sse2}
- fi
- %preun sse2-devel
- if [ $1 -ge 0 ] ; then
- /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse2
- fi
- %post -n atlas-sse3 -p /sbin/ldconfig
- %postun -n atlas-sse3 -p /sbin/ldconfig
- %posttrans sse3-devel
- if [ $1 -eq 0 ] ; then
- /sbin/alternatives --install %{_includedir}/atlas atlas-inc \
- %{_includedir}/atlas-%{_arch}-sse3 %{pr_sse3}
- fi
- %preun sse3-devel
- if [ $1 -ge 0 ] ; then
- /sbin/alternatives --remove atlas-inc %{_includedir}/atlas-%{_arch}-sse3
- fi
- %endif
- %endif
- %files
- %defattr(-,root,root,-)
- %doc doc/README.Fedora
- %dir %{_libdir}/atlas
- %{_libdir}/atlas/*.so.*
- %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}.conf
- %files devel
- %defattr(-,root,root,-)
- %doc doc
- %{_libdir}/atlas/*.so
- %{_includedir}/atlas-%{_arch}-base/
- %{_includedir}/*.h
- %ghost %{_includedir}/atlas
- %if "%{?enable_native_atlas}" == "0"
- %ifarch x86_64
- %files sse3
- %defattr(-,root,root,-)
- %doc doc/README.Fedora
- %dir %{_libdir}/atlas-sse3
- %{_libdir}/atlas-sse3/*.so.*
- %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse3.conf
- %files sse3-devel
- %defattr(-,root,root,-)
- %doc doc
- %{_libdir}/atlas-sse3/*.so
- %{_includedir}/atlas-%{_arch}-sse3/
- %{_includedir}/*.h
- %ghost %{_includedir}/atlas
- %endif
- %ifarch %{ix86}
- %files 3dnow
- %defattr(-,root,root,-)
- %doc doc/README.Fedora
- %dir %{_libdir}/atlas-3dnow
- %{_libdir}/atlas-3dnow/*.so.*
- %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-3dnow.conf
- %files 3dnow-devel
- %defattr(-,root,root,-)
- %doc doc
- %{_libdir}/atlas-3dnow/*.so
- %{_includedir}/atlas-%{_arch}-3dnow/
- %{_includedir}/*.h
- %ghost %{_includedir}/atlas
- %files sse
- %defattr(-,root,root,-)
- %doc doc/README.Fedora
- %dir %{_libdir}/atlas-sse
- %{_libdir}/atlas-sse/*.so.*
- %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse.conf
- %files sse-devel
- %defattr(-,root,root,-)
- %doc doc
- %{_libdir}/atlas-sse/*.so
- %{_includedir}/atlas-%{_arch}-sse/
- %{_includedir}/*.h
- %ghost %{_includedir}/atlas
- %files sse2
- %defattr(-,root,root,-)
- %doc doc/README.Fedora
- %dir %{_libdir}/atlas-sse2
- %{_libdir}/atlas-sse2/*.so.*
- %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse2.conf
- %files sse2-devel
- %defattr(-,root,root,-)
- %doc doc
- %{_libdir}/atlas-sse2/*.so
- %{_includedir}/atlas-%{_arch}-sse2/
- %{_includedir}/*.h
- %ghost %{_includedir}/atlas
- %files sse3
- %defattr(-,root,root,-)
- %doc doc/README.Fedora
- %dir %{_libdir}/atlas-sse3
- %{_libdir}/atlas-sse3/*.so.*
- %config(noreplace) /etc/ld.so.conf.d/atlas-%{_arch}-sse3.conf
- %files sse3-devel
- %defattr(-,root,root,-)
- %doc doc
- %{_libdir}/atlas-sse3/*.so
- %{_includedir}/atlas-%{_arch}-sse3/
- %{_includedir}/*.h
- %ghost %{_includedir}/atlas
- %endif
- %endif
- %changelog
- * Fri May 25 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.8.4-5
- - added Japanese Summary
- - turned off throttle checking
- * Thu Mar 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.8.4-4
- - initial build for Vine Linux
- * Thu Sep 01 2011 Deji Akingunola <dakingun@gmail.com> - 3.8.4-3
- - Apply patch to enable arm build (Patch provided by Jitesh Shah <jiteshs@marvell.com>)
- - Stop turning off throttle checking, upstream frown at it (seems O.K. for Koji)
- * Mon Jun 20 2011 Dan Horák <dan[at]danny.cz> - 3.8.4-2
- - Use -march=z10 for z196 optimised build because the builder is a z10
- (Christian Bornträger)
- * Tue Jun 14 2011 Deji Akingunola <dakingun@gmail.com> - 3.8.4-1
- - Update to 3.8.4
- - Build the default package for SSE2 and add a SSE3 subpackage on x86_64
- - Apply patch (and arch defs.) to build on s390 and s390x (Dan Horák)
- - Fix-up build on s390 and s390x (Christian Bornträger)
- * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Mon Jul 26 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-18
- - Create a subpackage for SSE2 on x86_64
- * Sat Jul 17 2010 Dan Horák <dan[at]danny.cz> - 3.8.3-17
- - rebuild against fixed lapack libraries
- * Thu Jul 15 2010 Dan Horák <dan[at]danny.cz> - 3.8.3-16
- - fix build on s390 (patch by Karsten Hopp)
- * Wed Feb 10 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-15
- - Disable the problematic sparc patch
- - Change lapack-devel BR to lapack-static, where liblapack_pic.a now resides.
- * Wed Feb 03 2010 Dennis Gilmore <dennis@ausil.us> - 3.8.3-14
- - fix sparc build
- * Fri Jan 29 2010 Deji Akingunola <dakingun@gmail.com> - 3.8.3-13
- - Remove static libraries.
- - Fix typo in SSE3 subpackage's summary.
- * Sat Oct 24 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-12
- - Use alternatives to workaround multilib conflicts (BZ#508565).
- * Tue Sep 29 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-11
- - Obsolete the -header subpackage properly.
- * Sat Sep 26 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-10
- - Use the new arch. default for Pentium PRO (Fedora bug #510498)
- - (Re-)Introduce 3dNow subpackage
- * Sun Sep 6 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 3.8.3-9
- - Rebuild against fixed lapack (see #520518)
- * Wed Aug 13 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-8
- - Revert the last change, it doesn't solve the problem.
- * Tue Aug 04 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-7
- - Create a -header subpackage to avoid multilib conflicts (BZ#508565).
- * Tue Aug 04 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-6
- - Add '-g' to build flag to allow proper genration of debuginfo subpackages (Fedora bug #509813)
- - Build for F12
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.3-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Sat May 02 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-4
- - Use the right -msse* option for the -sse* subpackages (Fedora bug #498715)
- * Tue Apr 21 2009 Karsten Hopp <karsten@redhat.com> 3.8.3-3.1
- - add s390x to 64 bit archs
- * Fri Feb 27 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-3
- - Rebuild
- * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Sun Feb 22 2009 Deji Akingunola <dakingun@gmail.com> - 3.8.3-1
- - Update to version 3.8.3
- * Sun Dec 21 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-5
- - Link in appropriate libs when creating shared libs, reported by Orcan 'oget' Ogetbil (BZ#475411)
- * Tue Dec 16 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-4
- - Don't symlink the atlas libdir on i386, cause upgrade issue (BZ#476787)
- - Fix options passed to gcc when making shared libs
- * Tue Dec 16 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-3
- - Use 'gcc -shared' to build shared libs instead of stock 'ld'
- * Sat Dec 13 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-2
- - Properly obsolete/provide older subpackages that are no longer packaged.
- * Mon Sep 01 2008 Deji Akingunola <dakingun@gmail.com> - 3.8.2-1
- - Upgrade to ver 3.8.2 with refined build procedures.
- * Thu Feb 28 2008 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-15
- - Disable altivec package--it is causing illegal instructions during build.
- * Thu Feb 28 2008 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-14
- - Enable compilation on alpha (bug 426086).
- - Patch for compilation on ia64 (bug 432744).
- * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.6.0-13
- - Autorebuild for GCC 4.3
- * Mon Jun 4 2007 Orion Poplawski <orion@cora.nwra.com> 3.6.0-12
- - Rebuild for ppc64
- * Fri Sep 8 2006 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-11
- - Rebuild for FC6.
- - Remove outdated comments from spec file.
- * Mon Feb 13 2006 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-10
- - Rebuild for Fedora Extras 5.
- - Add --noexecstack to compilation of assembly kernels. These were
- previously marked executable, which caused problems with selinux.
- * Mon Dec 19 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-9
- - Rebuild for gcc 4.1.
- * Mon Oct 10 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-8
- - Make all devel subpackages depend on their non-devel counterparts.
- - Add /etc/ld.so.conf.d files for -sse and -3dnow, because they don't
- seem to get picked up automatically.
- * Wed Oct 05 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-7
- - Forgot to add the new patch to sources.
- * Tue Oct 04 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-6
- - Use new Debian patch, and enable shared libs (they previously failed
- to build on gcc 4).
- - Minor updates to description and README.Fedora file.
- - Fix buildroot name to match FE preferred form.
- - Fixes for custom optimized builds.
- - Add dist tag.
- * Wed Sep 28 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-5
- - fix files lists.
- * Mon Sep 26 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-4
- - generate library symlinks earlier for the benefit of later linking steps.
- * Wed Sep 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-3
- - Change lapack dependency to lapack-devel, and use lapack_pic.a for
- building liblapack.so.
- * Wed Sep 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-2
- - Add "bit" macro to correctly build on x86_64.
- * Tue Aug 16 2005 Quentin Spencer <qspencer@users.sourceforge.net> 3.6.0-1
- - Initial version.
|