gnumeric-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431
  1. %define gnumeric_version %{version}-bonobo
  2. %define goffice_version 0.10.2
  3. Summary: A spreadsheet program for GNOME.
  4. Summary(ja): GNOME スプレッドシート
  5. Name: gnumeric
  6. Version: 1.12.2
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Productivity
  10. URL: http://www.gnome.org/projects/gnumeric
  11. Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.12/%{name}-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. # default font: VL Gothic
  14. Patch0: gnumeric-1.11.5-vlgothic.patch
  15. Distribution: Vine Linux
  16. Vendor: Project Vine
  17. BuildRequires: bison
  18. BuildRequires: flex
  19. BuildRequires: goffice-devel >= %{goffice_version}
  20. BuildRequires: pygobject3-devel
  21. BuildRequires: perl python-devel
  22. BuildRequires: automake
  23. BuildRequires: gnome-doc-utils
  24. BuildRequires: desktop-file-utils
  25. Requires(postun,posttrans): glib2
  26. Requires(post,postun): desktop-file-utils
  27. Obsoletes: %{name}-devel
  28. %description
  29. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  30. applications and desktop tools to be used in conjunction with a window
  31. manager for the X Window System.
  32. This is the Gnumeric, a spreadsheet for GNOME. It aims to be a drop in
  33. replacement for commercial spreadsheets. It provides import/export from
  34. MS Excel files and many other formats (csv, latex, xbase, applix).
  35. %description -l ja
  36. GNOME (GNU Network Object Model Environment)は
  37. Xウィンドウシステム用の、ウィンドウマネージャと連結した
  38. GUIアプリケーションおよびデスクトップツールのセットです。
  39. これは Gnumeric, GNOMEスプレッドシート・プログラムです。
  40. 商用のスプレッドシート・プログラムを代替できるものを目指しています。
  41. MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
  42. を読込み、出力できます.
  43. %prep
  44. %setup -q
  45. %patch0 -p1 -b .vlgothic
  46. %build
  47. %ifarch alpha
  48. MYARCH_FLAGS="--host=alpha-redhat-linux"
  49. %endif
  50. %configure \
  51. --without-gda \
  52. --with-perl \
  53. --with-python
  54. make
  55. %install
  56. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  57. make DESTDIR=$RPM_BUILD_ROOT install
  58. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
  59. desktop-file-install --vendor gnome --delete-original \
  60. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  61. --add-category Office \
  62. --add-category Application \
  63. --add-category Spreadsheet \
  64. --remove-mime-type="zz-application/zz-winassoc-xls" \
  65. $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  66. %find_lang %{name}-%{version}
  67. %find_lang %{name}-%{version}-functions
  68. cat %{name}-%{version}-functions.lang >> %{name}-%{version}.lang
  69. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  70. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  71. rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
  72. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  73. %clean
  74. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  75. %post
  76. /sbin/ldconfig
  77. scrollkeeper-update > /dev/null 2>&1 || :
  78. touch --no-create %{_datadir}/icons/hicolor || :
  79. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  80. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  81. fi
  82. update-desktop-database -q &> /dev/null || :
  83. %postun
  84. /sbin/ldconfig
  85. scrollkeeper-update > /dev/null 2>&1 || :
  86. touch --no-create %{_datadir}/icons/hicolor || :
  87. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  88. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  89. fi
  90. update-desktop-database -q &> /dev/null || :
  91. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  92. %posttrans
  93. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  94. %files -f %{name}-%{version}.lang
  95. %defattr (-, root, root)
  96. %doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
  97. %{_bindir}/*
  98. %{_libdir}/libspreadsheet*.so
  99. %{_libdir}/%{name}
  100. %{_libdir}/goffice/0.10/plugins/%{name}
  101. %{_datadir}/applications/*.desktop
  102. %{_datadir}/glib-2.0/schemas/*.xml
  103. %{_datadir}/gnome/help/%{name}
  104. %{_datadir}/%{name}
  105. %{_datadir}/pixmaps/*
  106. %{_datadir}/omf/*
  107. %{_datadir}/icons/hicolor/*
  108. %{_mandir}/man*/*
  109. %exclude %{_datadir}/pixmaps/win32-gnumeric.ico
  110. %changelog
  111. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  112. - new upstream release
  113. * Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
  114. - new upstream release
  115. * Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  116. - new upstream release
  117. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.11.5-1
  118. - new upstream release
  119. - add Patch0 (gnumeric-1.11.5-vlgothic.patch)
  120. - remove Patch1 (gnumeric-1.10.17-libgsf.patch)
  121. * Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-2
  122. - rebuild with libgsf-1.14.22
  123. - add Patch1 (gnumeric-1.10.17-libgsf.patch)
  124. * Wed Aug 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.17-1
  125. - new upstream release
  126. - update Patch0
  127. * Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.14-1
  128. - new upstream release
  129. * Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
  130. - new upstream release
  131. - add Patch0 (gnumeric-1.10.13-vlgothic.patch)
  132. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
  133. - new upstream release
  134. * Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
  135. - new upstream release
  136. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
  137. - new upstream release
  138. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
  139. - new upstream release
  140. - add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
  141. (fix error of MIME type)
  142. * Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  143. - new upstream release
  144. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
  145. - new upstream release
  146. * Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  147. - new upstream release
  148. - fix %post and %postun
  149. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  150. - new upstream release
  151. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  152. - new upstream release
  153. - add BuildRequires: libSM-devel
  154. - fix BuildRequires: goffice-devel >= 0.8.1
  155. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
  156. - spec in UTF-8 (fixed)
  157. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
  158. - spec in UTF-8
  159. - added BuildRequires: libffi-devel
  160. - added %%pre, %%preun section
  161. * Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
  162. - new upstream release
  163. - built with libgda-3.1.4, libgnomedb-3.1.2
  164. - applied new versioning policy
  165. * Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  166. - new upstream release
  167. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
  168. - rebuild
  169. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
  170. - new upstream release
  171. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
  172. - new upstream release
  173. - updated build dependancies
  174. - rebuilt with libgsf-1.14.0
  175. - built with libgda and libgnomedb again
  176. * Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
  177. - new upstream release
  178. - updated build dependancies
  179. - not compile with libgda and libgnomedb in this version
  180. * Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
  181. - new upstream release
  182. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
  183. - rebuild with libgda 1.2.0 and libgnome 1.2.0
  184. * Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
  185. - new upstream release
  186. * Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
  187. - new upstream release
  188. * Thu Dec 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
  189. - new upstream release
  190. * Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
  191. - rebuild with gnome-2.8 environment and libgsf-1.10.1
  192. * Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
  193. - new upstream release
  194. - added BuildRequires: desktop-file-utils
  195. * Thu May 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
  196. - new upstream release
  197. - Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
  198. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  199. - new upstream release
  200. * Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
  201. - new upstream release
  202. * Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  203. - new upstream release
  204. * Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  205. - new upstream release
  206. * Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  207. - new upstream release
  208. - clean up spec file (a little bit!)
  209. * Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  210. - new upstream release
  211. * Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
  212. - new upstream release
  213. - to use intltool-0.28
  214. * Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
  215. - new upstream release
  216. - rebuild with new toolchains
  217. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
  218. - new upstream release
  219. - build with new libgnomeprint, libgnomeprintui
  220. * Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  221. - new upstream release
  222. * Thu Oct 2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
  223. - rebuild with newer libgda, libgnomedb
  224. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  225. - updated to 1.2.0 (stable release)
  226. - guile support is temporarily off this version.
  227. * Tue Sep 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
  228. - update to 1.1.20 (gtk+-2 port)
  229. - based on Redhat Rawhide 1.1.20-1
  230. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
  231. - update to 1.0.13
  232. - rebuild with gal 0.24
  233. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
  234. - guile support on
  235. - rebuild with new gal, bonobo, libgda
  236. * Fri Feb 7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
  237. - New upstream release, remove xmliobackward.patch
  238. * Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
  239. - xml-io back to 1.0.10 because japanese corrups with new xml_parser
  240. * Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
  241. - New upstream release, fix for xml importing files with non ASCII characters.
  242. - Without guile, changelog.archive, requires, build scripts, description
  243. * Tue Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
  244. - files: add gnumericConf.sh, which was missing
  245. * Mon Nov 4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
  246. - New upstream release.
  247. - BuildPrereq oaf-devel
  248. * Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
  249. - New upstream release.
  250. * Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
  251. - New upstream release.
  252. - Default font and Japanese fonts in excel
  253. - requires
  254. * Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
  255. - New upstream release.
  256. - fixed plugins, apply patch2, remove patch3
  257. - files - no longer devel package
  258. - function-reference.html in help file
  259. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  260. - New upstream release.
  261. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
  262. - New upstream release.
  263. - Fixed several owner dir.
  264. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  265. - Build against with new gal
  266. * Mon Jan 7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  267. - New upstream release.
  268. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  269. - New upstream release.
  270. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
  271. - New upstream release.
  272. - Applied XIM over-the-spot patch.
  273. - Fixed directories owner.
  274. * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
  275. - New upstream release.
  276. - Enable Bonobo.
  277. - Merged several RH patches.
  278. - Added BuildPreReq tags.
  279. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
  280. - Fixed packaging mistake.
  281. * Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
  282. - Rebuild for GAL 0.7
  283. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
  284. - New upstream release.
  285. - Use rpmmacros.
  286. * Mon Feb 5 2001 Jun Nishii <jun@vinelinux.org>
  287. - 0.56-0vl2
  288. - update ja.po
  289. - avoid core dump when inserting a row
  290. * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  291. - updated to 0.56
  292. - remake spec with the orginal gnumeric spec file.
  293. - added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
  294. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  295. - updated to 0.53
  296. - remake SPEC based on gnumeric original.
  297. - added libxml183 patch for libxml 1.8.3
  298. * Wed Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
  299. - Removed gnome-gnumeric-xl.png since it is nowhere to be found.
  300. - Added --without-bonobo and --without-gb.
  301. - Added %define for sysconfdir
  302. * Tue Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
  303. - Updated version requirements for gnome-print, and gnome-libs.
  304. * Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
  305. - Added in some auto-detect the language files logic (rpm 3.0.xx only)
  306. * Wed Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
  307. - Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
  308. * Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
  309. - Updated to 0.47
  310. * Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
  311. - Updated the libglade dependancy.
  312. - Remove req for guile. We can build without it.
  313. * Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
  314. - Added small fix so glade generated dialogs appear.
  315. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  316. - Added the gnome-print requirement.
  317. - Updated the file list to try and quiet down the updating.
  318. - added the sysconfdir
  319. * Tue Mar 9 1999 Gregory McLean <gregm@comstar.net>
  320. - Updated the spec file.
  321. * Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
  322. - Version 0.2