123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372 |
- %define buildinfo yes
- %define name lilypond
- %define iconsdir /usr/share/pixmaps
- %define infodir %{_infodir}/%{name}
- %define fontdir %{_datadir}/fonts/%{name}
- Summary: A typesetting system for music notation
- Summary(ja): 楽譜作成プログラム
- Group: Applications/Publishing
- Name: %{name}
- Version: 2.18.2
- Release: 2%{?_dist_release}
- License: GPLv3
- URL: http://www.lilypond.org/
- Source0: http://download.linuxaudio.org/lilypond/sources/v2.12/%{name}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- ## from fc11
- Patch12: lilypond-2.21.2-gcc44-relocate.patch
- BuildRequires: t1utils ImageMagick-devel gettext texlive-common
- BuildRequires: gcc-c++
- BuildRequires: bison flex m4
- BuildRequires: python-devel >= 2.4.0
- BuildRequires: mftrace >= 1.1.19
- BuildRequires: texinfo >= 4.8
- BuildRequires: texi2html
- %if %{?_dist_release} == "vl6"
- BuildRequires: guile-devel >= 1.8
- %endif
- %if %{?_dist_release} >= "vl7"
- BuildRequires: guile18-devel >= 1.8
- %endif
- BuildRequires: ghostscript >= 8.15
- BuildRequires: pango-devel >= 1.12.0
- BuildRequires: rsync
- BuildRequires: texlive-collection-metapost
- %if %{?_dist_release} == "vl6"
- BuildRequires: texlive-collection-genericrecommended
- %endif
- %if %{?_dist_release} >= "vl7"
- BuildRequires: texlive-collection-plaingeneric
- %endif
- BuildRequires: dblatex
- BuildRequires: potrace >= 1.3
- BuildRequires: netpbm-progs
- BuildRequires: which
- BuildRequires: glibc-devel groff
- BuildRequires: fontforge
- %description
- LilyPond is a music typesetter. It produces beautiful sheet music using a
- high level description file as input. Lilypond is part of the GNU project.
- LilyPond is split into two packages. The package "lilypond" provides the
- core package, containing the utilities for converting the music source
- (.ly) files into printable output. The package "lilypond-documentation"
- provides the full documentation, example .ly files for various features and
- the Mutopia project files (musical equivalent of the Gutenberg project - see
- http://www.mutopiaproject.org for details).
- If you are new to lilypond, you will almost certainly want to install the
- "lilypond-documentation" package in addition to the "lilypond" package.
- %description -l ja
- LilyPond は GNU プロジェクトで開発されている楽譜作成ソフトです。高解像度の
- とてもきれいな楽譜を作ることができます。
- LiLyPond は2つのパッケージにわかれています。"lilypond"パッケージがメインパッ
- ケージで、楽譜ソースファイル(.ly)を印刷可能な形式に変換するプログラムが入っ
- てます。tex, html等に簡単に楽譜を挿入するための lilypond-book コマンドもあり
- ます。(Vine用パッケージでは、platexでの利用も可能に変更してあります。)
- "lilypond-documentation" にはマニュアルやいろいろなサンプルファイル(.ly)、
- Mutopiaプロジェクトによるいつくかのファイルが入ってます。Mutopia プロジェクト
- (musical equivalent of the Gutenberg project)については
- http://www.mutopiaproject.orgを見てください。
- %package -n liblilypond
- Summary: Lilypond libraries
- Summary(ja): Lilypond ライブラリ
- Group: System Environment/Libraries
- Requires: lilypond >= %{version}
- %description -n liblilypond
- Lilypond libs
- %package documentation
- Summary: LilyPond documentation, examples and Mutopia files.
- Summary(ja): LilyPond のマニュアル, サンプル,Mutopiaファイル
- Group: Applications/Documentation
- Requires: %{name}
- %description documentation
- The documentation of LilyPond, both in HTML and PostScript, along with
- example input files and the files from the Mutopia project.
- %description documentation -l ja
- LiLyPond のマニュアルです.HTML ,PostScript, PDF の形式のものがあります.
- サンプルや Mutopiaプロジェクトによるファイルも入ってます.
- %prep
- rm -rf $RPM_BUILD_ROOT
- %setup -q
- # from fc11
- %patch12 -p0
- %build
- %if %{?_dist_release} >= "vl7"
- sed -i "s|guile-config|guile-config-1.8|g" aclocal.m4
- %endif
- autoconf
- %configure \
- --without-kpathsea \
- --disable-checking \
- --with-ncsb-dir=%{_datadir}/fonts/default/Type1
- %{__make}
- %install
- %{__rm} -rf %{buildroot}
- make install DESTDIR=$RPM_BUILD_ROOT package_infodir=%{_infodir} vimdir=%{_datadir}/vim/vim74
- chmod +x $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/python/midi.so
- # Symlink lilypond-init.el in emacs' site-start.d directory
- pushd $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
- mkdir site-start.d
- ln -s ../lilypond-init.el site-start.d
- popd
- # Change encoding to UTF8
- pushd $RPM_BUILD_ROOT%{_infodir}
- iconv -f iso-8859-1 -t utf-8 music-glossary.info > music-glossary.info.utf8
- mv music-glossary.info.utf8 music-glossary.info
- sed -e s,lilypond/,, -i *.info
- popd
- rm -f $RPM_BUILD_ROOT%{_infodir}/dir
- %find_lang %{name}
- mkdir -p $RPM_BUILD_ROOT%{fontdir}
- mv $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf/*.otf $RPM_BUILD_ROOT%{fontdir}
- rmdir $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
- ln -s %{fontdir} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/otf
- %clean
- %{__rm} -rf %{buildroot}
- %files -f %{name}.lang
- %defattr(-, root, root)
- %doc AUTHORS.txt COPYING DEDICATION INSTALL.txt NEWS.txt README.txt
- %doc ROADMAP
- %{_datadir}/emacs/site-lisp/site-start.d/%{name}-init.el
- %{_datadir}/emacs/site-lisp/lilypond*
- %{_datadir}/fonts/%{name}/
- %{_bindir}/*
- %{_infodir}/*
- %{_mandir}/man1/*
- %{_datadir}/%{name}/%{version}/
- %{_datadir}/vim/vim*
- %files -n liblilypond
- %defattr(-,root,root)
- %{_libdir}/%{name}/%{version}/python/*.so
- %files documentation
- %defattr(-, root, root)
- %{_docdir}/*
- %changelog
- * Wed Oct 11 2017 Toshiaki Ara <ara_t@384.jp> 2.18.2-2
- - rebuild for Vine6
- - revert BuildRequires: guile-devel instead of guile18-devel for Vine6
- - skip 'sed -i "s|guile-config|guile-config-1.8|g" aclocal.m4' for Vine6
- - change BuildRequires: texlive-collection-plaingeneric
- instead of texlive-collection-genericrecommended for VineSeed
- - change License: GPLv3
- - define %%{_fontdir}
- * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.2-1
- - update to 2.18.2
- - change BuildRequires: texlive-common instead of tetex
- - change BuildRequires: guile18-devel instead of guile-devel
- - remove Patch0,10,13
- - add BuildRequires: texlive-collection-metapost, texlive-collection-genericrecommended, rsync, dblatex, texi2html
- * Thu Apr 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.12.3-1
- - updated LilyPond to 2.12.3
- - applied new versioning policy, spec in utf-8
- - dropt Patch0: lilypond-platex-2.4.5.patch
- - imported patch from fc11
- Patch10: lilypond-2.11.65-python26.patch
- Patch12: lilypond-2.21.2-gcc44-relocate.patch
- Patch13: lilypond-consts.patch
- - replaced build, install, pre/post scripts (from fc11)
- * Sun Jul 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl2
- - rebuilt for VineSeed
- * Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 2.4.5-0vl1
- - build on Vine 3.1
- * Wed Mar 24 2004 Jun Nishii <jun@vinelinux.org> 2.0.3-0vl1
- - build for Vine Linux
- - many fixes in post/postun scripts
- * Fri Mar 12 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.30-1thac
- - Updated to latest devel release
- * Wed Mar 10 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.29-1thac
- - Updated to latest devel release
- * Wed Feb 25 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.27-1thac
- - Updated to latest devel release
- * Thu Feb 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.25-1thac
- - Updated to latest devel release
- * Tue Feb 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.24-1thac
- - Updated to latest devel release
- * Fri Feb 13 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.21-1thac
- - Updated to latest devel release
- - Built against latest pfaedit-040211 and mftrace-1.0.27
- - Added requirement for potrace
- * Mon Feb 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.20-1thac
- - Updated to latest devel release
- * Tue Jan 27 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.15-1thac
- - Updated to latest devel release
- * Sat Jan 24 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.14-1thac
- - Updated to latest devel release
- * Mon Jan 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.12-1thac
- - Updated to latest devel release
- * Sun Jan 18 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.11-1thac
- - Updated to latest devel release
- * Sat Jan 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.10-1thac
- - Updated to latest devel release
- * Thu Jan 15 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.9-1thac
- - Updated to latest devel release
- * Fri Jan 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.8-1thac
- - Updated to latest devel release
- * Tue Jan 06 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.7-1thac
- - Updated to latest devel release
- * Mon Jan 05 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.6-1thac
- - Updated to latest devel release
- * Fri Jan 02 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.4-1thac
- - Updated to latest devel release
- * Sun Dec 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.3-1thac
- - Updated to latest devel release
- * Sun Dec 21 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.2-1thac
- - Updated to latest devel release
- * Wed Dec 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.1-1thac
- - Updated to latest devel release
- * Thu Oct 30 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-2thac
- - Rebuilt for Mandrake 9.2
- * Fri Oct 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-1thac
- - Updated to latest devel release
- * Mon Oct 06 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.1-1thac
- - Updated to latest devel release
- * Thu Sep 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.0-1thac
- - Updated to latest devel release
- - removed lilypond-words
- * Tue Sep 23 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.9-1thac
- - Updated to latest devel release
- - fixed lilypond.word install
- * Wed Sep 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.6-1thac
- - Updated to latest devel release
- * Thu Sep 11 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.5-1thac
- - Updated to latest devel release
- - Built against pyton2.3
- * Mon Sep 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.4-1thac
- - Updated to latest devel release
- * Sun Aug 31 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.3-1thac
- - Updated to latest devel release
- * Thu Aug 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.2-1thac
- - Updated to latest devel release
- * Wed Aug 27 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.1-1thac
- - Updated to latest devel release
- - Changed naming to differ from Mandrake cooker
- * Mon Aug 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-3mdk
- - Fixed documentation path
- - Added some of Heikki Johannes Junes suggestions
- * Sun Aug 24 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-2mdk
- - Added Heikki Johannes Junes fix for confilcting PHP variable
- out=/dev/vc/ by adding unset out before compiling
- - Compiled with recent guile = 1.6.4 and mftrace = 1.0.17
- - Changed icon to lilypond.png
- - Added menu and icons again
- * Sat Aug 23 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.8.1-1mdk
- - removed menu and icons, sync with redhat-spec
- * Thu Jun 12 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.23-1mdk
- - refreshed dependencies and file list.
- * Sat Feb 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.7.12-1mdk
- - Built for Mandrake 9.1
- * Sun Dec 01 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.9-1mdk
- - set menu-items to lilypond-info and lilypond-documentation.
- * Sat Nov 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.8-4mdk
- - add pre/post-dependencies and menus with icon from source.
- * Mon Oct 28 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.4-1mdk
- - info, commented menu
- * Fri Aug 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.6.0-1mdk
- - Adapted from lilypond.redhat.skel and skeleton found in Mandrake's RPM-docs.
- - TODO: info (?) and dependencies.
- * Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
- - updated by Michael Brown <mbrown@linux-mandrake.com> :
- - Upgraded to 1.4.2
- - Changed URL
- - Removed /etc/profile.d scripts: all TeX bits are now located properly
- - Rearranged documentation
- - Tidied spec file
- - Updated README.first
- * Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
- - added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
- - Removed info files completely (couldn't get info reader to read them)
- - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
- * Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
- - Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
- - Added mktexlsr to post-install and post-uninstall scripts
- - Patched scripts in /etc/profile.d to reflect changes to font locations
- - Added QuickStart guide and Points to note sections to README.first (well worth reading)
- - Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
- * Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
- - First Mandrake package
- - spec file heavily adapted from PowerPC contribs.
- - Note HTML documentation may contain duff links and may be incomplete. Lots of warnings appear when building HTML docs.
- - PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
- - Created README.first file
|