perl-SUPER-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126
  1. Name: perl-SUPER
  2. Version: 1.17
  3. Release: 1%{?_dist_release}
  4. Summary: Sane superclass method dispatcher
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/SUPER/
  8. Source0: http://search.cpan.org/CPAN/authors/id/C/CH/CHROMATIC/SUPER-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
  10. BuildArch: noarch
  11. BuildRequires: perl(Carp)
  12. BuildRequires: perl(Exporter)
  13. BuildRequires: perl(Module::Build)
  14. BuildRequires: perl(Scalar::Util) >= 1.20
  15. BuildRequires: perl(Sub::Identify) >= 0.03
  16. BuildRequires: perl(Test::Simple) >= 0.61
  17. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  18. Requires: perl(Scalar::Util) >= 1.20
  19. Requires: perl(Sub::Identify) >= 0.03
  20. # Filter out bogus provides (rpm 4.9 onwards)
  21. %global __provides_exclude ^perl\\((DB|UNIVERSAL)\\)
  22. %description
  23. When subclassing a class, you occasionally want to dispatch control to the
  24. superclass - at least conditionally and temporarily. This module provides
  25. an easier, cleaner way for class methods to access their ancestor's
  26. implementation.
  27. %prep
  28. %setup -q -n SUPER-%{version}
  29. # Filter out bogus provides (prior to rpm 4.9)
  30. %global provfilt /bin/sh -c "%{__perl_provides} | grep -Evx 'perl[(](DB|UNIVERSAL)[)]'"
  31. %define __perl_provides %{provfilt}
  32. %build
  33. perl Build.PL installdirs=vendor
  34. ./Build
  35. %install
  36. rm -rf %{buildroot}
  37. ./Build install destdir=%{buildroot} create_packlist=0
  38. %{_fixperms} %{buildroot}
  39. %check
  40. ./Build test
  41. %clean
  42. rm -rf %{buildroot}
  43. %files
  44. %doc Changes README
  45. %{perl_vendorlib}/SUPER.pm
  46. %{_mandir}/man3/SUPER.3pm*
  47. %changelog
  48. * Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
  49. - initial build for Vine Linux
  50. * Tue Mar 6 2012 Paul Howarth <paul@city-fan.org> - 1.17-7
  51. - Add provides filters that work with all supported distributions
  52. - BR: perl(Carp) and perl(Exporter)
  53. - Make %%files list more explicit
  54. - Drop explicit requires of perl(Exporter) since it's auto-detected by rpm
  55. 4.9 onwards, and is bundled with perl on all older distributions
  56. - Don't need to remove empty directories from buildroot
  57. - Don't use macros for commands
  58. - %%defattr redundant since rpm 4.4
  59. - Use tabs
  60. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-6
  61. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  62. * Sun Jun 19 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.17-5
  63. - Perl mass rebuild
  64. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-4
  65. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  66. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.17-3
  67. - Rebuild to fix problems with vendorarch/lib (#661697)
  68. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.17-2
  69. - Mass rebuild with perl-5.12.0
  70. * Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> - 1.17-1
  71. - Update filtering
  72. - Auto-update to 1.17 (by cpan-spec-update 0.01)
  73. - Added a new br on perl(Scalar::Util) (version 1.20)
  74. - Altered br on perl(Sub::Identify) (0 => 0.03)
  75. - Altered br on perl(Test::Simple) (0 => 0.61)
  76. - Added a new req on perl(Scalar::Util) (version 1.20)
  77. - Added a new req on perl(Sub::Identify) (version 0.03)
  78. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-5
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  80. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-4
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  82. * Tue Mar 04 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.16-3
  83. - Rebuild for new perl
  84. * Wed Jan 02 2008 Ralf Corsépius <rc040203@freenet.de> - 1.16-2
  85. - Adjust License-tag
  86. - BR: perl(Test::Simple) (BZ 419631)
  87. * Wed Apr 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 1.16-1
  88. - Update to 1.16
  89. * Tue Oct 03 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.15-1
  90. - Update to 1.15
  91. - Add explict requires on perl(Exporter); missed due to a use base construct
  92. * Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-4
  93. - Bump
  94. * Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-3
  95. - Update %%description and %%summary
  96. * Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-2
  97. - Filter errant perl(DB) provide
  98. * Tue Sep 05 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-1
  99. - Specfile autogenerated by cpanspec 1.69.1