perl-Path-Class-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. Name: perl-Path-Class
  2. Version: 0.25
  3. Release: 1%{?_dist_release}
  4. Summary: Cross-platform path specification manipulation
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Path-Class/
  8. Source0: http://search.cpan.org/CPAN/authors/id/K/KW/KWILLIAMS/Path-Class-%{version}.tar.gz
  9. Patch0: Path-Class-0.25-old-M::B.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
  11. BuildArch: noarch
  12. BuildRequires: perl(base)
  13. BuildRequires: perl(Carp)
  14. BuildRequires: perl(Cwd)
  15. BuildRequires: perl(Exporter)
  16. BuildRequires: perl(File::Path)
  17. BuildRequires: perl(File::Spec) >= 0.87
  18. BuildRequires: perl(File::stat)
  19. BuildRequires: perl(File::Temp)
  20. BuildRequires: perl(IO::Dir)
  21. BuildRequires: perl(IO::File)
  22. BuildRequires: perl(Module::Build)
  23. BuildRequires: perl(strict)
  24. BuildRequires: perl(Test::More)
  25. # We need Perl::Perl::Critic ≥ 1.080 for a fix to
  26. # Variables::ProhibitConditionalDeclarations, and the EPEL-5 version is too old
  27. %if "%{?rhel}" != "4" && "%{?rhel}" != "5"
  28. BuildRequires: perl(Test::Perl::Critic)
  29. %endif
  30. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  31. %description
  32. Path::Class is a module for manipulation of file and directory specifications
  33. (strings describing their locations, like '/home/ken/foo.txt' or
  34. 'C:\Windows\Foo.txt') in a cross-platform manner. It supports pretty much every
  35. platform Perl runs on, including Unix, Windows, Mac, VMS, Epoc, Cygwin, OS/2,
  36. and NetWare.
  37. %prep
  38. %setup -q -n Path-Class-%{version}
  39. # Don't really need Module::Build ≥ 0.3601
  40. %patch0 -p1
  41. %build
  42. perl Build.PL installdirs=vendor
  43. ./Build
  44. %install
  45. rm -rf %{buildroot}
  46. ./Build install destdir=%{buildroot} create_packlist=0
  47. %{_fixperms} %{buildroot}
  48. %check
  49. AUTHOR_TESTING=1 ./Build test
  50. %clean
  51. rm -rf %{buildroot}
  52. %files
  53. %defattr(-,root,root,-)
  54. %doc Changes README
  55. %{perl_vendorlib}/Path/
  56. %{_mandir}/man3/Path::Class.3pm*
  57. %{_mandir}/man3/Path::Class::Dir.3pm*
  58. %{_mandir}/man3/Path::Class::Entity.3pm*
  59. %{_mandir}/man3/Path::Class::File.3pm*
  60. %changelog
  61. * Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.25-1
  62. - initial build for Vine Linux
  63. * Thu Feb 16 2012 Paul Howarth <paul@city-fan.org> - 0.25-1
  64. - Update to 0.25:
  65. - resolve() now croak()s instead of die()s on non-existent file
  66. - Added a traverse() method for directories, based on the fmap_cont() method
  67. of Forest::Tree::Pure; it's an alternative to ->recurse, which allows for
  68. more control over how the recursion happens
  69. - Fixed a grammar error in the docs
  70. - Added a tempfile() method for Dir objects, which provides an interface to
  71. File::Temp (CPAN RT#60485)
  72. - Fixed a non-helpful fatal error message when calling resolve() on a path
  73. that doesn't exist; now dies with the proper "No such file or directory"
  74. message and exit status
  75. - BR: perl(Test::Perl::Critic) and run author tests where possible
  76. - Add patch to support building with Module::Build < 0.3601
  77. * Thu Feb 16 2012 Paul Howarth <paul@city-fan.org> - 0.23-4
  78. - Spec clean-up:
  79. - Add buildreqs for Perl core modules that might be dual-lived
  80. - Tidy %%description
  81. - Make %%files list more explicit
  82. - Don't use macros for commands
  83. - Use search.cpan.org source URL
  84. - BR: at least version 0.87 of File::Spec
  85. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.23-3
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  87. * Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.23-2
  88. - Perl mass rebuild
  89. * Thu Apr 14 2011 Ian Burrell <ianburrell@gmail.com> - 0.23-1
  90. - Update to 0.23
  91. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18-4
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  93. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.18-3
  94. - Rebuild to fix problems with vendorarch/lib (#661697)
  95. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.18-2
  96. - Mass rebuild with perl-5.12.0
  97. * Mon Feb 22 2010 Chris Weyl <cweyl@alumni.drew.edu> - 0.18-1
  98. - Update to 0.18 (for latest DBIx::Class)
  99. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.16-6
  100. - Rebuild against perl 5.10.1
  101. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16-5
  102. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  103. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16-4
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  105. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-3
  106. - Rebuild for new perl
  107. * Thu Aug 16 2007 Ian Burrell <ianburrell@gmail.com> - 0.16-2
  108. - Fix BuildRequires
  109. * Mon Jan 29 2007 Ian Burrell <ianburrell@gmail.com> - 0.16-1
  110. - Specfile autogenerated by cpanspec 1.69.1