perl-Class-Autouse-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149
  1. Name: perl-Class-Autouse
  2. Version: 2.01
  3. Release: 1%{?_dist_release}
  4. Summary: Run-time class loading on first method call
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Class-Autouse/
  8. Source0: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Class-Autouse-%{version}.tar.gz
  9. # Upstream does its very best to prevent us from running them.
  10. %bcond_with xt_tests
  11. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  12. BuildArch: noarch
  13. BuildRequires: perl(Carp)
  14. BuildRequires: perl(File::Spec) >= 0.80
  15. BuildRequires: perl(File::Temp) >= 0.17
  16. BuildRequires: perl(prefork)
  17. BuildRequires: perl(List::Util) >= 1.18
  18. BuildRequires: perl(Test::More) >= 0.47
  19. # for xt tests
  20. %if %{with xt_tests}
  21. BuildRequires: perl(Perl::MinimumVersion) >= 1.27
  22. BuildRequires: perl(Pod::Simple) >= 3.14
  23. BuildRequires: perl(Test::Pod) >= 1.44
  24. BuildRequires: perl(Test::MinimumVersion) >= 0.101080
  25. BuildRequires: perl(Test::CPAN::Meta) >= 0.17
  26. %endif
  27. %description
  28. Class::Autouse allows you to specify a class the will only load when a
  29. method of that class is called. For large classes that might not be used
  30. during the running of a program, such as Date::Manip, this can save you
  31. large amounts of memory, and decrease the script load time.
  32. %prep
  33. %setup -q -n Class-Autouse-%{version}
  34. %build
  35. AUTOMATED_TESTING=1 %{__perl} Makefile.PL INSTALLDIRS=vendor
  36. make %{?_smp_mflags}
  37. %install
  38. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  39. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  40. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  41. chmod -R u+w $RPM_BUILD_ROOT/*
  42. %check
  43. make test
  44. %if %{with xt_tests}
  45. # Manually invoke xt-tests
  46. AUTOMATED_TESTING=1 PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" xt/*.t
  47. %endif
  48. %files
  49. %defattr(-,root,root,-)
  50. %doc Changes LICENSE
  51. %{perl_vendorlib}/Class
  52. %{_mandir}/man3/*
  53. %changelog
  54. * Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.01-1
  55. - initial build for Vine Linux
  56. * Sun Feb 05 2012 Ralf Corsépius <corsepiu@fedoraproject.org> - 2.01-1
  57. - Upstream update.
  58. - Adjust BR:'s.
  59. - Modernize spec.
  60. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.00-4
  61. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  62. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 2.00-3
  63. - Perl mass rebuild
  64. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.00-2
  65. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  66. * Fri Jan 21 2011 Ralf Corsépius <corsepiu@fedoraproject.org> - 2.00-1
  67. - Upstream update.
  68. - Adjust BR:'s.
  69. - Add %%bcond_with xt_tests.
  70. * Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.29-10
  71. - 661697 rebuild for fixing problems with vendorach/lib
  72. * Tue Jul 20 2010 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.29-9
  73. - Reenable pmv test.
  74. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.29-8
  75. - Mass rebuild with perl-5.12.0
  76. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.29-7
  77. - rebuild against perl 5.10.1
  78. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-6
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  80. * Fri Feb 27 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.29-5
  81. - Adjust minimum perl version in META.yml (Add Class-Autouse-1.29.diff).
  82. - BR: perl(List::Util) >= 1.19.
  83. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-4
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  85. * Tue Mar 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.29-3
  86. - rebuild for new perl
  87. * Sun Nov 25 2007 Ralf Corsépius <rc040203@freenet.de> - 1.29-2
  88. - Add BR: perl(Test-MinimumVersion).
  89. * Tue Nov 20 2007 Ralf Corsépius <rc040203@freenet.de> - 1.29-1
  90. - Upstream update.
  91. * Wed Sep 05 2007 Ralf Corsépius <rc040203@freenet.de> - 1.28-1
  92. - Upstream update.
  93. - Update license.
  94. * Tue Sep 05 2006 Ralf Corsépius <rc040203@freenet.de> - 1.27-1
  95. - Upstream update.
  96. * Tue Sep 05 2006 Ralf Corsépius <rc040203@freenet.de> - 1.26-2
  97. - Mass rebuild.
  98. * Thu Apr 20 2006 Ralf Corsépius <rc040203@freenet.de> - 1.26-1
  99. - Upstream update.
  100. * Wed Mar 01 2006 Ralf Corsépius <rc040203@freenet.de> - 1.21-3
  101. - Rebuild for perl-5.8.8.
  102. * Wed Feb 01 2006 Ralf Corsepius <rc040203@freenet.de> - 1.21-2
  103. - Revert to 1.21 (List::Util in Perl is too old).
  104. * Sat Jan 14 2006 Ralf Corsepius <rc040203@freenet.de> - 1.24-1
  105. - Upstream update.
  106. * Wed Sep 28 2005 Ralf Corsepius <rc040203@freenet.de> - 1.21-1
  107. - Upstream update.
  108. - Fix bogus dep on perl(Carp).
  109. * Thu Sep 15 2005 Ralf Corsepius <rc040203@freenet.de> - 1.20-2
  110. - Spec cleanup.
  111. * Tue Sep 13 2005 Ralf Corsepius <rc040203@freenet.de> - 1.20-1
  112. - Spec cleanup.
  113. - FE submission.