chromium14-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. %define pkgname chromium
  5. #% define with_system_icu 1
  6. #% define with_system_v8 1
  7. #NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
  8. # libvpx doesn't currently supply a pkg-config file, so we assume that
  9. # -lvpx is sufficient.
  10. %define with_system_vpx 1
  11. Name: chromium14
  12. #Name: chromium
  13. Summary: Google's opens source browser project
  14. Summary(ja): Googleのオープンソースウェブブラウザ
  15. #'
  16. Version: 14.0.835.157
  17. Release: 1%{?_dist_release}
  18. License: BSD
  19. Group: Applications/Internet
  20. Source0: %{pkgname}-%{version}.tar.xz
  21. # Script used to create the %{pkgname}-%{version}.tar.xz archive from
  22. # a official tarball:
  23. # http://build.chromium.org/official/chromium-14.0.835.XXX.tar.bz2
  24. Source3: pack_chromium14_source-vine.sh
  25. # Official ffmpeg headers
  26. Source8: ffmpeg-0.6-headers.tar.xz
  27. # Patch template which adds vendor to user agent
  28. ##!!Source20: chromium-vendor.patch.in
  29. Source20: chromium-vendor-vine.patch.in
  30. # Set default prefs
  31. ##!!Source30: master_preferences
  32. Source30: master_preferences.vine
  33. ##!!Source31: default_bookmarks.html
  34. #Source31: default_bookmarks.html.vine
  35. Source99: chrome-wrapper
  36. ##!!Source100: chromium-browser.sh
  37. Source100: chromium-browser-vine.sh
  38. ##!!Source101: chromium-browser.desktop
  39. Source101: chromium-browser-vine.desktop
  40. Source102: chromium-browser.xml
  41. Source103: chromium-browser-rpmlintrc
  42. ##!!Source104: chromium-icons.tar.bz2
  43. %{?nosrc:NoSource: 0}
  44. Provides: chromium-unstable = %{version}-%{release}
  45. Obsoletes: chromium13
  46. Conflicts: chromium-stable
  47. # Provides: chromium-stable = %{version}-%{release}
  48. # Conflicts: chromium-unstable
  49. ## Start Patches
  50. # OpenSuse and Fedora
  51. # Many changes to the gyp systems so we can use system libraries
  52. #Patch1: chromium-gcc46.patch
  53. Patch4: chromium-no-sqlite-debug.patch
  54. Patch8: chromium-codechanges-zlib.patch
  55. Patch12: chromium-no-test-sources.patch
  56. Patch13: chromium-no-courgette.patch
  57. Patch14: chromium-master-prefs-path.patch
  58. Patch17: chromium-system-glew.patch
  59. Patch18: chromium-system-expat.patch
  60. Patch19: chromium-system-zlib.patch
  61. Patch20: chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
  62. Patch21: chromium-7.0.542.0-media-probe.patch
  63. Patch25: tcmalloc-factory.patch
  64. Patch26: chromium-remoting-build-fix.diff
  65. Patch28: chromium-7.0.500.0-system-speex.patch
  66. Patch29: chromium-7.0.510.0-system-ffmpeg.patch
  67. Patch32: chromium-7.0.542.0-system-libvpx.patch
  68. Patch34: chromium-7.0.542.0-codechanges-system-minizip-v8.patch
  69. Patch62: chromium-norpath.patch
  70. Patch63: chromium-6.0.406.0-system-gyp-v8.patch
  71. Patch999: buildfix.patch
  72. # Vine
  73. Patch100: chromium-14.0.835.31-no-tests.patch
  74. ##!!BuildRequires: Mesa-devel
  75. BuildRequires: mesa-libGLU-devel
  76. ##!!BuildRequires: alsa-devel
  77. BuildRequires: alsa-lib-devel
  78. BuildRequires: pulseaudio-libs-devel
  79. BuildRequires: bison
  80. BuildRequires: cups-devel
  81. BuildRequires: desktop-file-utils
  82. BuildRequires: fdupes
  83. BuildRequires: flex
  84. BuildRequires: freetype2-devel
  85. BuildRequires: gcc gcc-c++
  86. BuildRequires: gperf
  87. BuildRequires: hunspell-devel
  88. ##!!BuildRequires: libbz2-devel
  89. BuildRequires: bzip2-devel
  90. BuildRequires: libevent
  91. ##!!BuildRequires: libexpat-devel
  92. BuildRequires: expat-devel
  93. ##!!BuildRequires: libgnutls-devel
  94. BuildRequires: gnutls-devel
  95. BuildRequires: libjpeg-devel
  96. BuildRequires: libpng-devel
  97. BuildRequires: libstdc++-devel >= 4.4
  98. %{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5}
  99. BuildRequires: libxslt-devel
  100. BuildRequires: libzip-devel
  101. ##!!BuildRequires: lzma
  102. BuildRequires: xz
  103. ##!!BuildRequires: mozilla-nspr-devel
  104. BuildRequires: nspr-devel
  105. ##!!BuildRequires: mozilla-nss-devel
  106. BuildRequires: nss-devel
  107. BuildRequires: openssl-devel
  108. BuildRequires: pam-devel
  109. ##!!BuildRequires: perl(Switch)
  110. BuildRequires: perl
  111. ##!!BuildRequires: pkg-config
  112. BuildRequires: cairo-devel >= 1.6
  113. BuildRequires: dbus-devel
  114. ##!!BuildRequires: gconf2-devel
  115. BuildRequires: GConf2-devel
  116. BuildRequires: glib2-devel
  117. BuildRequires: gtk2-devel
  118. BuildRequires: libxml2-devel
  119. BuildRequires: python
  120. ##!!BuildRequires: python-xml
  121. BuildRequires: python-pyxml
  122. BuildRequires: sqlite3-devel
  123. ##!!BuildRequires: update-desktop-files
  124. %{?with_system_v8:BuildRequires: v8-devel = %{v8_ver}}
  125. ##!!BuildRequires: wdiff
  126. BuildRequires: zlib-devel
  127. BuildRequires: libgnome-keyring-devel
  128. BuildRequires: python-devel
  129. #BuildRequires: glew-devel
  130. BuildRequires: libevent-devel
  131. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  132. #BuildRequires: libjingle-devel >= 0.4.0-7
  133. #BuildRequires: srtp-devel
  134. BuildRequires: speex-devel
  135. ##Vine Linux
  136. #BuildRequires: libpaper-devel
  137. BuildRequires: libXScrnSaver-devel
  138. BuildRequires: libXtst-devel
  139. BuildRequires: libXdamage-devel
  140. BuildRequires: libXt-devel
  141. %ifarch x86_64
  142. Requires: nspluginwrapper
  143. %endif
  144. ##!!Requires: alsa
  145. Requires: alsa-lib
  146. Requires: pulseaudio-libs
  147. Requires: xdg-utils
  148. %{?with_system_v8:Requires: v8 = %{v8_ver}}
  149. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  150. %description
  151. Chromium is the open-source project behind Google Chrome.
  152. We invite you to join us in our effort to help build a safer, faster,
  153. and more stable way for all Internet users to experience the web,
  154. and to create a powerful platform for developing a new generation of
  155. web applications.
  156. %description -l ja
  157. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  158. ウェブを体験しているすべてのインターネットユーザに対して
  159. より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
  160. そして、ウェブアプリケーションの新しい世代を発展させ、
  161. 強力なプラットホームを作成するために、
  162. 私たちの取り組みにぜひ参加してください。
  163. %prep
  164. #%setup -q
  165. [ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
  166. xz -dc %{SOURCE0} | %__tar -xf - || exit 1
  167. %setup -D -T -n %{pkgname}-%{version}
  168. #%patch1 -p1
  169. %patch62 -p1
  170. %{?with_system_v8:%patch63 -p1}
  171. %patch100 -p1 -b .vine
  172. %patch4 -p1
  173. %patch8 -p1
  174. %patch12 -p1
  175. %patch13 -p1
  176. %patch14 -p1
  177. %patch17 -p1
  178. %patch18 -p1
  179. %patch19 -p1
  180. %patch20 -p1
  181. %patch21 -p1
  182. %patch25 -p1
  183. %patch26 -p1
  184. %patch28 -p1
  185. %patch29 -p1
  186. %{?with_system_vpx:%patch32 -p1}
  187. %{?with_system_v8:%patch34 -p1}
  188. %patch999 -p1
  189. pushd src/third_party/ffmpeg/
  190. %__tar xf %{SOURCE8} || exit 1
  191. ## built header file: avconfig.h
  192. [ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
  193. cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
  194. /* Generated by ffconf */
  195. #ifndef AVUTIL_AVCONFIG_H
  196. #define AVUTIL_AVCONFIG_H
  197. #define AV_HAVE_BIGENDIAN 0
  198. #endif /* AVUTIL_AVCONFIG_H */
  199. EOF
  200. popd
  201. #%__rm -rf src/third_party/libvpx/
  202. %__rm -rf src/third_party/speex/
  203. %__rm -rf src/third_party/nss src/third_party/nspr
  204. # apply vendor patch after substitution
  205. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  206. %build
  207. ## create make files
  208. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  209. for i in src/build/common.gypi; do
  210. %__sed -i "s|'-march=pentium4',||g" $i
  211. %__sed -i "s|'-mfpmath=sse',||g" $i
  212. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  213. %__sed -i "s|'-m32',||g" $i
  214. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  215. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  216. done
  217. # '
  218. pushd src
  219. ./build/gyp_chromium -f make build/all.gyp \
  220. -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
  221. -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
  222. -Ddisable_nacl=1 \
  223. -Duse_openssl=0 \
  224. -Duse_system_ffmpeg=1 \
  225. -Duse_system_zlib=1 \
  226. -Duse_system_libpng=1 \
  227. -Duse_system_bzip2=1 \
  228. -Duse_system_libbz2=1 \
  229. -Duse_system_libjpeg=1 \
  230. -Duse_system_libxml=1 \
  231. -Duse_system_libxslt=1 \
  232. -Duse_system_libevent=1 \
  233. %{?with_system_vpx:-Duse_system_vpx=1} \
  234. %{!?with_system_vpx:-Duse_system_vpx=0} \
  235. -Dremove_webcore_debug_symbols=1 \
  236. %{?with_system_v8:-Duse_system_v8=1} \
  237. %{!?with_system_v8:-Duse_system_v8=0} \
  238. %{?with_system_icu:-Duse_system_icu=1} \
  239. %{!?with_system_icu:-Duse_system_icu=0} \
  240. %{?_with_shared_library:-Dlibrary=shared_library} \
  241. -Dproprietary_codecs=1 \
  242. -Djavascript_engine=v8 \
  243. -Dlinux_fpic=1 \
  244. -Ddisable_sse2=1 \
  245. %ifarch %{ix86}
  246. -Dtarget_arch=ia32 \
  247. %endif
  248. %ifarch x86_64
  249. -Dtarget_arch=x64 \
  250. %endif
  251. -Dno_strict_aliasing=1 \
  252. -Drelease_extra_cflags=-fPIC \
  253. %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
  254. -Dgcc_version=44 \
  255. %endif
  256. ;
  257. #%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
  258. %__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release
  259. popd
  260. %install
  261. %{__rm} -rf %{buildroot}
  262. %__mkdir -p %{buildroot}%{_bindir}
  263. %__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
  264. # x86_64 capable systems need this
  265. %__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
  266. %__mkdir -p %{buildroot}%{_libdir}/chromium/
  267. %__mkdir -p %{buildroot}%{_mandir}/man1/
  268. pushd src/out/Release
  269. %__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
  270. %__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
  271. %__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
  272. %{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
  273. %{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
  274. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
  275. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
  276. fdupes %{buildroot}%{_mandir}/man1/
  277. popd
  278. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  279. %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
  280. for i in 16 22 24 32 48 64 128 256; do
  281. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
  282. %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
  283. done
  284. %__mkdir_p %{buildroot}%{_datadir}/applications/
  285. desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
  286. %__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  287. %__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  288. # # link to browser plugin path. Plugin patch doesn't work. Why?
  289. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  290. # pushd %{buildroot}%{_libdir}/%{pkgname}
  291. # %{__ln_s} %{_libdir}/browser-plugins plugins
  292. # popd
  293. pushd %{buildroot}%{_libdir}/%{pkgname}
  294. %ifarch x86_64
  295. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  296. %else
  297. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  298. %endif
  299. ## support ffmpeg libs
  300. touch %{buildroot}%{_libdir}/libavcodec.so.52
  301. %{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  302. touch %{buildroot}%{_libdir}/libavformat.so.52
  303. %{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  304. touch %{buildroot}%{_libdir}/libavutil.so.50
  305. %{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  306. popd
  307. # Install the master_preferences file
  308. %__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
  309. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
  310. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
  311. #%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
  312. %clean
  313. %{__rm} -rf %{buildroot}
  314. %post
  315. touch --no-create %{_datadir}/icons/hicolor
  316. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  317. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  318. fi
  319. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  320. %postun
  321. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  322. touch --no-create %{_datadir}/icons/hicolor
  323. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  324. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  325. fi || :
  326. %files
  327. %defattr(-,root,root,-)
  328. %config %{_sysconfdir}/%{pkgname}
  329. %dir %{_datadir}/gnome-control-center
  330. %dir %{_datadir}/gnome-control-center/default-apps
  331. %dir %{_libdir}/chromium/
  332. %{_bindir}/chromium
  333. %{_libdir}/chromium/chromium
  334. %{_libdir}/chromium/plugins/
  335. %{_libdir}/chromium/resources/
  336. %{_libdir}/chromium/xdg-settings
  337. %{_mandir}/man1/chrom*
  338. %{_datadir}/pixmaps/chromium-browser.png
  339. %{_datadir}/icons/hicolor/*/apps/chromium-browser.png
  340. %{_datadir}/applications/*.desktop
  341. %{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
  342. #%{_datadir}/icons/oxygen/
  343. %{_libdir}/chromium/chrome.pak
  344. %{_libdir}/chromium/resources.pak
  345. %{_libdir}/chromium/locales/
  346. %{?_with_shared_library:%{_libdir}/chromium/lib*.so}
  347. %{_libdir}/chromium/libavcodec.so.52
  348. %{_libdir}/chromium/libavutil.so.50
  349. %{_libdir}/chromium/libavformat.so.52
  350. %exclude %{_libdir}/libavcodec.so.52
  351. %exclude %{_libdir}/libavutil.so.50
  352. %exclude %{_libdir}/libavformat.so.52
  353. %changelog
  354. * Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
  355. - updated to 14.0.835.157
  356. * Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
  357. - updated to 14.0.835.102
  358. * Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
  359. - updated to 14.0.835.89
  360. - added Obsoletes: chromium-unstable < %{version}-%{release}
  361. * Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
  362. - updated to 14.0.835.35
  363. - added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
  364. - changed to Name: chromium14
  365. - Provides: chromium-unstable = %%{version}
  366. - Conflicts: chromium-stable
  367. * Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
  368. - changed to Name: chromium
  369. - updated to 13.0.782.107
  370. * Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
  371. - updated to 13.0.782.88
  372. - added BuildRequires: libzip-devel
  373. - added Provides: chromium-unstable = %%{version}
  374. - added Conflicts: chromium-stable
  375. * Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
  376. - fix user-agent string (chromium-vendor-vine.patch.in)
  377. - move vendor string (Vine/12.0.742.91-1vl6) to the end.
  378. * Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
  379. - updated to 12.0.742.93
  380. - fixed icon field of chromium-browser-vine.desktop
  381. * Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
  382. - updated to 12.0.742.91
  383. * Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
  384. - updated to 12.0.742.77
  385. * Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
  386. - updated to 12.0.742.63
  387. * Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
  388. - updated to 12.0.742.42
  389. * Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
  390. - updated to 12.0.742.6
  391. - dropped/upstreamed patches
  392. - updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
  393. * Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
  394. - updated to 11.0.696.50
  395. - dropped some Patches for MeeGo Netbook
  396. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
  397. - updated to 11.0.696.35
  398. * Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
  399. - updated to 11.0.696.29
  400. - dropped "--no-first-run" in command line options of chromium-browser-vine.sh
  401. * Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
  402. - updated to 11.0.696.22
  403. - improved chromium-browser-vine.sh
  404. - merged from chromium-browser-vine.desktop of 11.0.696.17-1
  405. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
  406. - updated to 11.0.696.20
  407. - improved chromium-browser-vine.desktop
  408. * Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
  409. - updated to 11.0.696.17
  410. * Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
  411. - updated to 11.0.696.15
  412. - ready for Vine Linux 6 release
  413. - dropped BuildRequires: v8-devel, libicu-devel
  414. * Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
  415. - updated to 11.0.696.5 with v8 3.2.0
  416. - added BuildRequires: pam-devel
  417. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
  418. - rebuilt with libevent-2.0.10
  419. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
  420. - updated to 10.0.651.0 with v8 3.0.12
  421. - added BuildRequires:
  422. - libpaper-devel
  423. - python-devel
  424. - added built header file: libavutil/avconfig.h %%prep
  425. - unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
  426. * Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
  427. - updated to 10.0.622.0
  428. - added BuildRequires: libXt-devel
  429. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
  430. - updated to 10.0.605.0
  431. - added BuildRequires:
  432. - libXdamage-devel
  433. - hunspell-devel
  434. * Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
  435. - updated to 9.0.598
  436. * Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
  437. - updated to 9.0.593
  438. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
  439. - updated to 9.0.582
  440. - added Requires: xdg-utils
  441. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
  442. - updated to 9.0.578
  443. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
  444. - updated to 9.0.569
  445. * Mon Oct 25 2010 tittiatcoke@gmail.com
  446. - Update to 9.0.564 build
  447. * Added specific patches for MeeGo.
  448. * We are now using shared libraries for Chromium
  449. * Spec-file cleanup (Thanks to prusnak)
  450. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
  451. - updated to snapshot 8.0.556
  452. * Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
  453. - updated to snapshot 8.0.551
  454. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
  455. - updated to snapshot 7.0.527
  456. * Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
  457. - updated to snapshot 7.0.519
  458. * Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
  459. - updated to snapshot 7.0.513
  460. - updated chromium-vendor-vine.patch.in
  461. * Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
  462. - updated to snapshot 7.0.507
  463. * Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
  464. - updated to snapshot 7.0.498
  465. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  466. - updated to snapshot 6.0.493
  467. - used with_system_icu (for vl6)
  468. - added BuildRequires: libicu-devel
  469. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  470. - build for Vine Linux 5.x
  471. - add BuildRequires: gnome-keyring-devel
  472. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  473. - updated to snapshot 6.0.454
  474. - added BuildRequires:
  475. - sqlite3-devel
  476. - gnutls-devel
  477. - libgnome-keyring-devel
  478. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  479. - updated to snapshot 6.0.431.0 r49253
  480. - added BuildRequires: cups-devel
  481. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  482. - updated to snapshot 6.0.405.0 r47263
  483. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  484. - unused with_system_icu (for vl6)
  485. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  486. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  487. - updated to snapshot 5.0.378.0 r44472
  488. - used with_system_icu (for vl6)
  489. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  490. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  491. - updated to snapshot 5.0.372.0 r43947
  492. - added BuildRequires: glew-devel
  493. - changed Group tag to Applications/Internet
  494. - added Summary(ja) and %%description -l ja
  495. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  496. - updated to snapshot 5.0.365.0 r42966
  497. - merged 5.0.353.0-4vl5
  498. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  499. - build on Vine Linux 5.1
  500. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  501. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  502. - updated to snapshot 5.0.364.0 r42779
  503. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  504. - updated to snapshot 5.0.359.0 r42116
  505. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  506. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  507. - fixed master_preferences.vine, little
  508. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  509. - fixed to install master_preferences
  510. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  511. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  512. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  513. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  514. - updated to snapshot 5.0.353.0 r41449
  515. * Wed Mar 10 2010 bgmerrell@novell.com
  516. - Add master_preferences source file and install it to /etc/chromium.
  517. - Create a new patch (chromium-master-prefs-path.patch) which tells
  518. chromium to look in /etc/chromium for the master_preferences file
  519. (instead of looking in the default directory, which is the same
  520. directory as the 'chrome' binary).
  521. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  522. - updated to snapshot 5.0.335.0 r39556
  523. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  524. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  525. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  526. - updated to snapshot 5.0.330.0 r39074
  527. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  528. - use_system_ffmpeg
  529. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  530. - added Requires: nspluginwrapper
  531. - fixed a symbolic link of plugins directory with nspluginwrapper
  532. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  533. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  534. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  535. - added BuildRequires: mesa-libGLU-devel
  536. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  537. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  538. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  539. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  540. - Update to 4.0.260
  541. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  542. - Update to 4.0.259
  543. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  544. - Update to 4.0.258
  545. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  546. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  547. changed to having an built-in v8
  548. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  549. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  550. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  551. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  552. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  553. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  554. - update to newer svn snapshot
  555. + Obsoletes fwrite patch (included upstream)
  556. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  557. - update to newer svn snapshot
  558. + Requires newer version of v8
  559. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  560. - do not force SSE on x86 (drop-sse.patch)
  561. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  562. - Update to newer svn snapshot
  563. - Fixed spec file in order to build
  564. - Included patch to build with system zlib
  565. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  566. - package renamed to chromium
  567. - cleaned up spec file
  568. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  569. - v8 is now built as a separate package, and is required
  570. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  571. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  572. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  573. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  574. - initial build
  575. #% changelog
  576. * Sun Jan 24 2010 prusnak@suse.cz
  577. - added vendor to user agent (chromium-vendor.patch.in)
  578. * Sun Nov 29 2009 prusnak@suse.cz
  579. - added --enable-sync to wrapper to enable bookmark sync
  580. * Sun Nov 29 2009 tittiatcoke@gmail.com
  581. - Update to 4.0.260
  582. * Fri Nov 27 2009 tittiatcoke@gmail.com
  583. - Update to 4.0.259
  584. * Thu Nov 26 2009 tittiatcoke@gmail.com
  585. - Update to 4.0.258
  586. * Tue Nov 24 2009 tittatcoke@gmai.com
  587. - In order to complete prevent the wrong v8 version to be used,
  588. the Chromium build has been changed to having an built-in v8
  589. * Tue Nov 24 2009 dbuck@example.com
  590. - Re-base patches.
  591. - Fixed a few patch errors.
  592. - Rename some patches to better correspond with function.
  593. - Removed some patches.
  594. - Minor SPEC changes.
  595. - I changed the v8 requirement to be exact, instead of greater than a specific version.
  596. * Fri Nov 13 2009 tittiatcoke@gmail.com
  597. - update to 247.0 svn 31928
  598. * Fri Oct 30 2009 tittiatcoke@gmail.com
  599. - update to 229.0 svn 30454
  600. + Fix regression where popups and app frames lost their titlebars.
  601. + Makes it so that when a folder is open on the bookmark bar
  602. and the mouse moves over another folder, the menu for that
  603. folder is shown.
  604. + Lazily create the find bar.
  605. + Polish to the gmail checker sample.
  606. * New, crisper icons that are exactly 19x19
  607. * Add a loading animation at the beginning before Gmail
  608. responds.
  609. * Fix a bug where we sometimes don't update the UI after a
  610. logout/login cycle.
  611. + Refactor widget methods to support desktop notifications,
  612. including GTK stubs.
  613. + Find-in-page should not ding while deleting characters.
  614. + Add SSL wrapper for linux and mac. This allows notifier to
  615. use chrome's SSL layer instead of OpenSSL.
  616. + Add three of the six extensions to PAC that Internet Explorer supports.
  617. + WebSocket support in chromium. (Run with --enable-web-sockets
  618. enables WebSocket features.)
  619. + Do not allow GTK File Chooser dialogs to return directories.
  620. + Fix the notifier SSL layer to make notifications work for
  621. Linux Bookmark sync.
  622. + linux: don't override mouse selection behavior in omnibox
  623. * Sun Oct 25 2009 tittiatcoke@gmail.com
  624. - Update to 224.4 svn 30027
  625. + First cut at new page and browser action docs based
  626. on new API. Deleted old stuff.
  627. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  628. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  629. + Minimize dependency of user scripts
  630. + Fixup the flip_framer eof-handling semantics now that we have
  631. the FIN bit in place
  632. + app depends on x11 because of active_window_watcher_x
  633. + Adding two images for the new Extension managment UI
  634. + Removing hard-coded Chrome Frame output path
  635. + Rearrange clipboard code
  636. + Fix crash bug when attempting to download a url with unsupported scheme,
  637. e.g. 'data:', by 'Alt + Click'
  638. + GTK: Change text for extension download UI
  639. + Ignore invalid urls on command line
  640. + Make dropped tabs animate from where they were dropped.
  641. + Make room for the full width of the tab placeholder.
  642. + Make tab dragging as smooth as glass.
  643. + Remove an annoying NOTIMPLEMNETED
  644. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  645. + If we're in the middle of a drag, don't allow the user to middle
  646. click to close or right click for the context menu
  647. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  648. + Remove +x bit from files that shouldn't have it
  649. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  650. + Adding new image needed for the managment UI
  651. + Fix a race bug where content scripts would not apply to the first page load
  652. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  653. + Fix bubbles deactivating the opaque frame
  654. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  655. + ake all pepper plugins default to windowless and transparent
  656. + Add styles for printing
  657. + Implement the new extension management UI
  658. + Add support for to automation interface load install and load extensions
  659. + GTK: theme the info bar border
  660. + Update V8 to version 1.3.16.1
  661. + Introduce WebSecurityPolicy for security related methods
  662. + New button scheme...borders are separate from the inner contents so
  663. that they can be highlighted / depressed independently
  664. + When opening Chrome maximized with an application window already
  665. running, the Chrome window was not activated
  666. + Fix compatibility problems with FileZilla FTP Server
  667. + Remove the extension shelf on Linux
  668. + Fix the proxy host and port string to start with http:// if it does not already
  669. + Enable HTML5 databases for all extension renderer processes
  670. * Sat Oct 24 2009 prusnak@opensuse.org
  671. - don't create desktop files in wrapper
  672. - fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  673. * Tue Oct 20 2009 tittiatcoke@gmail.com
  674. - update to newer svn snapshot
  675. + Obsoletes fwrite patch (included upstream)
  676. * Fri Oct 16 2009 tittiatcoke@gmail.com
  677. - update to newer svn snapshot
  678. + Requires newer version of v8
  679. * Thu Oct 15 2009 prusnak@suse.cz
  680. - do not force SSE on x86 (drop-sse.patch)
  681. * Tue Oct 13 2009 tittiatcoke@gmail.com
  682. - Update to newer svn snapshot
  683. - Fixed spec file in order to build
  684. - Included patch to build with system zlib
  685. * Mon Oct 12 2009 prusnak@suse.cz
  686. - package renamed to chromium
  687. - cleaned up spec file
  688. * Tue Oct 6 2009 dbuck@example.com
  689. - v8 is now built as a separate package, and is required
  690. - included many patches to use system libraries:
  691. v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  692. * Thu Oct 1 2009 dbuck@example.com
  693. - included a newer DEP than is in svn, native_client@823
  694. - things should compile cleanly now
  695. * Mon Aug 31 2009 dbuck@example.com
  696. - initial build