quota-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350
  1. Name: quota
  2. Summary: System administration tools for monitoring users' disk usage.
  3. Summary(ja): ユーザのディスク使用量をモニタするシステム管理ツール
  4. Version: 4.00
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Base
  8. URL: http://sourceforge.net/projects/linuxquota/
  9. #Source0: http://downloads.sourceforge.net/linuxquota/quota-%{version}.tar.gz
  10. Source0: quota-%{version}.tar.gz
  11. Source1: quota_nld.init
  12. Source2: quota_nld.sysconfig
  13. Patch0: quota-4.00-warnquota.patch
  14. Patch1: quota-3.06-man-page.patch
  15. Patch2: quota-3.06-pie.patch
  16. Patch3: quota-3.13-wrong-ports.patch
  17. # Bug #667757, submitted to upstream (SF#3152423)
  18. Patch4: quota-4.00_pre1-Make-RPC-block-factor-dynamic.patch
  19. # Bug #668691, submitted to upstream (SF#3152423)
  20. Patch5: quota-4.00_pre1-Check-set-limits-fit-into-the-range-supported-by-RPC.patch
  21. # Bug #634137, submitted to upstream (SF#3171791)
  22. Patch6: quota-4.00_pre1-Store-PID-of-quota_nld.patch
  23. # In upstream after 4.00 (SF#3393151), bug #731622
  24. Patch7: quota-4.00-Do-not-report-missing-utmp-record-to-syslog.patch
  25. BuildRoot: %{_tmppath}/%{name}-root
  26. Requires: kernel >= 2.4, initscripts >= 6.38
  27. Requires(post): chkconfig
  28. Requires(preun): chkconfig
  29. Conflicts: nfs-utils < 1.0.1
  30. BuildRequires: e2fsprogs-devel, gettext
  31. BuildRequires: tcp_wrappers, nss-devel
  32. BuildRequires: openldap-devel, openssl-devel, dbus-devel, libnl-devel
  33. %description
  34. The quota package contains system administration tools for monitoring
  35. and limiting user and or group disk usage per filesystem.
  36. %description -l ja
  37. quota パッケージには,ユーザやグループのディスク使用量を監視したり
  38. 制限したりできるシステム管理ツールが収録されています.これらの操作
  39. はファイルシステム単位で行うことが出来ます.
  40. ユーザやグループのディスク使用量を監視/制限した場合は quota をイン
  41. ストールして下さい.
  42. %prep
  43. %setup -q -n quota-tools
  44. %patch0 -p1
  45. %patch1 -p1
  46. %ifnarch ppc ppc64
  47. %patch2 -p1
  48. %endif
  49. %patch3 -p1
  50. %patch4 -p1 -b .rpc_block_factor_dynamic
  51. %patch5 -p1 -b .check_set_limits_rpc
  52. %patch6 -p1 -b .store_pid
  53. %patch7 -p1 -b .suppress_missing_utmp
  54. %build
  55. %configure \
  56. --enable-ext2direct=yes \
  57. --enable-ldapmail=yes \
  58. --enable-netlink=yes \
  59. --enable-rootsbin=yes \
  60. --enable-rpcsetquota=yes \
  61. --enable-strip-binaries=no
  62. make
  63. %install
  64. rm -fr %{buildroot}
  65. mkdir -p %{buildroot}/sbin
  66. mkdir -p %{buildroot}%{_sysconfdir}
  67. mkdir -p %{buildroot}%{_sbindir}
  68. mkdir -p %{buildroot}%{_bindir}
  69. mkdir -p %{buildroot}%{_mandir}/{man1,man3,man8}
  70. make install INSTALL='install -p' ROOTDIR=%{buildroot}
  71. install -m 644 warnquota.conf %{buildroot}%{_sysconfdir}
  72. # we don't support XFS yet
  73. #
  74. rm -f %{buildroot}%{_sbindir}/quot
  75. rm -f %{buildroot}%{_sbindir}/xqmstats
  76. rm -f %{buildroot}%{_mandir}/man8/quot.*
  77. rm -f %{buildroot}%{_mandir}/man8/xqmstats.*
  78. ln -s quotaon.8.gz \
  79. %{buildroot}%{_mandir}/man8/quotaoff.8
  80. ln -s rquotad.8.gz \
  81. %{buildroot}%{_mandir}/man8/rpc.rquotad.8
  82. install -p -m755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/quota_nld
  83. install -p -m644 -D %{SOURCE2} \
  84. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/quota_nld
  85. %find_lang %{name}
  86. %clean
  87. rm -rf %{buildroot}
  88. %post
  89. /sbin/chkconfig --add quota_nld
  90. %preun
  91. if [ $1 = 0 ] ; then
  92. /sbin/service quota_nld stop >/dev/null 2>&1
  93. /sbin/chkconfig --del quota_nld
  94. fi
  95. %files -f %{name}.lang
  96. %defattr(-,root,root)
  97. %doc Changelog doc/ README*
  98. %config(noreplace) %{_sysconfdir}/warnquota.conf
  99. %config(noreplace) %{_sysconfdir}/quotagrpadmins
  100. %config(noreplace) %{_sysconfdir}/quotatab
  101. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/quota_nld
  102. %attr(0755,root,root) %{_initrddir}/quota_nld
  103. %attr(0755,root,root) /sbin/*
  104. %attr(0755,root,root) %{_bindir}/*
  105. %attr(0755,root,root) %{_sbindir}/*
  106. %{_includedir}/rpcsvc/*
  107. %attr(0644,root,root) %{_mandir}/man1/*
  108. %attr(0644,root,root) %{_mandir}/man3/*
  109. %attr(0644,root,root) %{_mandir}/man8/*
  110. %changelog
  111. * Mon Mar 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.00-1
  112. - new upstram release
  113. - add BR: tcp_wrappers, nss-devel, openldap-devel,
  114. openssl-devel, dbus-devel, libnl-devel
  115. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.15-2
  116. - rebuilt with rpm-4.8.1-3
  117. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.15-1vl5
  118. - applied new versioning policy, spec in utf-8
  119. * Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 3.15-0vl1
  120. - updated quota to 3.15
  121. * Wed Apr 27 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl2
  122. - oops, removed unnecessary Patch3
  123. * Tue Apr 26 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl1
  124. - based on 3.12-5, being merged into 3.06-7vl1
  125. - Sun Sep 26 2004 Rik van Riel <riel@redhat.com> 3.12-5
  126. - add URL (bz# 131862)
  127. - Fri Sep 24 2004 Steve Dickson <SteveD@RedHat.com>
  128. - Fixed typos in warnquota.conf patch
  129. (bz# 82250 and bz# 83974)
  130. - Mon Sep 13 2004 Steve Dickson <SteveD@RedHat.com>
  131. - upgraded to 3.12
  132. - Tue Jan 27 2004 Florian La Roche <Florian.LaRoche@redhat.de>
  133. - add -pie support
  134. - update to 3.10
  135. - Sat Aug 16 2003 Steve Dickson <SteveD@RedHat.com>
  136. - upgraded to 3.0.9
  137. - added quota-3.09-root_sbindir.patch
  138. * Sun Feb 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.06-7vl1
  139. - merged with Vine Linux package (quota-2.00stable-0vl1)
  140. - based on rawhide release 3.06-7
  141. * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
  142. - 2.00stable-0vl1
  143. - ver.up
  144. * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
  145. - 2.00pre3-8vl2
  146. - added documents
  147. * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  148. - 2.00pre3-8vl1
  149. - based on 2.00pre3-8 from Rawhide
  150. - added Japanese summary and description
  151. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  152. - rebuilt
  153. * Mon Nov 18 2002 Tim Powers <timp@redhat.com>
  154. - rebuild on all arches
  155. * Fri Sep 6 2002 Philip Copeland <bryce@redhat.com> 3.06-5
  156. - added --with-ext2direct=no to fix #73244
  157. without this users with UID's > 65535 will not
  158. be able to exist on a quota enabled FS
  159. * Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 3.06-4
  160. - Man page change. #60108
  161. * Tue Aug 6 2002 Philip Copeland <bryce@redhat.com> 3.06-3
  162. - Bah, I'd dropped epoch from the spec file but seems
  163. we need this if you want to upgrade as the epoch
  164. number has precedence over the version/release
  165. numbers.
  166. * Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 3.06-2
  167. - Lets stop the makefile from stripping the
  168. binaries as thats rpms job (apparently)
  169. * Mon Jul 01 2002 Philip Copeland <bryce@redhat.com> 3.06-1
  170. - Ditched the 3.01-pre9 src base for 3.06
  171. Rebuilt without any patchs
  172. ============================================================
  173. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  174. - automated rebuild
  175. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  176. - automated rebuild
  177. * Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com>
  178. - IfArch the badkernelinclude patch for ppc-only.
  179. - Update to 3.03
  180. * Wed Dec 12 2001 Guy Streeter <streeter@redhat.com>
  181. - Make #include of kernel header file work on non-x86
  182. * Wed Sep 5 2001 Preston Brown <pbrown@redhat.com>
  183. - require new initscripts
  184. * Thu Aug 30 2001 Preston Brown <pbrown@redhat.com>
  185. - fixed bug #52075 (problem with ext2 labels)
  186. - backup data files off by default in quotacheck, optional backup flag added
  187. - fix bug where giving a bad directory or device would cause
  188. quotaon/quotacheck to simulate "-a" behaviour
  189. - if a device name (i.e /dev/hda1) is passed, look up the corresponding mount
  190. point
  191. * Wed Aug 29 2001 Preston Brown <pbrown@redhat.com>
  192. - return an error code in more cases in convertquota
  193. * Tue Aug 28 2001 Preston Brown <pbrown@redhat.com>
  194. - 3.01pre9
  195. * Fri Jul 20 2001 Preston Brown <pbrown@redhat.com>
  196. - more cleanups on 3.01pre8
  197. * Mon Jul 2 2001 Preston Brown <pbrown@redhat.com>
  198. - 3.01 version, everything has changed again. :(
  199. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  200. - Bump release + rebuild.
  201. * Fri Mar 30 2001 Preston Brown <pbrown@redhat.com>
  202. - use rpc.rquotad from here again (#33738)
  203. * Thu Mar 15 2001 Preston Brown <pbrown@redhat.com>
  204. - enable ALT_FORMAT for edquota
  205. * Tue Mar 13 2001 Preston Brown <pbrown@redhat.com>
  206. - I broke passing devices on the cmd line. Fixed.
  207. * Fri Mar 09 2001 Preston Brown <pbrown@redhat.com>
  208. - quota 3.00 is required by recent kernel 2.4 changes
  209. - no warnquota included this time, not yet ported
  210. - quite a bit of work on quotacheck to make is backwards compatible
  211. - we will likely go back to "quota 2.00" as these projects merge...
  212. * Fri Feb 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  213. - use "rm -f" instead of only "rm"
  214. * Wed Feb 7 2001 Preston Brown <pbrown@redhat.com>
  215. - fix quotacheck man page for -a option (#26380)
  216. * Thu Feb 1 2001 Preston Brown <pbrown@redhat.com>
  217. - 2.00 final, rolls in pretty much all our patches. :)
  218. - fix reporting of in use dquot entries from quotastats
  219. - change repquota man page to fix documentation of -v (#10330)
  220. - include warnquota.conf
  221. * Mon Nov 20 2000 Bill Nottingham <notting@redhat.com>
  222. - fix ia64 build
  223. * Mon Aug 21 2000 Jeff Johnson <jbj@redhat.com>
  224. - add LABEL=foo support (#16390).
  225. * Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
  226. - remote NFS quotas with different blocksize converted incorrectly (#11932).
  227. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  228. - automatic rebuild
  229. * Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
  230. - FHS packaging.
  231. * Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
  232. - apply patch5 (H.J. Lu)
  233. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  234. - fix description
  235. - man pages are compressed
  236. * Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
  237. - quota 2.00 series
  238. - removed unnecessary patches
  239. * Thu Aug 5 1999 Jeff Johnson <jbj@redhat.com>
  240. - fix man page FUD (#4369).
  241. * Thu May 13 1999 Peter Hanecak <hanecak@megaloman.sk>
  242. - changes to allow non-root users to build too (Makefile patch, %attr)
  243. * Tue Apr 13 1999 Jeff Johnson <jbj@redhat.com>
  244. - fix for sparc64 quotas (#2147)
  245. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  246. - auto rebuild in the new build environment (release 5)
  247. * Mon Dec 28 1998 Cristian Gafton <gafton@redhat.com>
  248. - don't install rpc.rquotad - we will use the one from the knfsd package
  249. instead
  250. * Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
  251. - merge ultrapenguin 1.1.9 changes.
  252. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  253. - translations modified for de, fr, tr
  254. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  255. - removed patch for mntent
  256. * Fri Mar 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  257. - updated to quota 1.66
  258. * Tue Jan 13 1998 Erik Troan <ewt@redhat.com>
  259. - builds rquotad
  260. - installs rpc.rquotad.8 symlink
  261. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  262. - removed /usr/include/rpcsvc/* from filelist
  263. - uses a buildroot and %attr
  264. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  265. - built against glibc
  266. * Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
  267. - Moved /usr/sbin/quota to /usr/bin/quota