qt-assistant-adp-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. Name: qt-assistant-adp
  2. Summary: Compatibility version of Qt Assistant
  3. Version: 4.6.3
  4. Release: 5%{?_dist_release}
  5. Group: System Environment/Libraries
  6. # See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
  7. License: LGPLv2 with exceptions or GPLv3 with exceptions
  8. URL: http://qt.nokia.com/doc/4.6/qassistantclient.html
  9. Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
  10. # missing header files from Debian (Fathi Boudra)
  11. Source1: QAssistantClient
  12. Source2: QtAssistant
  13. # build fixes from Debian (Fathi Boudra)
  14. Patch1: 01_build_system.diff
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: qt4-devel >= 4.7.2-2%{?_dist_release}
  17. %description
  18. The old version of Qt Assistant, based on Assistant Document Profile (.adp)
  19. files, and the associated QtAssistantClient library, for compatibility with
  20. applications providing help in that format.
  21. New applications should use the new version of Qt Assistant introduced in Qt
  22. 4.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.
  23. %package devel
  24. Summary: Development files for the compatibility QAssistantClient
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: qt4-devel
  28. %description devel
  29. This package contains the files necessary to build applications using the
  30. deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
  31. which is used together with the legacy Assistant Document Profile (.adp) version
  32. of Qt Assistant.
  33. This class is obsolete. It is provided to keep old source code working. We
  34. strongly advise against using it in new code. New code should use the Qt Help
  35. Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
  36. (also introduced in Qt 4.4) instead.
  37. %prep
  38. %setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
  39. %patch1 -p1 -b .build_system
  40. mkdir include
  41. cp -p %{SOURCE1} %{SOURCE2} include/
  42. %build
  43. # build assistant_adp
  44. qmake QT_PRODUCT=OpenSource
  45. make %{?_smp_mflags}
  46. # build libQtAssistantClient
  47. cd lib
  48. qmake CONFIG=create_prl
  49. make %{?_smp_mflags}
  50. # build assistant_adp translations
  51. cd ../translations
  52. lrelease assistant_adp_*.ts
  53. cd ..
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. # install assistant_adp
  57. make install INSTALL_ROOT=$RPM_BUILD_ROOT
  58. # install libQtAssistantClient
  59. make install INSTALL_ROOT=$RPM_BUILD_ROOT -C lib
  60. # install assistant_adp translations
  61. mkdir -p $RPM_BUILD_ROOT%{_qt4_translationdir}
  62. install -p -m644 translations/assistant_adp_*.qm \
  63. $RPM_BUILD_ROOT%{_qt4_translationdir}/
  64. # install assistant.prf mkspec
  65. install -D -p -m644 features/assistant.prf \
  66. $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/assistant.prf
  67. # install missing headers (thanks to Fathi Boudra from Debian)
  68. install -p -m644 include/Q* $RPM_BUILD_ROOT%{_qt4_headerdir}/QtAssistant/
  69. # nuke dangling reference(s) to the buildroot
  70. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" $RPM_BUILD_ROOT%{_qt4_libdir}/*.prl
  71. # let rpm handle binaries conflicts
  72. mkdir $RPM_BUILD_ROOT%{_bindir}
  73. pushd $RPM_BUILD_ROOT%{_qt4_bindir}
  74. mv assistant_adp ../../../bin/
  75. ln -s ../../../bin/assistant_adp .
  76. popd
  77. # _debug target (see bug #196513)
  78. pushd $RPM_BUILD_ROOT%{_qt4_libdir}
  79. echo "INPUT(-lQtAssistantClient)" >libQtAssistantClient_debug.so
  80. popd
  81. # Note that we intentionally DO NOT install a .desktop file for assistant_adp
  82. # because it makes no sense to invoke it without a specific .adp file to open.
  83. # By default, it views the Qt documentation, for which we already have a menu
  84. # entry using the current version of the Qt Assistant, and there is no UI for
  85. # viewing anything different. The .adp file needs to be passed on the command
  86. # line, which is usually done by the application.
  87. %find_lang assistant_adp --with-qt --without-mo
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %files -f assistant_adp.lang
  93. %defattr(-,root,root,-)
  94. %doc LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
  95. %{_bindir}/assistant_adp
  96. %{_qt4_bindir}/assistant_adp
  97. %{_qt4_libdir}/libQtAssistantClient.so.4*
  98. %files devel
  99. %defattr(-,root,root,-)
  100. %{_qt4_headerdir}/QtAssistant/
  101. %{_qt4_libdir}/libQtAssistantClient.so
  102. %{_qt4_libdir}/libQtAssistantClient_debug.so
  103. %{_qt4_libdir}/libQtAssistantClient.prl
  104. %{_libdir}/pkgconfig/QtAssistantClient.pc
  105. %{_qt4_datadir}/mkspecs/features/assistant.prf
  106. %changelog
  107. * Sat Jan 07 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-5
  108. - rebuilt with qt-4.8.0
  109. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-4
  110. - fixed BR
  111. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-3
  112. - Initial build for Vine Linux
  113. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.3-2
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  115. * Mon Jul 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.3-1
  116. - new upstream tarball with only the compat assistant_adp and QAssistantClient
  117. - build fixes from Debian (Fathi Boudra)
  118. - use find_lang to package the qm files (#609749)
  119. * Tue Mar 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-2
  120. - use versioned BR/Requires to avoid Conflicts
  121. * Sat Mar 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.2-1
  122. - first Fedora package