google-gadgets-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300
  1. Name: google-gadgets
  2. Summary: Google Gadgets platform for Linux
  3. Version: 0.11.2
  4. Release: 4%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: ASL 2.0
  7. URL: http://code.google.com/p/google-gadgets-for-linux/
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: inagaki,yasumichi
  11. Source0: http://google-gadgets-for-linux.googlecode.com/files/google-gadgets-for-linux-%{version}.tar.bz2
  12. # Vine Patches
  13. Patch0: NM-0.9.patch
  14. Patch1: nm-mobile-devtypes.patch
  15. Patch2: glib-2.32.patch
  16. Patch3: gcc-4.7.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: WebKit-gtk-devel
  19. BuildRequires: cairo-devel
  20. BuildRequires: curl-devel
  21. BuildRequires: dbus-devel
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: gstreamer-devel
  24. BuildRequires: gstreamer-plugins-base-devel
  25. BuildRequires: gtk2-devel
  26. BuildRequires: librsvg2-devel
  27. BuildRequires: libtool-ltdl-devel
  28. BuildRequires: libxml2-devel
  29. BuildRequires: pkgconfig
  30. BuildRequires: qt4-devel
  31. BuildRequires: zip
  32. BuildRequires: zlib-devel
  33. # Desktop integration
  34. BuildRequires: NetworkManager-devel
  35. BuildRequires: startup-notification-devel
  36. #Requires: %{name}-frontend = %{version}-%{release}
  37. Requires: hicolor-icon-theme
  38. %description
  39. Google Gadgets for Linux provides a platform for running desktop
  40. gadgets under Linux, catering to the unique needs of Linux users. It
  41. can run, without modification, many Google Desktop gadgets as well as
  42. the Universal Gadgets on iGoogle.
  43. %package gtk
  44. Summary: GTK+ front-end for %{name}
  45. Summary(ja): Google Gadgets の GTK+ 版フロントエンド
  46. Group: User Interface/Desktops
  47. Requires: %{name} = %{version}-%{release}
  48. Provides: %{name}-frontend = %{version}-%{release}
  49. %description gtk
  50. The %{name}-gtk package contains the GTK+ front-end for %{name}.
  51. %package qt
  52. Summary: Qt front-end for %{name}
  53. Summary(ja): Google Gadgets の Qt 版フロントエンド
  54. Group: User Interface/Desktops
  55. Requires: %{name} = %{version}-%{release}
  56. Provides: %{name}-frontend = %{version}-%{release}
  57. %description qt
  58. The %{name}-qt package contains the Qt front-end for %{name}.
  59. %package devel
  60. Summary: Development files for %{name}
  61. Summary(ja): %{name} の開発用ファイル
  62. Group: Development/Libraries
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: pkgconfig dbus-devel gtk2-devel qt4-devel
  65. Requires: %{name}-gtk
  66. Requires: %{name}-qt
  67. %description devel
  68. The %{name}-devel package contains libraries and header files for
  69. developing applications that use %{name}.
  70. %prep
  71. %setup -q -n %{name}-for-linux-%{version}
  72. %patch0 -p1
  73. %patch1 -p1
  74. %patch2 -p1
  75. %patch3 -p1
  76. # Permission fixes
  77. chmod -x ggadget/qt/utilities.h
  78. # Fix invalid desktop file MIME type
  79. # http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=360
  80. for f in hosts/*/ggl-*.desktop.in; do
  81. sed -i 's|;app/gg;|;|' $f
  82. done
  83. %build
  84. %configure --disable-static \
  85. --with-browser-plugins-dir=%{_libdir}/mozilla/plugins \
  86. --disable-gtkmoz-browser-element --disable-smjs-script-runtime
  87. # Rpath fix by Mamoru Tasaka
  88. # we don't want to obliterate all RPATHs, since it is used during build
  89. # Add library search path
  90. sed -i.libdir_syssearch -e \
  91. '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
  92. configure
  93. # Remove the redundant RPATH for %%{_libdir}, already searched by Fedora libtool
  94. sed -i.extra_R -e \
  95. 's|-R\$(libdir)||' \
  96. hosts/*/Makefile.in
  97. # default compile flags are impossibly strict
  98. make %{?_smp_mflags} DEFAULT_COMPILE_FLAGS=
  99. # Remove quotes from .pc files
  100. find . -name '*.pc' -exec sed -i 's|\"||g' '{}' \;
  101. %install
  102. rm -rf $RPM_BUILD_ROOT
  103. make install DESTDIR=$RPM_BUILD_ROOT \
  104. INSTALL="install -p" CPPROG="cp -p"
  105. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  106. # reinstall desktop files
  107. for i in gtk qt; do
  108. desktop-file-install \
  109. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  110. --delete-original \
  111. $RPM_BUILD_ROOT%{_datadir}/applications/ggl-$i.desktop
  112. done
  113. # wipe prematurely-generated MIME info
  114. rm -rf $RPM_BUILD_ROOT%{_datadir}/mime
  115. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
  116. %clean
  117. rm -rf $RPM_BUILD_ROOT
  118. %post
  119. /sbin/ldconfig
  120. touch --no-create %{_datadir}/icons/hicolor || :
  121. %postun
  122. /sbin/ldconfig
  123. if [ $1 -eq 0 ] ; then
  124. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  125. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  126. fi
  127. %posttrans
  128. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  129. %post gtk
  130. /sbin/ldconfig
  131. update-desktop-database &> /dev/null || :
  132. %postun gtk
  133. /sbin/ldconfig
  134. update-desktop-database &> /dev/null || :
  135. %post qt
  136. /sbin/ldconfig
  137. update-desktop-database &> /dev/null || :
  138. %postun qt
  139. /sbin/ldconfig
  140. update-desktop-database &> /dev/null || :
  141. %files
  142. %defattr(-,root,root,-)
  143. %doc AUTHORS COPYING README
  144. %{_libdir}/google-gadgets
  145. #%%exclude %{_libdir}/google-gadgets/gtkmoz-browser-child
  146. %exclude %{_libdir}/google-gadgets/modules/gtk*.so
  147. %exclude %{_libdir}/google-gadgets/modules/qt*.so
  148. %exclude %{_libdir}/google-gadgets/include
  149. %{_libdir}/lib*.so.*
  150. %exclude %{_libdir}/lib*gtk*
  151. %exclude %{_libdir}/lib*qt*
  152. %{_datadir}/google-gadgets
  153. %{_datadir}/pixmaps/google-gadgets.png
  154. %{_datadir}/icons/hicolor/*/*/*.png
  155. %files gtk
  156. %defattr(-,root,root,-)
  157. %{_bindir}/ggl-gtk
  158. %{_libdir}/libggadget-gtk*.so.*
  159. #%%{_libdir}/google-gadgets/gtkmoz-browser-child
  160. %{_libdir}/google-gadgets/modules/gtk*.so
  161. %{_datadir}/applications/*gtk.desktop
  162. %{_datadir}/applications/*designer.desktop
  163. %files qt
  164. %defattr(-,root,root,-)
  165. %{_bindir}/ggl-qt
  166. %{_libdir}/libggadget-qt*.so.*
  167. %{_libdir}/google-gadgets/modules/qt*.so
  168. %{_datadir}/applications/*qt.desktop
  169. %files devel
  170. %defattr(-,root,root,-)
  171. %{_includedir}/google-gadgets
  172. %{_libdir}/lib*.so
  173. %{_libdir}/google-gadgets/include
  174. %{_libdir}/pkgconfig/*.pc
  175. %changelog
  176. * Sat Dec 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.11.2-4
  177. - added Patch1, 2 and 3
  178. * Sat Aug 27 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-3
  179. - add patch for building with NetworkManager-0.9.0
  180. - add Vendor, Distribution and Packager tag
  181. * Thu Aug 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.11.2-2
  182. - not work with xulrunner 2.0, remove from BR.
  183. - add --disable-gtkmoz-browser-element , --disable-smjs-script-runtime
  184. * Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.2-1
  185. - new upstream release
  186. - built with rpm-4.8.1 for pkg-config
  187. - dropt Patch0
  188. - added BR: WebKit-gtk-devel
  189. - removed invalid MIME entry from .desktop files
  190. * Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.1-1
  191. - new upstream release
  192. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.0-2
  193. - Initial build for Vine Linux
  194. * Wed Jul 1 2009 Michel Salim <michel@erdos.localdomain> - 0.11.0-1
  195. - Update to 0.11.0
  196. * Sat May 2 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.6-0.1.20090430svn1449%{?dist}
  197. - Update to SVN checkout, for xulrunner 1.9.1 compatibility
  198. * Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-6
  199. - Rebuild against newer gecko
  200. * Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-4
  201. - Rebuild against newer gecko
  202. * Fri Mar 06 2009 Jan Horak <jhorak@redhat.com> - 0.10.5-3
  203. - Rebuild against newer gecko
  204. * Wed Feb 04 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-2
  205. - Rebuild against newer gecko
  206. * Wed Jan 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.10.5-1
  207. - 0.10.5, req'd by kde
  208. * Tue Dec 30 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.4-2
  209. - BR: Network-Manager-devel, startup-notification-devel
  210. - Pass the browser plugin directory to ./configure
  211. - Move designer desktop entry to -gtk subpackage
  212. * Sat Dec 20 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.4-1
  213. - Update to 0.10.4 (#477251)
  214. - -devel: Requires: %%name-gtk %%name-qt (devel symlinks)
  215. - BR: pkgconfig (automatic pkgconfig deps)
  216. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
  217. - Update to 0.10.3
  218. * Sat Nov 8 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.1-5
  219. - s/qt-devel/qt4-devel/
  220. - -qt: fix summary
  221. * Tue Sep 2 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-4
  222. - Unquote version strings in .pc files
  223. * Thu Aug 28 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-3
  224. - RPATH and timestamp fixes from Mamoru Tasaka
  225. * Tue Aug 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-2
  226. - Fix desktop file creation
  227. * Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-1
  228. - Update to 0.10.1
  229. * Mon Jul 14 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
  230. - Update to 0.10.0
  231. - Add missing dependencies for -devel subpackage
  232. * Sun Jul 6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.3-1
  233. - Update to 0.9.3
  234. * Fri Jun 6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.1-1
  235. - Initial package