commoncpp2-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. Summary: GNU Common C++ class framework
  2. Summary(ja): GNU 共通 C++ クラスフレームワーク
  3. Name: commoncpp2
  4. Version: 1.8.1
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+ with exceptions
  7. Group: System Environment/Libraries
  8. URL: http://www.gnu.org/software/commoncpp/
  9. Source0: https://ftp.gnu.org/gnu/commoncpp/commoncpp2-%{version}.tar.gz
  10. Patch1: commoncpp2-1.8.1-statfix.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libxml2-devel
  13. BuildRequires: zlib-devel
  14. BuildRequires: doxygen
  15. %description
  16. GNU Common C++ is a portable and highly optimized class framework for writing
  17. C++ applications that need to use threads, sockets, XML parsing,
  18. serialization, config files, etc. This framework offers a class foundation
  19. that hides platform differences from your C++ application so that you need
  20. not write platform specific code. GNU Common C++ has been ported to compile
  21. natively on most platforms which support posix threads.
  22. %package devel
  23. Summary: Header files and libraries for %{name} development
  24. Summary(ja): %{name} での開発に必要なヘッダファイルとライブラリ
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: pkgconfig
  28. Requires: libxml2-devel
  29. Requires: zlib-devel
  30. Requires(post): /sbin/install-info
  31. Requires(preun): /sbin/install-info
  32. %description devel
  33. The %{name}-devel package contains the header files and libraries needed
  34. to develop programs that use the %{name} library.
  35. %package doc
  36. Summary: Documents for the %{name} library
  37. Group: Documentation
  38. Requires: %{name} = %{version}-%{release}
  39. BuildArch: noarch
  40. %description doc
  41. The %{name}-doc package provide documents for zinnia library that
  42. use %{name}.
  43. %prep
  44. %setup -q
  45. #patch0 -p1
  46. %patch1 -p1
  47. %build
  48. %configure \
  49. --disable-static \
  50. --disable-dependency-tracking
  51. %{__make} #%%{?_smp_mflags} smp building disabled
  52. %install
  53. rm -rf $RPM_BUILD_ROOT
  54. make install DESTDIR=%{buildroot}
  55. rm -f %{buildroot}%{_infodir}/dir
  56. find %{buildroot} -name '*.la' -exec rm -f {} \;
  57. %clean
  58. rm -rf $RPM_BUILD_ROOT
  59. %post -p /sbin/ldconfig
  60. %post -n %{name}-devel
  61. /sbin/install-info %{_infodir}/commoncpp2.info %{_infodir}/dir || :
  62. %preun -n %{name}-devel
  63. if [ $1 = 0 ]; then
  64. /sbin/install-info --delete %{_infodir}/commoncpp2.info %{_infodir}/dir || :
  65. fi
  66. %postun -p /sbin/ldconfig
  67. %files
  68. %defattr(-,root,root,-)
  69. %doc COPYING README ChangeLog
  70. %{_libdir}/*.so.*
  71. %files devel
  72. %defattr(-,root,root,-)
  73. %dir %{_includedir}/cc++
  74. %{_includedir}/cc++/*
  75. %{_bindir}/ccgnu2-config
  76. %{_libdir}/*.so
  77. %{_libdir}/pkgconfig/libccext2.pc
  78. %{_libdir}/pkgconfig/libccgnu2.pc
  79. %{_datadir}/aclocal/ost_check2.m4
  80. %{_infodir}/commoncpp2.info*
  81. %files doc
  82. %defattr(-,root,root,-)
  83. %doc doc/html
  84. %changelog
  85. * Sun Dec 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.8.1-1
  86. - updated to 1.8.1
  87. - added Patch1 from FC
  88. - split documents into subpackage
  89. * Sun Jun 3 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.8.0-2
  90. - rebuilt with rpm-4.8.1-3
  91. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.8.0-1
  92. - Initial build for Vine Linux
  93. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.3-2
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  95. * Mon Apr 06 2009 Andreas Thienemann <andreas@bawue.net> - 1.7.3-1
  96. - Updated to new upstream version 1.7.3
  97. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-3
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  99. * Tue Jul 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-2
  100. - fix license tag
  101. * Wed Feb 06 2008 Andreas Thienemann <andreas@bawue.net> - 1.6.1-1
  102. - Updated to new upstream version 1.6.1
  103. - Reverted the ld-check patch as it's no longer needed
  104. * Fri Nov 10 2006 Andreas Thienemann <andreas@bawue.net> - 1.5.0-1
  105. - Updated package to 1.5.0
  106. * Sun May 28 2006 Andreas Thienemann <andreas@bawue.net> - 1.4.2-1
  107. - Updated to 1.4.2
  108. * Sun May 28 2006 Andreas Thienemann <andreas@bawue.net> - 1.4.1-1
  109. - Updated to 1.4.1
  110. * Sun Feb 05 2006 Andreas Thienemann <andreas@bawue.net> - 1.3.23-1
  111. - Incorporated suggestions for extras
  112. * Fri Feb 03 2006 Andreas Thienemann <andreas@bawue.net> - 1.3.22-1
  113. - Initial spec.