subversion-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493
  1. %define neon_version 0.25.5
  2. %define swig_version 1.3.29
  3. %define apache_dir /usr
  4. %define db_version 4.3.29
  5. %define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.7.6
  12. Release: 1%{?_dist_release}
  13. License: ASL 2.0
  14. Group: Development/Tools
  15. URL: http://subversion.apache.org/
  16. Packager: iwaim
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. SOURCE0: subversion-%{version}.tar.bz2
  20. SOURCE1: subversion.conf
  21. SOURCE2: httpd.davcheck.conf
  22. SOURCE3: filter-requires.sh
  23. Patch3: subversion-1.7.0-rpath.patch
  24. Requires: db4 >= %{db_version}
  25. Requires: expat
  26. Requires: neon >= %{neon_version}
  27. BuildRequires: apache2-devel
  28. BuildRequires: apr-devel, apr-util-devel
  29. BuildRequires: autoconf >= 2.53
  30. BuildRequires: db4-devel >= %{db_version}
  31. BuildRequires: expat-devel
  32. BuildRequires: gdbm-devel
  33. BuildRequires: libtool >= 1.4.2
  34. BuildRequires: neon-devel >= %{neon_version}
  35. BuildRequires: openssl-devel
  36. BuildRequires: python
  37. BuildRequires: python-devel
  38. BuildRequires: swig >= %{swig_version}
  39. BuildRequires: texinfo
  40. BuildRequires: zlib-devel
  41. BuildRequires: openldap-devel
  42. BuildRequires: ruby >= 1.8.2
  43. BuildRequires: ruby-devel >= 1.8.2
  44. BuildRequires: perl >= 5.8.0
  45. BuildRequires: sqlite3-devel
  46. BuildRequires: krb5-devel
  47. BuildRequires: keyutils-libs-devel
  48. BuildRequires: dbus-devel
  49. BuildRequires: libgnome-keyring-devel
  50. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  51. %define __perl_requires %{SOURCE3}
  52. %description
  53. Subversion is a concurrent version control system which enables one
  54. or more users to collaborate in developing and maintaining a
  55. hierarchy of files and directories while keeping a history of all
  56. changes. Subversion only stores the differences between versions,
  57. instead of every complete file. Subversion is intended to be a
  58. compelling replacement for CVS.
  59. %package devel
  60. Group: Development/Libraries
  61. Summary: Development package for Subversion developers.
  62. Requires: subversion = %{version}-%{release}
  63. Requires: apr-devel, apr-util-devel
  64. %description devel
  65. The subversion-devel package includes the static libraries and include files
  66. for developers interacting with the subversion package.
  67. %package mod_dav_svn
  68. Group: System Environment/Daemons
  69. Summary: Apache server module for Subversion server.
  70. Requires: httpd >= %{apache_version}
  71. Requires: subversion = %{version}-%{release}
  72. %description mod_dav_svn
  73. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  74. the Apache directories and configuration.
  75. %package tools
  76. Group: Development/Tools
  77. Summary: Tools for Subversion
  78. BuildRequires: perl >= 5.8.0
  79. Requires: perl >= 5.8.0
  80. Requires: subversion = %{version}-%{release}
  81. %description tools
  82. Tools for Subversion.
  83. %package perl
  84. Group: Development/Libraries
  85. Summary: Perl bindings to the Subversion libraries
  86. Requires: subversion = %{version}-%{release}
  87. Requires: perl >= 5.8.0
  88. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  89. %description perl
  90. This package includes the Perl bindings to the Subversion libraries.
  91. %package ruby
  92. Group: Development/Libraries
  93. Summary: Ruby bindings to the Subversion libraries
  94. Requires: subversion = %{version}-%{release}
  95. Requires: ruby >= 1.8.2
  96. %description ruby
  97. This package includes the Ruby bindings to the Subversion libraries.
  98. %package python
  99. Group: Development/Libraries
  100. Summary: Python bindings to the Subversion libraries
  101. Requires: subversion = %{version}-%{release}, python
  102. %description python
  103. This package includes the Python bindings to the Subversion libraries.
  104. %prep
  105. %setup -q
  106. %patch3 -p1 -b .rpath
  107. rm -rf neon apr apr-util db4
  108. %build
  109. ./autogen.sh
  110. # fix shebang lines, #111498
  111. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  112. # override weird -shrext from ruby
  113. export svn_cv_ruby_link="%{__cc} -shared"
  114. export svn_cv_ruby_sitedir_libsuffix=""
  115. export svn_cv_ruby_sitedir_archsuffix=""
  116. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
  117. export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
  118. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  119. --with-swig --with-neon=%{_prefix} \
  120. --with-ruby-sitedir=%{rarchdir} \
  121. --with-apxs=%{_bindir}/apxs \
  122. --with-gnome-keyring \
  123. --disable-mod-activation \
  124. --disable-static \
  125. --disable-neon-version-check
  126. # 1.3.0 tarball ships with generated swig sources
  127. make extraclean-swig-headers
  128. make %{?_smp_mflags} all
  129. make swig-py swig-py-lib %{swigdirs}
  130. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  131. %install
  132. echo %{rarchdir}
  133. rm -rf $RPM_BUILD_ROOT
  134. make install \
  135. install-swig-py \
  136. install-swig-pl-lib \
  137. install-swig-rb \
  138. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  139. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  140. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  141. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  142. # Add subversion.conf configuration file into httpd/conf.d directory.
  143. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  144. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  145. # Set up tools package files.
  146. mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
  147. cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
  148. # Remove unpackaged files
  149. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  150. $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
  151. $RPM_BUILD_ROOT%{_libdir}/*.la
  152. # remove stuff produced with Perl modules
  153. find $RPM_BUILD_ROOT -type f \
  154. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  155. -print0 | xargs -0 rm -f
  156. # make Perl modules writable so they get stripped
  157. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  158. xargs -0 chmod 755
  159. # unnecessary libraries for swig bindings
  160. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  161. # Remove unnecessary ruby libraries
  162. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  163. # Trim what goes in docdir
  164. rm -rf tools/*/*.in tools/test-scripts
  165. # Rename authz_svn INSTALL doc for docdir
  166. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  167. %clean
  168. rm -rf $RPM_BUILD_ROOT
  169. %post -p /sbin/ldconfig
  170. %postun -p /sbin/ldconfig
  171. %post tools -p /sbin/ldconfig
  172. %postun tools -p /sbin/ldconfig
  173. %files
  174. %defattr(-,root,root)
  175. %doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
  176. %doc subversion/LICENSE
  177. %{_bindir}/*
  178. %{_libdir}/libsvn_*.so.*
  179. %{_localedir}/*/*/subversion.mo
  180. %{_mandir}/man*/*
  181. %dir %{_sysconfdir}/subversion
  182. %exclude %{_mandir}/man*/*::*
  183. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  184. %exclude %{_libdir}/libsvn_swig_py*.so.*
  185. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  186. %files devel
  187. %defattr(-,root,root)
  188. %{_includedir}/subversion-1
  189. %{_libdir}/libsvn*.so
  190. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  191. %exclude %{_libdir}/libsvn_swig_py*.so.*
  192. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  193. %files mod_dav_svn
  194. %defattr(-,root,root)
  195. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  196. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  197. %files tools
  198. %defattr(-,root,root)
  199. %{_prefix}/lib/subversion/tools
  200. %files perl
  201. %defattr(-,root,root,-)
  202. %{perl_vendorarch}/auto/SVN
  203. %{perl_vendorarch}/SVN
  204. %{_libdir}/libsvn_swig_perl*
  205. %{_mandir}/man*/*::*
  206. %files ruby
  207. %defattr(-,root,root,-)
  208. %{_libdir}/libsvn_swig_ruby*
  209. %{rarchdir}/svn
  210. %files python
  211. %defattr(-,root,root,-)
  212. %{_libdir}/libsvn_swig_py*
  213. %{python_sitearch}/libsvn
  214. %{python_sitearch}/svn
  215. %changelog
  216. * Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
  217. - new upstream release
  218. - update License
  219. - update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
  220. - drop deplibs patch (Patch1)
  221. - drop obsolete patch files: Patch6, 10
  222. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  223. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  224. - add configure option with-gnome-keyring
  225. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  226. - fix Packager name
  227. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  228. - build with perl 5.12.3
  229. - add Requires: perl(:MODULE_COMPAT_...)
  230. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  231. - new upstream release with security fix
  232. - add Vendor/Distri tags
  233. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  234. - new upstream release
  235. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  236. - fix <BTS:VineLinux:941>
  237. - using rpm macro: rarchdir
  238. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  239. - using rpm macros: perl_vendorarch and python_sitearch
  240. - add BuildRequires: sqlite3-devel krb5-devel
  241. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  242. - new upstream release
  243. - update URL
  244. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  245. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  246. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  247. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  248. * Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  249. - new upstream release
  250. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  251. - new upstream release
  252. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  253. - rebuilt with python-2.5.2
  254. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  255. - new upstream release
  256. - rebuild with neon-0.28.2
  257. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  258. - added Patch6, 8, 9, 10 from Fedora Core
  259. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  260. - Correct install location of java stuff (#433295)
  261. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  262. - fix build with new glibc open()-as-macro
  263. - build all swig code in %%build, not %%install
  264. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  265. - build /usr/bin/* as PIEs
  266. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  267. - rebuild with expat-2.0.1
  268. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  269. - new upstream release
  270. - add Patch10 to build with neon.
  271. 1.3.2-0vl5 does not support neon..
  272. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  273. - rebuild with new neon
  274. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  275. - rebuilt with new toolchain and db4-4.3.x
  276. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  277. - modified %%files section for lib64 architecture
  278. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  279. - new upstream release
  280. - rebuild with new openldap-2.3.24
  281. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  282. - new upstream release
  283. - change Group to Develoment/Tools
  284. - build with apr-1.2.7/apr-util-1.2.7
  285. - require apr/apr-util instead of apache2-apr
  286. - build with swig-1.3.29
  287. - split {perl,python,ruby} related files to subpackage.
  288. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  289. - new upstream release
  290. - add noreplace option for config file
  291. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  292. - fix Requires and BuildPreReq.
  293. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  294. - new upstream release.
  295. - add swig-runtime to 'BuildPreReq:'.
  296. - fix %%files.
  297. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  298. - require neon version 0.24.7 for ra_dav
  299. - add BuildPreReq: openldap-devel
  300. - replace BuildPreReq: httpd to BuildPreReq: apache2
  301. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  302. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  303. - new upstream release
  304. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  305. - new upstream release
  306. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  307. - new upstream release
  308. - clean up specfile.
  309. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  310. - new upstream release
  311. - build with apache2-2.0.47
  312. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  313. - build Vine Linux
  314. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  315. - Enabled RA_DAV checking.
  316. Now requires httpd package to build because of RA_DAV tests.
  317. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  318. - Created tools package to hold the tools.
  319. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  320. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  321. version of APR/APR-UTILS as of 2003.01.15.
  322. - Added svnversion command.
  323. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  324. - Create a svnadmin.static which is copied to svnadmin-version-release
  325. when the package is erased, so users can still dump/load their repositories
  326. even after they have upgraded the RPM package.
  327. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  328. - SWIG now builds so we can use cvs2svn.
  329. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  330. - Made cvs2svn conditional (at least until we can get it to build consistently
  331. and work).
  332. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  333. - Added SWIG dependencies to add cvs2svn capabilities.
  334. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  335. - Now requires neon-0.22.0.
  336. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  337. - Took out loading mod_dav_svn from subversion.spec file and put it in
  338. subversion.conf file which goes into the apache conf directory.
  339. - Simplify what gets put into httpd.conf to only the include for the
  340. subversion.conf file.
  341. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  342. me to do this).
  343. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  344. - Updated to APR/APR-UTIL 2002-08-08.
  345. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  346. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  347. - Previous version had a few problems because of missing apache error/ files.
  348. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  349. - Updated to apache-2.0.40-0.3.
  350. - Updated to subversion-0.13.1-2318.
  351. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  352. - Updated for RedHat 7.3 (autoconf253).
  353. - Added a bunch of pre-requisites I didn't know were needed because I built a
  354. new machine that didn't have them already installed.
  355. - Fixed installation of man and info documentation pages.
  356. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  357. - Back to apache-libapr* stuff, hopefully to stay.
  358. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  359. - Fixed expat.patch to not have to make so many changes by writing a small
  360. shell script that changes libexpat to -lexpat.
  361. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  362. - Updated to neon-0.19.2.
  363. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  364. - Back to using apr and apr-util separately from apache.
  365. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  366. - Updated to APR and APR-UTIL 2002.02.11.
  367. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  368. - Took out a (now non-existant) documentation file.
  369. - Moved SPEC file changelog to after all package definitions.
  370. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  371. - Updated to neon-0.18.5.
  372. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  373. apache-apr-utils, and apache-apr-utils-devel.
  374. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  375. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  376. - Now builds without the separate APR package as it is built into and
  377. "exported" from apache-2.0.31-0.3.
  378. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  379. - Took out patches to install procedure now not required because of fixes
  380. in rev 1130.
  381. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  382. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  383. program was added.
  384. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  385. - Release M5-r340: Added the subversion-server package.
  386. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  387. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  388. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  389. - Release M3-r117: Initial Version.