cmake-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. # Set to bcond_with or use --without gui to disable qt4 gui build
  2. %bcond_without gui
  3. Name: cmake
  4. Summary: Cross-platform make system
  5. Summary(ja): クロスプラットフォームな Make システム
  6. Version: 2.8.3
  7. Release: 1%{?_dist_release}
  8. Group: Development/Tools
  9. License: BSD
  10. URL: http://www.cmake.org/
  11. Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
  12. Source1: macros.cmake
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. #BuildRequires: curl-devel
  15. #BuildRequires: expat-devel
  16. BuildRequires: libidn-devel
  17. BuildRequires: ncurses-devel
  18. BuildRequires: openssl-devel
  19. #BuildRequires: zlib-devel
  20. %if %{with gui}
  21. BuildRequires: qt4-devel, desktop-file-utils
  22. %define qt_gui --qt-gui
  23. %else
  24. %define qt_gui --no-qt-gui
  25. %endif
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %description
  29. CMake is used to control the software compilation process using simple
  30. platform and compiler independent configuration files. CMake generates
  31. native makefiles and workspaces that can be used in the compiler
  32. environment of your choice. CMake is quite sophisticated: it is possible
  33. to support complex environments requiring system configuration, pre-processor
  34. generation, code generation, and template instantiation.
  35. %package gui
  36. Summary: Qt GUI for %{name}
  37. Group: Development/Tools
  38. Requires: %{name} = %{version}-%{release}
  39. Requires(post): desktop-file-utils, shared-mime-info
  40. Requires(postun): desktop-file-utils, shared-mime-info
  41. %description gui
  42. The %{name}-gui package contains the Qt based GUI for CMake.
  43. %prep
  44. %setup -q
  45. # Fixup permissions
  46. find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
  47. %build
  48. ./bootstrap \
  49. --prefix=%{_prefix} \
  50. --datadir=/share/%{name} \
  51. --mandir=/share/man \
  52. --no-system-libs \
  53. %{?qt_gui}
  54. %if %{?_dist_release} == "vl5"
  55. sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
  56. %endif
  57. make VERBOSE=1 %{?_smp_mflags}
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. make install DESTDIR=$RPM_BUILD_ROOT
  61. find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  62. rm -rf $RPM_BUILD_ROOT/usr/doc
  63. # RPM macros
  64. install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  65. sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  66. touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  67. %if %{with gui}
  68. # Desktop file
  69. desktop-file-install --delete-original \
  70. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  71. $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
  72. %endif
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %if %{with gui}
  76. %post gui
  77. update-desktop-database &> /dev/null || :
  78. update-mime-database %{_datadir}/mime &> /dev/null || :
  79. %postun gui
  80. update-desktop-database &> /dev/null || :
  81. update-mime-database %{_datadir}/mime &> /dev/null || :
  82. %endif
  83. %files
  84. %defattr(-,root,root)
  85. %doc CMakeLogo.gif ChangeLog.* Copyright.txt
  86. %doc Docs/*
  87. %doc Example/
  88. %config(noreplace) %{_sysconfdir}/rpm/macros.cmake
  89. %{_bindir}/ccmake
  90. %{_bindir}/cmake
  91. %{_bindir}/cpack
  92. %{_bindir}/ctest
  93. %{_datadir}/%{name}/
  94. %{_mandir}/man1/*
  95. %if %{with gui}
  96. %files gui
  97. %defattr(-,root,root,-)
  98. %{_bindir}/cmake-gui
  99. %{_datadir}/applications/CMake.desktop
  100. %{_datadir}/mime/packages/cmakecache.xml
  101. %{_datadir}/pixmaps/CMakeSetup32.png
  102. %endif
  103. %changelog
  104. * Sat Jan 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
  105. - new upstream release
  106. - used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
  107. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  108. - fixed typo (not --with-system-libs, but --system-libs)
  109. - added BR: curl-devel, expat-devel, zlib-devel
  110. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  111. - add BuildRequires: ncurses-devel
  112. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  113. - generate gui package
  114. - renamed module directory
  115. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  116. - new upstream release
  117. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  118. - rebuilt with new toolchain
  119. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  120. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  121. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  122. - new upstream release
  123. - added Vendor/Distribution tag
  124. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  125. - new upstream release
  126. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  127. - new upstream release
  128. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  129. - new upstream release
  130. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  131. - new upstream release
  132. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  133. - new upstream release
  134. - drop Patch100
  135. - use bootstrap script instead of configure
  136. - delete caches from %%doc
  137. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  138. - rebuilt with new toolchain
  139. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  140. - new upstream release
  141. - delete duped docs
  142. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  143. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  144. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  145. - source version up
  146. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  147. - initial build for Vine Linux