llvm-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # Build options:
  3. # Components skipped by default:
  4. %bcond_with doxygen
  5. # Documentation install path
  6. %global llvmdocdir() %{_docdir}/%1-%{version}
  7. Name: llvm
  8. Version: 3.6.2
  9. Release: 2%{?_dist_release}
  10. Summary: The Low Level Virtual Machine
  11. Summary(ja): LLVM - 低レベルバーチャルマシン
  12. Group: Development/Languages
  13. License: NCSA
  14. URL: http://llvm.org/
  15. Source0: http://llvm.org/releases/%{version}/llvm-%{version}.src.tar.xz
  16. Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
  17. Source2: http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
  18. Source3: http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
  19. # multilib fixes
  20. Source10: llvm-Config-config.h
  21. Source11: llvm-Config-llvm-config.h
  22. # patches
  23. Patch1: llvm-3.5.0-build-fix.patch
  24. Patch2: 0001-data-install-preserve-timestamps.patch
  25. # newish glibc hides the definition of __extern_always_inline behind
  26. # a check for gcc 4.3, clang pretends to be gcc 4.2. a proper fix would
  27. # be to build everything herein with gcc, but i don't have the patience
  28. # atm, so in the interest of bootstrapping...
  29. Patch100: clang-fake-gcc43.patch
  30. # http://llvm.org/bugs/show_bug.cgi?id=22625
  31. Patch101: clang-pr22625.patch
  32. Patch200: lldb-python.patch
  33. Patch201: lldb-fix-expression-parser.patch
  34. Patch202: lldb-python-module-symlink.patch
  35. # Vine Patch
  36. Patch1000: clang-3.6.1-driver-ld.gold.patch
  37. Patch1001: clang-3.5.0-driver-lib64.patch
  38. Patch1002: clang-3.5.0-driver-vine.patch
  39. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  40. BuildRequires: binutils-devel
  41. BuildRequires: bison
  42. BuildRequires: chrpath
  43. BuildRequires: flex
  44. BuildRequires: gcc-c++ >= 3.4
  45. BuildRequires: groff
  46. BuildRequires: libffi-devel
  47. BuildRequires: libtool-ltdl-devel
  48. BuildRequires: libxml2-devel
  49. BuildRequires: ocaml-findlib
  50. BuildRequires: ocaml-ctypes
  51. BuildRequires: ocaml-ounit
  52. # for DejaGNU test suite
  53. BuildRequires: dejagnu tcl-devel python
  54. %if %{with doxygen}
  55. BuildRequires: doxygen graphviz
  56. %endif
  57. # pod2man
  58. BuildRequires: perl
  59. # lldb
  60. BuildRequires: swig
  61. BuildRequires: libedit-devel
  62. BuildRequires: python-devel >= 2.7
  63. Requires: llvm-libs = %{version}-%{release}
  64. # LLVM is not supported on PPC64
  65. # http://llvm.org/bugs/show_bug.cgi?id=3729
  66. ExcludeArch: ppc64
  67. %description
  68. LLVM is a compiler infrastructure designed for compile-time,
  69. link-time, runtime, and idle-time optimization of programs from
  70. arbitrary programming languages. The compiler infrastructure includes
  71. mirror sets of programming tools as well as libraries with equivalent
  72. functionality.
  73. %package devel
  74. Summary: Libraries and header files for LLVM
  75. Summary(ja): LLVM のライブラリおよびヘッダファイル
  76. Group: Development/Libraries
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: libstdc++-devel
  79. Requires: libffi-devel
  80. Provides: llvm-static = %{version}-%{release}
  81. %description devel
  82. This package contains library and header files needed to develop new
  83. native programs that use the LLVM infrastructure.
  84. %package doc
  85. Summary: Documentation for LLVM
  86. Summary(ja): LLVM のドキュメント
  87. Group: Documentation
  88. BuildArch: noarch
  89. Requires: %{name} = %{version}-%{release}
  90. # might seem redundant, but needed to kill off the old arch-ed -doc subpackage
  91. Obsoletes: %{name}-doc < %{version}-%{release}
  92. %description doc
  93. Documentation for the LLVM compiler infrastructure.
  94. %package libs
  95. Summary: LLVM shared libraries
  96. Summary(ja): LLVM 共有ライブラリ
  97. Group: System Environment/Libraries
  98. %description libs
  99. Shared libraries for the LLVM compiler infrastructure.
  100. %description libs -l ja
  101. LLVM コンパイラ基盤の共有ライブラリです.
  102. %package -n clang
  103. Summary: A C language family front-end for LLVM
  104. Summary(ja): LLVM の C 言語フロントエンド
  105. License: NCSA
  106. Group: Development/Languages
  107. Requires: %{name} = %{version}-%{release}
  108. # clang requires gcc, clang++ requires libstdc++-devel
  109. Requires: libstdc++-devel
  110. # remove clang-doc pacakge
  111. Obsoletes: clang-doc < %{version}-%{release}
  112. %description -n clang
  113. clang: noun
  114. 1. A loud, resonant, metallic sound.
  115. 2. The strident call of a crane or goose.
  116. 3. C-language family front-end toolkit.
  117. The goal of the Clang project is to create a new C, C++, Objective C
  118. and Objective C++ front-end for the LLVM compiler. Its tools are built
  119. as libraries and designed to be loosely-coupled and extensible.
  120. %Package -n clang-libs
  121. Summary: Runtime library for clang
  122. Summary(ja): Clang のランタイムライブラリ
  123. Group: System Environment/Libraries
  124. %description -n clang-libs
  125. Runtime library for clang.
  126. %description -n clang-libs -l ja
  127. Clang のランタイムライブラリです.
  128. %package -n clang-devel
  129. Summary: Header files for clang
  130. Summary(ja): Clang のヘッダファイル
  131. Group: Development/Libraries
  132. Requires: clang = %{version}-%{release}
  133. %description -n clang-devel
  134. This package contains header files for the Clang compiler.
  135. %description -n clang-devel -l ja
  136. Clang コンパイラのヘッダファイル集です.
  137. %package -n clang-analyzer
  138. Summary: A source code analysis framework
  139. Summary(ja): ソースコー分析フレームワーク
  140. License: NCSA
  141. Group: Development/Languages
  142. Requires: clang = %{version}-%{release}
  143. # not picked up automatically since files are currently not instaled
  144. # in standard Python hierarchies yet
  145. Requires: python
  146. %description -n clang-analyzer
  147. The Clang Static Analyzer consists of both a source code analysis
  148. framework and a standalone tool that finds bugs in C and Objective-C
  149. programs. The standalone tool is invoked from the command-line, and is
  150. intended to run in tandem with a build of a project or code base.
  151. #%package -n clang-doc
  152. #Summary: Documentation for Clang
  153. #Summary(ja): Clang のドキュメント
  154. #Group: Documentation
  155. #Requires: %{name} = %{version}-%{release}
  156. #
  157. #%description -n clang-doc
  158. #Documentation for the Clang compiler front-end.
  159. %package -n lldb
  160. Summary: Next generation high-performance debugger
  161. Summary(ja): 高性能デバッガー
  162. License: NCSA
  163. Group: Development/Debuggers
  164. Requires: %{name} = %{version}-%{release}
  165. %description -n lldb
  166. LLDB is a next generation, high-performance debugger. It is built as a set
  167. of reusable components which highly leverage existing libraries in the
  168. larger LLVM Project, such as the Clang expression parser and LLVM
  169. disassembler.
  170. %package -n lldb-devel
  171. Summary: Header files for LLDB
  172. Summary(ja): LLDB のヘッダファイル
  173. Group: Development/Libraries
  174. Requires: lldb = %{version}-%{release}
  175. %description -n lldb-devel
  176. This package contains header files for the LLDB debugger.
  177. %if %{with doxygen}
  178. %package apidoc
  179. Summary: API documentation for LLVM
  180. Summary(ja): LLVM の API ドキュメント
  181. Group: Documentation
  182. BuildArch: noarch
  183. Requires: %{name}-docs = %{version}-%{release}
  184. %description apidoc
  185. API documentation for the LLVM compiler infrastructure.
  186. %package -n clang-apidoc
  187. Summary: API documentation for Clang
  188. Summary(ja): Clang の API ドキュメント
  189. Group: Documentation
  190. BuildArch: noarch
  191. %description -n clang-apidoc
  192. API documentation for the Clang compiler.
  193. %endif
  194. %package ocaml
  195. Summary: OCaml binding for LLVM
  196. Summary(ja): LLVM の OCaml バインディング
  197. Group: System Environment/Libraries
  198. Requires: %{name} = %{version}-%{release}
  199. Requires: ocaml
  200. %description ocaml
  201. OCaml binding for LLVM.
  202. %package ocaml-devel
  203. Summary: Development files for %{name}-ocaml
  204. Summary(ja): %{name}-ocaml の開発ファイル
  205. Group: Development/Libraries
  206. Requires: %{name}-devel = %{version}-%{release}
  207. Requires: %{name}-ocaml = %{version}-%{release}
  208. Requires: ocaml
  209. %description ocaml-devel
  210. The %{name}-ocaml-devel package contains libraries and signature files
  211. for developing applications that use %{name}-ocaml.
  212. %package ocaml-doc
  213. Summary: Documentation for %{name}-ocaml
  214. Summary(ja): %{name}-ocaml のドキュメント
  215. Group: Documentation
  216. BuildArch: noarch
  217. Requires: %{name}-ocaml = %{version}-%{release}
  218. # might seem redundant, but needed to kill off the old arch-ed -doc subpackage
  219. Obsoletes: %{name}-ocaml-doc < %{version}-%{release}
  220. %description ocaml-doc
  221. HTML documentation for LLVM's OCaml binding.
  222. # compat32'
  223. %package -n compat32-%{name}-libs
  224. Summary: LLVM shared libraries
  225. Summary(ja): LLVM 共有ライブラリ
  226. Group: System Environment/Libraries
  227. Requires: %{name}-libs = %{version}-%{release}
  228. %description -n compat32-%{name}-libs
  229. Shared libraries for the LLVM compiler infrastructure.
  230. %prep
  231. %setup -q -a1 -a2 -a3 -n llvm-%{version}.src
  232. rm -rf tools/clang tools/lldb projects/compiler-rt
  233. mv cfe-%{version}.src tools/clang
  234. mv compiler-rt-%{version}.src projects/compiler-rt
  235. mv lldb-%{version}.src tools/lldb
  236. #patch1 -p1
  237. %patch2 -p1
  238. # clang
  239. #pushd tools/clang
  240. #%patch100 -p1
  241. #%patch101 -p0
  242. #popd
  243. # lldb
  244. pushd tools/lldb
  245. # careful when recreating this patch...
  246. %patch200 -p1 -b .python
  247. #patch201 -p2
  248. %patch202 -p1
  249. sed -i s/@lib@/%{_lib}/g scripts/Python/modules/readline/Makefile
  250. popd
  251. # Vine Linux
  252. %patch1000 -p1 -b .driver-ld.gold
  253. #%ifarch x86_64
  254. #%patch1001 -p1 -b .driver-lib64
  255. #%endif
  256. %patch1002 -p1 -b .driver-vine
  257. # fix library paths
  258. sed -i 's|/lib /usr/lib $lt_ld_extra|%{_libdir} $lt_ld_extra|' configure
  259. sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config.in
  260. sed -i 's|/lib\>|/%{_lib}/%{name}|g' tools/llvm-config/llvm-config.cpp
  261. %build
  262. # -fno-devirtualize shouldn't be necessary, but gcc has scary template-related
  263. # bugs that make it so. gcc 5 ought to be fixed.
  264. export CC=gcc
  265. export CXX=g++
  266. export CFLAGS="%{optflags} -DLLDB_DISABLE_PYTHON"
  267. export CXXFLAGS="%{optflags} -DLLDB_DISABLE_PYTHON"
  268. %configure \
  269. --with-extra-options="-fno-devirtualize" \
  270. --with-extra-ld-options=-Wl,-Bsymbolic \
  271. --libdir=%{_libdir}/%{name} \
  272. --disable-polly \
  273. --disable-libcpp \
  274. --enable-cxx11 \
  275. --enable-clang-arcmt \
  276. --enable-clang-static-analyzer \
  277. --enable-clang-rewriter \
  278. --enable-optimized \
  279. --disable-profiling \
  280. --disable-assertions \
  281. --disable-werror \
  282. --disable-expensive-checks \
  283. --enable-debug-runtime \
  284. --enable-keep-symbols \
  285. --enable-jit \
  286. --enable-docs \
  287. %if %{with doxygen}
  288. --enable-doxygen \
  289. %else
  290. --disable-doxygen \
  291. %endif
  292. --enable-threads \
  293. --enable-pthreads \
  294. --enable-zlib \
  295. --enable-pic \
  296. --enable-shared \
  297. --disable-embed-stdcxx \
  298. --enable-timestamps \
  299. --enable-backtraces \
  300. --enable-targets=x86,powerpc,arm,aarch64,cpp,nvptx,systemz,r600 \
  301. --enable-bindings=ocaml \
  302. --enable-libffi \
  303. --enable-ltdl-install \
  304. \
  305. %ifarch armv7hl armv7l
  306. --with-cpu=cortex-a8 \
  307. --with-tune=cortex-a8 \
  308. --with-arch=armv7-a \
  309. --with-float=hard \
  310. --with-fpu=vfpv3-d16 \
  311. --with-abi=aapcs-vfp \
  312. %endif
  313. \
  314. --with-binutils-include=%{_includedir} \
  315. --with-c-include-dirs=%{_includedir}:$(echo %{_prefix}/lib/gcc/%{_target_cpu}*/*/include) \
  316. --with-optimize-option=-O3
  317. # --datadir=%{_libdir}/%{name} \
  318. # --enable-experimental-targets=R600 \
  319. make %{?_smp_mflags} REQUIRES_RTTI=1 VERBOSE=1
  320. %install
  321. rm -rf %{buildroot}
  322. make install DESTDIR=%{buildroot} \
  323. PROJ_docsdir=/moredocs
  324. # you have got to be kidding me
  325. rm -f %{buildroot}%{_bindir}/{FileCheck,count,not,verify-uselistorder,obj2yaml,yaml2obj}
  326. # multilib fixes
  327. mv %{buildroot}%{_bindir}/llvm-config{,-%{__isa_bits}}
  328. pushd %{buildroot}%{_includedir}/llvm/Config
  329. mv config.h config-%{__isa_bits}.h
  330. cp -p %{SOURCE10} config.h
  331. mv llvm-config.h llvm-config-%{__isa_bits}.h
  332. cp -p %{SOURCE11} llvm-config.h
  333. popd
  334. # Create ld.so.conf.d entry
  335. mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
  336. cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
  337. %{_libdir}/%{name}
  338. EOF
  339. # Static analyzer not installed by default:
  340. # http://clang-analyzer.llvm.org/installation#OtherPlatforms
  341. # scan-view
  342. mkdir -p %{buildroot}%{_libexecdir}/clang-analyzer/
  343. cp -pr tools/clang/tools/scan-view %{buildroot}%{_libexecdir}/clang-analyzer/
  344. # scan-build
  345. mkdir -p %{buildroot}%{_libexecdir}/clang-analyzer/scan-build
  346. for file in c++-analyzer ccc-analyzer scan-build scanview.css sorttable.js; do
  347. cp -p tools/clang/tools/scan-build/$file \
  348. %{buildroot}%{_libexecdir}/clang-analyzer/scan-build/
  349. done
  350. # scan-build manual page
  351. mkdir -p %{buildroot}%{_mandir}/man1
  352. cp -p tools/clang/tools/scan-build/scan-build.1 %{buildroot}%{_mandir}/man1/
  353. # scan-build requires clang in search path
  354. ln -s ../../../bin/clang %{buildroot}%{_libexecdir}/clang-analyzer/scan-build/clang
  355. # launchers in /bin
  356. for f in scan-{build,view}; do
  357. ln -s %{_libexecdir}/clang-analyzer/$f/$f %{buildroot}%{_bindir}/$f
  358. done
  359. # Get rid of erroneously installed example files.
  360. rm %{buildroot}%{_libdir}/%{name}/*LLVMHello.*
  361. # remove executable bit from static libraries
  362. find %{buildroot}%{_libdir} -name "*.a" -type f -print0 | xargs -0 chmod -x
  363. # Install man page for LLDB
  364. mkdir -p %{buildroot}%{_mandir}/man1
  365. cp tools/lldb/docs/lldb.1 %{buildroot}%{_mandir}/man1/
  366. # Install documentation documentation
  367. find %{buildroot}/moredocs/ -name "*.tar.gz" -print0 | xargs -0 rm -rf
  368. mkdir -p %{buildroot}%{_docdir}
  369. # llvm-doc
  370. mkdir -p %{buildroot}%{llvmdocdir %{name}-doc}
  371. cp -ar examples %{buildroot}%{llvmdocdir %{name}-doc}/examples
  372. find %{buildroot}%{llvmdocdir %{name}-doc} -name Makefile -o -name CMakeLists.txt -o -name LLVMBuild.txt -print0 | xargs -0 rm -f
  373. # llvm-apidoc
  374. %if %{with doxygen}
  375. mv %{buildroot}/moredocs/html/doxygen %{buildroot}%{llvmdocdir %{name}-apidoc}
  376. %endif
  377. # llvm-ocaml-doc
  378. #mv %{buildroot}/moredocs/ocamldoc/html %{buildroot}%{llvmdocdir %{name}-ocaml-doc}
  379. # clang
  380. mkdir -p %{buildroot}%{llvmdocdir clang}
  381. for f in LICENSE.TXT NOTES.txt README.txt CODE_OWNERS.TXT; do
  382. cp tools/clang/$f %{buildroot}%{llvmdocdir clang}/
  383. done
  384. # clang-apidoc
  385. %if %{with doxygen}
  386. cp -ar tools/clang/docs/doxygen/html %{buildroot}%{llvmdocdir clang-apidoc}
  387. %endif
  388. # lldb
  389. mkdir -p %{buildroot}%{llvmdocdir lldb}
  390. cp tools/lldb/LICENSE.TXT %{buildroot}%{llvmdocdir lldb}/
  391. # delete the rest of installed documentation (because it's bad)
  392. rm -rf %{buildroot}/moredocs
  393. # install CMake modules
  394. mkdir -p %{buildroot}%{_datadir}/llvm/cmake/
  395. cp -p cmake/modules/*.cmake %{buildroot}%{_datadir}/llvm/cmake/
  396. # remove RPATHs
  397. file %{buildroot}/%{_bindir}/* | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
  398. file %{buildroot}/%{_libdir}/%{name}/*.so | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
  399. %check
  400. # the || : is wrong, i know, but the git snaps fail to make check due to
  401. # broken makefiles in the doc dirs.
  402. make check LIT_ARGS="-v -j4" | tee llvm-testlog.txt ||:
  403. make -C tools/clang/test TESTARGS="-v -j4" | tee clang-testlog.txt ||:
  404. %clean
  405. rm -rf %{buildroot}
  406. %post libs -p /sbin/ldconfig
  407. %postun libs -p /sbin/ldconfig
  408. %post -n clang-libs -p /sbin/ldconfig
  409. %postun -n clang-libs -p /sbin/ldconfig
  410. %post -n lldb -p /sbin/ldconfig
  411. %postun -n lldb -p /sbin/ldconfig
  412. %posttrans devel
  413. # link llvm-config to the platform-specific file;
  414. # use ISA bits as priority so that 64-bit is preferred
  415. # over 32-bit if both are installed
  416. alternatives \
  417. --install \
  418. %{_bindir}/llvm-config \
  419. llvm-config \
  420. %{_bindir}/llvm-config-%{__isa_bits} \
  421. %{__isa_bits}
  422. %postun devel
  423. if [ $1 -eq 0 ]; then
  424. alternatives --remove llvm-config \
  425. %{_bindir}/llvm-config-%{__isa_bits}
  426. fi
  427. exit 0
  428. %files
  429. %defattr(-,root,root,-)
  430. %doc CREDITS.TXT README.txt
  431. %{_bindir}/bugpoint
  432. %{_bindir}/llc
  433. %{_bindir}/lli
  434. %{_bindir}/lli-child-target
  435. %exclude %{_bindir}/llvm-config-%{__isa_bits}
  436. %{_bindir}/llvm*
  437. %{_bindir}/macho-dump
  438. %{_bindir}/opt
  439. %dir %{_datadir}/llvm
  440. %exclude %{_mandir}/man1/clang.1.*
  441. %exclude %{_mandir}/man1/scan-build.1.*
  442. %exclude %{_mandir}/man1/lldb.1.*
  443. %doc %{_mandir}/man1/*.1.*
  444. %files devel
  445. %defattr(-,root,root,-)
  446. #doc %{llvmdocdir %{name}-devel}/
  447. %{_bindir}/llvm-config-%{__isa_bits}
  448. %{_includedir}/%{name}
  449. %{_includedir}/%{name}-c
  450. %{_libdir}/%{name}/*.a
  451. %{_datadir}/%{name}/cmake
  452. %files libs
  453. %defattr(-,root,root,-)
  454. %doc LICENSE.TXT
  455. %config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
  456. %dir %{_libdir}/%{name}
  457. %exclude %{_libdir}/%{name}/libclang.so
  458. %exclude %{_libdir}/%{name}/liblldb.so
  459. %{_libdir}/%{name}/*.so
  460. %files -n clang
  461. %defattr(-,root,root,-)
  462. %doc %{llvmdocdir clang}/
  463. %{_bindir}/clang*
  464. %{_bindir}/c-index-test
  465. %{_prefix}/lib/clang
  466. %doc %{_mandir}/man1/clang.1.*
  467. %files -n clang-libs
  468. %defattr(-,root,root,-)
  469. %{_libdir}/%{name}/libclang.so
  470. %files -n clang-devel
  471. %defattr(-,root,root,-)
  472. #doc %{llvmdocdir clang-devel}/
  473. %{_includedir}/clang
  474. %{_includedir}/clang-c
  475. %files -n clang-analyzer
  476. %defattr(-,root,root,-)
  477. %{_bindir}/scan-build
  478. %{_bindir}/scan-view
  479. %{_libexecdir}/clang-analyzer
  480. %{_mandir}/man1/scan-build.1.*
  481. %files -n lldb
  482. %defattr(-,root,root,-)
  483. %doc %{llvmdocdir lldb}/
  484. %{_bindir}/lldb
  485. %{_bindir}/lldb-*
  486. %{_libdir}/%{name}/liblldb.so
  487. # XXX double check this
  488. #{python_sitearch}/*
  489. %doc %{_mandir}/man1/lldb.1.*
  490. %files -n lldb-devel
  491. %defattr(-,root,root,-)
  492. %{_includedir}/lldb
  493. %files doc
  494. %defattr(-,root,root,-)
  495. %doc %{llvmdocdir %{name}-doc}/
  496. %files ocaml
  497. %defattr(-,root,root,-)
  498. %{_libdir}/ocaml/*.cma
  499. %{_libdir}/ocaml/*.cmi
  500. %{_libdir}/ocaml/*.so
  501. %{_libdir}/ocaml/META.llvm*
  502. %files ocaml-devel
  503. %defattr(-,root,root,-)
  504. %{_libdir}/ocaml/*.a
  505. %{_libdir}/ocaml/*.cmx*
  506. %{_libdir}/ocaml/*.mli
  507. %files ocaml-doc
  508. %defattr(-,root,root,-)
  509. #doc %{llvmdocdir %{name}-ocaml-doc}/
  510. %if 0%{?_with_doxygen}
  511. %files apidoc
  512. %defattr(-,root,root,-)
  513. %doc %{llvmdocdir %{name}-apidoc}/
  514. %files -n clang-apidoc
  515. %defattr(-,root,root,-)
  516. %doc %{llvmdocdir clang-apidoc}/
  517. %endif
  518. %if %{build_compat32}
  519. %files -n compat32-%{name}-libs
  520. %defattr(-,root,root)
  521. %doc LICENSE.TXT
  522. %config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
  523. %dir %{_libdir}/%{name}
  524. %exclude %{_libdir}/%{name}/libclang.so
  525. %exclude %{_libdir}/%{name}/liblldb.so
  526. %{_libdir}/%{name}/*.so
  527. %endif
  528. %changelog
  529. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  530. - rebuild with gcc-5.4.0
  531. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  532. - new upstream release
  533. - added BR: ocaml-ctypes
  534. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  535. - new upstream release
  536. - dropt Patch 1, 201 and 1001
  537. - updated Patch 1000
  538. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  539. - updated to 3.5.1
  540. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  541. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  542. - obsoleted clang-doc
  543. - built with ocaml 4.02.1
  544. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  545. - fix <BTS:2832>
  546. - fix configure option "--with-c-include-dirs"
  547. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  548. - update Patch1001: clang-3.5.0-driver-lib64.patch
  549. - update Patch1002: clang-3.5.0-driver-vine.patch
  550. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  551. - update to 3.5.0
  552. - remove Patch11 (clang-hardfloat-hack.patch)
  553. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  554. - rebuild with libffi-3.0.13
  555. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  556. - update to 3.3
  557. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  558. - ld.gold (patch1000,1001)
  559. - add /%{_lib} to ld search path
  560. - add support *-vine-linux gcc (patch1002)
  561. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  562. - update to 3.1
  563. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  564. - updated to 3.0 release
  565. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  566. - added patch 2-4 to support -O4 link-time optimization
  567. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  568. - disable -fno-var-tracking-assignments on ppc
  569. (seems like gcc-4.4.5 still doesn't support this)
  570. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  571. - new upstream release
  572. - add BR: libffi-devel
  573. - add R: libffi-devel to -devel
  574. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  575. - initial build for Vine Linux
  576. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  577. - Update to final 2.7 release
  578. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  579. - Update to first 2.7 pre-release
  580. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  581. - Update to 2.6 pre-release2
  582. - -devel subpackage now virtually provides -static
  583. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  584. - Disable var tracking assignments on PPC
  585. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  586. - Don't adjust clang include dir; files there are noarch (bz#521893)
  587. - Enable clang unit tests
  588. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  589. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  590. - Package Clang's static analyzer tools
  591. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  592. - PIC is now enabled by default; explicitly disable on %%{ix86}
  593. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  594. - First 2.6 prerelease
  595. - Enable Clang front-end
  596. - Enable debuginfo generation
  597. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  598. - Disable assertions (needed by OpenGTL, bz#521261)
  599. - Align spec file with upstream build instructions
  600. - Enable unit tests
  601. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  602. - Only disable PIC on %%ix86; ppc actually needs it
  603. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  604. - Disable use of position-independent code on 32-bit platforms
  605. (buggy in LLVM <= 2.5)
  606. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  607. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  608. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  609. - Remove build scripts; they require the build directory to work
  610. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  611. - Update to 2.5
  612. - Package build scripts (bug #457881)
  613. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  614. - Patched build process for the OCaml binding
  615. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  616. - Update to 2.4
  617. - Package Ocaml binding
  618. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  619. - Add dependency on groff
  620. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  621. - LLVM 2.3
  622. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  623. - fix license tags
  624. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  625. - Fix compilation problems with gcc 4.3
  626. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  627. - Autorebuild for GCC 4.3
  628. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  629. - Fix review comments
  630. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  631. - Initial version