gnome-shell-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186
  1. %define pkg_version 3.1.90.1
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. # settings for Vine
  9. Patch101: gnome-shell-vine-settings.patch
  10. Patch102: gnome-shell-vine-customize.patch
  11. Patch103: gnome-shell-3.1.90.1-ja.po.patch
  12. License: GPLv2+
  13. Group: User Interface/Desktops
  14. URL: http://live.gnome.org/GnomeShell
  15. Requires(post,postun): scrollkeeper >= 0.1.4
  16. Requires(post,pre,preun): GConf2 >= 2.14
  17. Requires: mutter
  18. Requires: caribou
  19. BuildRequires: gnome-common
  20. BuildRequires: libtool
  21. BuildRequires: automake
  22. BuildRequires: autoconf
  23. BuildRequires: pkgconfig
  24. BuildRequires: gtk2-devel
  25. BuildRequires: clutter-devel
  26. BuildRequires: mutter-devel
  27. BuildRequires: gjs-devel
  28. BuildRequires: gnome-desktop3-devel
  29. BuildRequires: gnome-menus-devel
  30. BuildRequires: libSM-devel
  31. BuildRequires: libffi-devel
  32. BuildRequires: GConf2-devel
  33. BuildRequires: startup-notification-devel
  34. BuildRequires: gnome-doc-utils
  35. BuildRequires: desktop-file-utils
  36. BuildRequires: libcroco-devel
  37. BuildRequires: librsvg2-devel
  38. BuildRequires: gobject-introspection-devel
  39. BuildRequires: gstreamer-devel
  40. BuildRequires: dbus-glib-devel
  41. BuildRequires: telepathy-logger-devel
  42. BuildRequires: polkit-devel
  43. BuildRequires: pulseaudio-libs-devel
  44. BuildRequires: evolution-data-server-devel
  45. BuildRequires: folks-devel
  46. BuildRequires: NetworkManager-glib-devel
  47. BuildRequires: intltool
  48. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  49. Vendor: Project Vine
  50. Distribution: Vine Linux
  51. Packager: Takemikaduchi
  52. %description
  53. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  54. It provides core interface functions like switching to windows and launching
  55. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  56. hardware and introduces innovative user interface concepts to provide a delightful
  57. and easy to use experience.
  58. %prep
  59. %setup -q
  60. %patch101 -p1 -b .vine
  61. %patch102 -p1 -b .vine
  62. %patch103 -p1 -b .old_po
  63. %build
  64. libtoolize --copy --force
  65. autoreconf
  66. %configure --disable-static
  67. %{__make} %{?_smp_mflags}
  68. %install
  69. %{__rm} -rf ${RPM_BUILD_ROOT}
  70. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  71. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  72. %find_lang %{name}
  73. %clean
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %post
  76. /sbin/ldconfig
  77. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  78. gconftool-2 --makefile-install-rule \
  79. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  80. > /dev/null || :
  81. touch --no-create %{_datadir}/icons/hicolor
  82. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  83. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  84. fi
  85. %pre
  86. if [ "$1" -gt 1 ]; then
  87. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  88. gconftool-2 --makefile-uninstall-rule \
  89. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  90. > /dev/null || :
  91. fi
  92. %preun
  93. if [ "$1" -eq 0 ]; then
  94. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  95. gconftool-2 --makefile-uninstall-rule \
  96. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  97. > /dev/null || :
  98. fi
  99. %postun
  100. scrollkeeper-update -q || :
  101. /sbin/ldconfig
  102. touch --no-create %{_datadir}/icons/hicolor
  103. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  104. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  105. fi
  106. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  107. %posttrans
  108. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  109. %files -f %{name}.lang
  110. %defattr(-,root,root)
  111. %doc COPYING NEWS README
  112. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
  113. %{_bindir}/gnome-shell
  114. %{_bindir}/gnome-shell-extension-tool
  115. %{_libdir}/gnome-shell/*
  116. %{_libexecdir}/gnome-shell-calendar-server
  117. %{_libexecdir}/gnome-shell-hotplug-sniffer
  118. %{_libexecdir}/gnome-shell-perf-helper
  119. %{_datadir}/applications/gnome-shell.desktop
  120. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  121. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  122. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  123. %{_datadir}/gnome-shell/*
  124. %{_datadir}/man/man1/*.1.gz
  125. %changelog
  126. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  127. - new upstream release
  128. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  129. - add Requires: caribou
  130. - remove Patch0
  131. - update Patch101
  132. - update Patch102
  133. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  134. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  135. - rebuild with gnome-menus-3.1.5
  136. - add Patch0 (gnome-shell-git20110821.patch)
  137. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  138. - new upstream release
  139. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  140. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  141. - remove BuildRequires: xulrunner-devel
  142. - add Patch101 (gnome-shell-vine-settings.patch)
  143. - add Patch102 (gnome-shell-vine-customize.patch)
  144. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  145. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  146. - add Requires: mutter
  147. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  148. - new upstream release
  149. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  150. - initial build for Vine Linux