libmicrohttpd-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194
  1. Summary: Lightweight library for embedding a webserver in applications
  2. Name: libmicrohttpd
  3. Version: 0.9.70
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: LGPLv2+
  9. URL: https://www.gnu.org/software/libmicrohttpd/
  10. Source0: https://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: autoconf, automake, libtool
  13. BuildRequires: curl-devel
  14. BuildRequires: gnutls-devel
  15. BuildRequires: libgcrypt-devel
  16. BuildRequires: openssl-devel
  17. BuildRequires: zlib-devel
  18. BuildRequires: graphviz
  19. BuildRequires: doxygen
  20. Requires(post): info
  21. Requires(preun): info
  22. %description
  23. GNU libmicrohttpd is a small C library that is supposed to make it
  24. easy to run an HTTP server as part of another application.
  25. Key features that distinguish libmicrohttpd from other projects are:
  26. * C library: fast and small
  27. * API is simple, expressive and fully reentrant
  28. * Implementation is http 1.1 compliant
  29. * HTTP server can listen on multiple ports
  30. * Support for IPv6
  31. * Support for incremental processing of POST data
  32. * Creates binary of only 25k (for now)
  33. * Three different threading models
  34. %package devel
  35. Summary: Development files for libmicrohttpd
  36. Summary(ja): libmicrohttpd の開発用ファイル
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. %description devel
  40. Development files for libmicrohttpd
  41. %package doc
  42. Summary: Documentation for libmicrohttpd
  43. Summary(ja): libmicrohttpd のドキュメント
  44. Group: Documentation
  45. Buildarch: noarch
  46. Requires: %{name} = %{version}-%{release}
  47. %description doc
  48. Doxygen documentation for libmicrohttpd and some example source code
  49. %prep
  50. %setup -q
  51. %build
  52. %configure --disable-static --with-gnutls
  53. make %{?_smp_mflags}
  54. make full -C doc/doxygen
  55. # Disabled for now due to problems reported at
  56. # https://gnunet.org/bugs/view.php?id=1619
  57. #check
  58. #make check %{?_smp_mflags}
  59. %install
  60. rm -rf %{buildroot}
  61. make install DESTDIR=%{buildroot}
  62. rm -f %{buildroot}%{_libdir}/libmicrohttpd.la
  63. rm -f %{buildroot}%{_libdir}/libmicrospdy.la
  64. rm -f %{buildroot}%{_infodir}/dir
  65. # Install some examples in /usr/share/doc/libmicrohttpd-${version}/examples
  66. rm -rf examples
  67. mkdir -p examples
  68. install -m 644 src/examples/*.c examples
  69. # Install the doxygen documentation in /usr/share/doc/libmicrohttpd-${version}/html
  70. rm -rf html
  71. cp -R doc/doxygen/html .
  72. %clean
  73. rm -rf %{buildroot}
  74. %post -p /sbin/ldconfig
  75. %postun -p /sbin/ldconfig
  76. %post doc
  77. /sbin/install-info %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
  78. /sbin/install-info %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
  79. %preun doc
  80. if [ $1 = 0 ] ; then
  81. /sbin/install-info --delete %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
  82. /sbin/install-info --delete %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
  83. fi
  84. %files
  85. %defattr(-,root,root,-)
  86. %license COPYING
  87. %{_libdir}/libmicro*.so.*
  88. %files devel
  89. %defattr(-,root,root,-)
  90. %{_includedir}/micro*.h
  91. %{_libdir}/libmicro*.so
  92. %{_libdir}/pkgconfig/libmicro*.pc
  93. %files doc
  94. %doc AUTHORS README ChangeLog
  95. %doc examples
  96. %doc html
  97. %defattr(-,root,root,-)
  98. %{_mandir}/man3/libmicrohttpd.3.gz
  99. %{_infodir}/libmicrohttpd.info.gz
  100. %{_infodir}/libmicrohttpd_performance_data.png.gz
  101. %{_infodir}/libmicrohttpd-tutorial.info.gz
  102. %changelog
  103. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.70-1
  104. - rebuilt with current environment.
  105. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.39-2
  106. - rebuild with openssl-1.0.2
  107. * Mon Jan 12 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.39-1
  108. - updated to 0.9.39
  109. - built with libgcrypt 1.6.0 and gnutls 3.2.20
  110. * Mon Jan 17 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9.2-1
  111. - initial build for Vine Linux based on fedora development
  112. * Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-3
  113. - Add missing BR gnutls-devel and libgcrypt-devel
  114. - Added patch to fix test apps (NSS instead of GnuTLS/OpenSSL curl,
  115. implicit DSO linking)
  116. - Disable test cases for now due to false errors, reported upstream
  117. * Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-2
  118. - Re-enable HTTPS, configure flags had unexpected result
  119. * Sun Nov 7 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-1
  120. - Update to 0.9.2
  121. * Fri Jun 4 2010 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.6-1
  122. - Update to 0.4.6
  123. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  125. * Tue Jul 21 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.2-1
  126. - Update to version 0.4.2
  127. - Drop upstreamed patch
  128. * Fri Feb 27 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0a-1
  129. - Update to version 0.4.0a
  130. - Drop upstreamed patch
  131. - Added a new patch to fix a 64bit issue
  132. - The -devel package now contains a pkgconfig file
  133. - The configure script is now run with '--enable-messages --enable-https'
  134. - Made the -doc subpackage noarch (F11+)
  135. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  137. * Sat Feb 14 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0-1
  138. - Update to version 0.4.0
  139. - This version introduces a API bump (which is required for
  140. supporting large files on 32bit environments)
  141. - The license issues we had with version 0.3.1 of this package (as
  142. discussed in #457924) are resolved in this version. The license
  143. of this package is now changed to LGPLv2+
  144. - Added a patch to fix two testcases on 64bit environments (upstream bug #1454)
  145. * Sat Sep 6 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-3
  146. - Changed license to GPLv3+ and added some comments
  147. regarding the license issues with this package
  148. * Sun Aug 10 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-2
  149. - Changed license to LGPLv2+
  150. - Moved the COPYING file to the main package
  151. * Tue Aug 5 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-1
  152. - Initial release