123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150 |
- %define svndate 20100411
- %define mono_dir %{_prefix}/lib/mono
- %define monodoc_dir %{_prefix}/lib/monodoc
- Name: notify-sharp
- Version: 0.4.0
- Release: 9.%{svndate}svn%{?_dist_release}
- Summary: A C# implementation for Desktop Notifications
- Summary(ja): デスクトップ通知の C# による実装
- Group: System Environment/Libraries
- License: MIT
- URL: http://trac.galago-project.org/wiki/DesktopNotifications
- #svn checkout, revision 3032. To reproduce tarball:
- #svn co -r 3032 http://svn.galago-project.org/trunk/notify-sharp notify-sharp-20100411 && tar -cvjf notify-sharp-20100411.tar.bz2 notify-sharp-20100411
- Source0: %{name}-%{svndate}.tar.bz2
- #use dbus-sharp instead of deprecated ndesk-dbus
- #patch is a modifed version of https://build.opensuse.org/package/view_file?file=notify-sharp-use-dbus-sharp.patch&package=notify-sharp&project=Mono%3ACleanup
- Patch0: notify-sharp-0.4.0-use-dbus-sharp.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: mono-devel, gtk-sharp2-devel, gnome-sharp2-devel
- BuildRequires: dbus-sharp-glib-devel
- BuildRequires: autoconf, automake, libtool
- BuildRequires: monodoc-devel
- Packager: kazutaka
- %description
- notify-sharp is a C# client implementation for Desktop Notifications,
- i.e. notification-daemon. It is inspired by the libnotify API.
- Desktop Notifications provide a standard way of doing passive pop-up
- notifications on the Linux desktop. These are designed to notify the
- user of something without interrupting their work with a dialog box
- that they must close. Passive popups can automatically disappear after
- a short period of time.
- %package devel
- Summary: Development files for notify-sharp
- Summary(ja): notify-sharp の開発用ファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: pkgconfig
- %description devel
- Development files for notify-sharp
- %package doc
- Summary: Documention files for notify-sharp
- Summary(ja): notify-sharp のドキュメント
- Group: Documentation
- Requires: %{name} = %{version}-%{release}
- Requires: monodoc
- %description doc
- Documentation files for notify-sharp
- %prep
- %setup -qn %{name}-%{svndate}
- %patch0 -p1 -b .use_dbus_sharp
- sed -i -e 's|dbus-sharp-1\.0|dbus-sharp-2\.0|g' configure.ac
- sed -i -e 's|dbus-sharp-glib-1\.0|dbus-sharp-glib-2\.0|g' configure.ac
- #sed -i -e 's!${exec_prefix}/lib!%{_prefix}/lib!' notify-sharp.pc.in
- %build
- autoreconf --install
- %configure --libdir=%{_prefix}/lib
- make
- %install
- rm -rf ${RPM_BUILD_ROOT}
- make install DESTDIR=${RPM_BUILD_ROOT} pkgconfigdir=%{_libdir}/pkgconfig
- %clean
- rm -rf ${RPM_BUILD_ROOT}
- %files
- %defattr(-,root,root,-)
- %doc COPYING NEWS README AUTHORS
- %{mono_dir}/gac/notify-sharp/
- %{mono_dir}/notify-sharp/notify-sharp.dll
- %files devel
- %defattr(-,root,root,-)
- %{_libdir}/pkgconfig/notify-sharp.pc
- %files doc
- %defattr(-,root,root,-)
- %{monodoc_dir}/sources/*
- %changelog
- * Tue Mar 31 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.0-9.20100411svn
- - updated to source as of 20100411
- - added Patch0
- - added BR: dbus-sharp-glib-devel instead of ndesk-dbus-glib
- - built with mono 3.12.1
- * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.0-8.20080912svn
- - rebuild with VineSeed environment
- * Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 0.4.0-7.20080912svn
- - rebuilt with mono-2.10.1-3
- * Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 0.4.0-6.20080912svn
- - rebuilt with mono-2.10.1
- * Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-5.20080912svn
- - rebuilt with mono-2.8
- * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-4.20080912svn
- - rebuilt with rpm-4.8.1 for pkg-config
- * Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-3.20080912svn
- - rebuild with latest rpm to update mono-dependencies
- * Sat Jun 13 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.0-2.20080912svn
- - added mono_dir, monodoc_dir macros
- - added --libdir=%%{_prefix}/lib option to %%configure
- - added pkgconfigdir=%%{_libdir}/pkgconfig option to make install
- * Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.0-1.20080912svn
- - initial build for Vine Linux based on fedora development
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-0.6.20080912svn
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Thu Oct 9 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.5.20080912svn
- - Fix doc package dependencies.
- * Wed Sep 24 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.4.20080912svn
- - Replace with simple sed line in spec
- - Build documentation, add monodoc dependencies.
- * Wed Sep 24 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.3.20080912svn
- - Add patch to fix libdir on all arches.
- * Mon Sep 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.2.20080912svn
- - Update changelog
- - Fix whitespace issues
- * Fri Sep 12 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org - 0.4.0-0.1.20080912svn
- - Redid svn checkout and tarball creation process
- - Added autoreconfig shebang + autotools deps
- * Sat May 31 2008 Nigel Jones <dev@nigelj.com> - 0.4.0-0.1.20080531svn
- - Initial RPM based on David Nielsen's work on fedorapeople.org
|