libdb-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599
  1. %define __soversion_major 5
  2. %define __soversion %{__soversion_major}.3
  3. %bcond_with java
  4. Summary: The Berkeley DB database library for C
  5. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  6. Name: libdb
  7. Version: 5.3.28
  8. Release: 7%{?_dist_release}
  9. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  10. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  11. # For mt19937db.c
  12. Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
  13. Patch0: libdb-multiarch.patch
  14. # db-1.85 upstream patches
  15. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  16. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  17. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  18. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  19. # other patches
  20. Patch20: db-1.85-errno.patch
  21. Patch22: db-4.6.21-1.85-compat.patch
  22. Patch24: db-4.5.20-jni-include-dir.patch
  23. # License clarification patch
  24. # http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
  25. Patch25: 007-mt19937db.c_license.patch
  26. URL: http://www.oracle.com/database/berkeley-db/
  27. License: BSD and LGPLv2 and Sleepycat
  28. Group: System Environment/Libraries
  29. BuildRequires: perl libtool
  30. BuildRequires: tcl >= 8.5.2-3
  31. %if %{with java}
  32. BuildRequires: java-devel >= 1:1.6.0
  33. %endif
  34. #BuildRequires: chrpath
  35. #Conflicts: filesystem < 3
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: tomop
  39. %description
  40. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  41. provides embedded database support for both traditional and
  42. client/server applications. The Berkeley DB includes B+tree, Extended
  43. Linear Hashing, Fixed and Variable-length record access methods,
  44. transactions, locking, logging, shared memory caching, and database
  45. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  46. used by many applications, including Python and Perl, so this should
  47. be installed on all systems.
  48. %package utils
  49. Summary: Command line tools for managing Berkeley DB databases
  50. Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
  51. Group: Applications/Databases
  52. Requires: %{name}%{?_isa} = %{version}-%{release}
  53. Obsoletes: db4-utils
  54. Provides: db4-utils
  55. %description utils
  56. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  57. provides embedded database support for both traditional and
  58. client/server applications. Berkeley DB includes B+tree, Extended
  59. Linear Hashing, Fixed and Variable-length record access methods,
  60. transactions, locking, logging, shared memory caching, and database
  61. recovery. DB supports C, C++, Java and Perl APIs.
  62. %package devel
  63. Summary: C development files for the Berkeley DB library
  64. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  65. Group: Development/Libraries
  66. Requires: %{name}%{?_isa} = %{version}-%{release}
  67. Obsoletes: db4-devel
  68. Provides: db4-devel
  69. %description devel
  70. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  71. provides embedded database support for both traditional and
  72. client/server applications. This package contains the header files
  73. and libraries for building programs which use the Berkeley DB.
  74. %package devel-doc
  75. Summary: C development documentation files for the Berkeley DB library
  76. Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
  77. Group: Documentation
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: %{name}-devel = %{version}-%{release}
  80. BuildArch: noarch
  81. %description devel-doc
  82. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  83. provides embedded database support for both traditional and
  84. client/server applications. This package contains the documentation
  85. for building programs which use the Berkeley DB.
  86. %package devel-static
  87. Summary: Berkeley DB static libraries
  88. Summary(ja): Berkeley DB 静的ライブラリ
  89. Group: Development/Libraries
  90. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  91. %description devel-static
  92. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  93. provides embedded database support for both traditional and
  94. client/server applications. This package contains static libraries
  95. needed for applications that require static linking of
  96. Berkeley DB.
  97. %package cxx
  98. Summary: The Berkeley DB database library for C++
  99. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  100. Group: System Environment/Libraries
  101. Requires: %{name}%{?_isa} = %{version}-%{release}
  102. %description cxx
  103. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  104. provides embedded database support for both traditional and
  105. client/server applications. The Berkeley DB includes B+tree, Extended
  106. Linear Hashing, Fixed and Variable-length record access methods,
  107. transactions, locking, logging, shared memory caching, and database
  108. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  109. used by many applications, including Python and Perl, so this should
  110. be installed on all systems.
  111. %package cxx-devel
  112. Summary: C++ development files for the Berkeley DB library
  113. Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
  114. Group: Development/Libraries
  115. Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
  116. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  117. %description cxx-devel
  118. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  119. provides embedded database support for both traditional and
  120. client/server applications. This package contains the header files,
  121. libraries, and documentation for building programs which use the
  122. Berkeley DB in C++.
  123. %package tcl
  124. Summary: The Berkeley DB library for tcl
  125. Summary(ja): tcl 用 Berkeley DB データベースライブラリ
  126. Group: System Environment/Libraries
  127. Requires: %{name}%{?_isa} = %{version}-%{release}
  128. %description tcl
  129. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  130. provides embedded database support for both traditional and
  131. client/server applications. This package contains the libraries
  132. for building programs which use the Berkeley DB in Tcl.
  133. %package tcl-devel
  134. Summary: Development files for using the Berkeley DB with tcl
  135. Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
  136. Group: Development/Libraries
  137. Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
  138. %description tcl-devel
  139. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  140. provides embedded database support for both traditional and
  141. client/server applications. This package contains the libraries
  142. for building programs which use the Berkeley DB in Tcl.
  143. %package sql
  144. Summary: The Berkeley DB library for SQL
  145. Summary(ja): SQL 用 Berkeley DB データベースライブラリ
  146. Group: System Environment/Libraries
  147. Requires: %{name}%{?_isa} = %{version}-%{release}
  148. %description sql
  149. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  150. provides embedded database support for both traditional and
  151. client/server applications. This package contains the libraries
  152. for building programs which use the Berkeley DB in SQL.
  153. %package sql-devel
  154. Summary: Development files for using the Berkeley DB with sql
  155. Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
  156. Group: Development/Libraries
  157. Requires: %{name}-sql%{?_isa} = %{version}-%{release}
  158. %description sql-devel
  159. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  160. provides embedded database support for both traditional and
  161. client/server applications. This package contains the libraries
  162. for building programs which use the Berkeley DB in SQL.
  163. %if %{with java}
  164. %package java
  165. Summary: The Berkeley DB library for Java
  166. Summary(ja): Java 用 Berkeley DB データベースライブラリ
  167. Group: System Environment/Libraries
  168. Requires: %{name}%{?_isa} = %{version}-%{release}
  169. %description java
  170. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  171. provides embedded database support for both traditional and
  172. client/server applications. This package contains the libraries
  173. for building programs which use the Berkeley DB in Java.
  174. %package java-devel
  175. Summary: Development files for using the Berkeley DB with Java
  176. Summary(ja): Java で Berkeley DB を利用するための開発ファイル
  177. Group: Development/Libraries
  178. Requires: %{name}-java%{?_isa} = %{version}-%{release}
  179. %description java-devel
  180. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  181. provides embedded database support for both traditional and
  182. client/server applications. This package contains the libraries
  183. for building programs which use the Berkeley DB in Java.
  184. %endif
  185. %prep
  186. %setup -q -n db-%{version} -a 1
  187. cp %{SOURCE2} .
  188. %patch0 -p1 -b .multiarch
  189. pushd db.1.85/PORT/linux
  190. %patch10 -p0 -b .1.1
  191. popd
  192. pushd db.1.85
  193. %patch11 -p0 -b .1.2
  194. %patch12 -p0 -b .1.3
  195. %patch13 -p0 -b .1.4
  196. %patch20 -p1 -b .errno
  197. popd
  198. %patch22 -p1 -b .185compat
  199. %patch24 -p1 -b .4.5.20.jni
  200. %patch25 -p1 -b .licensefix
  201. cd dist
  202. ./s_config
  203. cd ..
  204. %build
  205. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  206. CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
  207. export CFLAGS
  208. # Build the old db-185 libraries.
  209. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  210. test -d dist/dist-tls || mkdir dist/dist-tls
  211. # Static link db_dump185 with old db-185 libraries.
  212. /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
  213. /bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  214. # Update config files to understand aarch64
  215. #for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
  216. # cp /usr/lib/rpm/config.{guess,sub} "$dir"
  217. #done
  218. pushd dist/dist-tls
  219. %define _configure ../configure
  220. %configure -C \
  221. --enable-compat185 \
  222. --enable-dump185 \
  223. --enable-shared \
  224. --enable-static \
  225. --enable-tcl \
  226. --with-tcl=%{_libdir} \
  227. --enable-cxx \
  228. --enable-sql \
  229. --enable-test \
  230. --disable-rpath \
  231. --with-tcl=%{_libdir}/tcl8.5 \
  232. %if %{with java}
  233. --enable-java
  234. %endif
  235. # Remove libtool predep_objects and postdep_objects wonkiness so that
  236. # building without -nostdlib doesn't include them twice. Because we
  237. # already link with g++, weird stuff happens if you don't let the
  238. # compiler handle this.
  239. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  240. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  241. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  242. make %{?_smp_mflags}
  243. %if %{with java}
  244. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  245. LDBJ=./.libs/libdb_java-%{__soversion}.la
  246. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  247. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  248. fi
  249. %endif
  250. popd
  251. %install
  252. rm -rf ${RPM_BUILD_ROOT}
  253. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  254. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  255. %makeinstall STRIP=/bin/true -C dist/dist-tls
  256. # XXX Nuke non-versioned archives and symlinks
  257. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
  258. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  259. # Move the header files to a subdirectory, in case we're deploying on a
  260. # system with multiple versions of DB installed.
  261. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  262. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  263. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  264. for i in db.h db_cxx.h db_185.h; do
  265. ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
  266. done
  267. %if %{with java}
  268. # Move java jar file to the correct place
  269. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  270. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  271. %endif
  272. # Eliminate installed doco
  273. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  274. # XXX Avoid Permission denied. strip when building as non-root.
  275. chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
  276. # remove unneeded .la files (#225675)
  277. rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  278. # remove RPATHs
  279. #chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
  280. # unify documentation and examples, remove stuff we don't need
  281. rm -rf docs/csharp
  282. rm -rf examples/csharp
  283. rm -rf docs/installation
  284. mv examples docs
  285. %clean
  286. rm -rf ${RPM_BUILD_ROOT}
  287. %post
  288. /sbin/ldconfig
  289. %postun
  290. /sbin/ldconfig
  291. %post cxx
  292. /sbin/ldconfig
  293. %postun cxx
  294. /sbin/ldconfig
  295. %post sql
  296. /sbin/ldconfig
  297. %postun sql
  298. /sbin/ldconfig
  299. %post tcl
  300. /sbin/ldconfig
  301. %postun tcl
  302. /sbin/ldconfig
  303. %if %{with java}
  304. %post java
  305. /sbin/ldconfig
  306. %postun java
  307. /sbin/ldconfig
  308. %endif
  309. %files
  310. %defattr(-,root,root,-)
  311. %doc LICENSE README lgpl-2.1.txt
  312. %{_libdir}/libdb-%{__soversion}.so
  313. %{_libdir}/libdb-%{__soversion_major}.so
  314. %files devel
  315. %defattr(-,root,root,-)
  316. %{_libdir}/libdb.so
  317. %dir %{_includedir}/%{name}
  318. %{_includedir}/%{name}/db.h
  319. %{_includedir}/%{name}/db_185.h
  320. %{_includedir}/db.h
  321. %{_includedir}/db_185.h
  322. %files devel-doc
  323. %defattr(-,root,root,-)
  324. %doc docs/*
  325. %files devel-static
  326. %defattr(-,root,root,-)
  327. %{_libdir}/libdb-%{__soversion}.a
  328. %{_libdir}/libdb_cxx-%{__soversion}.a
  329. %{_libdir}/libdb_tcl-%{__soversion}.a
  330. %{_libdir}/libdb_sql-%{__soversion}.a
  331. %if %{with java}
  332. %{_libdir}/libdb_java-%{__soversion}.a
  333. %endif
  334. %files utils
  335. %defattr(-,root,root,-)
  336. %{_bindir}/db*_archive
  337. %{_bindir}/db*_checkpoint
  338. %{_bindir}/db*_deadlock
  339. %{_bindir}/db*_dump*
  340. %{_bindir}/db*_hotbackup
  341. %{_bindir}/db*_load
  342. %{_bindir}/db*_printlog
  343. %{_bindir}/db*_recover
  344. %{_bindir}/db*_replicate
  345. %{_bindir}/db*_stat
  346. %{_bindir}/db*_upgrade
  347. %{_bindir}/db*_verify
  348. %{_bindir}/db*_tuner
  349. %files cxx
  350. %defattr(-,root,root,-)
  351. %{_libdir}/libdb_cxx-%{__soversion}.so
  352. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  353. %files cxx-devel
  354. %defattr(-,root,root,-)
  355. %{_includedir}/%{name}/db_cxx.h
  356. %{_includedir}/db_cxx.h
  357. %{_libdir}/libdb_cxx.so
  358. %files tcl
  359. %defattr(-,root,root,-)
  360. %{_libdir}/libdb_tcl-%{__soversion}.so
  361. %{_libdir}/libdb_tcl-%{__soversion_major}.so
  362. %files tcl-devel
  363. %defattr(-,root,root,-)
  364. %{_libdir}/libdb_tcl.so
  365. %files sql
  366. %defattr(-,root,root,-)
  367. %{_libdir}/libdb_sql-%{__soversion}.so
  368. %{_libdir}/libdb_sql-%{__soversion_major}.so
  369. %files sql-devel
  370. %defattr(-,root,root,-)
  371. %{_bindir}/dbsql
  372. %{_libdir}/libdb_sql.so
  373. %{_includedir}/%{name}/dbsql.h
  374. %if %{with java}
  375. %files java
  376. %defattr(-,root,root,-)
  377. %{_libdir}/libdb_java-%{__soversion_major}*.so
  378. %{_datadir}/java/*.jar
  379. %files java-devel
  380. %defattr(-,root,root,-)
  381. %{_libdir}/libdb_java.so
  382. %endif
  383. %changelog
  384. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
  385. - updated Summary and Group
  386. * Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
  387. - added "Provides: db4-{utils,devel}".
  388. * Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
  389. - initial build for Vine Linux.
  390. * Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
  391. - Add some of the previous aarch64 bits back as the sub configure don't use the macro
  392. * Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
  393. - Fix configure macro usage for better aarch64 build fix
  394. * Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
  395. - Updated config files to allow build on aarch64 (#1022970)
  396. * Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
  397. - Added Sleepycat to the license list (#1013841)
  398. - Updated to 5.3.28 (#1013233)
  399. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
  400. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  401. * Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
  402. - add copy of lgpl-2.1.txt
  403. * Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
  404. - Fix missing debuginfo issue for utils subpackage
  405. * Thu May 9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
  406. - add license clarification fix
  407. * Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
  408. - Added sqlite compability CFLAGS (#788496)
  409. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
  410. - Cleaning the specfile - removed gcc-java dependecy other way
  411. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
  412. - Removed dependency on obsolete gcc-java package (#927742)
  413. * Thu Mar 7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
  414. - add LGPLv2+ and remove Sleepycat in license tag (#886838)
  415. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
  416. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  417. * Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
  418. - fix license tag
  419. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
  420. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  421. * Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
  422. - Specify tag for libtool (fixes FTBFS # 838334 )
  423. * Thu Jul 5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
  424. - update to 5.3.21
  425. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  426. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
  427. - move C++ header files to cxx-devel
  428. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
  429. - fix -devel packages dependencies yet more (#832225)
  430. * Sun May 6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
  431. - package -devel packages correctly
  432. * Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
  433. - fix multiarch conflict in libdb-devel (#812901)
  434. - remove unneeded dos2unix BR
  435. * Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
  436. - update to 5.3.15
  437. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  438. * Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
  439. - Resolves rhbz#794472
  440. - Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
  441. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
  442. - add filesystem guard
  443. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
  444. - install everything in /usr
  445. https://fedoraproject.org/wiki/Features/UsrMove
  446. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
  447. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  448. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
  449. - update to 5.2.36,
  450. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
  451. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
  452. - move development documentation to devel-doc subpackage (#705386)
  453. * Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
  454. - update to 5.2.28
  455. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
  456. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  457. * Thu Feb 3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
  458. - update to 5.1.25
  459. * Wed Sep 29 2010 jkeating - 5.1.19-2
  460. - Rebuilt for gcc bug 634757
  461. * Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
  462. - update to 5.1.19
  463. - rename -devel-static to -static subpackage (#617800)
  464. - build java on all arches
  465. * Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
  466. - update to 5.0.26
  467. - drop BR: ed
  468. * Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
  469. - add Requires: libdb-cxx to libdb-devel
  470. * Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
  471. - initial build
  472. * Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
  473. - remove C# documentation
  474. - disable/remove rpath
  475. - fix description
  476. - tighten dependencies
  477. - run ldconfig for cxx and sql subpackages
  478. * Fri Apr 9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
  479. - enable sql
  480. - package 5.0.21