f-spot-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430
  1. Name: f-spot
  2. Version: 0.8.2
  3. Release: 1%{?_dist_release}
  4. Summary: Photo management application
  5. Summary(ja): 写真管理アプリケーション
  6. Group: Applications/Multimedia
  7. License: GPLv2+ and LGPLv2+ and CPL and MIT
  8. URL: http://f-spot.org/
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/f-spot/0.8/f-spot-%{version}.tar.bz2
  10. Patch1: f-spot-0.7.1-build-fixes.patch
  11. # unmount cameras before importing
  12. Patch3: 0002-enhance-the-f-spot-import-script.patch
  13. # Patch from fedora
  14. # two upstream patches to fix compile issue with Mono 2.8:
  15. # http://git.gnome.org/browse/f-spot/commit/?id=9d6e8052b188c2b1cb310ef05842da74a730a39f
  16. Patch13: 0001-PixbufLoader-from-gtk-sharp-master-does-not-have-a-C.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: mono-devel mono-web mono-data mono-data-sqlite lcms-devel
  19. BuildRequires: libexif-devel gphoto2-devel >= 2.1.4
  20. BuildRequires: gtk-sharp2 libgnome-devel libgnomeui-devel
  21. BuildRequires: gtk2-devel mono-devel libjpeg-devel sqlite3-devel
  22. BuildRequires: gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
  23. BuildRequires: gconf-sharp2
  24. BuildRequires: gettext
  25. BuildRequires: autoconf, automake, libtool, intltool
  26. BuildRequires: perl-XML-Parser
  27. BuildRequires: gnome-doc-utils
  28. BuildRequires: ndesk-dbus-glib
  29. BuildRequires: mono-addins
  30. BuildRequires: desktop-file-utils
  31. BuildRequires: gnome-keyring-sharp-devel
  32. BuildRequires: unique-devel
  33. BuildRequires: flickrnet-devel
  34. BuildRequires: libSM-devel
  35. Requires: sqlite3
  36. Requires: lcms
  37. Requires: dcraw
  38. Requires: hicolor-icon-theme
  39. Requires: yelp
  40. Requires(post): desktop-file-utils
  41. Requires(postun): desktop-file-utils
  42. # no mono available
  43. ExcludeArch: sparc64
  44. # Some compiler segfault on ia64:
  45. ExcludeArch: ia64
  46. # No libgphoto etc on s390
  47. ExcludeArch: s390
  48. %description
  49. F-Spot is an application designed to provide personal photo management
  50. to the GNOME desktop. Features include import, export, printing and advanced
  51. sorting and tagging of digital images.
  52. %package screensaver
  53. Summary: F-Spot gnome-screensaver plugin
  54. Summary(ja): F-Spot gnome-screensaver plugin
  55. Group: Applications/Multimedia
  56. Requires: %{name} = %{version}-%{release}
  57. Requires: gnome-screensaver
  58. Obsoletes: f-spot < 0.6.1.1
  59. %description screensaver
  60. F-Spot provides a plugin for gnome-screensaver which displays parts of the
  61. photo collection in a slideshow as a screensaver.
  62. %prep
  63. %setup -q
  64. #%patch1 -p1 -b .buildfix
  65. %patch3 -p1 -b .gvfs-gphoto
  66. %patch13 -p1 -b mono28-compile-fix
  67. %build
  68. intltoolize --force --copy
  69. libtoolize --force --copy --automake
  70. aclocal -I build/m4/f-spot -I build/m4/shamrock -I build/m4/shave
  71. autoconf
  72. autoheader
  73. test -f config.h.in && touch config.h.in
  74. automake --gnu --add-missing --force --copy -Wno-portability
  75. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  76. %configure --disable-scrollkeeper
  77. make %{?_smp_mflags}
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
  83. rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
  84. rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
  85. # only files marked executable are used to auto-generate the
  86. # requires/provides of the package
  87. find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
  88. -exec chmod a+x {} \;
  89. for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  90. do
  91. desktop-file-validate $file
  92. done
  93. %find_lang %name
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %pre
  97. if [ "$1" -gt 1 ]; then
  98. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  99. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  100. fi
  101. %post
  102. update-desktop-database &> /dev/null ||:
  103. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  104. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  105. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  106. %preun
  107. if [ "$1" -eq 0 ]; then
  108. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  109. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  110. fi
  111. %postun
  112. update-desktop-database &> /dev/null ||:
  113. if [ $1 -eq 0 ] ; then
  114. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  115. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  116. fi
  117. %posttrans
  118. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  119. %files -f %{name}.lang
  120. %defattr(-,root,root,-)
  121. %doc AUTHORS COPYING README NEWS
  122. %{_sysconfdir}/gconf/schemas/*
  123. %{_datadir}/applications/*.desktop
  124. %{_datadir}/gnome/help/f-spot/
  125. %{_datadir}/icons/hicolor/*/*/*.png
  126. %{_datadir}/f-spot/
  127. %dir %{_libdir}/f-spot/
  128. %{_libdir}/f-spot/*.dll
  129. %{_libdir}/f-spot/*.exe
  130. %{_libdir}/f-spot/*.addins
  131. %{_libdir}/f-spot/*.config
  132. %{_libdir}/f-spot/*.mdb
  133. %{_libdir}/f-spot/*.so
  134. %{_libdir}/f-spot/*.so.*
  135. %exclude %{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll*
  136. %{_libdir}/f-spot/Extensions/
  137. %{_bindir}/f-spot
  138. %{_bindir}/f-spot-import
  139. %{_bindir}/f-spot-sqlite-upgrade
  140. %files screensaver
  141. %defattr(-,root,root,-)
  142. %{_libdir}/f-spot/Extensions/FSpot.Tools.ScreensaverConfig.dll
  143. %{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
  144. %{_datadir}/applications/screensavers/f-spot-screensaver.desktop
  145. %changelog
  146. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
  147. - new upstream release
  148. - delete Patch11,12
  149. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  150. - new upstream release
  151. - drop Patch1
  152. - add Patch11,12,13 from fedora
  153. - add BuildRequires: libSM-devel
  154. * Thu Aug 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-1
  155. - new upstream release
  156. - add patch1 to support parallel builds
  157. - add BR: unique-devel, flickrnet-devel
  158. * Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
  159. - initial build for Vine Linux
  160. * Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
  161. - Corrected the permission fix for all .exe and .dll files in order
  162. to generate the dependencies correctly (BZ 547063)
  163. * Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
  164. - Update to 0.6.1.5 (BZ 531955)
  165. - Build f-spot against system gnome-keyring-sharp library (BZ 442343)
  166. - Make all .dll and .exe files executable so that they are respected
  167. by the find-requires/find-provides scripts
  168. - Remove upstreamed patch
  169. * Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
  170. - ExcludeArch sparc64
  171. * Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
  172. - Update to 0.6.1.3 (BZ 526217)
  173. - Remove two upstreamed patches
  174. - Use a slightly different fix for the cairo-devel dependency
  175. (suggested by upstream)
  176. * Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
  177. - Add patch to fix f-spot crash when using "soft focus" and cairo-devel
  178. was not installed (BZ 526563)
  179. - Minor spec file beautification
  180. * Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
  181. - Add upstream patches (
  182. commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
  183. commit 807dab4344ecdadc7e46793369821de8b49692e5 )
  184. to fix crash in facebook exporter (BZ 524860)
  185. * Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
  186. - Update to 0.6.1.2 (BZ 519290)
  187. * Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
  188. - Move the screensaver plugin into a sub-package (BZ 519640)
  189. - Let f-spot-screensaver obsolete older f-spot version so that it
  190. is pulled in during update (fresh installations of f-spot will not
  191. pull in gnome-screensaver)
  192. * Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
  193. - Update to 0.6.1.1
  194. - Remove upstreamed patch
  195. - Updated use-system-Mono.Addins-if-available patch
  196. - Add a patch to enable parallel build
  197. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
  198. - Build arch ppc64.
  199. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
  200. - Fix Icon Cache script in %%post section
  201. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
  202. - Update to new upstream version 0.6.0.0
  203. - Cleanup spec file
  204. * Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
  205. - Avoid showing f-spot twice for photo imports
  206. - Make f-spot-import work with gvfs
  207. - Minor indentation fix
  208. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
  209. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  210. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
  211. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  212. * Sun Feb 8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
  213. - Rebuild against new mono stack to fix broken deps
  214. * Thu Dec 4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
  215. - Update to 0.5.0.3
  216. * Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
  217. - Better URL
  218. - Tweak %%description
  219. * Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
  220. - Run desktop-file-validate against desktop files
  221. * Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
  222. - rebuild against new gnome-sharp
  223. * Thu Oct 2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
  224. - Use a standard icon name instead of a non-existing one
  225. * Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
  226. - Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
  227. packaging it.
  228. - Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
  229. effectively a backport of r4010 Upstream.
  230. - Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
  231. recommendation of upstream.
  232. - Re-add patch to use system mono-addins
  233. - Include GIO stuff for now (until it appears in gtk-sharp)
  234. * Wed Jul 5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
  235. - gtkhtml dependency now provided by gnome-desktop-sharp-devel
  236. rather than gnome-sharp-devel, so add as BuildRequires
  237. * Wed Jun 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
  238. - Fix it to not look for non-existant glib-sharp-2.12.1
  239. * Wed Jun 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
  240. - update to 0.4.4
  241. - fix license tag
  242. * Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
  243. - Update to 0.4.3.1
  244. * Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
  245. - Add patch from Debian to use system mono-addins (from #442343)
  246. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
  247. - Require dcraw
  248. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
  249. - Fix the build
  250. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  251. - Autorebuild for GCC 4.3
  252. * Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
  253. - Update to 0.4.2
  254. * Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
  255. - Add support for content-types
  256. * Thu Dec 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
  257. - Update to 0.4.1
  258. * Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
  259. - Remove comments from ExclusiveArch line (#388581)
  260. * Tue Oct 2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
  261. - Add alpha to ExclusiveArch
  262. * Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
  263. - Rebuild for build ID
  264. * Sat Aug 4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
  265. - Update to 0.4.0
  266. * Mon Jul 2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
  267. - Hack to get screensavers to work again (#221546)
  268. * Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
  269. - Now with validated desktop files!
  270. * Wed Mar 7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
  271. - Update to 0.3.5
  272. * Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  273. - Update to 0.3.4
  274. * Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
  275. - Update to 0.3.3
  276. * Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  277. - Update to 0.3.2
  278. * Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
  279. - Update to 0.2.2
  280. * Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
  281. - Fix a directory ownership issue (#211009)
  282. * Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
  283. - Update to 0.2.1
  284. * Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
  285. - Add libgphoto2_port version to dll config (#205302)
  286. * Mon Sep 4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
  287. - Update to 0.2.0
  288. * Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
  289. - Rebuild with new mono and gtk-sharp2
  290. * Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
  291. - Fix dbus-sharp BR
  292. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
  293. - rebuild
  294. * Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
  295. - Add missing BR gettext
  296. * Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
  297. - Rebuild for gmime update
  298. * Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
  299. - Update to 0.1.11
  300. * Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
  301. - Update to 0.1.10
  302. * Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
  303. - add BuildRequires libgnome-devel libgnomeui-devel
  304. gtk2-devel mono-devel libjpeg-devel sqlite-devel
  305. * Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
  306. - Update to 0.1.9
  307. * Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
  308. - Rebuild
  309. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
  310. - rebuilt for new gcc4.1 snapshot and glibc changes
  311. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
  312. - Add sqlite3.patch to ensure that sqlite3 is used if both
  313. sqlite2 and sqlite3 are installed.
  314. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
  315. - Update to 0.1.8
  316. - Use sqlite3 instead of sqlite2
  317. * Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
  318. - don't blindly run f-spot from current working directory
  319. (bug 177407)
  320. * Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
  321. - Add lcms depencency
  322. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
  323. - Update to 0.1.5
  324. * Thu Dec 8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
  325. - Use sqlite2 to avoid problems with beagle
  326. * Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
  327. - Make exes and dlls executable to pick up dependencies
  328. - Remove .a and .la files
  329. * Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
  330. - Initial version