xulrunner-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813
  1. %define nspr_version 4.8
  2. %define nss_version 3.12
  3. %define cairo_version 1.8.6
  4. %define libnotify_version 0.4
  5. %define tarballdir mozilla-1.9.2
  6. %define build_vine6 0
  7. %define build_vine5 0
  8. %if "%{?_dist_release}" == "vl6"
  9. %define build_vine6 1
  10. %define build_vine5 1
  11. %endif
  12. %if "%{?_dist_release}" == "vl5"
  13. %define build_vine5 1
  14. %endif
  15. %if %build_vine6
  16. %define sqlite_version 3.6.21
  17. %endif
  18. %define version_internal 1.9.2
  19. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  20. # Separated plugins are supported on x86(64) only
  21. %ifarch %{ix86} x86_64
  22. %define separated_plugins 1
  23. %else
  24. %define separated_plugins 0
  25. %endif
  26. Summary: XUL Runtime for Gecko Applications
  27. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  28. Name: xulrunner
  29. Version: 1.9.2.4
  30. Release: 2%{?_dist_release}
  31. URL: http://www.mozilla.org/projects/xulrunner/
  32. License: MPLv1.1 or GPLv2+ or LGPLv2+
  33. Group: Applications/Internet
  34. Source0: %{name}-%{version}-source.tar.bz2
  35. Source10: %{name}-mozconfig
  36. Source11: %{name}-mozconfig-vine5
  37. Source12: %{name}-vine-default-prefs.js
  38. Source21: %{name}.sh.in
  39. Source23: %{name}.1
  40. # locale sources
  41. %define MOZ_BUILD_LOCALES "ja"
  42. Source1000: xulrunner-%{version}-ja.tar.bz2
  43. # build patches
  44. Patch0: xulrunner-version.patch
  45. Patch1: mozilla-build.patch
  46. Patch3: mozilla-jemalloc.patch
  47. Patch5: mozilla-jemalloc-526152.patch
  48. Patch7: xulrunner-1.9.2.1-build.patch
  49. Patch8: mozilla-plugin.patch
  50. Patch9: mozilla-build-sbrk.patch
  51. Patch10: firefox-3.6.4-ipc-chromium-nspr4.patch
  52. # patches from Fedora
  53. Patch100: mozilla-192-pkgconfig.patch
  54. # Upstream patches
  55. Patch200: mozilla-ps-pdf-simplify-operators.patch
  56. # ---------------------------------------------------
  57. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  58. BuildRequires: nspr-devel >= %{nspr_version}
  59. BuildRequires: nss-devel >= %{nss_version}
  60. BuildRequires: cairo-devel >= %{cairo_version}
  61. BuildRequires: libpng-devel
  62. BuildRequires: libjpeg-devel
  63. BuildRequires: bzip2-devel
  64. BuildRequires: zlib-devel
  65. BuildRequires: lcms-devel
  66. BuildRequires: libIDL-devel
  67. BuildRequires: gtk2-devel
  68. BuildRequires: gnome-vfs2-devel
  69. BuildRequires: libgnome-devel
  70. BuildRequires: libgnomeui-devel
  71. BuildRequires: pango-devel
  72. BuildRequires: freetype2-devel >= 2.1.9
  73. BuildRequires: libXt-devel
  74. BuildRequires: libXrender-devel
  75. %if %{build_vine6}
  76. BuildRequires: sqlite3-devel >= %{sqlite_version}
  77. %endif
  78. BuildRequires: libnotify-devel >= %{libnotify_version}
  79. BuildRequires: startup-notification-devel
  80. BuildRequires: alsa-lib-devel
  81. BuildRequires: lcms-devel
  82. BuildRequires: zip
  83. # For -sqlite.patch
  84. BuildRequires: autoconf213
  85. Requires: nspr >= %{nspr_version}
  86. Requires: nss >= %{nss_version}
  87. Provides: gecko-libs = %{version}
  88. %description
  89. XULRunner provides the XUL Runtime environment for Gecko applications.
  90. %package devel
  91. Summary: Development files for Gecko
  92. Group: Development/Libraries
  93. Obsoletes: mozilla-devel
  94. Obsoletes: firefox-devel < 2.1
  95. Obsoletes: xulrunner-devel-unstable
  96. Provides: gecko-devel = %{version}
  97. Provides: gecko-devel-unstable = %{version}
  98. Requires: xulrunner = %{version}-%{release}
  99. Requires: nspr-devel >= %{nspr_version}
  100. Requires: nss-devel >= %{nss_version}
  101. Requires: cairo-devel >= %{cairo_version}
  102. Requires: libjpeg-devel
  103. Requires: zip
  104. Requires: bzip2-devel
  105. Requires: zlib-devel
  106. Requires: lcms-devel
  107. Requires: libIDL-devel
  108. Requires: gtk2-devel
  109. Requires: gnome-vfs2-devel
  110. Requires: libgnome-devel
  111. Requires: libgnomeui-devel
  112. Requires: pango-devel
  113. Requires: freetype2-devel >= 2.1.9
  114. Requires: libXt-devel
  115. Requires: libXrender-devel
  116. %if %{build_vine6}
  117. Requires: sqlite3-devel >= %{sqlite_version}
  118. %endif
  119. Requires: startup-notification-devel
  120. Requires: alsa-lib-devel
  121. %description devel
  122. Gecko development files.
  123. #---------------------------------------------------------------------
  124. %prep
  125. %setup -q -c -b 1000
  126. cd %{tarballdir}
  127. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
  128. %{P:%%PATCH0} > version.patch
  129. %{__patch} -p1 -b --suffix .version < version.patch
  130. %patch1 -p1 -b .build
  131. %patch3 -p1 -b .jemalloc
  132. %patch5 -p1 -b .jemalloc-526152
  133. %patch7 -p2 -b .del
  134. %patch8 -p1 -b .plugin
  135. %patch9 -p2 -b .sbrk
  136. %patch10 -p1 -b .nspr4
  137. %patch100 -p1 -b .pkgconfig
  138. %patch200 -p1 -b .ps-pdf-simplify-operators
  139. %{__rm} -f .mozconfig
  140. %if %{build_vine6}
  141. %{__cp} %{SOURCE10} .mozconfig
  142. %else
  143. %{__cp} %{SOURCE11} .mozconfig
  144. %endif
  145. %if !%{?separated_plugins}
  146. echo "ac_add_options --disable-ipc" >> .mozconfig
  147. %endif
  148. #---------------------------------------------------------------------
  149. %build
  150. cd %{tarballdir}
  151. INTERNAL_GECKO=%{version_internal}
  152. MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
  153. # Mozilla builds with -Wall with exception of a few warnings which show up
  154. # everywhere in the code; so, don't override that.
  155. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
  156. export CFLAGS=$MOZ_OPT_FLAGS
  157. export CXXFLAGS=$MOZ_OPT_FLAGS
  158. export PREFIX='%{_prefix}'
  159. export LIBDIR='%{_libdir}'
  160. MOZ_SMP_FLAGS=-j1
  161. %ifnarch ppc ppc64 s390 s390x
  162. [ -z "$RPM_BUILD_NCPUS" ] && \
  163. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  164. [ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
  165. %endif
  166. export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
  167. make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  168. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  169. # build locales
  170. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  171. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  172. for dir in $LOCALEDIRS
  173. do
  174. for lang in %{MOZ_BUILD_LOCALES} ; do
  175. make -C $dir/locales AB_CD=$lang
  176. done
  177. done
  178. #---------------------------------------------------------------------
  179. %install
  180. cd %{tarballdir}
  181. %{__rm} -rf $RPM_BUILD_ROOT
  182. INTERNAL_GECKO=%{version_internal}
  183. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  184. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  185. INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
  186. MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
  187. #DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
  188. DESTDIR=$RPM_BUILD_ROOT make install
  189. %{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
  190. $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  191. $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
  192. %{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
  193. %{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
  194. # set up our default preferences
  195. %{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
  196. %{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
  197. %{__rm} vl-default-prefs
  198. # Start script install
  199. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  200. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
  201. $RPM_BUILD_ROOT%{_bindir}/%{name}
  202. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  203. %{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
  204. cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
  205. find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
  206. cd -
  207. # install locales
  208. for lang in %{MOZ_BUILD_LOCALES} ; do
  209. %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
  210. done
  211. # Prepare our devel package
  212. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  213. %{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
  214. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  215. %{__cp} -rL dist/include/* \
  216. $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  217. # Copy pc files (for compatibility with 1.9.1)
  218. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  219. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  220. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  221. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  222. # Fix multilib devel conflicts...
  223. %ifarch x86_64 ia64 s390x ppc64
  224. %define mozbits 64
  225. %else
  226. %define mozbits 32
  227. %endif
  228. function install_file() {
  229. genheader=$*
  230. mv ${genheader}.h ${genheader}%{mozbits}.h
  231. cat > ${genheader}.h << EOF
  232. // This file exists to fix multilib conflicts
  233. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
  234. #include "${genheader}64.h"
  235. #else
  236. #include "${genheader}32.h"
  237. #endif
  238. EOF
  239. }
  240. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  241. install_file "mozilla-config"
  242. popd
  243. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
  244. install_file "jsautocfg"
  245. popd
  246. %{__install} -p -c -m 755 dist/bin/xpcshell \
  247. dist/bin/xpidl \
  248. dist/bin/xpt_dump \
  249. dist/bin/xpt_link \
  250. $RPM_BUILD_ROOT/${MOZ_APP_DIR}
  251. %{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  252. %{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
  253. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  254. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  255. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
  256. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  257. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  258. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
  259. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  260. ln -s %{_includedir}/${INTERNAL_APP_SDK_NAME} \
  261. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
  262. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  263. ln -s %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
  264. $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
  265. find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
  266. find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
  267. %{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
  268. pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
  269. for i in *.so; do
  270. ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
  271. done
  272. popd
  273. # GRE stuff
  274. %ifarch x86_64 ia64 ppc64 s390x
  275. %define gre_conf_file gre64.conf
  276. %else
  277. %define gre_conf_file gre.conf
  278. %endif
  279. MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
  280. %{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
  281. $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  282. chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
  283. # Library path
  284. %ifarch x86_64 ia64 ppc64 s390x
  285. %define ld_conf_file xulrunner-64.conf
  286. %else
  287. %define ld_conf_file xulrunner-32.conf
  288. %endif
  289. %{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
  290. %{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
  291. ${MOZ_APP_DIR}
  292. EOF
  293. # Copy over the LICENSE
  294. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
  295. # Use the system hunspell dictionaries
  296. %{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  297. ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
  298. # ghost files
  299. %{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
  300. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
  301. touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
  302. #---------------------------------------------------------------------
  303. %clean
  304. %{__rm} -rf $RPM_BUILD_ROOT
  305. #---------------------------------------------------------------------
  306. %post
  307. /sbin/ldconfig
  308. %postun
  309. /sbin/ldconfig
  310. %preun
  311. # is it a final removal?
  312. if [ $1 -eq 0 ]; then
  313. %{__rm} -rf ${MOZ_APP_DIR}/components
  314. fi
  315. %files
  316. %defattr(-,root,root,-)
  317. %{_bindir}/xulrunner
  318. %dir /etc/gre.d
  319. /etc/gre.d/%{gre_conf_file}
  320. %dir %{mozappdir}
  321. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  322. %doc %attr(644, root, root) %{mozappdir}/README.txt
  323. %{mozappdir}/chrome
  324. %{mozappdir}/dictionaries
  325. %dir %{mozappdir}/components
  326. %ghost %{mozappdir}/components/compreg.dat
  327. %ghost %{mozappdir}/components/xpti.dat
  328. %{mozappdir}/components/*.so
  329. %{mozappdir}/components/*.xpt
  330. %attr(644, root, root) %{mozappdir}/components/*.js
  331. %{mozappdir}/defaults
  332. %{mozappdir}/greprefs
  333. %dir %{mozappdir}/icons
  334. %attr(644, root, root) %{mozappdir}/icons/*
  335. %{mozappdir}/modules
  336. %{mozappdir}/plugins
  337. %{mozappdir}/res
  338. %{mozappdir}/*.so
  339. %{mozappdir}/mozilla-xremote-client
  340. %{mozappdir}/run-mozilla.sh
  341. %{mozappdir}/regxpcom
  342. %{mozappdir}/xulrunner
  343. %{mozappdir}/xulrunner-bin
  344. %{mozappdir}/xulrunner-stub
  345. %if %{?separated_plugins}
  346. %{mozappdir}/plugin-container
  347. %endif
  348. %{mozappdir}/platform.ini
  349. %{mozappdir}/dependentlibs.list
  350. %{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  351. # XXX See if these are needed still
  352. %{mozappdir}/updater*
  353. %exclude %{mozappdir}/update.locale
  354. %exclude %{mozappdir}/components/components.list
  355. %files devel
  356. %defattr(-,root,root,-)
  357. %dir %{_datadir}/idl/%{name}*%{version_internal}
  358. %{_datadir}/idl/%{name}*%{version_internal}/*
  359. %{_includedir}/%{name}*%{version_internal}
  360. %dir %{_libdir}/%{name}-sdk-*
  361. %dir %{_libdir}/%{name}-sdk-*/sdk
  362. %{_libdir}/%{name}-sdk-*/*
  363. %{_libdir}/%{name}-sdk-*/sdk/*
  364. %{_libdir}/pkgconfig/*.pc
  365. %{mozappdir}/xpcshell
  366. %{mozappdir}/xpidl
  367. %{mozappdir}/xpt_dump
  368. %{mozappdir}/xpt_link
  369. #---------------------------------------------------------------------
  370. %changelog
  371. * Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
  372. - enable ipc only on ix86/x86_64 arches
  373. * Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
  374. - update to 1.9.2.4 (sync with firefox-3.6.4)
  375. - add patch10 to fix build failure
  376. * Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
  377. - update to 1.9.2.3 (sync with firefox-3.6.3)
  378. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  379. - update to 1.9.2.2 (sync with firefox-3.6.2)
  380. - add patch7,9 for fix build failure
  381. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  382. - enable libnotify support
  383. - add ac_add_options --enable-libnotify
  384. - disable Necko wifi monitor
  385. - add ac_add_options --disable-necko-wifi
  386. - remove BR: wireless-tools-devel
  387. - fix %%files devel
  388. - add patch3,5 to fix jemalloc alignment assertion
  389. - add Patch8 to fix mozilla-plugin.pc
  390. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  391. - add BR: libnotify-devel, wireless-tools-devel
  392. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  393. - update to 1.9.2 (sync with firefox-3.6)
  394. - obsoletes xulrunner-devel-unstable
  395. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  396. - use internal sqlite3 on vine5
  397. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  398. - update to 1.9.1.7
  399. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  400. - update to 1.9.1.6
  401. - build with sqlite3-3.6.21
  402. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  403. - update to 1.9.1.5
  404. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  405. - update to 1.9.1.3
  406. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  407. - really update to 1.9.1.2 (<BTS:0748>)
  408. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  409. - update to 1.9.1.2 (sync with firefox-3.5.2)
  410. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  411. - update to 1.9.1.1 (sync with firefox-3.5.1)
  412. - add missing Requires to -devel
  413. - add missing BR
  414. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  415. - enable-system-cairo
  416. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  417. - update to 1.9.1 (based on firefox 3.5)
  418. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  419. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  420. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  421. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  422. - remove old patches
  423. - require nspr >= 4.8
  424. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  425. - new upstream release
  426. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  427. - update mozconfig
  428. - disable-system-cairo for stability
  429. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  430. - new upstream release
  431. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  432. - new upstream release
  433. - add ja locale
  434. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  435. - new upstream release
  436. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  437. - new upstream release
  438. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  439. - add Patch3
  440. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  441. - update to xulrunner 1.9.0.2 byild 6
  442. - build with gnome-2.24
  443. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  444. - new upstream release
  445. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  446. - initial build for Vine Linux
  447. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  448. - Update to 1.9 final
  449. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  450. - Simplify PS/PDF operators
  451. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  452. - Upstream patch to fsync() less
  453. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  454. - Ensure we enable startup notification; add BR and modify config
  455. (bug #445543)
  456. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  457. - Some files moved to mozilla-filesystem; kill them and add the Req
  458. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  459. - Clean up the %%files list and get rid of the executable bit on some files
  460. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  461. - Fix font scaling
  462. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  463. - Enabled phishing protection (#443403)
  464. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  465. - Changed "__ppc64__" to "__powerpc64__",
  466. "__ppc64__" doesn't work anymore
  467. - Added fix for #443725 - Critical hanging bug with fix
  468. available upstream (mozbz#429903)
  469. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  470. - Fixed multilib issues, added starting script instead of a symlink
  471. to binary (#436393)
  472. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  473. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  474. - Re-enable system cairo
  475. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  476. - Spec cleanups
  477. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  478. - Beta 5
  479. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  480. - Beta 5 RC2
  481. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  482. - Update to latest trunk (2008-03-27)
  483. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  484. - Update to latest trunk (2008-03-26)
  485. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  486. - Update to latest trunk (2008-03-25)
  487. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  488. - Update to latest trunk (2008-03-24)
  489. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  490. - Update to latest trunk (2008-03-20)
  491. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  492. - Update to latest trunk (2008-03-17)
  493. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  494. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  495. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  496. - Update to latest trunk (2008-03-16)
  497. - Add patch to negate a11y slowdown on some pages (#431162)
  498. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  499. - Update to latest trunk (2008-03-15)
  500. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  501. - Avoid conflicts between gecko debuginfo packages
  502. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  503. - Update to latest trunk (2008-03-12)
  504. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  505. - Update to latest trunk (2008-03-11)
  506. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  507. - Update to latest trunk (2008-03-10)
  508. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  509. - Update to latest trunk (2008-03-09)
  510. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  511. - Update to latest trunk (2008-03-07)
  512. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  513. - Update to latest trunk (2008-03-06)
  514. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  515. - Update to latest trunk (2008-03-04)
  516. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  517. - Update to latest trunk (2008-03-02)
  518. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  519. - Update to latest trunk (2008-03-01)
  520. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  521. - Update to latest trunk (2008-02-29)
  522. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  523. - Update to latest trunk (2008-02-28)
  524. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  525. - Update to latest trunk (2008-02-27)
  526. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  527. - Update to latest trunk (2008-02-26)
  528. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  529. - Update to latest trunk (2008-02-23)
  530. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  531. - Update to latest trunk (2008-02-22)
  532. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  533. - Update to latest trunk (2008-02-21)
  534. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  535. - Update to latest trunk (2008-02-20)
  536. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  537. - Update to latest trunk (2008-02-17)
  538. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  539. - Update to latest trunk (2008-02-15)
  540. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  541. - Update to latest trunk (2008-02-14)
  542. - Use system hunspell
  543. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  544. - Update to latest trunk (2008-02-11)
  545. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  546. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  547. you know, debuginfo.
  548. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  549. - Update to latest trunk (2008-02-10)
  550. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  551. - Update to latest trunk (2008-02-09)
  552. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  553. - Update to latest trunk (2008-02-06)
  554. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  555. - Update to latest trunk (2008-01-30)
  556. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  557. - rebuild agains new nss
  558. - enabled gnome vfs
  559. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  560. - fixed stable pkg-config files (#429654)
  561. - removed sqlite patch
  562. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  563. - Update to latest trunk (2008-01-21)
  564. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  565. - Update to latest trunk (2008-01-15)
  566. - Now with system extensions directory support
  567. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  568. - Update to latest trunk (2008-01-13)
  569. - Use CFLAGS instead of configure arguments
  570. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  571. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  572. - Provide gecko-devel-unstable as well
  573. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  574. - divided devel package to devel and devel-unstable
  575. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  576. - removed fedora specific pkg-config files
  577. - updated to the latest trunk (2008-01-07)
  578. - removed unnecessary patches
  579. - fixed idl dir (#427965)
  580. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  581. - Re-enable camellia256 support now that NSS supports it
  582. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  583. - updated to the latest trunk (2008-01-03)
  584. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  585. - Don't Provide webclient (xulrunner is not itself a webclient)
  586. - Don't Obsolete old firefox, only firefox-devel
  587. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  588. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  589. - added java and plugin subdirs to plugin includes
  590. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  591. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  592. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  593. - updated to Beta 2.
  594. - moved SDK to xulrunner-sdk
  595. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  596. - fixed mozilla-plugin.pc (#412971)
  597. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  598. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  599. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  600. - added xulrunner/js include dir to xulrunner-js
  601. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  602. - update to beta 1
  603. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  604. - packed all gecko libraries (#389391)
  605. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  606. - registered xulrunner libs system-wide
  607. - added xulrunner-gtkmozembed.pc
  608. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  609. - added proper nss/nspr dependencies
  610. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  611. - more build fixes, use system nss libraries
  612. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  613. - build fixes
  614. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  615. - updated to the latest trunk
  616. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  617. - build fixes for ppc/ppc64
  618. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  619. - removed conflicts with the current gecko-based apps
  620. - added updated ppc64 patch
  621. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  622. - build fixes
  623. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  624. - Initial cut at XULRunner 1.9 Alpha 7
  625. - Temporarily revert camellia 256 support since our nss doesn't support it yet