openssl-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 6
  3. %define version 0.9.8m
  4. %define release 1%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source3: ca-bundle.crt
  12. Source5: make-dummy-cert
  13. Source6: openssl-%{version}.pc
  14. Patch0: openssl-0.9.8b-soversion.patch
  15. Patch2: openssl-0.9.8e-rpm_opt.patch
  16. Patch4: openssl-0.9.8m-enginesdir.patch
  17. # security fix
  18. # nothing ;-)
  19. License: BSDish
  20. Group: System Environment/Libraries
  21. URL: http://www.openssl.org/
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: perl, sed
  24. Requires: mktemp
  25. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  29. %description
  30. The OpenSSL certificate management tool and the shared libraries that
  31. provide various cryptographic algorithms and protocols.
  32. %package devel
  33. Summary: OpenSSL libraries and development headers.
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. The static libraries and include files needed to compile apps
  38. with support for various the cryptographic algorithms and protocols
  39. supported by OpenSSL.
  40. Patches for many networking apps can be found at:
  41. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  42. %package perl
  43. Summary: OpenSSL scripts which require Perl.
  44. Group: Applications/Internet
  45. Requires: perl
  46. Requires: %{name} = %{version}-%{release}
  47. %description perl
  48. Perl scripts provided with OpenSSL for converting certificates and keys
  49. from other formats to those used by OpenSSL.
  50. ## to build compat32 for x86_64 architecture support
  51. %package -n compat32-%{name}
  52. Summary: Secure Sockets Layer Toolkit
  53. Group: System Environment/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. %description -n compat32-%{name}
  56. The OpenSSL certificate management tool and the shared libraries that
  57. provide various cryptographic algorithms and protocols.
  58. %package -n compat32-%{name}-devel
  59. Summary: OpenSSL libraries and development headers.
  60. Group: Development/Libraries
  61. Requires: compat32-%{name} = %{version}-%{release}
  62. %description -n compat32-%{name}-devel
  63. The static libraries and include files needed to compile apps
  64. with support for various the cryptographic algorithms and protocols
  65. supported by OpenSSL.
  66. %prep
  67. %setup -q -n openssl-%{version}
  68. %patch0 -p1 -b .soversion
  69. %patch2 -p1 -b .rpm_opt
  70. %patch4 -p1 -b .enginesdir
  71. # security fix
  72. # nothing ;-)
  73. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  74. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  75. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  76. chmod 644 doc/ssleay.txt
  77. # Link the configuration header to the one we're going to make.
  78. ln -sf ../../crypto/opensslconf.h include/openssl/
  79. %build
  80. PATH=${PATH}:${PWD}/bin
  81. TOPDIR=${PWD}
  82. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  83. # Figure out which flags we want to use. Can't use assembler because it's
  84. # not lowest-common-denominator in most cases.
  85. perl util/perlpath.pl `dirname %{__perl}`
  86. %ifarch %ix86
  87. sslarch=linux-elf
  88. sslflags="no-asm 386"
  89. %endif
  90. %ifarch ppc
  91. sslarch=linux-ppc
  92. sslflags=no-asm
  93. %endif
  94. %ifarch sparc
  95. sslarch=linux-sparcv9
  96. sslflags=no-asm
  97. %endif
  98. %ifarch ia64
  99. sslarch=linux-ia64
  100. sslflags=no-asm
  101. %endif
  102. %ifarch alpha
  103. sslarch=linux-alpha-gcc
  104. sslflags=no-asm
  105. %endif
  106. %ifarch s390
  107. sslarch=linux-s390
  108. %endif
  109. %ifarch s390x
  110. sslarch=linux-s390x
  111. %endif
  112. %ifarch mipsel
  113. sslarch=linux-mips
  114. sslflags=no-asm
  115. %endif
  116. ## to build for x86_64 architecture support
  117. %ifarch x86_64
  118. sslarch=linux-x86_64
  119. sslflags=no-asm
  120. %endif
  121. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  122. # usable on all platforms. The Configure script already knows to use -fPIC and
  123. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  124. ./Configure \
  125. --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
  126. --enginesdir=%{_libdir}/openssl/engines \
  127. shared ${sslarch}
  128. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  129. # marked as not requiring an executable stack.
  130. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  131. make depend
  132. make all build-shared
  133. # Generate hashes for the included certs.
  134. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  135. export LD_LIBRARY_PATH
  136. make rehash build-shared
  137. # Verify that what was compiled actually works.
  138. make -C test apps tests
  139. # Relink the main binary to get it dynamically linked.
  140. rm apps/openssl
  141. make all build-shared
  142. %install
  143. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  144. # Install OpenSSL.
  145. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  146. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  147. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  148. # added for lib64
  149. mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  150. mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  151. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  152. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  153. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  154. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  155. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  156. chmod 755 ${lib}
  157. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  158. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  159. done
  160. install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  161. # Install a makefile for generating keys and self-signed certs, and a script
  162. # for generating them on the fly.
  163. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
  164. install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
  165. install -m644 $RPM_SOURCE_DIR/make-dummy-cert $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
  166. # Make sure we actually include the headers we built against.
  167. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  168. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  169. install -m644 include/openssl/`basename ${header}` ${header}
  170. fi
  171. done
  172. # Rename man pages so that they don't conflict with system man pages. We used
  173. # to change the file extensions, but that only prevents file conflicts. The
  174. # man viewer still can't select either of the two unless we physically change
  175. # the directory.
  176. for section in 1 2 3 4 5 6 7 8 ; do
  177. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  178. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  179. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  180. fi
  181. done
  182. # Pick a CA script.
  183. pushd $RPM_BUILD_ROOT%{_datadir}/ssl/misc
  184. mv CA.sh CA
  185. popd
  186. # Install root CA stuffs.
  187. cat %{SOURCE3} > ca-bundle.crt
  188. install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
  189. ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
  190. # Fix libdir.
  191. #sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
  192. sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
  193. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
  194. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
  195. cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
  196. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
  197. rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
  198. %clean
  199. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  200. %files
  201. %defattr(-,root,root)
  202. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  203. %doc doc/README doc/c-indentation.el doc/openssl.txt
  204. %doc doc/openssl_button.html doc/openssl_button.gif
  205. %doc doc/ssleay.txt
  206. %dir %{_datadir}/ssl
  207. %{_datadir}/ssl/certs
  208. %{_datadir}/ssl/cert.pem
  209. %{_datadir}/ssl/misc/CA
  210. %{_datadir}/ssl/misc/c_*
  211. %{_datadir}/ssl/private
  212. %config(noreplace) %{_datadir}/ssl/openssl.cnf
  213. %attr(0755,root,root) %{_bindir}/openssl
  214. %attr(0755,root,root) /%{_lib}/*.so.*
  215. %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  216. %attr(0755,root,root) %dir %{_mandir}/man1*
  217. %attr(0644,root,root) %{_mandir}/man1*/*
  218. %attr(0755,root,root) %dir %{_mandir}/man5*
  219. %attr(0644,root,root) %{_mandir}/man5*/*
  220. %attr(0755,root,root) %dir %{_mandir}/man7*
  221. %attr(0644,root,root) %{_mandir}/man7*/*
  222. %files devel
  223. %defattr(-,root,root)
  224. %{_prefix}/include/openssl
  225. %exclude %{_libdir}/lib*.a
  226. %attr(0755,root,root) %{_libdir}/*.so
  227. %attr(0755,root,root) %dir %{_mandir}/man3*
  228. %attr(0644,root,root) %{_mandir}/man3*/*
  229. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  230. %files perl
  231. %defattr(-,root,root)
  232. %attr(0755,root,root) %{_bindir}/c_rehash
  233. %attr(0755,root,root) %dir %{_mandir}/man1*
  234. %attr(0644,root,root) %{_mandir}/man1*/*.pl*
  235. %{_datadir}/ssl/misc/*.pl
  236. ## to build compat32 for x86_64 architecture support
  237. %if %{build_compat32}
  238. %files -n compat32-%{name}
  239. %defattr(-,root,root)
  240. %attr(0755,root,root) /%{_lib}/*.so.*
  241. %files -n compat32-%{name}-devel
  242. %defattr(-,root,root)
  243. %exclude %{_libdir}/lib*.a
  244. %attr(0755,root,root) %{_libdir}/*.so
  245. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  246. %endif
  247. %post -p /sbin/ldconfig
  248. %postun -p /sbin/ldconfig
  249. %post -n compat32-%{name} -p /sbin/ldconfig
  250. %postun -n compat32-%{name} -p /sbin/ldconfig
  251. %changelog
  252. * Thu Mar 18 2010 IWAI, Masaharu <iwai@alib.jp> 0.9.8m-1
  253. - new upstream release
  254. - update enginsdir patch (Patch4)
  255. - drop unnecessary patch: upstream fixed
  256. - dtls dos patch (Patch10)
  257. - CVE-2009-4355 (memory leak) patch (Patch11)
  258. - CVE-2009-3555 (renegotiation) patch (Patch12)
  259. - update SOURCE6 for pkgconfig
  260. - replace BuildPreReq to BuildRequires
  261. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  262. - add patch12 for fix CVE-2009-3555 (renegotiation)
  263. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  264. - add patch11 for fix CVE-2009-4355 (memory leak)
  265. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  266. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  267. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  268. - removed unnecessary %%if %{build_compat32} statements
  269. - removed lib*.a from devel package
  270. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  271. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  272. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  273. - new upstream release with security fix (CVE-2008-5077)
  274. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  275. - new upstream release
  276. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  277. - new upstream release
  278. - new versioning policy
  279. * Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  280. - new upstream release
  281. - drop patch10,20 which is merged in upstream
  282. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  283. - add security patch in advance for CVE-2007-5135
  284. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  285. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  286. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  287. - add security patch for CVE-2007-3108
  288. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  289. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  290. - new upstream release
  291. * Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  292. - update (fix) openssl.pc <BTS:437>
  293. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  294. - new upstream release (with security fix)
  295. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  296. - new upstream release
  297. - add patch2 to use RPM_OPT macro
  298. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  299. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  300. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  301. - added compat32-* packages for x86_64 architecture support
  302. - added openssl-0.9.7i.Configure-compat32.patch
  303. - changed '/lib' to '/%{_lib}'
  304. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  305. - new upstream release
  306. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  307. - rebuild on VineSeed
  308. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  309. - added a security patch from Gentoo.
  310. - Patch1: openssl-0.9.7c-tempfile.patch
  311. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  312. - sslarch for ppc was missing... added.
  313. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  314. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  315. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  316. - new upstream version
  317. - clean up of spec file
  318. -- removed old patches
  319. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  320. - new upstream release
  321. - SECURITY fix.
  322. - http://www.openssl.org/news/secadv_20040317.txt
  323. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  324. - new upstream release
  325. - [Security fix]
  326. - Vulnerabilities in ASN.1 parsing
  327. http://www.openssl.org/news/secadv_20030930.txt
  328. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  329. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  330. - add openssl.pc for pkgconfig
  331. * Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  332. - New upstream version
  333. - dropped patch10, 11
  334. -- merged upstream version
  335. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  336. - rebuild for VineSeed
  337. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  338. - [Security Fix]
  339. - Timing-based attacks on RSA keys
  340. http://www.openssl.org/news/secadv_20030317.txt
  341. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  342. http://www.openssl.org/news/secadv_20030317.txt
  343. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  344. - new upstream release 0.9.6i
  345. - [Security Fix]
  346. - build for Vine Linux 2.6 errata
  347. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  348. - new upstream release 0.9.6h
  349. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  350. - new upstream release 0.9.6g
  351. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  352. - SECURITY: CAN-2002-0659 fixed
  353. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  354. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  355. - update asn patch to fix accidental reversal of a logic check
  356. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  357. - update asn patch to reduce chance that compiler optimization will remove
  358. one of the added tests
  359. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  360. - rebuild
  361. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  362. - add patch to fix ASN.1 vulnerabilities
  363. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  364. - rename spec file name
  365. - SECURITY: CA-2002-23 fixed
  366. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  367. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  368. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  369. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  370. - added ${PATH} in LD_LIBRARY_PATH
  371. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  372. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  373. - remove --no-<cipher>
  374. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  375. - add Patch10 for mipsel shared ( Configure )
  376. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  377. - build for Vine Linux
  378. - use openssl-engine-0.9.6b.tar.gz
  379. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  380. - update to 0.9.6b
  381. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  382. - move .so symlinks back to %%{_libdir}
  383. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  384. - move shared libraries to /lib (#38410)
  385. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  386. - switch to engine code base
  387. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  388. - add a script for creating dummy certificates
  389. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  390. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  391. - add s390x support
  392. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  393. - change two memcpy() calls to memmove()
  394. - don't define L_ENDIAN on alpha
  395. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  396. - make subpackages depend on the main package
  397. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  398. - adjust the hobble script to not disturb symlinks in include/ (fix from
  399. Joe Orton)
  400. * Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  401. - drop the m2crypo patch we weren't using
  402. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  403. - configure using "shared" as well
  404. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  405. - update to 0.9.6a
  406. - use the build-shared target to build shared libraries
  407. - bump the soversion to 2 because we're no longer compatible with
  408. our 0.9.5a packages or our 0.9.6 packages
  409. - drop the patch for making rsatest a no-op when rsa null support is used
  410. - put all man pages into <section>ssl instead of <section>
  411. - break the m2crypto modules into a separate package
  412. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  413. - use BN_LLONG on s390
  414. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  415. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  416. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  417. - move c_rehash to the perl subpackage, because it's a perl script now
  418. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  419. - update to 0.9.6
  420. - enable MD2
  421. - use the libcrypto.so and libssl.so targets to build shared libs with
  422. - bump the soversion to 1 because we're no longer compatible with any of
  423. the various 0.9.5a packages circulating around, which provide lib*.so.0
  424. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  425. - change hobble-openssl for disabling MD2 again
  426. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  427. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  428. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  429. apps built against a version of the library without it
  430. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  431. - disable some inline assembly, which on x86 is Pentium-specific
  432. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  433. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  434. - fix s390 patch
  435. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  436. - added support s390
  437. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  438. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  439. - add the CA.pl man page to the perl subpackage
  440. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  441. - always build with -mcpu=ev5 on alpha
  442. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  443. - add a symlink from cert.pem to ca-bundle.crt
  444. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  445. - add a ca-bundle file for packages like Samba to reference for CA certificates
  446. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  447. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  448. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  449. - add unzip as a buildprereq (#17662)
  450. - update m2crypto to 0.05-snap4
  451. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  452. - fix some issues in building when it's not installed
  453. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  454. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  455. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  456. - add Richard Henderson's patch for BN on ia64
  457. - clean up the changelog
  458. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  459. - fix the building of python modules without openssl-devel already installed
  460. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  461. - byte-compile python extensions without the build-root
  462. - adjust the makefile to not remove temporary files (like .key files when
  463. building .csr files) by marking them as .PRECIOUS
  464. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  465. - break out python extensions into a subpackage
  466. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  467. - tweak the makefile some more
  468. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  469. - disable MD2 support
  470. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  471. - disable MDC2 support
  472. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  473. - tweak the disabling of RC5, IDEA support
  474. - tweak the makefile
  475. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  476. - strip binaries and libraries
  477. - rework certificate makefile to have the right parts for Apache
  478. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  479. - use %%{_perl} instead of /usr/bin/perl
  480. - disable alpha until it passes its own test suite
  481. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  482. - move the passwd.1 man page out of the passwd package's way
  483. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  484. - update to 0.9.5a, modified for U.S.
  485. - add perl as a build-time requirement
  486. - move certificate makefile to another package
  487. - disable RC5, IDEA, RSA support
  488. - remove optimizations for now
  489. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  490. - Bero told me to move the Makefile into this package
  491. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  492. - add lib*.so symlinks to link dynamically against shared libs
  493. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  494. - update to 0.9.5
  495. - run ldconfig directly in post/postun
  496. - add FAQ
  497. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  498. - Fix build on non-x86 platforms
  499. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  500. - move /usr/share/ssl/* from -devel to main package
  501. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  502. - inital packaging
  503. - changes from base:
  504. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  505. - handle RPM_OPT_FLAGS