chromium-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. #% define with_system_icu 1
  7. %endif
  8. %define svn_rev 49253
  9. Name: chromium
  10. Summary: Google's opens source browser project
  11. Summary(ja): Googleのオープンソースウェブブラウザ
  12. #'
  13. Version: 6.0.431.0
  14. Release: 1%{?_dist_release}
  15. License: BSD
  16. Group: Applications/Internet
  17. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  18. ## The following are included for source reasons only
  19. # Custom build tools for chromium, hammer is a fancy front-end for scons
  20. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  21. %{?nosrc:NoSource: 0}
  22. %{?nosrc:NoSource: 1}
  23. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  24. Source2: repack_chromium_archive.sh
  25. # Script used to create the tar.lzma archive from a checked out source
  26. #Source3: pack_chromium_source.sh
  27. Source3: pack_chromium_source-vine.sh
  28. #Source10: chromium.desktop
  29. Source10: chromium-vine.desktop
  30. # Patch template which adds vendor to user agent
  31. ##!!Source20: chromium-vendor.patch.in
  32. Source20: chromium-vendor-vine.patch.in
  33. ##!!Source30: master_preferences
  34. Source30: master_preferences.vine
  35. #Source31: default_bookmarks.html
  36. #Source31: default_bookmarks.html.vine
  37. # icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
  38. Source100: icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
  39. Provides: chromium-browser = %{version}
  40. #Obsoletes: chromium-browser < %{version}
  41. ## Start Patches
  42. # Many changes to the gyp system so we can use system libraries
  43. # My first ever patch set. I hope I did well.
  44. Patch3: chromium-gyp-system-icu.patch
  45. Patch4: chromium-no-sqlite-debug.patch
  46. Patch5: chromium-gyp-system-04-nss-nspr.patch
  47. Patch7: chromium-codechanges-nss-nspr.patch
  48. Patch8: chromium-codechanges-zlib.patch
  49. #Patch9: chromium-drop-sse.patch
  50. Patch10: chromium-fix-wrapper.patch
  51. Patch12: chromium-no-test-sources.patch
  52. Patch13: chromium-no-courgette.patch
  53. Patch14: chromium-master-prefs-path.patch
  54. #Patch15: chromium-media-probe.patch
  55. Patch16: chromium-icu-code-changes.patch
  56. Patch17: chromium-system-glew.patch
  57. Patch18: chromium-system-expat.patch
  58. Patch19: chromium-system-zlib.patch
  59. Patch20: chromium-noffmpeg.patch
  60. Patch21: chromium-system-old-ffmpeg-way.patch
  61. Patch23: chromium-disable-mmx.patch
  62. Patch24: chromium-fix-yuv_row_posix-shared.patch
  63. Patch25: tcmalloc-factory.patch
  64. # Vine
  65. #Patch40: chromium-5.0.353-no-ffmpeg-vine.patch
  66. ## Gentoo patches
  67. # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
  68. #Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
  69. BuildRequires: gcc gcc-c++
  70. %if %{?_dist_release} == "vl5"
  71. BuildRequires: libstdc++34 libstdc++34-devel
  72. %elseif %{?_dist_release} == "vl6"
  73. BuildRequires: libstdc++ libstdc++-devel
  74. %endif
  75. BuildRequires: libevent
  76. ##!!BuildRequires: pkg-config
  77. BuildRequires: python
  78. ##!!BuildRequires: python-xml
  79. BuildRequires: python-pyxml
  80. BuildRequires: perl bison flex gperf
  81. ##!!BuildRequires: wdiff
  82. ##!!BuildRequires: update-desktop-files
  83. BuildRequires: desktop-file-utils
  84. BuildRequires: lzma
  85. ##!!BuildRequires: mozilla-nss-devel
  86. BuildRequires: nss-devel
  87. ##!!BuildRequires: alsa-devel
  88. BuildRequires: alsa-lib-devel
  89. BuildRequires: gtk2-devel
  90. BuildRequires: glib2-devel
  91. BuildRequires: cairo-devel >= 1.6
  92. ##!!BuildRequires: mozilla-nspr-devel
  93. BuildRequires: nspr-devel
  94. ##!!BuildRequires: gconf2-devel
  95. BuildRequires: GConf2-devel
  96. BuildRequires: freetype2-devel
  97. ##!!BuildRequires: dbus-1-devel
  98. BuildRequires: dbus-devel
  99. BuildRequires: libxslt-devel
  100. BuildRequires: libxml2-devel
  101. BuildRequires: libjpeg-devel
  102. BuildRequires: zlib-devel
  103. BuildRequires: libpng-devel
  104. ##!!BuildRequires: libbz2-devel
  105. BuildRequires: bzip2-devel
  106. BuildRequires: cups-devel
  107. %if %{?_dist_release} == "vl6"
  108. BuildRequires: fdupes
  109. %endif
  110. ##!!BuildRequires: libexpat-devel
  111. BuildRequires: expat-devel
  112. BuildRequires: glew-devel
  113. ##!!BuildRequires: Mesa-devel
  114. BuildRequires: mesa-libGLU-devel
  115. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  116. BuildRequires: libevent-devel
  117. ##Vine Linux
  118. BuildRequires: libXScrnSaver-devel
  119. #BuildRequires: gle-devel
  120. #BuildRequires: webkit-gtk-devel
  121. #BuildRequires: scons
  122. %ifarch x86_64
  123. Requires: nspluginwrapper
  124. %endif
  125. ##!!Requires: alsa
  126. Requires: alsa-lib
  127. # shouldn't be required to name all dependencies
  128. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  129. ## Recommends the ffmpeg libraries (available from packman)
  130. #Recommends: libavcodec52 libavformat52 libavutil50
  131. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  132. %description
  133. Chromium is the open-source project behind Google Chrome.
  134. We invite you to join us in our effort to help build a safer, faster,
  135. and more stable way for all Internet users to experience the web,
  136. and to create a powerful platform for developing a new generation of
  137. web applications.
  138. %description -l ja
  139. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  140. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  141. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  142. ウェブアプリケーションの新しい世代を発展させるように
  143. 強力なプラットホームを作成するために、
  144. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  145. %prep
  146. [ -d %{name} ] && %__rm -rf %{name}
  147. lzma -cd %{SOURCE0} | tar xf -
  148. %setup -D -T -n %{name}
  149. # use static libicu
  150. #%if %{?_dist_release} == "vl5"
  151. cd src/third_party || exit 1
  152. %__rm -rf icu || exit 1
  153. tar jxvf %{SOURCE100} || exit 1
  154. %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
  155. cd - || exit 1
  156. #%endif
  157. # use system libicu only if >= 4.0
  158. %{?with_system_icu:%patch3 -p1}
  159. %patch4 -p1
  160. %patch5 -p1
  161. %patch7 -p1
  162. %patch8 -p1
  163. #%patch9 -p1
  164. %patch10 -p1
  165. #%patch11 -p1
  166. %patch12 -p1
  167. %patch13 -p1
  168. %patch14 -p1
  169. #%patch15 -p0
  170. %{?with_system_icu:%patch16 -p1}
  171. %patch17 -p1
  172. %patch18 -p1
  173. %patch19 -p1
  174. %patch20 -p1
  175. %patch21 -p1
  176. #%patch22 -p1
  177. %patch25 -p1
  178. %ifarch %ix86
  179. %patch23 -p1
  180. %endif
  181. %patch24 -p1
  182. # apply vendor patch after substitution
  183. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  184. %build
  185. ## create make files
  186. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  187. for i in src/build/common.gypi; do
  188. %__sed -i "s|'-march=pentium4',||g" $i
  189. %__sed -i "s|'-msse2',||g" $i
  190. %__sed -i "s|'-mfpmath=sse',||g" $i
  191. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  192. %__sed -i "s|'-m32',||g" $i
  193. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  194. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  195. done
  196. # '
  197. pushd src
  198. ./build/gyp_chromium -f make build/all.gyp \
  199. -Duse_system_ffmpeg=1 \
  200. -Duse_system_zlib=1 \
  201. -Duse_system_libpng=1 \
  202. -Duse_system_bzip2=1 \
  203. -Duse_system_libjpeg=1 \
  204. -Duse_system_libxml=1 \
  205. -Duse_system_libxslt=1 \
  206. -Duse_system_libevent=1 \
  207. -Dproprietary_codecs=1 \
  208. -Dlinux_fpic=1 \
  209. %{?with_system_icu:-Duse_system_icu=1} \
  210. %{!?with_system_icu:-Duse_system_icu=0} \
  211. %ifarch %{ix86}
  212. -Dtarget_arch=ia32 \
  213. -Ddisable_sse2=1 \
  214. %endif
  215. %ifarch x86_64
  216. -Dtarget_arch=x64 \
  217. %endif
  218. %if %{?_dist_release} == "vl6"
  219. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  220. %endif
  221. -Drelease_extra_cflags=-fPIC \
  222. ;
  223. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  224. #%__make -r -j5 chrome BUILDTYPE=Release
  225. %__make %{?_smp_mflags} chrome BUILDTYPE=Release
  226. popd
  227. %install
  228. %{__rm} -rf %{buildroot}
  229. ## Create install directories
  230. %{__mkdir_p} %{buildroot}%{_libdir}/%{name}
  231. %{__mkdir_p} %{buildroot}%{_bindir}
  232. %{__mkdir_p} %{buildroot}%{_datadir}/applications
  233. %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
  234. %{__mkdir_p} %{buildroot}%{_mandir}/man1
  235. %{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
  236. # chromium 'make' deposits us back at the top level build directory
  237. pushd src/out/Release
  238. ls -l
  239. # clean somechromium-codechanges-zlib.patch
  240. # clean debug junk
  241. %{__rm} -rf obj/ mksnapshot obj.target obj.host
  242. find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
  243. # clean NaCl stuff... maybe NaCl will be in its own package in the future.
  244. %{__rm} -f ncdecode_table ncdecode_tablegen
  245. # clean other temporary binaries used in the compilation of chromium
  246. %{__rm} -f protoc xdg-settings
  247. %{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
  248. # Man page
  249. [ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
  250. %__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
  251. # Add startup file with plugins enabled
  252. %{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
  253. #!/bin/bash
  254. %{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
  255. EOF
  256. # # link to browser plugin path. Plugin patch doesn't work. Why?
  257. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  258. # pushd %{buildroot}%{_libdir}/%{name}
  259. # %{__ln_s} %{_libdir}/browser-plugins plugins
  260. # popd
  261. pushd %{buildroot}%{_libdir}/%{name}
  262. %ifarch x86_64
  263. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  264. %else
  265. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  266. %endif
  267. #touch %{buildroot}%{_libdir}/libavcodec.so.52
  268. #%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  269. #touch %{buildroot}%{_libdir}/libavformat.so.52
  270. #%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  271. #touch %{buildroot}%{_libdir}/libavutil.so.50
  272. #%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  273. popd
  274. # Install desktop-related files
  275. %__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
  276. %__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
  277. desktop-file-install --vendor Vine \
  278. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  279. --delete-original \
  280. --mode 644 \
  281. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  282. # Install the master_preferences file
  283. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  284. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  285. ## install o3d plugin
  286. #pushd src/o3d/build/out/Release
  287. #%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
  288. %clean
  289. %{__rm} -rf %{buildroot}
  290. %files
  291. %defattr(-,root,root)
  292. %doc src/AUTHORS src/LICENSE
  293. %dir %{_libdir}/%{name}
  294. %attr(0755,root,root) %{_bindir}/%{name}
  295. %{_mandir}/man1/*
  296. %{_datadir}/applications/*%{name}.desktop
  297. %{_datadir}/pixmaps/%{name}.png
  298. %{_libdir}/%{name}/*
  299. %config %{_sysconfdir}/%{name}
  300. #%{_libdir}/browser-plugins/*
  301. #%exclude %{_libdir}/libavcodec.so.52
  302. #%exclude %{_libdir}/libavutil.so.50
  303. #%exclude %{_libdir}/libavformat.so.52
  304. %changelog
  305. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  306. - updated to snapshot 6.0.431.0 r49253
  307. - added BuildRequires: cups-devel
  308. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  309. - updated to snapshot 6.0.405.0 r47263
  310. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  311. - unused with_system_icu (for vl6)
  312. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  313. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  314. - updated to snapshot 5.0.378.0 r44472
  315. - used with_system_icu (for vl6)
  316. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  317. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  318. - updated to snapshot 5.0.372.0 r43947
  319. - added BuildRequires: glew-devel
  320. - changed Group tag to Applications/Internet
  321. - added Summary(ja) and %%description -l ja
  322. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  323. - updated to snapshot 5.0.365.0 r42966
  324. - merged 5.0.353.0-4vl5
  325. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  326. - build on Vine Linux 5.1
  327. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  328. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  329. - updated to snapshot 5.0.364.0 r42779
  330. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  331. - updated to snapshot 5.0.359.0 r42116
  332. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  333. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  334. - fixed master_preferences.vine, little
  335. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  336. - fixed to install master_preferences
  337. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  338. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  339. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  340. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  341. - updated to snapshot 5.0.353.0 r41449
  342. * Wed Mar 10 2010 bgmerrell@novell.com
  343. - Add master_preferences source file and install it to /etc/chromium.
  344. - Create a new patch (chromium-master-prefs-path.patch) which tells
  345. chromium to look in /etc/chromium for the master_preferences file
  346. (instead of looking in the default directory, which is the same
  347. directory as the 'chrome' binary).
  348. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  349. - updated to snapshot 5.0.335.0 r39556
  350. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  351. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  352. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  353. - updated to snapshot 5.0.330.0 r39074
  354. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  355. - use_system_ffmpeg
  356. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  357. - added Requires: nspluginwrapper
  358. - fixed a symbolic link of plugins directory with nspluginwrapper
  359. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  360. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  361. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  362. - added BuildRequires: mesa-libGLU-devel
  363. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  364. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  365. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  366. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  367. - Update to 4.0.260
  368. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  369. - Update to 4.0.259
  370. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  371. - Update to 4.0.258
  372. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  373. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  374. changed to having an built-in v8
  375. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  376. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  377. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  378. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  379. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  380. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  381. - update to newer svn snapshot
  382. + Obsoletes fwrite patch (included upstream)
  383. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  384. - update to newer svn snapshot
  385. + Requires newer version of v8
  386. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  387. - do not force SSE on x86 (drop-sse.patch)
  388. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  389. - Update to newer svn snapshot
  390. - Fixed spec file in order to build
  391. - Included patch to build with system zlib
  392. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  393. - package renamed to chromium
  394. - cleaned up spec file
  395. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  396. - v8 is now built as a separate package, and is required
  397. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  398. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  399. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  400. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  401. - initial build
  402. #% changelog
  403. * Sun Jan 24 2010 prusnak@suse.cz
  404. - added vendor to user agent (chromium-vendor.patch.in)
  405. * Sun Nov 29 2009 prusnak@suse.cz
  406. - added --enable-sync to wrapper to enable bookmark sync
  407. * Fri Nov 13 2009 tittiatcoke@gmail.com
  408. - update to 247.0 svn 31928
  409. * Fri Oct 30 2009 tittiatcoke@gmail.com
  410. - update to 229.0 svn 30454
  411. + Fix regression where popups and app frames lost their titlebars.
  412. + Makes it so that when a folder is open on the bookmark bar
  413. and the mouse moves over another folder, the menu for that
  414. folder is shown.
  415. + Lazily create the find bar.
  416. + Polish to the gmail checker sample.
  417. * New, crisper icons that are exactly 19x19
  418. * Add a loading animation at the beginning before Gmail
  419. responds.
  420. * Fix a bug where we sometimes don't update the UI after a
  421. logout/login cycle.
  422. + Refactor widget methods to support desktop notifications,
  423. including GTK stubs.
  424. + Find-in-page should not ding while deleting characters.
  425. + Add SSL wrapper for linux and mac. This allows notifier to
  426. use chrome's SSL layer instead of OpenSSL.
  427. + Add three of the six extensions to PAC that Internet Explorer supports.
  428. + WebSocket support in chromium. (Run with --enable-web-sockets
  429. enables WebSocket features.)
  430. + Do not allow GTK File Chooser dialogs to return directories.
  431. + Fix the notifier SSL layer to make notifications work for
  432. Linux Bookmark sync.
  433. + linux: don't override mouse selection behavior in omnibox
  434. * Sun Oct 25 2009 tittiatcoke@gmail.com
  435. - Update to 224.4 svn 30027
  436. + First cut at new page and browser action docs based
  437. on new API. Deleted old stuff.
  438. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  439. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  440. + Minimize dependency of user scripts
  441. + Fixup the flip_framer eof-handling semantics now that we have
  442. the FIN bit in place
  443. + app depends on x11 because of active_window_watcher_x
  444. + Adding two images for the new Extension managment UI
  445. + Removing hard-coded Chrome Frame output path
  446. + Rearrange clipboard code
  447. + Fix crash bug when attempting to download a url with unsupported scheme,
  448. e.g. 'data:', by 'Alt + Click'
  449. + GTK: Change text for extension download UI
  450. + Ignore invalid urls on command line
  451. + Make dropped tabs animate from where they were dropped.
  452. + Make room for the full width of the tab placeholder.
  453. + Make tab dragging as smooth as glass.
  454. + Remove an annoying NOTIMPLEMNETED
  455. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  456. + If we're in the middle of a drag, don't allow the user to middle
  457. click to close or right click for the context menu
  458. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  459. + Remove +x bit from files that shouldn't have it
  460. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  461. + Adding new image needed for the managment UI
  462. + Fix a race bug where content scripts would not apply to the first page load
  463. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  464. + Fix bubbles deactivating the opaque frame
  465. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  466. + ake all pepper plugins default to windowless and transparent
  467. + Add styles for printing
  468. + Implement the new extension management UI
  469. + Add support for to automation interface load install and load extensions
  470. + GTK: theme the info bar border
  471. + Update V8 to version 1.3.16.1
  472. + Introduce WebSecurityPolicy for security related methods
  473. + New button scheme...borders are separate from the inner contents so
  474. that they can be highlighted / depressed independently
  475. + When opening Chrome maximized with an application window already
  476. running, the Chrome window was not activated
  477. + Fix compatibility problems with FileZilla FTP Server
  478. + Remove the extension shelf on Linux
  479. + Fix the proxy host and port string to start with http:// if it does not already
  480. + Enable HTML5 databases for all extension renderer processes