at-spi-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define atk_version 1.30.0
  3. %define gtk2_version 2.20.0
  4. %define libbonobo_version 2.24.0
  5. %define orbit2_version 2.6.0
  6. %define pango_version 1.28.0
  7. %define gconf2_version 2.28.0
  8. %define dbus_glib_version 0.76
  9. Summary: Assistive Technology Service Provider Interface
  10. Name: at-spi
  11. Version: 1.30.1
  12. Release: 1%{?_dist_release}
  13. URL: http://developer.gnome.org/projects/gap/
  14. Source0: http://download.gnome.org/sources/at-spi/1.24/%{name}-%{version}.tar.bz2
  15. License: LGPLv2+
  16. Group: System Environment/Libraries
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: pango-devel >= %{pango_version}
  19. BuildRequires: gtk2-devel >= %{gtk2_version}
  20. BuildRequires: libbonobo-devel >= %{libbonobo_version}
  21. BuildRequires: ORBit2-devel >= %{orbit2_version}
  22. BuildRequires: atk-devel >= %{atk_version}
  23. BuildRequires: GConf2-devel >= %{gconf2_version}
  24. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  25. BuildRequires: popt-devel
  26. BuildRequires: fontconfig
  27. BuildRequires: gettext
  28. BuildRequires: intltool
  29. BuildRequires: perl(XML::Parser)
  30. BuildRequires: libX11-devel
  31. BuildRequires: libXtst-devel
  32. BuildRequires: libXi-devel
  33. BuildRequires: libXevie-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: desktop-file-utils
  36. Patch2: at-spi-silence-no-event-spew.patch
  37. %description
  38. at-spi allows assistive technologies to access GTK-based
  39. applications. Essentially it exposes the internals of applications for
  40. automation, so tools such as screen readers, magnifiers, or even
  41. scripting interfaces can query and interact with GUI controls.
  42. %package devel
  43. Summary: Development libraries and headers for at-spi
  44. Group: Development/Libraries
  45. Requires: %name = %{version}-%{release}
  46. Requires: atk-devel
  47. Requires: gtk2-devel
  48. Requires: libbonobo-devel
  49. Requires: ORBit2-devel
  50. Requires: pkgconfig
  51. %description devel
  52. Libraries and header files allowing compilation of apps that use at-spi.
  53. %package python
  54. Summary: Python bindings for at-spi
  55. Group: Development/Libraries
  56. Requires: %name = %{version}-%{release}
  57. Requires: python
  58. %description python
  59. Python bindings allowing to use at-spi in python programs.
  60. %prep
  61. %setup -q
  62. ## %patch2 -p1 -b .spew
  63. %build
  64. %configure --disable-gtk-doc --disable-static
  65. make
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make install DESTDIR=$RPM_BUILD_ROOT
  69. %find_lang at-spi
  70. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  71. rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
  73. %post
  74. /sbin/ldconfig
  75. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  76. gconftool-2 --makefile-install-rule \
  77. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  78. %pre
  79. if [ "$1" -gt 1 ]; then
  80. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  81. gconftool-2 --makefile-uninstall-rule \
  82. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  83. fi
  84. %preun
  85. if [ "$1" -eq 0 ]; then
  86. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  87. gconftool-2 --makefile-uninstall-rule \
  88. %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
  89. fi
  90. %postun -p /sbin/ldconfig
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %files -f at-spi.lang
  94. %defattr(-,root,root)
  95. %doc AUTHORS COPYING NEWS README
  96. %{_sysconfdir}/gconf/schemas/at-spi.schemas
  97. %{_sysconfdir}/xdg/autostart/at-spi-registryd.desktop
  98. %{_libdir}/lib*.so.*
  99. %{_libdir}/bonobo/servers/*
  100. %{_libdir}/orbit-2.0/*
  101. %{_libdir}/gtk-2.0/modules/*
  102. %{_libexecdir}/*
  103. %files devel
  104. %defattr(-,root,root)
  105. %{_datadir}/gtk-doc/html/*
  106. %{_datadir}/idl/*
  107. %{_libdir}/lib*.so
  108. %{_libdir}/pkgconfig/*
  109. %{_includedir}/*
  110. %files python
  111. %defattr(-,root,root)
  112. %{python_sitearch}/pyatspi/
  113. %changelog
  114. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
  115. - new upstream release
  116. * Sat Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  117. - new upstream release
  118. - drop Patch2
  119. - add BuildRequires: GConf2-devel, dbus-glib-devel, popt-devel, desktop-file-utils
  120. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
  121. - rebuild with python-2.6
  122. * Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
  123. - remove BuildRequires gail-devel
  124. (gtk2-2.14.x now includes/provides gail)
  125. * Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  126. - initial build for Vine Linux
  127. * Mon Sep 8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
  128. - Update to 1.23.92
  129. - Drop upstreamed patch
  130. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
  131. - Fix an evo crash caused by the greeter crash fix
  132. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
  133. - Fix a greeter crash
  134. * Tue Sep 2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
  135. - Update to 1.23.91
  136. * Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
  137. - Silence incessant atk-bridge spew filling xsession-errors (#459275)
  138. * Mon Aug 4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
  139. - Update to 1.23.6
  140. * Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
  141. - Update to 1.23.5
  142. * Tue Jun 3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
  143. - Update to 1.23.3
  144. * Mon May 5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
  145. - Bump rev
  146. * Mon Apr 7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
  147. - Update to 1.22.1
  148. * Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
  149. - Update to 1.22.0
  150. * Wed Mar 5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
  151. - Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
  152. * Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
  153. - Update to 1.21.92
  154. * Fri Feb 8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
  155. - Rebuild for gcc 4.3
  156. * Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
  157. - Update to 1.21.5
  158. * Thu Dec 6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
  159. - Update to 1.21.3
  160. * Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
  161. - Update to 1.21.1
  162. * Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
  163. - Update to 1.20.1
  164. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
  165. - Update to 1.20.0
  166. * Mon Aug 6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
  167. - Update license field
  168. * Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
  169. - Update to 1.19.5
  170. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
  171. - Update to 1.19.3
  172. - Add a -python subpackage
  173. * Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
  174. - Update to 1.19.1
  175. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
  176. - Don't ship .la files
  177. * Mon Apr 9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
  178. - Update to 1.18.1, which includes the previous patch
  179. - Drop obsolete patch
  180. - Fix a small memory leak
  181. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
  182. - Backport a patch to fix deadlocks in applications
  183. * Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
  184. - Update to 1.18.0
  185. - Drop obsolete patch
  186. * Thu Mar 8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
  187. - add a patch that might fix some deadlock issues (bug 329454)
  188. * Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
  189. - Update to 1.17.2
  190. * Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
  191. - Update to 1.17.1
  192. * Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
  193. - Bump atk requirement
  194. * Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
  195. - Update to 1.17.0
  196. * Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
  197. - Update to 1.7.16
  198. * Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
  199. - Update to 1.7.15
  200. * Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
  201. - Update to 1.7.14
  202. * Sat Dec 9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
  203. - Small spec file cleanups
  204. * Tue Nov 7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
  205. - Update to 1.7.13
  206. * Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
  207. - Update to 1.7.12
  208. * Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
  209. - Remove debug spew
  210. * Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
  211. - Update to 1.7.11
  212. - Drop upstreamed patch
  213. - Require pkgconfig in the -devel package
  214. * Wed Aug 2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
  215. - Update to 1.7.10
  216. * Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
  217. - Fix segfault if a11y enabled on x86-64 (#196063)
  218. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
  219. - Rebuild
  220. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
  221. - Update to 1.7.9
  222. * Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
  223. - Update to 1.7.8
  224. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
  225. - rebuild
  226. * Thu Jun 8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
  227. - Add a BuildRequires
  228. * Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
  229. - Make it build in mock
  230. * Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
  231. - Revert the previous change
  232. * Tue Apr 4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
  233. - Fix a missing declaration
  234. - Fix segfaults on x86_64
  235. * Tue Apr 4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
  236. - Update to 1.7.7
  237. * Thu Mar 9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
  238. - Fix a crash on x86_64
  239. * Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
  240. - Update to 1.7.6
  241. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
  242. - Update to 1.7.5
  243. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
  244. - bump again for double-long bug on ppc(64)
  245. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
  246. - rebuilt for new gcc4.1 snapshot and glibc changes
  247. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
  248. - Update to 1.7.4
  249. * Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
  250. - Update to 1.7.3
  251. * Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
  252. - Update to 1.7.2
  253. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  254. - rebuilt
  255. * Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
  256. - Switch requires to modular X
  257. * Wed Sep 7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
  258. - Update to 1.6.6
  259. * Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
  260. - Rebuilt
  261. * Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
  262. - Update to 1.6.4
  263. * Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
  264. - Update to 1.6.3
  265. * Wed Mar 2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
  266. - Rebuilt with gcc4
  267. * Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
  268. - Update to 1.6.2
  269. * Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
  270. - Remove dependency on linc-devel
  271. * Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
  272. - Fix some random spec file issues (fixes #133430?)
  273. * Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
  274. - bump version
  275. * Wed Aug 4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
  276. - Update to 1.5.3
  277. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  278. - rebuilt
  279. * Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
  280. - Update to 1.4.0
  281. * Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
  282. - Update to 1.3.15
  283. * Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
  284. - Update to 1.3.14
  285. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  286. - rebuilt
  287. * Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
  288. - update to 1.3.13
  289. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  290. - rebuilt
  291. * Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
  292. - new version
  293. * Thu Oct 2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
  294. - new version
  295. * Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
  296. - Fix rebuild failure (stderr.patch)
  297. * Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
  298. - disable gtk doc
  299. * Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
  300. - automated rebuild
  301. * Mon Jul 7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
  302. - 1.1.9
  303. - remove multilib patch fixed upstream
  304. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  305. - rebuilt
  306. * Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
  307. - kill Xft buildreq
  308. * Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
  309. - rebuild to fix self-dependency
  310. * Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
  311. - extend multilib patch to cover -lXi
  312. * Tue Feb 4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
  313. - 1.1.8
  314. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  315. - rebuilt
  316. * Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
  317. - Add patch to help multilib systems find libXtst
  318. * Fri Dec 6 2002 Havoc Pennington <hp@redhat.com>
  319. - rebuild
  320. * Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
  321. - rebuild with new libbonobo and gail
  322. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  323. - automated rebuild
  324. * Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
  325. - add libatk-bridge.so to the file list
  326. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  327. - 1.0.1
  328. - add at-spi-registryd to file list
  329. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  330. - rebuild in different environment
  331. * Tue Jun 4 2002 Havoc Pennington <hp@redhat.com>
  332. - 1.0.0
  333. - add post/postun ldconfig
  334. * Wed May 29 2002 Bill Nottingham <notting@redhat.com>
  335. - rebuild again?
  336. * Tue May 28 2002 Havoc Pennington <hp@redhat.com>
  337. - rebuild in different environment
  338. * Tue May 28 2002 Havoc Pennington <hp@redhat.com>
  339. - 0.12.1
  340. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  341. - Version 0.0.6
  342. * Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
  343. - rebuild in rawhide, seems to have been linked incorrectly
  344. * Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
  345. - rebuild in rawhide, upgrade to 0.0.5
  346. - add gail deps
  347. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  348. - Initial build.