speech-dispatcher-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338
  1. %define with_nas 1
  2. %define with_pulse 1
  3. %define with_flite 1
  4. Name: speech-dispatcher
  5. Version: 0.8.1
  6. Release: 1%{?_dist_release}
  7. Summary: To provide a high-level device independent layer for speech synthesis
  8. Group: System Environment/Libraries
  9. # Almost all files are under GPLv2+, however
  10. # src/c/clients/spdsend/spdsend.h is licensed under GPLv2,
  11. # which makes %%_bindir/spdsend GPLv2.
  12. License: GPLv2+ and GPLv2
  13. URL: http://www.freebsoft.org/pub/projects/speechd/
  14. Source0: http://www.freebsoft.org/pub/projects/speechd/%{name}-%{version}.tar.gz
  15. Source1: http://www.nsitonline.in/hemant/stuff/speechd-rpm/speech-dispatcherd
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: espeak-devel
  18. BuildRequires: alsa-lib-devel
  19. BuildRequires: dotconf-devel
  20. BuildRequires: texinfo
  21. BuildRequires: libraw1394-devel
  22. BuildRequires: pulseaudio-lib-devel
  23. BuildRequires: libao-devel
  24. BuildRequires: glib2-devel
  25. BuildRequires: flite-devel
  26. BuildRequires: nas-devel
  27. BuildRequires: libtool-ltdl-devel
  28. Requires(post): /sbin/chkconfig
  29. Requires(preun): /sbin/chkconfig /sbin/service
  30. Requires(postun): /sbin/service
  31. Obsoletes: %{name}-python < 0.8.0
  32. %description
  33. * Common interface to different TTS engines
  34. * Handling concurrent synthesis requests – requests may come
  35. asynchronously from multiple sources within an application
  36. and/or from more different applications.
  37. * Subsequent serialization, resolution of conflicts and
  38. priorities of incoming requests
  39. * Context switching – state is maintained for each client
  40. connection independently, event for connections from
  41. within one application.
  42. * High-level client interfaces for popular programming languages
  43. * Common sound output handling – audio playback is handled by
  44. Speech Dispatcher rather than the TTS engine, since most engines
  45. have limited sound output capabilities.
  46. %package devel
  47. Summary: Development files for %{name}
  48. Group: Development/Libraries
  49. Requires: speech-dispatcher = %{version}-%{release}
  50. License: GPLv2+
  51. %description devel
  52. The %{name}-devel package contains libraries and header files for
  53. developing applications that use %{name}.
  54. %package doc
  55. Summary: Documentation for speech-dispatcher
  56. License: GPLv2+
  57. Group: Applications/Documentation
  58. Requires: speech-dispatcher = %{version}-%{release}
  59. Requires(post): /sbin/install-info
  60. Requires(preun):/sbin/install-info
  61. %description doc
  62. speechd documentation
  63. %prep
  64. %setup -q
  65. %build
  66. %configure \
  67. --disable-static \
  68. --with-alsa \
  69. --with-pulse \
  70. --with-flite \
  71. --sysconfdir=%{_sysconfdir} \
  72. --with-default-audio-method=pulse
  73. make %{?_smp_mflags}
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. for dir in \
  77. config/ doc/ include/ src/audio/ src/api/ src/modules/ src/tests/ src/server/ src/clients/
  78. do
  79. pushd $dir
  80. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  81. popd
  82. done
  83. #Install the init shell script
  84. mkdir -p $RPM_BUILD_ROOT%{_initrddir}
  85. install -p -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/
  86. #Remove %{_infodir}/dir file
  87. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  88. cd ../../
  89. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  90. # Move the config files from /usr/share to /etc
  91. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
  92. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
  93. mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/speechd.conf $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/
  94. mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/clients/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/clients
  95. mv $RPM_BUILD_ROOT%{_datadir}/speech-dispatcher/conf/modules/* $RPM_BUILD_ROOT%{_sysconfdir}/speech-dispatcher/modules
  96. # Remove dummy sound
  97. rm -rf $RPM_BUILD_ROOT/%{_datadir}/sounds/
  98. # Create log dir
  99. mkdir -p -m 0700 $RPM_BUILD_ROOT%{_localstatedir}/log/speech-dispatcher/
  100. # enable pulseaudio as default with a fallback to alsa
  101. sed 's/# AudioOutputMethod "pulse,alsa"/AudioOutputMethod "pulse,alsa"/' %{buildroot}%{_sysconfdir}/speech-dispatcher/speechd.conf
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %post
  105. /sbin/ldconfig
  106. /sbin/chkconfig --add speech-dispatcherd
  107. %postun
  108. /sbin/ldconfig
  109. if [ "$1" -ge "1" ] ; then
  110. /sbin/service speech-dispatcherd condrestart >/dev/null 2>&1 || :
  111. fi
  112. %preun
  113. if [ $1 = 0 ] ; then
  114. /sbin/service speech-dispatcherd stop >/dev/null 2>&1
  115. /sbin/chkconfig --del speech-dispatcherd
  116. fi
  117. %post doc
  118. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  119. /sbin/install-info %{_infodir}/spd-say.info %{_infodir}/dir || :
  120. /sbin/install-info %{_infodir}/ssip.info %{_infodir}/dir || :
  121. /sbin/install-info %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
  122. %preun doc
  123. if [ $1 = 0 ]; then
  124. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
  125. /sbin/install-info --delete %{_infodir}/spd-say.info %{_infodir}/dir || :
  126. /sbin/install-info --delete %{_infodir}/ssip.info %{_infodir}/dir || :
  127. /sbin/install-info --delete %{_infodir}/%{name}-cs.info %{_infodir}/dir || :
  128. fi
  129. %files
  130. %defattr(-,root,root,-)
  131. %doc AUTHORS ChangeLog NEWS README TODO COPYING
  132. %config(noreplace) %{_sysconfdir}/speech-dispatcher/speechd.conf
  133. %config(noreplace) %{_sysconfdir}/speech-dispatcher/clients/*.conf
  134. %config(noreplace) %{_sysconfdir}/speech-dispatcher/modules/*.conf
  135. %dir %{_sysconfdir}/speech-dispatcher/
  136. %dir %{_sysconfdir}/speech-dispatcher/clients
  137. %dir %{_sysconfdir}/speech-dispatcher/modules
  138. %{_bindir}/*
  139. %{_libdir}/speech-dispatcher-modules/sd_*
  140. %dir %{_libdir}/speech-dispatcher-modules
  141. %{_libdir}/libspeechd.so.*
  142. %dir %{_libdir}/speech-dispatcher
  143. %{_libdir}/speech-dispatcher/spd*.so
  144. %dir %attr(0700, root, root) %{_localstatedir}/log/speech-dispatcher/
  145. %attr(0755,root,root)%{_initrddir}/speech-dispatcherd
  146. %files devel
  147. %defattr(-,root,root,-)
  148. %{_includedir}/*
  149. %{_libdir}/lib*.so
  150. %files doc
  151. %defattr(-,root,root,-)
  152. %{_infodir}/*
  153. %changelog
  154. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-1
  155. - new upstream release
  156. - remove %%{name}-python subpackage
  157. - add BuildRequires: libtool-ltdl-devel
  158. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
  159. - rebuild with python-2.7.2
  160. * Sat Nov 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-1
  161. - new upstream release
  162. - remove all patches
  163. * Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.7-5
  164. - Initial build for Vine Linux
  165. * Wed Mar 3 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-4
  166. - Add patch to fix dso linking. Bug 564851
  167. * Sat Jan 9 2010 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-3
  168. - Updated to the new python sysarch spec file reqs
  169. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.7-2
  170. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  171. * Wed May 20 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.7-1
  172. - New upstream release, some spec file cleanups.
  173. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-21
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  175. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.6.6-20
  176. - Rebuild for Python 2.6
  177. * Sun Sep 21 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.6-19
  178. - Fix Patch0:/%%patch mismatch.
  179. * Wed Jul 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-18
  180. - removed suid permission for speech-dispatcher binary.
  181. * Wed Jul 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-17
  182. - changing permissions of speech-dispatcher to 6711 (setuid and setguid)
  183. - relocating configuration files in case of OLPC branch.
  184. - excluding init script in case of OLPC branch.
  185. * Wed Jul 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-16
  186. - yet another release bump required :-/
  187. * Wed Jul 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-15
  188. - release bump
  189. * Sun Jul 13 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-14
  190. - conditional build required for OLPC Branch - Building without nas and
  191. pulse-audio support.
  192. * Mon Jun 23 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-13
  193. - changed permission of speech-dispatcherd to 0644 too.
  194. * Fri Jun 20 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-12
  195. - added BuildRequires: texinfo (for makeinfo)
  196. - changed permissions of Sourcex to 0644
  197. - incorporated modified init script by mtasaka
  198. - fixed a few more macros in changelog
  199. - modified location of Source1 and Patch0 to point to online locations
  200. * Wed Jun 18 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-11
  201. - fixed encoding of speech-dispatcher-cs.info file to UTF-8
  202. * Wed Jun 11 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-10
  203. - removed Requires(preun) duplicates
  204. - applied -p option correctly to install command
  205. - fixed macros in changelog to prevent them from exapnding
  206. - fixed the init script
  207. - added patch to change log directory of speech-dispatcher and start only espeak
  208. * Sun Jun 08 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-9
  209. - removed %%{_infodir}/dir file
  210. * Sat Jun 07 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-8
  211. - converted speech-dispatcher-cs.info to UTF-8 encoding
  212. - removed multiple file listings of /usr/lib/python2.5/site-packages/speechd/_test.py
  213. and fixed its mode
  214. - added init script as a SOURCE instead as a patch
  215. - duplicate Requires have now been removed
  216. - Timestamping of files has now been added
  217. - Install script fixed
  218. - init script fixed
  219. * Tue Jun 03 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-7
  220. - changed license of base package to GPLv2+ and GPL
  221. - changed license of all other packages to GPLv2+
  222. - fixed install sequence using cleaner for loop and pushd and popd commands
  223. - added init script for speech-dispatcher daemon
  224. - added COPYING to doc in base package
  225. - removed comment after /sbin/ldconfig
  226. - resolved rpmlint errors for base package [except UTF-8 encoding error for (cs) documentation file]
  227. - renamed long_message to spd_long_message and run_test to spd_run_test
  228. - reset mode of _test.py to 0755
  229. * Sun Apr 27 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-6
  230. - changed BR to pulseaudio-lib-devel
  231. - removed dotconf BR
  232. - gave ownership of /%%{python_sitelib}/speechd-0.3-py2.5.egg-info to python package if package is built for Fedora 9 or above
  233. * Sun Apr 13 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-5
  234. - Removed conitional building options
  235. - Added BuildRequires for dotconf-devel
  236. * Mon Feb 18 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-4
  237. - Manually specyfying make install for each src directory to be installed
  238. - Installing python package seprately by by-passing make install
  239. * Sun Feb 17 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-3
  240. - Added Requires(post), Requires(preun) for -doc package
  241. - Changed scriptlet from postun to preun for -doc package
  242. - Removed Epoch
  243. - Moved %%{_libdir}/lib*.so back to devel pacakge
  244. - Require dependecny on base pacakge is now set to %%{version}-%%{release} instead of %%{version}
  245. - removed --prefix=$RPM_BUILD_ROOT/%%{_prefix} against configure macro.
  246. -- -python subpackage does not build anymore.
  247. - removed python subpackag rules from SPEC file.
  248. * Sat Feb 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-2
  249. - fixed directory ownerships
  250. * Sat Feb 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.6-1
  251. - using newest version of speech-dispatcher
  252. - updated %%{_libdir}/libspeechd.so.2.0.4 to %%{_libdir}/libspeechd.so.2.0.5
  253. - python packages are being generated correctly now
  254. - must force prefix=$RPM_BUILD_ROOT/%%{_prefix} to enable python packages to get installed correctly.
  255. - finding and deleting .*la files in $RPM_BUILD_ROOT to avoid unpackaged files error.
  256. * Sat Feb 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-4
  257. - updated build root
  258. * Sat Feb 16 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-3
  259. - added macro to prevent error from stopping build for not including *.la files
  260. - added epoch to the SPEC
  261. - conditional build seems to be working correctly the old way only??
  262. - unified changelogs
  263. * Fri Feb 15 2008 Hemant Goyal <goyal.hemant@gmail.com> 0.6.5-2
  264. - Removed .la files
  265. - Removed doc-cs packages and merged it into doc package
  266. - Removed packaging of static files, and tested -without static_libs option for configure script
  267. - Moved symlink .so files from devel package to main package
  268. - Commented /sbin/ldconfig for devel package.