perl-WWW-Curl-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. Name: perl-WWW-Curl
  2. Version: 4.17
  3. Release: 1%{?_dist_release}
  4. Summary: Perl extension interface for libcurl
  5. License: MIT
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/WWW-Curl/
  8. Source0: http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT/WWW-Curl-%{version}.tar.gz
  9. BuildRequires: perl
  10. BuildRequires: perl(inc::Module::Install)
  11. BuildRequires: perl(Carp)
  12. BuildRequires: perl(Exporter)
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(File::Temp)
  15. %{?_with_network_tests: BuildRequires: perl(lib) }
  16. BuildRequires: perl(strict)
  17. BuildRequires: perl(Test::More)
  18. # Test::Pod is optional
  19. BuildRequires: perl(warnings)
  20. BuildRequires: perl(XSLoader)
  21. BuildRequires: curl-devel
  22. Requires: perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
  23. %{?perl_default_filter}
  24. %description
  25. WWW::Curl is a Perl extension interface for libcurl.
  26. %prep
  27. %setup -q -n WWW-Curl-%{version}
  28. rm -rf inc && sed -i -e '/^inc\//d' MANIFEST
  29. %build
  30. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  31. make %{?_smp_mflags}
  32. %install
  33. make pure_install DESTDIR=$RPM_BUILD_ROOT
  34. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
  35. find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
  36. %{_fixperms} $RPM_BUILD_ROOT/*
  37. %check
  38. # These tests require network, use "--with network_tests" to execute them
  39. %{?!_with_network_tests: rm t/01basic.t }
  40. %{?!_with_network_tests: rm t/02callbacks.t }
  41. %{?!_with_network_tests: rm t/04abort-test.t }
  42. %{?!_with_network_tests: rm t/05progress.t }
  43. %{?!_with_network_tests: rm t/08ssl.t }
  44. %{?!_with_network_tests: rm t/09times.t }
  45. %{?!_with_network_tests: rm t/14duphandle.t }
  46. %{?!_with_network_tests: rm t/15duphandle-callback.t }
  47. %{?!_with_network_tests: rm t/18twinhandles.t }
  48. %{?!_with_network_tests: rm t/19multi.t }
  49. %{?!_with_network_tests: rm t/21write-to-scalar.t }
  50. make test
  51. %files
  52. %doc Changes LICENSE README
  53. %{perl_vendorarch}/auto/*
  54. %{perl_vendorarch}/WWW*
  55. %{_mandir}/man3/*
  56. %changelog
  57. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.17-1
  58. - initial build for Vine Linux
  59. * Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 4.17-4
  60. - Perl 5.20 rebuild
  61. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.17-3
  62. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  63. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.17-2
  64. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  65. * Wed Feb 26 2014 Petr Šabata <contyk@redhat.com> - 4.17-1
  66. - 4.17 bump, license change
  67. * Fri Feb 21 2014 Petr Šabata <contyk@redhat.com> - 4.16-1
  68. - 4.16 bump
  69. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-12
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  71. * Fri Aug 02 2013 Petr Pisar <ppisar@redhat.com> - 4.15-11
  72. - Perl 5.18 rebuild
  73. * Sun Jul 14 2013 Jitka Plesnikova <jplesnik@redhat.com> - 4.15-10
  74. - Update dependencies
  75. - Use DESTDIR rather than PERL_INSTALL_ROOT
  76. - Remove buildroot cleaning
  77. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-9
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  79. * Thu Aug 16 2012 Jitka Plesnikova <jplesnik@redhat.com> - 4.15-8
  80. - Specify all dependencies
  81. - Modernize spec file
  82. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-7
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  84. * Fri Jun 22 2012 Petr Pisar <ppisar@redhat.com> - 4.15-6
  85. - Perl 5.16 rebuild
  86. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-5
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  88. * Sun Jul 24 2011 Iain Arnell <iarnell@gmail.com> 4.15-4
  89. - use perl_default_filter
  90. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.15-3
  91. - Perl mass rebuild
  92. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-2
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  94. * Tue Nov 30 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.15-1
  95. - Update to 4.15
  96. * Thu Oct 28 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.14-1
  97. - Update to 4.14
  98. - Add a filter provide to avoid private-shared-object-provides error
  99. * Sun Sep 5 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.13-1
  100. - Update to 4.13
  101. * Wed Aug 25 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.12-1
  102. - Update to 4.12
  103. * Thu Jun 3 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.11-3
  104. - Remove test 19 because it requires network
  105. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 4.11-2
  106. - Mass rebuild with perl-5.12.0
  107. * Fri Dec 18 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.11-1
  108. - Update to 4.11
  109. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 4.09-3
  110. - rebuild against perl 5.10.1
  111. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.09-2
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  113. * Sat Jul 11 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.09-1
  114. - Rebuild for 4.09
  115. * Mon Jun 1 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.07-1
  116. - Rebuild for 4.07
  117. * Sat Apr 18 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.06-1
  118. - Step to 4.06
  119. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.05-5
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  121. * Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-4
  122. - Licence update
  123. * Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-3
  124. - README.Win32 file removed
  125. * Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-2
  126. - Timestamp preserved
  127. - changelog format fix
  128. - README.Win32 file removed
  129. * Thu Dec 11 2008 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-1
  130. - Initial build with cpan2spec