perl-Module-Install-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221
  1. Name: perl-Module-Install
  2. Version: 1.04
  3. Release: 2%{?_dist_release}
  4. Summary: Standalone, extensible Perl module installer
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Module-Install/
  8. Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/Module-Install-%{version}.tar.gz
  9. BuildArch: noarch
  10. # Note, Makefile.PL is going to complain about having lower versions of
  11. # certain modules than is supported. (Especially under F-10.) However,
  12. # all tests pass and AFAICT everything works just fine in normal usage.
  13. BuildRequires: perl(Archive::Tar) >= 1.44
  14. BuildRequires: perl(CPAN)
  15. BuildRequires: perl(Devel::PPPort)
  16. BuildRequires: perl(ExtUtils::Install) >= 1.52
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. BuildRequires: perl(ExtUtils::ParseXS) >= 2.19
  19. BuildRequires: perl(File::Remove) >= 1.42
  20. BuildRequires: perl(File::Spec)
  21. BuildRequires: perl(JSON) >= 2.14
  22. BuildRequires: perl(LWP::UserAgent) >= 5.812
  23. BuildRequires: perl(Module::Build) >= 0.29
  24. BuildRequires: perl(Module::CoreList) >= 2.17
  25. BuildRequires: perl(Module::ScanDeps) >= 0.89
  26. BuildRequires: perl(PAR::Dist) >= 0.29
  27. BuildRequires: perl(Parse::CPAN::Meta) >= 1.39
  28. BuildRequires: perl(Test::CPAN::Meta) >= 0.07
  29. BuildRequires: perl(Test::Harness) >= 3.13
  30. BuildRequires: perl(Test::MinimumVersion)
  31. BuildRequires: perl(Test::More)
  32. BuildRequires: perl(Test::Pod)
  33. BuildRequires: perl(YAML::Tiny) >= 1.38
  34. Requires: perl(Archive::Tar)
  35. Requires: perl(ExtUtils::ParseXS)
  36. Requires: perl(Module::Build)
  37. Requires: perl(Module::ScanDeps)
  38. Requires: perl(PAR::Dist) >= 0.29
  39. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. Packager: shaolin
  43. %description
  44. Module::Install is a package for writing installers for CPAN (or CPAN-like)
  45. distributions that are clean, simple, minimalist, act in a strictly correct
  46. manner with ExtUtils::MakeMaker, and will run on any Perl installation
  47. version 5.005 or newer.
  48. %prep
  49. %setup -q -n Module-Install-%{version}
  50. %build
  51. %{__perl} Makefile.PL INSTALLDIRS=vendor
  52. make %{?_smp_mflags}
  53. %install
  54. make pure_install DESTDIR=%{buildroot}
  55. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  56. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
  57. rm -rf %{buildroot}/blib/lib/auto/share/dist/Module-Install/dist_file.txt
  58. %{_fixperms} %{buildroot}/*
  59. find %{buildroot}%{perl_vendorlib} -type f -perm +100 -exec chmod a-x {} \;
  60. %check
  61. make test AUTOMATED_TESTING=1
  62. %files
  63. %doc Changes LICENSE README
  64. %{perl_vendorlib}/*
  65. %{_mandir}/man3/*
  66. %changelog
  67. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.04-2
  68. - rebuild with VineSeed environment
  69. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.04-1
  70. - initial build for Vine Linux
  71. * Thu Jan 12 2012 Iain Arnell <iarnell@gmail.com> 1.04-1
  72. - update to latest upstream version
  73. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1.01-2
  74. - Perl mass rebuild
  75. * Sat May 14 2011 Iain Arnell <iarnell@gmail.com> 1.01-1
  76. - update to latest upstream version
  77. - clean up spec for modern rpmbuild
  78. * Thu Mar 10 2011 Steven Pritchard <steve@kspei.com> 1.00-1
  79. - Update to 1.00.
  80. - Update build dependencies:
  81. + Archive::Tar >= 1.44
  82. + ExtUtils::Install >= 1.52
  83. + ExtUtils::ParseXS >= 2.19
  84. + JSON >= 2.14
  85. + LWP::UserAgent >= 5.812
  86. + Module::Build >= 0.29
  87. + Module::CoreList >= 2.17
  88. + Module::ScanDeps >= 0.89
  89. - Update description (pulled from module).
  90. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.95-3
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  92. * Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.95-2
  93. - 661697 rebuild for fixing problems with vendorach/lib
  94. * Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.95-1
  95. - Mass rebuild with perl-5.12.0 & update
  96. * Thu Feb 25 2010 Marcela Mašláňová <mmaslano@redhat.com> - 0.91-4
  97. - change to DESTDIR
  98. - add README
  99. - dist_file.txt wasn't packaged -> removed, it's needed only for test of build
  100. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.91-3
  101. - rebuild against perl 5.10.1
  102. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-2
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  104. * Sun Jun 14 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.91-1
  105. - update to 0.91
  106. - add br on Parse::CPAN::Meta: 1.39
  107. * Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.90-1
  108. - update to 0.90
  109. - add br on JSON, Test::Harness (3.13)
  110. - update br on YAML::Tiny (1.38)
  111. * Mon May 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.87-1
  112. - update to 0.87
  113. * Sun Apr 26 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.85-1
  114. - update to 0.85
  115. - add BR on File::Spec
  116. * Thu Apr 09 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.82-1
  117. - update to 0.82
  118. * Sun Mar 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.80-1
  119. - update to 0.80
  120. - remove 03_autoinstall.t swizzle (now self-skipped; see RT29448)
  121. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.79-1
  122. - update to 0.79
  123. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.77-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  125. * Thu Dec 04 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.77-1
  126. - update to 0.77
  127. * Wed Jun 04 2008 Steven Pritchard <steve@kspei.com> 0.75-1
  128. - Update to 0.75.
  129. * Sat May 31 2008 Steven Pritchard <steve@kspei.com> 0.74-1
  130. - Update to 0.74.
  131. - Update versioned dependencies for File::Remove, Module::ScanDeps,
  132. PAR::Dist, and YAML::Tiny.
  133. - BR Test::CPAN::Meta.
  134. * Fri May 16 2008 Steven Pritchard <steve@kspei.com> 0.73-1
  135. - Update to 0.73.
  136. - BR File::Remove.
  137. - Drop zero-length README.
  138. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.68-3
  139. - disable broken test (upstream bug present)
  140. - add Test::MinimumVersion as BR
  141. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.68-2
  142. - rebuild for new perl
  143. * Mon Jan 28 2008 Steven Pritchard <steve@kspei.com> 0.68-1
  144. - Update to 0.68.
  145. - Explicitly require Archive::Tar and ExtUtils::ParseXS.
  146. * Sun Dec 30 2007 Ralf Corsépius <rc040203@freenet.de> - 0.67-2
  147. - BR: perl(Test::More), perl(CPAN) (BZ 419631).
  148. - Remove TEST_POD (Unused).
  149. - Add AUTOMATED_TESTING.
  150. - BR: perl(Test::Pod) for AUTOMATED_TESTING.
  151. - Adjust License-tag.
  152. * Fri May 18 2007 Steven Pritchard <steve@kspei.com> 0.67-1
  153. - Update to 0.67.
  154. - BR Archive::Tar, ExtUtils::ParseXS, and YAML::Tiny.
  155. - Add a couple more docs.
  156. * Tue Mar 13 2007 Steven Pritchard <steve@kspei.com> 0.65-1
  157. - Update to 0.65.
  158. - Use fixperms macro instead of our own chmod incantation.
  159. - BR ExtUtils::MakeMaker.
  160. * Sun Sep 17 2006 Steven Pritchard <steve@kspei.com> 0.64-2
  161. - Rebuild.
  162. * Fri Aug 25 2006 Steven Pritchard <steve@kspei.com> 0.64-1
  163. - Update to 0.64.
  164. - Fix find option order.
  165. * Thu Jun 08 2006 Steven Pritchard <steve@kspei.com> 0.63-1
  166. - Update to 0.63.
  167. * Mon May 08 2006 Steven Pritchard <steve@kspei.com> 0.62-2
  168. - Fix Source0 URL.
  169. * Sat May 06 2006 Steven Pritchard <steve@kspei.com> 0.62-1
  170. - Update to 0.62.
  171. - Drop executable bit from everything in vendor_perl to make rpmlint happy.
  172. * Thu Mar 23 2006 Steven Pritchard <steve@kspei.com> 0.61-1
  173. - Specfile autogenerated by cpanspec 1.63.
  174. - Drop explicit BR: perl.
  175. - Turn on TEST_POD.