chrony-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239
  1. Name: chrony
  2. Version: 3.2
  3. Release: 2%{?_dist_release}
  4. Summary: An NTP client/server
  5. Group: System Environment/Daemons
  6. License: GPLv2
  7. URL: http://chrony.tuxfamily.org
  8. Source0: http://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
  9. Source1: chrony.conf
  10. Source2: chrony.dhclient
  11. Source3: chronyd.sysconfig
  12. Source4: chronyd.init
  13. Source5: chrony.logrotate
  14. # Fedora's patches
  15. Patch102: chrony-select-timeout.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  17. BuildRequires: libcap-devel readline-devel ncurses-devel bison
  18. Requires(pre): shadow-utils
  19. Requires(post): chkconfig
  20. Requires(preun): chkconfig initscripts
  21. Requires(postun): initscripts
  22. %if "%{?_dist_release}" == "vl7"
  23. Obsoletes: ntp < 4.2.6p5
  24. %endif
  25. Obsoletes: networkmanager-dispatcher-chrony
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: tomop
  29. %description
  30. A client/server for the Network Time Protocol, this program keeps your
  31. computer's clock accurate. It was specially designed to support
  32. systems with intermittent internet connections, but it also works well
  33. in permanently connected environments. It can use also hardware reference
  34. clocks, system real-time clock or manual input as time references.
  35. %prep
  36. %setup -q -n %{name}-%{version}%{?prerelease}
  37. %patch102 -p1
  38. echo '# Keys used by chronyd for command and NTP authentication' > chrony.keys
  39. # regenerate the file from getdate.y
  40. rm -f getdate.c
  41. %build
  42. #CFLAGS="$RPM_OPT_FLAGS"
  43. #%ifarch %{sparc}
  44. #CFLAGS="$CFLAGS -pie -fPIE"
  45. #%else
  46. #CFLAGS="$CFLAGS -pie -fpie"
  47. #%endif
  48. #export CFLAGS
  49. #export LDFLAGS="-Wl,-z,relro,-z,now"
  50. %configure \
  51. --docdir=%{_docdir} \
  52. --with-user=chrony \
  53. --with-sendmail=%{_sbindir}/sendmail \
  54. --enable-forcednsretry
  55. make %{?_smp_mflags} all docs
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. make install install-docs DESTDIR=$RPM_BUILD_ROOT
  59. rm -rf $RPM_BUILD_ROOT%{_docdir}
  60. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,logrotate.d}
  61. mkdir -p $RPM_BUILD_ROOT%{_initrddir}
  62. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
  63. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
  64. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d
  65. install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
  66. install -m 640 -p chrony.keys $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
  67. install -m 755 -p examples/chrony.nm-dispatcher \
  68. $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
  69. install -m 755 -p %{SOURCE2} \
  70. $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
  71. install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
  72. install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
  73. install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
  74. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %pre
  78. getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
  79. getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
  80. -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
  81. :
  82. %post
  83. /sbin/chkconfig --add chronyd
  84. :
  85. %preun
  86. if [ "$1" -eq 0 ]; then
  87. /sbin/service chronyd stop &> /dev/null
  88. /sbin/chkconfig --del chronyd
  89. fi
  90. :
  91. %postun
  92. if [ "$1" -ge 1 ]; then
  93. /sbin/service chronyd condrestart &> /dev/null
  94. fi
  95. :
  96. %files
  97. %defattr(-,root,root,-)
  98. %doc COPYING FAQ NEWS README examples/*
  99. %config(noreplace) %{_sysconfdir}/chrony.conf
  100. %config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
  101. %config(noreplace) %{_sysconfdir}/sysconfig/chronyd
  102. %config(noreplace) %{_sysconfdir}/logrotate.d/chrony
  103. %{_initrddir}/chronyd
  104. %{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
  105. %{_sysconfdir}/dhcp/dhclient.d/chrony.sh
  106. %{_bindir}/chronyc
  107. %{_sbindir}/chronyd
  108. %{_mandir}/man[158]/%{name}*.[158]*
  109. %dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
  110. %ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
  111. %ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
  112. %dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
  113. %changelog
  114. * Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.2-2
  115. - rebuild with readline-8.0 and ncurses-6.1
  116. * Sat Jun 9 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.2-1
  117. - update to 3.2
  118. - drop Patch101; upstream merged
  119. - add Fedora's patch (Patch102)
  120. * Tue Dec 05 2017 Miroslav Lichvar <mlichvar@redhat.com> 3.2-2
  121. - fix chronyc getting stuck in infinite loop after clock step (#1520884)
  122. - restrict obsoleting 'ntp' package to VineSeed; for Vine Linux 6
  123. * Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0-1
  124. - update to 3.0
  125. - add patch to fix time smoothing in interleaved mode (Patch101); from Debian 3.0-4
  126. - drop chrony.txt in %%doc; upstream dropped
  127. - drop info file; upstream dropped
  128. - drop R: info
  129. - drop BR: texinfo
  130. - drop scripts for info
  131. * Mon Jul 11 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-2
  132. - Obsoletes: networkmanager-dispatcher-chrony
  133. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
  134. - new upstream release.
  135. * Fri Oct 23 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2-1
  136. - new upstream release.
  137. * Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  138. - new upstream release.
  139. * Tue Dec 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31-1
  140. - new upstream release.
  141. * Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
  142. - new upstream release.
  143. - initial build for Vine Linux.
  144. * Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
  145. - fix buffer overflow when processing crafted command packets (CVE-2012-4502)
  146. - don't send uninitialized data in command replies (CVE-2012-4503)
  147. * Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
  148. - remove timepps.h, NM and dhclient scripts
  149. - build with readline
  150. * Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
  151. - update to 1.25
  152. - link with -Wl,-z,relro,-z,now options
  153. - use iburst, four pool servers, rtcsync, stratumweight in default config
  154. - suppress install-info errors
  155. * Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
  156. - update to 20100428git73d775
  157. - replace initstepslew directive with makestep in default config
  158. - add NetworkManager dispatcher script
  159. - add dhclient script
  160. - retry server/peer name resolution at least once to workaround
  161. NetworkManager race condition on boot
  162. - don't verify chrony.keys
  163. * Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
  164. - update to snapshot 20100302git5fb555
  165. - compile with PPS API support
  166. * Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
  167. - update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
  168. - modify default config
  169. - step clock on start if it is off by more than 100 seconds
  170. - disable client log
  171. - build with -fPIE on sparc
  172. * Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
  173. - update to 1.24-pre1
  174. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  176. * Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
  177. - switch to editline
  178. - support arbitrary chronyc commands in init script
  179. * Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
  180. - add patch with support for s390/s390x
  181. * Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
  182. - fix building with broken libcap header (#483548)
  183. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  185. * Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
  186. - fix info uninstall
  187. - generate random command key in init script
  188. - support cyclelogs, online, offline commands in init script
  189. - add logrotate script
  190. * Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
  191. - initial release