perl-Eval-Closure-vl.spec 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. Name: perl-Eval-Closure
  2. Version: 0.11
  3. Release: 1%{?_dist_release}
  4. Summary: Safely and cleanly create closures via string eval
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Eval-Closure/
  8. Source0: http://www.cpan.org/authors/id/D/DO/DOY/Eval-Closure-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. BuildArch: noarch
  11. BuildRequires: perl(ExtUtils::MakeMaker)
  12. BuildRequires: perl(PadWalker)
  13. BuildRequires: perl(Perl::Tidy)
  14. BuildRequires: perl(Scalar::Util)
  15. BuildRequires: perl(Sub::Exporter)
  16. BuildRequires: perl(Test::Fatal)
  17. BuildRequires: perl(Test::More) >= 0.88
  18. BuildRequires: perl(Test::Output)
  19. BuildRequires: perl(Test::Requires)
  20. BuildRequires: perl(Try::Tiny)
  21. Requires: perl(Perl::Tidy)
  22. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  23. %{?perl_default_filter}
  24. %description
  25. String eval is often used for dynamic code generation. For instance, Moose uses
  26. it heavily, to generate inlined versions of accessors and constructors, which
  27. speeds code up at runtime by a significant amount. String eval is not without
  28. its issues however - it's difficult to control the scope it's used in (which
  29. determines which variables are in scope inside the eval), and it's easy to miss
  30. compilation errors, since eval catches them and sticks them in $@ instead.
  31. This module attempts to solve these problems. It provides an eval_closure
  32. function, which evals a string in a clean environment, other than a fixed list
  33. of specified variables. Compilation errors are rethrown automatically.
  34. %prep
  35. %setup -q -n Eval-Closure-%{version}
  36. %build
  37. %{__perl} Makefile.PL INSTALLDIRS=vendor
  38. make %{?_smp_mflags}
  39. %install
  40. rm -rf %{buildroot}
  41. make pure_install DESTDIR=%{buildroot}
  42. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  43. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
  44. %{_fixperms} %{buildroot}/*
  45. %check
  46. make test
  47. %clean
  48. rm -rf %{buildroot}
  49. %files
  50. %doc Changes LICENSE README
  51. %{perl_vendorlib}/*
  52. %{_mandir}/man3/*
  53. %changelog
  54. * Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.11-1
  55. - updated to 0.11
  56. - built with perl 5.16.3
  57. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.08-1
  58. - initial build for Vine Linux
  59. * Fri Feb 10 2012 Iain Arnell <iarnell@gmail.com> 0.08-1
  60. - update to latest upstream version
  61. * Sat Feb 04 2012 Iain Arnell <iarnell@gmail.com> 0.07-1
  62. - update to latest upstream version
  63. - update description
  64. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-3
  65. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  66. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-2
  67. - Perl mass rebuild
  68. * Tue Jun 07 2011 Iain Arnell <iarnell@gmail.com> 0.06-1
  69. - update to latest upstream version
  70. * Wed May 04 2011 Iain Arnell <iarnell@gmail.com> 0.05-1
  71. - update to latest upstream version
  72. * Wed Apr 20 2011 Iain Arnell <iarnell@gmail.com> 0.04-1
  73. - update to latest upstream version
  74. * Thu Mar 03 2011 Iain Arnell <iarnell@gmail.com> 0.03-1
  75. - update to latest upstream version
  76. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-2
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  78. * Fri Jan 28 2011 Iain Arnell <iarnell@gmail.com> 0.02-1
  79. - update to latest upstream version
  80. * Sun Jan 23 2011 Iain Arnell <iarnell@gmail.com> 0.01-1
  81. - Specfile autogenerated by cpanspec 1.78.