jsoncpp-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152
  1. Name: jsoncpp
  2. Version: 1.9.1
  3. Release: 1%{?_dist_release}
  4. Summary: JSON library implemented in C++
  5. Summary(ja): C++ で実装された JSON ライブラリ
  6. Group: System Environment/Libraries
  7. License: Public Domain or MIT
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. URL: https://github.com/open-source-parsers/jsoncpp
  11. Source0: https://github.com/open-source-parsers/jsoncpp/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  12. Patch0000: %{name}-1.9.1-fix_version.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cmake > 3.15.0
  15. BuildRequires: python3-devel
  16. BuildRequires: python3-rpm-macros
  17. %description
  18. %{name} is an implementation of a JSON (http://json.org) reader and writer in
  19. C++. JSON (JavaScript Object Notation) is a lightweight data-interchange format.
  20. It is easy for humans to read and write. It is easy for machines to parse and
  21. generate.
  22. %package devel
  23. Summary: Development headers and library for %{name}
  24. Summary(ja): %{name} の開発用ヘッダファイルとライブラリ
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. Obsoletes: %{name}-doc < 1.0.0
  28. %description devel
  29. This package contains the development headers and library for %{name}.
  30. %prep
  31. %autosetup -p1
  32. %build
  33. mkdir -p %{_target_platform}
  34. pushd %{_target_platform}
  35. %cmake -DBUILD_STATIC_LIBS=OFF \
  36. -DJSONCPP_WITH_WARNING_AS_ERROR=OFF \
  37. -DJSONCPP_WITH_PKGCONFIG_SUPPORT=ON \
  38. -DJSONCPP_WITH_CMAKE_PACKAGE=ON \
  39. -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF \
  40. -DPYTHON_EXECUTABLE="%{__python3}" \
  41. ..
  42. popd
  43. %make_build -C %{_target_platform}
  44. %check
  45. %make_build -C %{_target_platform} jsoncpp_check
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. %make_install -C %{_target_platform}
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %post -p /sbin/ldconfig
  52. %postun -p /sbin/ldconfig
  53. %files
  54. %license AUTHORS LICENSE
  55. %doc README*
  56. %{_libdir}/lib%{name}.so.*
  57. %files devel
  58. %doc doc/*.html
  59. %{_libdir}/lib%{name}.so
  60. %{_includedir}/json
  61. %{_libdir}/cmake/*
  62. %{_libdir}/pkgconfig/%{name}.pc
  63. %changelog
  64. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.1-1
  65. - new upstream release.
  66. - dropped Source1.
  67. - dropped Patch0.
  68. - imported Patch0000 from rawhide.
  69. - dropped a sub-package "doc".
  70. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
  71. - rebuild with gcc-5.4.0
  72. * Tue Jan 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.7.1-1
  73. - Initial build for Vine Linux
  74. * Sun Sep 21 2014 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.14.rc2
  75. - Allow int values to be converted to string (#1143774)
  76. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.13.rc2
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  78. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.12.rc2
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  80. * Tue Sep 10 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.11.rc2
  81. - https://bugzilla.redhat.com/show_bug.cgi?id=998149 : applied Michael Schwendt's
  82. patch to fix duplicated documentation
  83. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.10.rc2
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  85. * Fri Mar 15 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.9.rc2
  86. - Changed Summary
  87. - Added %%doc files to the doc package
  88. - Added python as an explicit BuildRequires
  89. * Fri Feb 15 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.8.rc2
  90. - Added documentation sub-package
  91. * Sun Jan 20 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.7.rc2
  92. - Added graphviz as a BuildRequire
  93. * Sat Jan 19 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.6.rc2
  94. - Install the corrected library
  95. * Sat Dec 22 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.5.rc2
  96. - Added libjsoncpp.so.0
  97. - Moved the shared lib build to the correct section
  98. * Fri Dec 21 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.4.rc2
  99. - Removed doc subpackage
  100. - Added .pc file
  101. - Fixed shared lib
  102. * Wed Dec 12 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.3.rc2
  103. - Removed static package
  104. - Preserving timestamp on installed files
  105. - Added guard grep to the sed expression
  106. - Removed duplicated doc files
  107. - Removed dependency on pkgconfig
  108. - Changed base package group
  109. * Sun Dec 02 2012 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.2.rc2
  110. - Changed license field to Public Domain or MIT
  111. * Tue Nov 27 2012 Sébastien Willmann <sebastien.willmann@gmail.com> 0.6.0-0.1.rc2
  112. - Creation of the spec file