nginx-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.11.8
  26. Release: 1%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.3.5
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. ## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
  51. %define passenger_version 5.0.30
  52. Source1020: passenger-%{passenger_version}.tar.gz
  53. %define upstream_fair_version 2131c73
  54. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  55. %define mod_wsgi_version 6975f0ec7eeb
  56. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  57. # removes -Werror in upstream build scripts. -Werror conflicts with
  58. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  59. Patch0: nginx-auto-cc-gcc.patch
  60. # to fix https://svn.boost.org/trac/boost/ticket/8731
  61. Patch100: boost-changeset_84950.diff
  62. # to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
  63. Patch101: gnosek-nginx-upstream-fair-pull-23.patch
  64. # to fix compile error with C++11.
  65. Patch1000: passenger-5.0.28-boost.patch
  66. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  67. BuildRequires: pcre-devel
  68. BuildRequires: zlib-devel
  69. BuildRequires: openssl-devel
  70. BuildRequires: gd-devel
  71. BuildRequires: perl
  72. BuildRequires: perl(ExtUtils::Embed)
  73. BuildRequires: libxml2-devel
  74. BuildRequires: libxslt-devel
  75. BuildRequires: curl-devel
  76. %if %{with geoip}
  77. BuildRequires: GeoIP-devel
  78. %endif
  79. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  80. # for /usr/sbin/useradd
  81. Requires(pre): shadow-utils
  82. Requires(post): chkconfig
  83. # for /sbin/service
  84. Requires(preun): chkconfig, initscripts
  85. Requires(postun): initscripts
  86. %if "%{_dist_release}" > "vl6"
  87. Requires(pre): www-common
  88. %endif
  89. Provides: webserver
  90. Vendor: Project Vine
  91. Distribution: Vine Linux
  92. Packager: daisuke
  93. %description
  94. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  95. proxy server written by Igor Sysoev.
  96. %description -l ja
  97. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  98. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  99. - HTTP(S) サーバ
  100. - HTTP(S) リバースプロキシサーバ
  101. - IMAP/POP3 プロキシサーバ
  102. %package passenger
  103. Summary: Nginx with mod_passenger support
  104. Summary(ja): Passenger サポート入りの Nginx
  105. Group: System Environment/Daemons
  106. BuildRequires: ruby, rubygem-rake
  107. Requires: ruby, rubygem-rake
  108. %if "%{_dist_release}" >= "vl7"
  109. BuildRequires: ruby-devel, ruby-rubygems
  110. Requires: ruby-rubygems
  111. %else
  112. BuildRequires: rubygems
  113. Requires: rubygems
  114. %endif
  115. Requires: nginx
  116. %description passenger
  117. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  118. This package contains nginx server with passenger support.
  119. %description -l ja passenger
  120. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  121. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  122. - HTTP(S) サーバ
  123. - HTTP(S) リバースプロキシサーバ
  124. - IMAP/POP3 プロキシサーバ
  125. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  126. %prep
  127. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  128. %patch0 -p0
  129. # pushd passenger-%{passenger_version}/ext/
  130. # %patch100 -p2
  131. # popd
  132. pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
  133. %patch101 -p1
  134. popd
  135. %if %{?_dist_release} == "vl7"
  136. pushd passenger-%{passenger_version}
  137. %patch1000 -p1
  138. popd
  139. %endif
  140. %build
  141. # nginx does not utilize a standard configure script. It has its own
  142. # and the standard configure options cause the nginx configure script
  143. # to error out. This is is also the reason for the DESTDIR environment
  144. # variable. The configure script(s) have been patched (Patch1 and
  145. # Patch2) in order to support installing into a build environment.
  146. export DESTDIR=%{buildroot}
  147. CONFIGOPTS="\
  148. --user=%{nginx_user} \
  149. --group=%{nginx_group} \
  150. --prefix=%{nginx_datadir} \
  151. --sbin-path=%{_sbindir}/%{name} \
  152. --conf-path=%{nginx_confdir}/%{name}.conf \
  153. --error-log-path=%{nginx_logdir}/error.log \
  154. --http-log-path=%{nginx_logdir}/access.log \
  155. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  156. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  157. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  158. --pid-path=%{_localstatedir}/run/%{name}.pid \
  159. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  160. --with-file-aio \
  161. --with-ipv6 \
  162. --with-http_ssl_module \
  163. --with-http_v2_module \
  164. --with-http_realip_module \
  165. --with-http_addition_module \
  166. --with-http_xslt_module \
  167. --with-http_image_filter_module \
  168. %if %{with geoip}
  169. --with-http_geoip_module \
  170. %endif
  171. --with-http_sub_module \
  172. --with-http_dav_module \
  173. --with-http_flv_module \
  174. --with-http_mp4_module \
  175. --with-http_gunzip_module \
  176. --with-http_gzip_static_module \
  177. --with-http_auth_request_module \
  178. --with-http_random_index_module \
  179. --with-http_secure_link_module \
  180. --with-http_degradation_module \
  181. --with-http_stub_status_module \
  182. --with-http_perl_module \
  183. --with-mail \
  184. --with-mail_ssl_module \
  185. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  186. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  187. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  188. %if %{with wsgi}
  189. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  190. %endif
  191. %ifarch i686
  192. --with-cpu-opt=pentiumpro \
  193. --with-zlib-asm=pentiumpro \
  194. --with-md5-asm \
  195. --with-sha1-asm \
  196. %endif
  197. "
  198. ## build with passenger
  199. ./configure \
  200. $CONFIGOPTS \
  201. --with-cc-opt="%{optflags}" \
  202. --add-module=passenger-%{passenger_version}/src/nginx_module
  203. make %{?_smp_mflags}
  204. mv objs/nginx objs/nginx.passenger
  205. ## build without passenger
  206. ./configure \
  207. $CONFIGOPTS \
  208. --with-cc-opt="%{optflags}"
  209. make %{?_smp_mflags}
  210. %install
  211. rm -rf %{buildroot}
  212. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  213. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  214. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  215. find %{buildroot} -type f -empty -exec rm -f {} \;
  216. find %{buildroot} -type f -exec chmod 0644 {} \;
  217. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  218. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  219. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  220. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  221. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  222. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  223. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  224. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  225. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  226. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  227. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  228. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  229. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  230. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  231. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  232. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  233. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  234. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  235. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  236. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  237. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  238. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  239. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  240. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  241. %if %{with wsgi}
  242. %{__install} -p -m 0644 \
  243. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  244. %{buildroot}%{nginx_confdir}
  245. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  246. %endif
  247. # upstream fair module document
  248. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  249. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  250. # convert to UTF-8 all files that give warnings.
  251. for textfile in CHANGES
  252. do
  253. mv $textfile $textfile.old
  254. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  255. rm -f $textfile.old
  256. done
  257. %clean
  258. rm -rf %{buildroot}
  259. %post
  260. if [ $1 == 1 ]; then
  261. /sbin/chkconfig --add %{name}
  262. fi
  263. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  264. %post passenger
  265. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  266. %preun
  267. if [ $1 = 0 ]; then
  268. /sbin/service %{name} stop >/dev/null 2>&1
  269. /sbin/chkconfig --del %{name}
  270. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  271. fi
  272. %preun passenger
  273. if [ $1 = 0 ]; then
  274. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  275. fi
  276. %postun
  277. if [ $1 == 2 ]; then
  278. /sbin/service %{name} upgrade || :
  279. fi
  280. %files
  281. %defattr(-,root,root,-)
  282. %doc LICENSE CHANGES README
  283. %doc README.upstream_fair
  284. %doc %{?with_wsgi:README.mod_wsgi}
  285. %{nginx_datadir}/
  286. %{_sbindir}/%{name}.normal
  287. %{_mandir}/man3/%{name}.3pm.gz
  288. %{_initrddir}/%{name}
  289. %dir %{nginx_confdir}
  290. %dir %{nginx_confdir}/conf.d
  291. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  292. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  293. %config(noreplace) %{nginx_confdir}/sites.d/*
  294. %config(noreplace) %{nginx_confdir}/win-utf
  295. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  296. %config(noreplace) %{nginx_confdir}/mime.types.default
  297. %config(noreplace) %{nginx_confdir}/fastcgi_params
  298. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  299. %config(noreplace) %{nginx_confdir}/koi-win
  300. %config(noreplace) %{nginx_confdir}/koi-utf
  301. %config(noreplace) %{nginx_confdir}/%{name}.conf
  302. %config(noreplace) %{nginx_confdir}/mime.types
  303. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  304. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  305. %config(noreplace) %{nginx_confdir}/scgi_params
  306. %config(noreplace) %{nginx_confdir}/scgi_params.default
  307. %config(noreplace) %{nginx_confdir}/uwsgi_params
  308. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  309. %if %{with wsgi}
  310. %config(noreplace) %{nginx_confdir}/wsgi_vars
  311. %endif
  312. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  313. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  314. %dir %{perl_vendorarch}/auto/%{name}
  315. %{perl_vendorarch}/%{name}.pm
  316. %{perl_vendorarch}/auto/%{name}/%{name}.so
  317. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  318. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  319. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  320. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  321. %files passenger
  322. %defattr(-,root,root,-)
  323. %doc passenger-%{passenger_version}/doc/*.md
  324. %doc passenger-%{passenger_version}/doc/*.txt
  325. %doc passenger-%{passenger_version}/doc/*.html
  326. %doc passenger-%{passenger_version}/doc/templates
  327. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  328. %doc passenger-%{passenger_version}/doc/images
  329. %{_sbindir}/%{name}.passenger
  330. %changelog
  331. * Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
  332. - updated to 1.11.8
  333. * Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
  334. - updated to 1.11.6
  335. - applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
  336. * Mon Sep 5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
  337. - updated to 1.11.3
  338. - updated passenger to 5.0.30
  339. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
  340. - rebuild with gcc-5.4.0
  341. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
  342. - updated to 1.10.1.
  343. - updated passenger to 5.0.28.
  344. * Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
  345. - updated to 1.9.15
  346. * Thu Apr 7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
  347. - updated to 1.9.14
  348. - updated passenger to 5.0.27
  349. * Wed Apr 6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
  350. - new upstream release
  351. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
  352. - updated to 1.9.12.
  353. - updated passenger to 5.0.26.
  354. * Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
  355. - new upstream release
  356. * Wed Feb 3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
  357. - update to 1.9.10
  358. - update passenger to 5.0.24
  359. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
  360. - update passenger to 5.0.23
  361. * Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
  362. - new upstream release
  363. * Sat Dec 5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
  364. - new upstream release
  365. * Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
  366. - new upstream release
  367. * Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
  368. - new upstream release
  369. * Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
  370. - update to 1.9.3
  371. - update passenger to 5.0.11
  372. * Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
  373. - updated Source4 (ssl.conf).
  374. * Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
  375. - update to 1.9.2
  376. - update passenger to 5.0.10
  377. - update ngx-fancyindex to 0.3.5
  378. * Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
  379. - update to 1.6.2
  380. - update passenger to 4.0.52
  381. * Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
  382. - new upstream release
  383. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
  384. - rebuild with new environment
  385. * Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
  386. - update passenger to 4.0.45
  387. * Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  388. - update to 1.6.0 (stable)
  389. * Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
  390. - update fancyindex to 0.3.3
  391. * Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
  392. - update to 1.5.10
  393. - update passenger to 4.0.37
  394. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
  395. - rebuilt with GeoIP-1.6.0.
  396. - added Patch100.
  397. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  398. - update to 1.5.6
  399. - update passenger to 4.0.21
  400. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  401. - rebuilt with gd-2.1.0.
  402. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  403. - update to 1.4.1
  404. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  405. - update to 1.4.0
  406. - enable SPDY module
  407. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  408. - new upstream release
  409. - update passenger to 3.0.19
  410. - update ngx-fancyindex to upstream git master
  411. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  412. - new upstream release
  413. - update passenger to 3.0.17
  414. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  415. - rebuild with pcre-8.31
  416. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  417. - added http_geoip_module.
  418. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  419. - update to 1.2.4
  420. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  421. - update to 1.2.2
  422. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  423. - update to 1.2.1
  424. - change nginx user from nginx to www-data
  425. - R(pre): www-common
  426. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  427. - update to 1.2.0
  428. - update passenger to 3.0.12
  429. - drop http_upstream_keepalive
  430. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  431. - new upstream release
  432. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  433. - update to 1.0.12
  434. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  435. - update to 1.0.11
  436. - update passenger to 3.0.11
  437. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  438. - update to 1.0.10
  439. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  440. - update passenger to 3.0.9
  441. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  442. - update to 1.0.6
  443. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  444. - update to 1.0.4
  445. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  446. - add gnosek-nginx-upstream-fair module
  447. - add ngx_http_upstream_keepalive module
  448. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  449. - add nginx-passenger sub pakckage
  450. - use alternatives to choose nginx with or without passenger
  451. - add BR: ruby, rubygems, rubygem-rake
  452. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  453. - update to 1.0.2
  454. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  455. - update to 1.0.1
  456. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  457. - add bcond_with wsgi for mod_wsgi
  458. - add bcond_with passenger
  459. - you need to install rake.gem to build with this option.
  460. - add Provides: webserver
  461. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  462. - new upstream release 1.0.0!
  463. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  464. - rebuild with perl-5.12.3
  465. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  466. - update to 0.8.54
  467. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  468. - update to 0.8.53
  469. - add nginx_accept_language_module
  470. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  471. - update to 0.8.50
  472. - update ngx-fancyindex to 0.3
  473. - add BR: libxml2-devel, libxslt-devel
  474. - add scgi_params* and uwsgi_params* to %%files
  475. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  476. - update to 0.8.35 (development version)
  477. - add sites.d/ to store vitualhost settings
  478. - split out default server settings to sites.d/default
  479. - add fancyindex module
  480. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  481. - new upstream release
  482. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  483. - update to 0.7.62 (included security fix: VU#180065)
  484. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  485. - fix typo
  486. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  487. - add translated descriptions
  488. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  489. - update 404.html/50x.html to use powered by vine logo.
  490. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  491. - initial build for Vine Linux
  492. - update to 0.7.61
  493. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  494. - init script updates from Gena Makhomed
  495. - remove nginx-upstream-fair
  496. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  497. - update to 0.6.36
  498. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  499. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  500. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  501. - rebuild
  502. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  503. - update to 0.6.35
  504. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  505. - rebuild with new openssl
  506. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  507. - update to 0.6.34
  508. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  509. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  510. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  511. - update to 0.6.33
  512. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  513. - update to 0.6.32
  514. - nginx now supports DESTDIR so removed the patches that enabled it
  515. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  516. - init script fixes
  517. - resolve 'listen 80 default' [#447873]
  518. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  519. - update to 0.6.31
  520. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  521. - upate to new upstream stable branch 0.6
  522. - added 3rd party module nginx-upstream-fair
  523. - added default webpages
  524. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  525. - update init script to match recommended guidelines
  526. - add /etc/nginx/conf.d support [#443280]
  527. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  528. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  529. - add Requires for versioned perl (libperl.so)
  530. - drop silly file Requires
  531. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  532. - Autorebuild for GCC 4.3
  533. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  534. - update to 0.5.35
  535. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  536. - update to 0.5.34
  537. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  538. - Rebuild for deps
  539. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  540. - update to 0.5.33
  541. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  542. - updated to 0.5.32
  543. - fixed rpmlint UTF-8 complaints.
  544. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  545. - added --with-http_stub_status_module build option.
  546. - added --with-http_sub_module build option.
  547. - added use of pcre-config --cflags
  548. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  549. - Update to 0.5.31
  550. - specify license is BSD
  551. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  552. - Add BuildRequires: perl-devel - fixing rawhide build
  553. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  554. - Update to 0.5.30
  555. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  556. - Update to 0.5.29
  557. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  558. - Update to 0.5.28
  559. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  560. - Update to 0.5.27
  561. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  562. - Update to 0.5.26
  563. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  564. - Update to 0.5.19
  565. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  566. - Update to 0.5.17
  567. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  568. - Update to 0.5.16
  569. - add ownership of /usr/share/nginx/html (#233950)
  570. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  571. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  572. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  573. - fixed package review bugs (#233522) given by kevin@tummy.com
  574. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  575. - create patches to assist with building for Fedora
  576. - initial packaging for Fedora