python-pyxml-vl.spec 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. %define module PyXML
  2. #%define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. #%define pysite %{_libdir}/python%{pyver}/site-packages
  4. %define pyinc %{_includedir}/python%{pyver}
  5. Summary: XML libraries for python
  6. Summary(ja): Python XML ライブラリ
  7. Name: python-pyxml
  8. Version: 0.8.4
  9. Release: 4%{?_dist_release}
  10. URL: http://pyxml.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/pyxml/PyXML-%{version}.tar.gz
  12. License: Apacheish
  13. Group: Development/Languages
  14. Requires: python, libexpat
  15. BuildRequires: python-devel, expat-devel
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Obsoletes: %{module}
  18. Provides: %{module}
  19. %description
  20. An XML package for Python. The distribution contains a validating XML
  21. parser, an implementation of the SAX and DOM programming interfaces
  22. and an interface to the Expat parser.
  23. %prep
  24. %setup -q -n %{module}-%{version}
  25. %build
  26. CFLAGS="%{optflags}" \
  27. %{_bindir}/python setup.py build --with-libexpat=%{_prefix}
  28. %install
  29. %__rm -rf %{buildroot}
  30. %{_bindir}/python setup.py install --root=%{buildroot}
  31. %{_bindir}/python -O %{_libdir}/python%{pyver}/compileall.py \
  32. %{buildroot}%{python_sitearch}
  33. %clean
  34. %__rm -rf %{buildroot}
  35. %files
  36. %defattr(-,root,root)
  37. %doc LICENCE ANNOUNCE CREDITS README README.* TODO doc/*
  38. %{_bindir}/*
  39. %{python_sitearch}/*
  40. %changelog
  41. * Sat Jun 06 2009 Shu KONNO <owa@bg.wakwak.com> 0.8.4-4
  42. - spec in utf-8 properly
  43. - use rpm macros: pyver, python_sitearch
  44. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.4-3vl5
  45. - rebuilt with python-2.5.2
  46. - applied new versioning policy and spec in utf-8
  47. * Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.8.4-2vl3
  48. - rebuild with expat-2.0.1
  49. * Mon May 8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.4-2vl2
  50. - fixed Japanese summary
  51. - changed Group:
  52. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.4-2vl1
  53. - initial build for Vine Linux
  54. * Wed May 4 2005 Gotz Waschk <waschk@mandriva.org> 0.8.4-2mdk
  55. - use external libexpat
  56. - enable xpath and xslt
  57. * Thu Dec 16 2004 Guillaume Rousse <guillomovitch@mandrake.org> 0.8.4-1mdk
  58. - new version
  59. - changed name
  60. * Sun Dec 05 2004 Michael Scherer <misc@mandrake.org> 0.8.3-4mdk
  61. - Rebuild for new python
  62. * Mon Nov 01 2004 Michael Scherer <misc@mandrake.org> 0.8.3-3mdk
  63. - [DIRM]
  64. * Sat Apr 10 2004 Michael Scherer <misc@mandrake.org> 0.8.3-2mdk
  65. - [DIRM]
  66. * Wed Aug 20 2003 Austin Acton <aacton@yorku.ca> 0.8.3-1mdk
  67. - 0.8.3
  68. * Tue Aug 12 2003 Per Oyvind Karlsen <peroyvind@linux-mandrake.com> 0.8.2-4mdk
  69. - rebuild for new python
  70. * Sat Mar 29 2003 David Walluck <walluck@linux-mandrake.com> 0.8.2-3mdk
  71. - release
  72. * Tue Mar 25 2003 David Walluck <david@anti-microsoft.org> 0.8.2-2plf
  73. - spec file cleanups
  74. * Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 0.8.2-1plf
  75. - release