gpsd-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. Summary: Service daemon for mediating access to a GPS
  3. Summary(ja): GPS にアクセスするためのサービスデーモン
  4. Name: gpsd
  5. Version: 2.37
  6. Release: 3%{?_dist_release}
  7. Group: System Environment/Daemons
  8. License: BSD
  9. URL: http://developer.berlios.de/projects/gpsd/
  10. Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
  11. Source1: xgps.desktop
  12. Source2: xgpsspeed.desktop
  13. Source3: gpsd-logo.png
  14. Patch0: python-pyexecdir-install-gpsd-2.37.patch
  15. Patch1: zero.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
  18. BuildRequires: openMotif-devel libXaw-devel desktop-file-utils
  19. BuildRequires: python
  20. BuildRequires: libXp-devel
  21. Requires(post): /sbin/ldconfig
  22. Requires(postun): /sbin/ldconfig
  23. %description
  24. gpsd is a service daemon that mediates access to a GPS sensor
  25. connected to the host computer by serial or USB interface, making its
  26. data on the location/course/velocity of the sensor available to be
  27. queried on TCP port 2947 of the host computer. With gpsd, multiple
  28. GPS client applications (such as navigational and wardriving software)
  29. can share access to a GPS without contention or loss of data. Also,
  30. gpsd responds to queries with a format that is substantially easier to
  31. parse than NMEA 0183.
  32. %package devel
  33. Summary: Client libraries in C and Python for talking to a running gpsd or GPS
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. Requires: pkgconfig
  37. %description devel
  38. This package provides C header files and python modules for the gpsd shared
  39. libraries that manage access to a GPS for applications
  40. %package clients
  41. Summary: Clients for gpsd
  42. Summary(ja): gpsd 用クライアント
  43. Group: Applications/System
  44. %description clients
  45. xgps is a simple test client for gpsd with an X interface. It displays
  46. current GPS position/time/velocity information and (for GPSes that
  47. support the feature) the locations of accessible satellites.
  48. xgpsspeed is a speedometer that uses position information from the GPS.
  49. It accepts an -h option and optional argument as for gps, or a -v option
  50. to dump the package version and exit. Additionally, it accepts -rv
  51. (reverse video) and -nc (needle color) options.
  52. cgps resembles xgps, but without the pictorial satellite display. It
  53. can run on a serial terminal or terminal emulator.
  54. %prep
  55. %setup -q
  56. %patch0 -p1
  57. %patch1 -p0
  58. %build
  59. %configure --enable-dbus --disable-static
  60. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  61. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  62. make %{?_smp_mflags}
  63. %install
  64. rm -rf %{buildroot}
  65. make DESTDIR=%{buildroot} install
  66. # X11 defaults
  67. %{__install} -d -m 0755 %{buildroot}%{_datadir}/X11/app-defaults/
  68. %{__install} -p -m 0644 xgps.ad %{buildroot}%{_datadir}/X11/app-defaults/xgps
  69. %{__install} -p -m 0644 xgpsspeed.ad \
  70. %{buildroot}%{_datadir}/X11/app-defaults/xgpsspeed
  71. # hotplug script
  72. %{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/hotplug.d/usb
  73. %{__install} -p -m 0644 gpsd.hotplug gpsd.usermap \
  74. %{buildroot}%{_sysconfdir}/hotplug.d/usb/
  75. # remove .la files
  76. rm -f %{buildroot}%{_libdir}/libgps.la
  77. # fix non-executable libraries
  78. %{__chmod} +x %{buildroot}%{_libdir}/libgps.so.17.0.0
  79. %{__chmod} +x %{buildroot}%{python_sitearch}/gpspacket.so
  80. # fix non-executable python script
  81. %{__chmod} +x %{buildroot}%{python_sitearch}/gps.py
  82. # Install the .desktop files
  83. desktop-file-install --vendor fedora \
  84. --dir %{buildroot}%{_datadir}/applications \
  85. --add-category X-Fedora \
  86. %{SOURCE1}
  87. desktop-file-install --vendor fedora \
  88. --dir %{buildroot}%{_datadir}/applications \
  89. --add-category X-Fedora \
  90. %{SOURCE2}
  91. # Install logo icon for .desktop files
  92. %{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
  93. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
  94. %clean
  95. rm -rf %{buildroot}
  96. %post -p /sbin/ldconfig
  97. %postun -p /sbin/ldconfig
  98. %files
  99. %defattr(-,root,root,-)
  100. %doc README INSTALL COPYING
  101. %{_sbindir}/gpsd
  102. %{_bindir}/gpsprof
  103. %{_bindir}/sirfmon
  104. %{_bindir}/gpsctl
  105. %{_libdir}/libgps.so.*
  106. %{python_sitearch}/gps.py*
  107. %{python_sitearch}/gpspacket.so
  108. %{_mandir}/man8/gpsd.8*
  109. %{_mandir}/man1/gpsprof.1*
  110. %{_mandir}/man1/sirfmon.1*
  111. %{_mandir}/man1/gpsctl.1*
  112. %{_sysconfdir}/hotplug.d/usb/gpsd.hotplug
  113. %{_sysconfdir}/hotplug.d/usb/gpsd.usermap
  114. %files devel
  115. %defattr(-,root,root,-)
  116. %doc TODO
  117. %{_bindir}/gpsfake
  118. %{_bindir}/rtcmdecode
  119. %{_bindir}/gpsflash
  120. %{_libdir}/libgps.so
  121. %{_libdir}/pkgconfig/*.pc
  122. %{python_sitearch}/gpsfake*
  123. %{_includedir}/gps.h
  124. %{_includedir}/libgpsmm.h
  125. %{_includedir}/gpsd.h
  126. %{_mandir}/man1/gpsfake.1*
  127. %{_mandir}/man1/rtcmdecode.1*
  128. %{_mandir}/man1/gpsflash.1*
  129. %{_mandir}/man3/libgps.3*
  130. %{_mandir}/man3/libgpsmm.3*
  131. %{_mandir}/man3/libgpsd.3*
  132. %{_mandir}/man5/rtcm-104.5*
  133. %{_mandir}/man5/srec.5*
  134. %files clients
  135. %defattr(-,root,root,-)
  136. %{_bindir}/xgps
  137. %{_bindir}/xgpsspeed
  138. %{_bindir}/cgps
  139. %{_bindir}/gpspipe
  140. %{_bindir}/gpxlogger
  141. %{_bindir}/cgpxlogger
  142. %{_bindir}/gpscat
  143. %{_mandir}/man1/gps.1*
  144. %{_mandir}/man1/gpspipe.1*
  145. %{_mandir}/man1/xgps.1*
  146. %{_mandir}/man1/xgpsspeed.1*
  147. %{_mandir}/man1/cgps.1*
  148. %{_mandir}/man1/gpscat.1*
  149. %{_mandir}/man1/cgpxlogger.1*
  150. %{_datadir}/X11/app-defaults/xgps
  151. %{_datadir}/X11/app-defaults/xgpsspeed
  152. %{_datadir}/applications/*.desktop
  153. %dir %{_datadir}/gpsd
  154. %{_datadir}/gpsd/gpsd-logo.png
  155. %changelog
  156. * Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.37-3
  157. - add BuildRequires: libXp-devel
  158. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.37-2
  159. - rebuilt with python-2.6.4
  160. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.37-1
  161. - initial build for Vine Linux
  162. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.37-3
  163. - Rebuild for Python 2.6
  164. * Wed Mar 19 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-2
  165. - moving gpspacket.so python lib to main package
  166. - adding zero.patch to make ZEROIZE error go away on fedora 7
  167. * Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
  168. - update to 2.37
  169. - removed install-gpsd_config.h.patch
  170. - installed pkgconfig files in devel package
  171. - added patch to install python modules in sitearch
  172. - removing rpath from inclucded libtool
  173. - moving X11 app-defaults to datadir
  174. - using macros for commands in install; using install instead of cp and mkdir
  175. - cleaning up spaces/tabs for rpmlint
  176. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.34-9
  177. - Autorebuild for GCC 4.3
  178. * Sun Aug 19 2007 Matthew Truch <matt at truch.net> - 2.34-8
  179. - Patch Makefile to also install gpsd_config.h as needed by
  180. libgpsmm.h. Redhat BZ 253433.
  181. * Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-7
  182. - Make sure the logo is actually included (via the spec file).
  183. I need to wake up before I try even trivial updates.
  184. * Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-6
  185. - Learn how to use search and replace (aka fix all instances of
  186. gpsd-logo.png spelled incorrectly as gspd-logo.png).
  187. * Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-5
  188. - Fix desktop file and logo file name.
  189. * Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-4
  190. - Include icon for .desktop files per BZ 241428
  191. * Tue Mar 20 2007 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.34-3
  192. - Bump release for FE5 -> Fedora 7 upgrade path.
  193. * Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-2
  194. - BR python-devel instead of python to make it build.
  195. * Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-1
  196. - Upgrade to 2.34.
  197. - Get rid of %%makeinstall (which was never needed).
  198. - Possibly fix hotplug issuses (BZ 219750).
  199. - Use %%python_sitelib for python site-files stuff.
  200. * Sat Dec 9 2006 Matthew Truch <matt at truch.net> - 2.33-6
  201. - Rebuild to pull in new version of python.
  202. * Tue Sep 26 2006 Matthew Truch <matt at truch.net> - 2.33-5
  203. - Remove openmotif requirment, and switch to lesstif.
  204. * Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 2.33-4
  205. - Bump release for rebuild in prep. for FC6.
  206. * Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-3
  207. - Actually, was a missing BR glib-dbus-devel. Ooops.
  208. * Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-2
  209. - Missing BR glib-devel
  210. * Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-1
  211. - Update to version 2.33
  212. * Wed Apr 19 2006 Matthew Truch <matt at truch.net> - 2.32-5
  213. - Don't --enable-tnt in build as it causes some gpses to not work
  214. properly with sattelite view mode. See bugzilla bug 189220.
  215. * Thu Apr 13 2006 Matthew Truch <matt at truch.net> - 2.32-4
  216. - Add dbus-glib to BuildRequires as needed for build.
  217. * Sun Apr 9 2006 Matthew Truch <matt at truch.net> - 2.32-3
  218. - Include xmlto and python in buildrequires so things build right.
  219. - Don't package static library file.
  220. * Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-2
  221. - Use ye olde %%{?dist} tag.
  222. * Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-1
  223. - Initial Fedora Extras specfile