gnome-web-photo-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189
  1. %define build_vine5 0
  2. %define build_vine6 0
  3. %if "%{?_dist_release}" == "vl5"
  4. %define build_vine5 1
  5. %endif
  6. %if "%{?_dist_release}" == "vl6"
  7. %define build_vine6 1
  8. %endif
  9. %if %{build_vine5}
  10. %define gecko_version 1.9.1.8
  11. %endif
  12. %if %{build_vine6}
  13. %define gecko_version 1.9.2
  14. %endif
  15. Summary: HTML pages thumbnailer
  16. Summary(ja): HTML ページのサムネール作成ツール
  17. Name: gnome-web-photo
  18. Version: 0.9
  19. Release: 3%{?_dist_release}
  20. License: LGPLv2+
  21. Group: Applications/Internet
  22. URL: http://ftp.gnome.org/pub/GNOME/sources/gnome-web-photo/%{version}/
  23. Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-web-photo/%{version}/%{name}-%{version}.tar.bz2
  24. Patch0: gnome-web-photo-xulrunner192.patch
  25. BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
  26. Requires(post): GConf2
  27. Requires(preun):GConf2
  28. Requires: gecko-libs = %{gecko_version}
  29. BuildRequires: gtk2-devel >= 2.10.0
  30. BuildRequires: libxml2-devel
  31. BuildRequires: gnome-vfs2-devel
  32. BuildRequires: gecko-devel = %{gecko_version}
  33. BuildRequires: gecko-devel-unstable = %{gecko_version}
  34. BuildRequires: libjpeg-devel
  35. BuildRequires: gettext intltool
  36. Packager: kazutaka
  37. %description
  38. gnome-web-photo contains a thumbnailer that will be used by
  39. GNOME applications, including the file manager, to generate
  40. screenshots of web pages.
  41. %prep
  42. %setup -q
  43. %if %{build_vine6}
  44. %patch0 -p1 -b .xulrunner192
  45. %endif
  46. %build
  47. %configure
  48. %{__make} %{?_smp_mflags}
  49. %install
  50. %{__rm} -rf $RPM_BUILD_ROOT
  51. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  52. %{__make} DESTDIR=$RPM_BUILD_ROOT install
  53. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  54. %{__mv} $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/thumbnailer.schemas \
  55. $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas
  56. %find_lang %{name}
  57. %post
  58. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  59. gconftool-2 --makefile-install-rule \
  60. %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas >& /dev/null
  61. %pre
  62. if [ "$1" -gt 1 ]; then
  63. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  64. gconftool-2 --makefile-uninstall-rule \
  65. %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas \
  66. >& /dev/null || :
  67. fi
  68. %preun
  69. if [ "$1" -eq 0 ]; then
  70. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  71. gconftool-2 --makefile-uninstall-rule \
  72. %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas >& /dev/null
  73. fi
  74. %clean
  75. %{__rm} -rf $RPM_BUILD_ROOT
  76. %files -f %{name}.lang
  77. %defattr(-,root,root,-)
  78. %doc ChangeLog AUTHORS README TODO COPYING.README
  79. %{_sysconfdir}/gconf/schemas/gnome-web-photo.schemas
  80. %{_bindir}/gnome-web-photo
  81. %{_bindir}/gnome-web-print
  82. %{_bindir}/gnome-web-thumbnail
  83. %{_datadir}/gnome-web-photo
  84. %changelog
  85. * Sat Mar 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-3
  86. - rebuild with xulrunner-%{gecko_version}
  87. * Wed Jan 27 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-2
  88. - rebuild with xulrunner-%{gecko_version}
  89. - add Patch0 to fix xulrunner-1.9.2 build
  90. * Fri Jan 15 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9-1
  91. - new upstream release
  92. - build with xulrunner-1.9.1.7 (gecko-libs)
  93. * Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8-1
  94. - initial build for Vine Linux based on fedora development
  95. * Fri Sep 11 2009 Jan Horak <jhorak@redhat.com> - 0.8-6
  96. - Rebuild against newer gecko
  97. * Thu Aug 06 2009 Jan Horak <jhorak@redhat.com> - 0.8-5
  98. - Rebuild against newer gecko
  99. * Tue Aug 04 2009 Jan Horak <jhorak@redhat.com> - 0.8-4
  100. - Rebuild against newer gecko
  101. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8-3
  102. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  103. * Mon Jul 20 2009 Jan Horak <jhorak@redhat.com> - 0.8-2
  104. - Rebuild against newer gecko
  105. * Tue Jun 30 2009 Matthias Clasen <mclasen@redhat.com> - 0.8-1
  106. - Update to 0.8
  107. * Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.7-2
  108. - Rebuild against newer gecko
  109. * Mon Apr 13 2009 Matthias Clasen <mclasen@redhat.com> - 0.7-1
  110. - Update to 0.7
  111. * Tue Mar 24 2009 Jan Horak <jhorak@redhat.com> - 0.6-2
  112. - Fix for rebuild against newer gecko
  113. * Tue Mar 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.6-1
  114. - Update to 0.6
  115. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-14
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  117. * Tue Jan 06 2009 Christopher Aillon <caillon@redhat.com> - 0.3-13
  118. - Rebuild against newer gecko
  119. * Wed Nov 12 2008 Christopher Aillon <caillon@redhat.com> - 0.3-12
  120. - Rebuild against newer gecko
  121. * Wed Mar 12 2008 Marco Pesenti Gritti <mpg@redhat.com> - 0.3-11
  122. - Better xulrunner-1.9 patch which also works with very long pages
  123. * Fri Mar 7 2008 Marco Pesenti Gritti <mpg@redhat.com> - 0.3-10
  124. - Add patch to make it work with xulrunner 1.9
  125. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.3-9
  126. - Autorebuild for GCC 4.3
  127. * Tue Nov 27 2007 Christopher Aillon <caillon@redhat.com> - 0.3-8
  128. - Rebuild against newer gecko
  129. * Fri Nov 23 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-7
  130. - Rebuilding against xulrunner will require a lot of porting,
  131. disable for now
  132. * Fri Nov 16 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-6
  133. - Try to rebuild with xulrunner
  134. * Thu Oct 25 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-5
  135. - Rebuild for new Gecko, tighten dependencies
  136. * Mon Sep 10 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-4
  137. - Fix license, as mentioned by Kevin Fenzi
  138. * Thu Sep 06 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-3
  139. - Update following Matthias Clasen's comments
  140. * Wed Sep 05 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-2
  141. - Update following Peter Gordon's comments
  142. * Tue Mar 20 2007 - Bastien Nocera <bnocera@redhat.com> - 0.3-1
  143. - First post!