gnome-power-manager-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369
  1. %define hal_version 0.5.13
  2. %define dbus_version 1.2
  3. %define dbus_glib_version 0.82
  4. Summary: GNOME power management service
  5. Summary(ja): GNOME 電源管理ツール
  6. Name: gnome-power-manager
  7. Version: 2.28.3
  8. Release: 1%{?_dist_release}
  9. License: GPLv2+ and GFDL
  10. Group: Applications/System
  11. URL: http://projects.gnome.org/gnome-power-manager/
  12. Source: http://download.gnome.org/sources/gnome-power-manager/2.28/gnome-power-manager-%{version}.tar.bz2
  13. # Fedora-specific backport, already same UI in git master
  14. Patch1: 0001-Do-not-show-About-and-Help-menu-items-on-the-panel-i.patch
  15. # Fedora-specific backport, already same UI in git master
  16. Patch2: 0002-Make-the-left-and-right-buttons-on-the-status-icon-b.patch
  17. # https://bugzilla.gnome.org/show_bug.cgi?id=594664
  18. %define _default_patch_fuzz 2
  19. BuildRequires: autoconf automake libtool
  20. Patch3: 0001-Use-gnome-settings-daemon-popup-code.patch
  21. # for Vine Linux
  22. Patch10: gnome-power-manager-2.28.2-warningflags.patch
  23. Patch11: gnome-power-manager-2.28.2-math.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: libgnomeui-devel
  26. BuildRequires: libglade2-devel
  27. BuildRequires: libwnck-devel
  28. BuildRequires: hal-devel >= %{hal_version}
  29. BuildRequires: dbus-devel >= %{dbus_version}
  30. BuildRequires: libnotify-devel
  31. BuildRequires: gnome-panel-devel
  32. BuildRequires: scrollkeeper
  33. BuildRequires: gnome-doc-utils >= 0.3.2
  34. BuildRequires: desktop-file-utils
  35. BuildRequires: gettext
  36. BuildRequires: libtool
  37. BuildRequires: cairo-devel
  38. BuildRequires: libcanberra-devel >= 0.10
  39. BuildRequires: unique-devel >= 1.0.0
  40. BuildRequires: DeviceKit-power-devel >= 008
  41. BuildRequires: intltool
  42. BuildRequires: xmlto
  43. Requires: gtk2 >= 2.10.0
  44. Requires: gnome-mime-data
  45. Requires: gnome-icon-theme
  46. Requires: libnotify >= 0.4.3
  47. Requires: hal >= %{hal_version}
  48. Requires: dbus-glib >= %{dbus_glib_version}
  49. Requires: dbus-x11 >= %{dbus_version}
  50. Requires: libcanberra-gtk2 >= 0.10
  51. Requires: unique >= 1.0.0
  52. Requires: DeviceKit-power >= 008
  53. Requires(post,postun): scrollkeeper
  54. Requires(post,pre,preun): GConf2
  55. Vendor: Project Vine
  56. Distribution: Vine Linux
  57. Packager: daisuke, Takemikaduchi
  58. %description
  59. GNOME Power Manager uses the information and facilities provided by HAL
  60. displaying icons and handling user callbacks in an interactive GNOME session.
  61. GNOME Power Preferences allows authorised users to set policy and
  62. change preferences.
  63. %package extra
  64. Summary: GNOME Power Manager extra utility programs
  65. Group: Applications/System
  66. Requires: %{name} = %{version}-%{release}
  67. %description extra
  68. Extra GNOME power management applications that are not normally needed.
  69. %prep
  70. %setup -q
  71. #%setup -q -n %{?name}-%{?version}-%{?alphatag}
  72. %patch1 -p1 -b .remove-help
  73. %patch2 -p1 -b .uni-menu
  74. %patch3 -p1 -b .osd
  75. %patch10 -p1 -b .warnings
  76. %patch11 -p1 -b .math
  77. autoreconf -i
  78. %build
  79. %configure \
  80. --disable-scrollkeeper
  81. make
  82. # strip unneeded translations from .mo files
  83. # ideally intltool (ha!) would do that for us
  84. # http://bugzilla.gnome.org/show_bug.cgi?id=474987
  85. cd po
  86. grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
  87. mv POTFILES.keep POTFILES.in
  88. intltool-update --pot
  89. for p in *.po; do
  90. msgmerge $p %{name}.pot > $p.out
  91. msgfmt -o `basename $p .po`.gmo $p.out
  92. done
  93. %install
  94. rm -rf $RPM_BUILD_ROOT
  95. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  96. make install DESTDIR=$RPM_BUILD_ROOT
  97. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  98. desktop-file-install --vendor gnome --delete-original \
  99. --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart \
  100. $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
  101. # save space by linking identical images in translated docs
  102. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  103. for f in $helpdir/C/figures/*.png; do
  104. b="$(basename $f)"
  105. for d in $helpdir/*; do
  106. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  107. g="$d/figures/$b"
  108. if [ -f "$g" ]; then
  109. if cmp -s $f $g; then
  110. rm "$g"; ln -s "../../C/figures/$b" "$g"
  111. fi
  112. fi
  113. fi
  114. done
  115. done
  116. %find_lang %name --with-gnome
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %post
  120. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  121. gconftool-2 --makefile-install-rule \
  122. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas >/dev/null || :
  123. scrollkeeper-update -q &> /dev/null || :
  124. touch --no-create %{_datadir}/icons/hicolor
  125. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  126. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  127. fi
  128. %pre
  129. if [ "$1" -gt 1 ]; then
  130. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  131. gconftool-2 --makefile-uninstall-rule \
  132. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
  133. fi
  134. %preun
  135. if [ "$1" -eq 0 ]; then
  136. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  137. gconftool-2 --makefile-uninstall-rule \
  138. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
  139. fi
  140. %postun
  141. scrollkeeper-update -q &> /dev/null || :
  142. touch --no-create %{_datadir}/icons/hicolor
  143. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  144. gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
  145. fi
  146. %files -f %{name}.lang
  147. %defattr(-,root,root)
  148. %doc AUTHORS COPYING README
  149. %{_bindir}/gnome-power-bugreport.sh
  150. %{_bindir}/gnome-power-manager
  151. %{_bindir}/gnome-power-preferences
  152. %dir %{_datadir}/gnome-power-manager
  153. %{_datadir}/gnome-power-manager/acme.ui
  154. %{_datadir}/gnome-power-manager/gpm-prefs.ui
  155. %{_datadir}/gnome-power-manager/gpm-feedback-widget.ui
  156. %{_mandir}/man1/gnome-power-manager.1.gz
  157. %{_mandir}/man1/gnome-power-preferences.1.gz
  158. %{_sysconfdir}/gconf/schemas/*.schemas
  159. %{_datadir}/dbus-1/services/gnome-power-manager.service
  160. #%{_datadir}/omf/gnome-power-manager
  161. %{_sysconfdir}/xdg/autostart/*.desktop
  162. %{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
  163. %{_datadir}/icons/hicolor/*/apps/gnome-power-manager.*
  164. %{_datadir}/applications/gnome-power-preferences.desktop
  165. %{_libexecdir}/gnome-brightness-applet
  166. %{_libdir}/bonobo/servers/GNOME_BrightnessApplet.server
  167. %{_datadir}/gnome-2.0/ui/GNOME_BrightnessApplet.xml
  168. %{_datadir}/icons/hicolor/*/apps/gnome-brightness-applet.*
  169. %files extra
  170. %defattr(-,root,root,-)
  171. %doc AUTHORS COPYING NEWS README
  172. %{_bindir}/gnome-power-statistics
  173. %{_mandir}/man1/gnome-power-statistics.1.gz
  174. %{_datadir}/gnome-power-manager/gpm-statistics.ui
  175. %{_datadir}/applications/gnome-power-statistics.desktop
  176. %{_datadir}/icons/hicolor/*/apps/gnome-power-statistics.*
  177. %{_libexecdir}/gnome-inhibit-applet
  178. %{_libdir}/bonobo/servers/GNOME_InhibitApplet.server
  179. %{_datadir}/gnome-2.0/ui/GNOME_InhibitApplet.xml
  180. %{_datadir}/icons/hicolor/*/apps/gnome-inhibit-applet.*
  181. %changelog
  182. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  183. - new upstream release
  184. * Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  185. - merge spec file from FC package
  186. - add Patch1, Patch2 and Patch3 from FC package
  187. - add Patch10 and Patch11 for Vine Linux
  188. - remove configure option --enable-policykit
  189. - add new package (extra)
  190. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
  191. - new upstream release
  192. * Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  193. - new upstream release
  194. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  195. - new upstream release
  196. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  197. - new upstream release
  198. * Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  199. - new upstream release
  200. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
  201. - rebuild with new environment/toolchain
  202. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
  203. - new upstream release
  204. - drop Patch10 to enable suspend-to-ram.
  205. * Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
  206. - new upstream release
  207. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
  208. - new upstream release
  209. * Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
  210. - new upstream release
  211. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
  212. - new upstream release
  213. * Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
  214. - new upstream release
  215. * Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
  216. - new upstream release
  217. * Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
  218. - new upstream release
  219. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  220. - new upstream release
  221. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  222. - add Patch10 to disable suspend-to-ram by default.
  223. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  224. - update ja.po from CVS head.
  225. * Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  226. - new upstream release
  227. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
  228. - initial build for Vine Linux based on FC package
  229. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
  230. - fix the fix in -2 and -3
  231. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
  232. - fix the fix in -2
  233. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
  234. - fix icon in bubbles (bug 184192).
  235. * Fri Mar 3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
  236. - Update to 2.13.93
  237. - ignore d-bus timeout errors
  238. * Thu Mar 2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
  239. - Add patch from Richard Hughes to potentially fix a
  240. crasher bug (bug 183127)
  241. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
  242. - Buildrequires: gnome-doc-utils
  243. * Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
  244. - Update to 2.13.92
  245. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
  246. - Update to 2.13.91
  247. - Drop upstreamed patch
  248. * Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
  249. - Update to 2.13.90
  250. - Require dbus-x11 (#176656)
  251. * Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
  252. - remove Hibernate and Suspend from menus as part of
  253. panel/g-p-m integration effort
  254. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
  255. - bump again for double-long bug on ppc(64)
  256. * Tue Feb 7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
  257. - pull cvs snapshot from HEAD and drop the patches caillon
  258. just added
  259. * Tue Feb 7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
  260. - Install into the autostart directory
  261. - Don't suspend on lid close while on AC power
  262. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
  263. - rebuilt for new gcc4.1 snapshot and glibc changes
  264. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
  265. - rebuild
  266. * Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
  267. - packaging tweaks
  268. * Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
  269. - Update to 2.13.5
  270. * Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
  271. - Left clicking on the applet should bring up the menu
  272. * Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
  273. - update to 0.3.4
  274. - disable updating scrollkeeper database in buildroot
  275. (move to %%post)
  276. * Fri Jan 6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
  277. - update to a cvs snap so that it works with hal cvs snap
  278. - make sure we use libnotify
  279. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
  280. - rebuilt
  281. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  282. - rebuild for new dbus
  283. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
  284. - Update to 0.3.1
  285. * Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
  286. - Update to 0.3.0
  287. * Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
  288. - update to 0.2.8
  289. * Wed Oct 3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
  290. - update to 0.2.6
  291. * Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
  292. - update to 0.2.4
  293. * Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
  294. - Initial import based on an SRPM from Richard Hughes