gedit-plugins-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176
  1. Name: gedit-plugins
  2. Version: 2.28.0
  3. Release: 2%{?_dist_release}
  4. Summary: A collection Official Plugins for gedit
  5. Summary: gedit の公式プラグイン集
  6. Group: Applications/Editors
  7. License: GPLv2+
  8. URL: http://live.gnome.org/GeditPlugins
  9. Source0: ftp://ftp.gnome.org/pub/gnome/sources/gedit-plugins/2.28/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: intltool >= 0.35.0
  12. BuildRequires: perl >= 5.8.1
  13. BuildRequires: perl-XML-Parser
  14. BuildRequires: gettext
  15. BuildRequires: glib2-devel >= 2.16.0
  16. BuildRequires: gtk2-devel >= 2.13.0
  17. BuildRequires: GConf2-devel
  18. BuildRequires: gtksourceview2-devel >= 2.5.1
  19. BuildRequires: gedit-devel >= 2.25.4
  20. BuildRequires: gucharmap-devel >= 2.23.0
  21. BuildRequires: gnome-doc-utils
  22. BuildRequires: vte-devel
  23. BuildRequires: pygtk2-devel >= 2.12.0
  24. BuildRequires: pygtksourceview-devel >= 2.2.0
  25. BuildRequires: pygobject-devel >= 2.15.4
  26. Requires: gedit
  27. Requires: pygtk2
  28. Requires: pygtksourceview
  29. Requires: pygobject
  30. Requires(pre): GConf2
  31. Requires(post): GConf2
  32. Requires(preun): GConf2
  33. %description
  34. A collection of Official plugins for gedit.
  35. * Bookmarks: Easy document navigation with bookmarks
  36. * Bracket Completion: Automatically adds closing brackets.
  37. * Character Map: Insert special characters just by clicking on them.
  38. * Code comment: Comment out or uncomment a selected block of code.
  39. * Color Picker: Pick a color from a dialog and insert its hexadecimal representation.
  40. * Draw Spaces: Draw Spaces and Tabs
  41. * Join/Split Lines: Join several lines or split long ones
  42. * Session Saver: Save and restore your working sessions
  43. * Show/Hide Tabbar: Add a menu entry to show/hide the tabbar.
  44. * Smart Spaces: Forget you're not using tabulations.
  45. * Embedded Terminal: Embed a terminal in the bottom pane.
  46. %description -l ja
  47. gedit の公式プラグイン集です。
  48. * ブックマーク: ブックマークを使って簡単にドキュメントを閲覧できるようにします。
  49. * 括弧の補完: 対応する閉じ括弧を自動的に追加します。
  50. * 文字マップ: 特殊な文字をクリックしながら挿入していきます。
  51. * コードのコメント: 選択した範囲をコメントアウトしたり解除します。
  52. * 色の取得: 色選択ダイアログから色を取得して 16進形式の文字列として挿入します。
  53. * 空白文字の表示: 空白やタブ文字を描画します。
  54. * 行の結合・分割: 複数の行と結合したり一行を分割したりします。
  55. * セッションの保存: 現在、作業中のセッションを保存したりリストアします。
  56. * タブバーの表示/非表示: タブバーの表示切り替えエントリをメニューに追加します。
  57. * スマート・スペース: 作表を使っていないことを忘れて下さい。
  58. * 埋め込み式の端末: ボトム・ペインに端末を埋め込みます。
  59. %prep
  60. %setup -q
  61. grep '"import vte' configure && sed \
  62. -i "s!import vte!import imp; imp.find_module('vte')!" configure
  63. %build
  64. %configure --disable-schemas-install --enable-python
  65. #--with-plugins=bracketcompletion,charmap,codecomment,colorpicker,drawspaces,joinlines,showtabbar,smartspaces,terminal,bookmarks
  66. make %{?_smp_mflags}
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. make install DESTDIR=$RPM_BUILD_ROOT
  70. %find_lang %{name}
  71. find $RPM_BUILD_ROOT/%{_libdir}/gedit-2/plugins -name "*.la" -exec rm {} \;
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %pre
  75. if [ "$1" -gt 1 ]; then
  76. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  77. gconftool-2 --makefile-uninstall-rule \
  78. %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas >/dev/null || :
  79. fi
  80. %post
  81. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  82. gconftool-2 --makefile-install-rule \
  83. %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas > /dev/null || :
  84. %preun
  85. if [ "$1" -eq 0 ]; then
  86. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  87. gconftool-2 --makefile-uninstall-rule \
  88. %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas > /dev/null || :
  89. fi
  90. %check
  91. [ -f ${RPM_BUILD_ROOT}%{_libdir}/gedit-2/plugins/terminal.py ]
  92. %files -f %{name}.lang
  93. %defattr(-,root,root,-)
  94. %doc README NEWS AUTHORS COPYING
  95. %config(noreplace) %{_sysconfdir}/gconf/schemas/*.schemas
  96. %{_libdir}/gedit-2/plugins/*
  97. %{_datadir}/gedit-2/plugins/*
  98. %changelog
  99. * Tue Dec 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.28.0-2
  100. - added BuildRequires: gedit-devel
  101. * Tue Nov 3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.0-1
  102. - new upstream release
  103. * Sun Aug 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.3-1
  104. - Update to upstream release
  105. * Fri Jun 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.2-1
  106. - Update to upstream release
  107. * Tue May 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.1-1
  108. - initial build for VineSeed
  109. * Sat Apr 11 2009 Dodji Seketeli <dodji@redhat.org> - 2.26.1-1
  110. - Update to upstream release 2..26.1
  111. - Fixes GNOME bugzilla bug #576766 - Crash when Configuring "Draw Spaces"
  112. - Make sure to remove all *.la files
  113. - Remove BuildRequire libgnomeui-devel as needless now
  114. * Fri Apr 10 2009 Dodji Seketeli <dodji@redhat.org> - 2.26.0-1
  115. - Update to upstream release (2.26.1)
  116. - Add plugin files from %%{_datadir}
  117. - Don't check for vte anymore, the package checks it pkg-config
  118. - Add 'bookmarks' to the plugin set
  119. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-4
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  121. * Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.22.3-3
  122. - Rebuild for Python 2.6
  123. * Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.3-2
  124. - Fixed buildrequires
  125. * Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.3-1
  126. - Updated to 2.22.3
  127. * Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.0-2
  128. - rebuild to pick latest gucharmap
  129. * Tue Mar 18 2008 Trond Danielsen <trond.danielsen@gmail.com> - 2.22.0-1
  130. - Updated.
  131. * Mon Apr 30 2007 Trond Danielsen <trond.danielsen@gmail.com> - 2.18.0-2
  132. - Disable buggy session saver plugin.
  133. - Removed static libraries.
  134. * Sun Apr 01 2007 Trond Danielsen <trond.danielsen@gmail.com> - 2.18.0-1
  135. - Initial version.