gcdemu-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %global python_module_name gcdemu
  3. Summary: A GNOME panel applet to control CDEmu daemon
  4. Summary: CDEmu daemon を制御するための GNOME パネルアプレット
  5. Name: gcdemu
  6. Version: 1.2.0
  7. Release: 2%{?_dist_release}
  8. License: GPLv2+
  9. Group: Applications/Accessories
  10. URL: http://cdemu.sourceforge.net
  11. Source: http://downloads.sourceforge.net/cdemu/%{name}-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: dbus-python-devel
  15. BuildRequires: gettext
  16. BuildRequires: intltool >= 0.21
  17. BuildRequires: gnome-panel-devel
  18. BuildRequires: gnome-python-devel
  19. BuildRequires: perl-XML-Parser
  20. BuildRequires: pygtk2-devel >= 2.6
  21. BuildRequires: python-devel
  22. Requires: dbus-python >= 0.80
  23. Requires: gnome-python-applet
  24. Requires: hicolor-icon-theme
  25. Requires: pygtk2 >= 2.6
  26. Requires(pre): GConf2
  27. Requires(post): GConf2
  28. Requires(preun): GConf2
  29. Requires(post): scrollkeeper
  30. Requires(postun): scrollkeeper
  31. %description
  32. This is gCDEmu, a GNOME applet for controlling CDEmu daemon. It is part of the
  33. userspace-cdemu suite, a free, GPL CD/DVD-ROM device emulator for linux.
  34. It provides a graphic interface that allows performing the key tasks related to
  35. controlling the CDEmu daemon, such as loading and unloading devices, displaying
  36. devices' status and retrieving/setting devices' debug masks.
  37. In addition, applet listens to the signals emitted by CDEmu daemon and provides
  38. the notification via libnotify's notifications (provided that python bindings
  39. are installed).
  40. %prep
  41. %setup -q
  42. %build
  43. %{configure} --disable-schemas-install --disable-scrollkeeper
  44. %{__make} %{?_smp_mflags}
  45. %install
  46. %{__rm} -rf $RPM_BUILD_ROOT
  47. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  48. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  49. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  50. %find_lang gcdemu --with-gnome
  51. %clean
  52. %{__rm} -rf $RPM_BUILD_ROOT
  53. %pre
  54. if [ "$1" -gt 1 ]; then
  55. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  56. gconftool-2 --makefile-uninstall-rule \
  57. %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  58. fi
  59. %post
  60. scrollkeeper-update -q
  61. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  62. gconftool-2 --makefile-install-rule \
  63. %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  64. %preun
  65. if [ "$1" -eq 0 ]; then
  66. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  67. gconftool-2 --makefile-uninstall-rule \
  68. %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
  69. fi
  70. %postun
  71. scrollkeeper-update -q
  72. %files -f gcdemu.lang
  73. %defattr(-,root,root,-)
  74. %doc AUTHORS ChangeLog COPYING NEWS README
  75. %{_datadir}/pixmaps/*
  76. #%{_datadir}/omf/gcdemu/gcdemu-C.omf
  77. %{_libdir}/bonobo/servers/*
  78. %{_libexecdir}/*
  79. %dir %{python_sitelib}/%{python_module_name}/
  80. %{python_sitelib}/%{python_module_name}/*.py*
  81. %{_sysconfdir}/gconf/schemas/*
  82. %changelog
  83. * Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
  84. - rebuilt with python-2.6.4
  85. * Fri Sep 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
  86. - initial build for VineSeed
  87. * Sat Jun 28 2008 Rok Mandeljc <rok.mandeljc@email.si> - 1.1.0-1
  88. - Updated to 1.1.0
  89. * Thu Dec 20 2007 Rok Mandeljc <rok.mandeljc@email.si> - 1.0.0-1
  90. - Initial RPM release.