openssh-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751
  1. %define ver 5.8p1
  2. %define rel 2%{_dist_release}
  3. # SELinux
  4. %define WITH_SELINUX 0
  5. # OpenSSH privilege separation requires a user & group ID
  6. %define sshd_uid 74
  7. %define sshd_gid 74
  8. # Version of ssh-askpass
  9. %define aversion 1.2.4.1
  10. # Do we want to disable building of gnome-askpass? (1=yes 0=no)
  11. %define no_gnome_askpass 0
  12. # Use GTK2 for gnome-ssh-askpass
  13. %define gtk2 1
  14. # Build position-independent executables (requires toolchain support)?
  15. %define pie 1
  16. # Do we want to link against a static libcrypto? (1=yes 0=no)
  17. %define static_libcrypto 0
  18. # Do we want smartcard support (1=yes 0=no)
  19. %define scard 0
  20. # Disable IPv6 (avoids DNS hangs on some glibc versions)
  21. %define noip6 0
  22. # Do we want kerberos5 support (1=yes 0=no)
  23. %define kerberos5 0
  24. # Reserve options to override askpass settings with:
  25. # rpm -ba|--rebuild --define 'skip_xxx 1'
  26. %{?skip_gnome_askpass:%define no_gnome_askpass 1}
  27. # Options for static OpenSSL link:
  28. # rpm -ba|--rebuild --define "static_openssl 1"
  29. %{?static_openssl:%define static_libcrypto 1}
  30. # Options for Smartcard support: (needs libsectok and openssl-engine)
  31. # rpm -ba|--rebuild --define "smartcard 1"
  32. %{?smartcard:%define scard 1}
  33. # Option to disable ipv6
  34. # rpm -ba|--rebuild --define "noipv6 1"
  35. %{?noipv6:%define noip6 1}
  36. # Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
  37. %define rescue 0
  38. %{?build_rescue:%define rescue 1}
  39. # Turn off some stuff for resuce builds
  40. %if %{rescue}
  41. %define kerberos5 0
  42. %endif
  43. Summary: The OpenSSH implementation of SSH.
  44. Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
  45. Name: openssh
  46. Version: %{ver}
  47. Release: %{rel}
  48. URL: http://www.openssh.com/portable.html
  49. Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
  50. Patch0: openssh-5.5p1-vine.patch
  51. Patch4: openssh-5.2p1-vendor.patch
  52. Patch12: openssh-selinux.patch
  53. Patch20: openssh-3.9p1-gssapimitm.patch
  54. Patch21: openssh-3.9p1-safe-stop.patch
  55. Patch24: openssh-5.7p1-fromto-remote.patch
  56. Patch26: openssh-5.2p1-pam-no-stack.patch
  57. Patch27: openssh-5.1p1-log-in-chroot.patch
  58. Patch30: openssh-4.0p1-exit-deadlock.patch
  59. # Patch31: openssh-3.9p1-skip-used.patch
  60. Patch35: openssh-4.2p1-askpass-progress.patch
  61. # Vine Source
  62. Source100: sshd.init
  63. Source110: sshd.sysconfig
  64. # Vine Patch
  65. Patch100: openssh-norootlogin.patch
  66. License: BSD
  67. Group: Applications/Internet
  68. BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
  69. Obsoletes: ssh
  70. BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
  71. BuildRequires: util-linux
  72. BuildRequires: db4-devel
  73. BuildRequires: pam-devel
  74. BuildRequires: zlib-devel
  75. %if ! %{no_gnome_askpass}
  76. BuildRequires: libX11-devel
  77. BuildRequires: gtk2-devel
  78. %endif
  79. BuildRequires: xorg-x11-xauth
  80. BuildRequires: groff
  81. BuildRequires: libedit-devel
  82. Vendor: Project Vine
  83. Distribution: Vine Linux
  84. Packager: daisuke
  85. %package clients
  86. Summary: OpenSSH clients.
  87. Summary(ja): OpenSSH Secure Shell プロトコルクライアント
  88. Requires: openssh = %{version}-%{release}
  89. Group: Applications/Internet
  90. Obsoletes: ssh-clients
  91. Obsoletes: openssh-contrib
  92. %package server
  93. Summary: The OpenSSH server daemon.
  94. Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
  95. Group: System Environment/Daemons
  96. Obsoletes: ssh-server
  97. Requires(post): openssh = %{version}-%{release}
  98. Requires(post): chkconfig
  99. Requires(pre): shadow-utils
  100. Requires(post): initscripts >= 5.20
  101. Requires: pam
  102. %package askpass-gnome
  103. Summary: A passphrase dialog for OpenSSH, X, and GNOME.
  104. Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
  105. Group: Applications/Internet
  106. Requires: openssh = %{version}-%{release}
  107. Obsoletes: ssh-extras
  108. Obsoletes: openssh-askpass < 5.5p1-3vl6
  109. Provides: openssh-askpass = %{version}-%{release}
  110. %description
  111. SSH (Secure SHell) is a program for logging into and executing
  112. commands on a remote machine. SSH is intended to replace rlogin and
  113. rsh, and to provide secure encrypted communications between two
  114. untrusted hosts over an insecure network. X11 connections and
  115. arbitrary TCP/IP ports can also be forwarded over the secure channel.
  116. OpenSSH is OpenBSD's version of the last free version of SSH, bringing
  117. it up to date in terms of security and features, as well as removing
  118. all patented algorithms to separate libraries.
  119. This package includes the core files necessary for both the OpenSSH
  120. client and server. To make this package useful, you should also
  121. install openssh-clients, openssh-server, or both.
  122. #'
  123. %description -l ja
  124. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  125. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  126. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  127. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  128. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  129. な通信路の中を通すことができます。
  130. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  131. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  132. アルゴリズムは分割したライブラリにわかれています。
  133. このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
  134. コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
  135. openssh-clients および/または openssh-server が必要です。
  136. %description clients
  137. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  138. into and executing commands on a remote machine. This package includes
  139. the clients necessary to make encrypted connections to SSH servers.
  140. You'll also need to install the openssh package on OpenSSH clients.
  141. #'
  142. %description -l ja clients
  143. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  144. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  145. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  146. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  147. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  148. な通信路の中を通すことができます。
  149. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  150. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  151. アルゴリズムは分割したライブラリにわかれています。
  152. このパッケージは OpenSSH をクライアントとして使用する場合に
  153. 必要なものを含んでいます。
  154. %description server
  155. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  156. into and executing commands on a remote machine. This package contains
  157. the secure shell daemon (sshd). The sshd daemon allows SSH clients to
  158. securely connect to your SSH server. You also need to have the openssh
  159. package installed.
  160. %description -l ja server
  161. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  162. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  163. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  164. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  165. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  166. な通信路の中を通すことができます。
  167. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  168. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  169. アルゴリズムは分割したライブラリにわかれています。
  170. このパッケージは OpenSSH をサーバとして使用する場合に必要な
  171. デーモンなどを含んでいます。
  172. %description askpass-gnome
  173. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  174. into and executing commands on a remote machine. This package contains
  175. an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
  176. environment.
  177. %description -l ja askpass-gnome
  178. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  179. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  180. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  181. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  182. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  183. な通信路の中を通すことができます。
  184. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  185. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  186. アルゴリズムは分割したライブラリにわかれています。
  187. このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
  188. %prep
  189. %setup -q
  190. %patch0 -p1 -b .vine
  191. %patch4 -p1 -b .vendor
  192. %if %{WITH_SELINUX}
  193. #SELinux
  194. %patch12 -p1 -b .selinux
  195. %endif
  196. %patch21 -p1 -b .safe-stop
  197. %patch24 -p1 -b .fromto-remote
  198. %patch26 -p1 -b .stack
  199. %patch27 -p1 -b .log-chroot
  200. %patch30 -p1 -b .exit-deadlock
  201. %patch35 -p1 -b .progress
  202. %patch100 -p1 -b .norootlogin
  203. autoreconf
  204. %build
  205. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  206. %if %{rescue}
  207. CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
  208. %endif
  209. %if %{pie}
  210. %ifarch s390 s390x sparc sparc64
  211. CFLAGS="$CFLAGS -fPIE"
  212. %else
  213. CFLAGS="$CFLAGS -fpie"
  214. %endif
  215. export CFLAGS
  216. LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
  217. %endif
  218. %configure \
  219. --sysconfdir=%{_sysconfdir}/ssh \
  220. --libexecdir=%{_libexecdir}/openssh \
  221. --datadir=%{_datadir}/openssh \
  222. --with-tcp-wrappers \
  223. --with-default-path=/usr/local/bin:/bin:/usr/bin \
  224. --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
  225. --with-privsep-path=%{_var}/empty/sshd \
  226. --enable-vendor-patchlevel="VL-%{version}-%{release}" \
  227. --with-libedit \
  228. %if %{scard}
  229. --with-smartcard \
  230. %endif
  231. %if %{noip6}
  232. --with-ipv4-default \
  233. %endif
  234. %if %{rescue}
  235. --without-pam --with-md5-passwords
  236. %else
  237. --with-pam
  238. %endif
  239. %if %{static_libcrypto}
  240. perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
  241. %endif
  242. make
  243. %if %{gtk2}
  244. gtk2=yes
  245. %else
  246. gtk2=no
  247. %endif
  248. %if ! %{no_gnome_askpass}
  249. pushd contrib
  250. if [ $gtk2 = yes ]; then
  251. make gnome-ssh-askpass2
  252. mv gnome-ssh-askpass2 gnome-ssh-askpass
  253. else
  254. make gnome-ssh-askpass1
  255. mv gnome-ssh-askpass1 gnome-ssh-askpass
  256. fi
  257. popd
  258. %endif
  259. %install
  260. rm -rf $RPM_BUILD_ROOT
  261. mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
  262. mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
  263. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
  264. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
  265. make install DESTDIR=$RPM_BUILD_ROOT
  266. touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
  267. install -d $RPM_BUILD_ROOT/etc/pam.d/
  268. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  269. install -d $RPM_BUILD_ROOT/etc/sysconfig/
  270. install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
  271. install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
  272. install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
  273. install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
  274. %if ! %{scard}
  275. rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
  276. %endif
  277. %if ! %{no_gnome_askpass}
  278. install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
  279. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  280. install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  281. %endif
  282. %if %{no_gnome_askpass}
  283. rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
  284. %endif
  285. # for contrib package
  286. install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
  287. install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
  288. mv contrib/README contrib/README.contrib
  289. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
  290. %clean
  291. rm -rf $RPM_BUILD_ROOT
  292. %triggerun server -- ssh-server
  293. if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
  294. touch /var/run/sshd.restart
  295. fi
  296. %triggerun server -- openssh-server < 2.5.0p1
  297. # Count the number of HostKey and HostDsaKey statements we have.
  298. gawk 'BEGIN {IGNORECASE=1}
  299. /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
  300. END {exit sawhostkey}' /etc/ssh/sshd_config
  301. # And if we only found one, we know the client was relying on the old default
  302. # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
  303. # specified. Now that HostKey is used for both SSH1 and SSH2 keys, specifying
  304. # one nullifies the default, which would have loaded both.
  305. if [ $? -eq 1 ] ; then
  306. echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
  307. echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
  308. fi
  309. %triggerpostun server -- ssh-server
  310. if [ "$1" != 0 ] ; then
  311. /sbin/chkconfig --add sshd
  312. if test -f /var/run/sshd.restart ; then
  313. rm -f /var/run/sshd.restart
  314. # /sbin/service sshd start > /dev/null 2>&1 || :
  315. /sbin/service sshd start
  316. fi
  317. fi
  318. %pre server
  319. %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
  320. %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
  321. -g sshd -M -r sshd 2>/dev/null || :
  322. %post server
  323. /sbin/chkconfig --add sshd
  324. %postun server
  325. # /sbin/service sshd condrestart > /dev/null 2>&1 || :
  326. /sbin/service sshd condrestart
  327. exit 0
  328. %preun server
  329. if [ "$1" = 0 ]
  330. then
  331. /sbin/service sshd stop > /dev/null 2>&1 || :
  332. /sbin/chkconfig --del sshd
  333. fi
  334. %files
  335. %defattr(-,root,root)
  336. %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
  337. %attr(0755,root,root) %{_bindir}/scp
  338. %attr(0644,root,root) %{_mandir}/man1/scp.1*
  339. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  340. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
  341. %attr(644,root,root) %{_mandir}/man5/moduli.5*
  342. %if ! %{rescue}
  343. %attr(0755,root,root) %{_bindir}/ssh-keygen
  344. %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
  345. %attr(0755,root,root) %dir %{_libexecdir}/openssh
  346. %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
  347. %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
  348. %endif
  349. %if %{scard}
  350. %attr(0755,root,root) %dir %{_datadir}/openssh
  351. %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
  352. %endif
  353. %files clients
  354. %defattr(-,root,root)
  355. %attr(0755,root,root) %{_bindir}/ssh
  356. %attr(0644,root,root) %{_mandir}/man1/ssh.1*
  357. %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
  358. %attr(0644,root,root) %{_mandir}/man1/slogin.1*
  359. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
  360. %attr(-,root,root) %{_bindir}/slogin
  361. %if ! %{rescue}
  362. %attr(0755,root,root) %{_bindir}/ssh-agent
  363. %attr(0755,root,root) %{_bindir}/ssh-add
  364. %attr(0755,root,root) %{_bindir}/ssh-keyscan
  365. %attr(0755,root,root) %{_bindir}/sftp
  366. %attr(0755,root,root) %{_bindir}/ssh-copy-id
  367. %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
  368. %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
  369. %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
  370. %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
  371. %attr(0644,root,root) %{_mandir}/man1/sftp.1*
  372. %attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
  373. %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
  374. %endif
  375. %if ! %{rescue}
  376. %files server
  377. %defattr(-,root,root)
  378. %dir %attr(0711,root,root) %{_var}/empty/sshd
  379. %dir %attr(0755,root,root) %{_var}/empty/sshd/etc
  380. %ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
  381. %attr(0755,root,root) %{_sbindir}/sshd
  382. %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
  383. %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
  384. %attr(0644,root,root) %{_mandir}/man8/sshd.8*
  385. %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
  386. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  387. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
  388. %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
  389. %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
  390. %attr(0755,root,root) %config /etc/sysconfig/sshd
  391. %endif
  392. %if ! %{no_gnome_askpass}
  393. %files askpass-gnome
  394. %defattr(-,root,root)
  395. %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
  396. %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
  397. %endif
  398. %changelog
  399. * Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
  400. - add our own sshd.init based on fedora's sshd.init
  401. - generate ECDSA host key.
  402. * Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
  403. - new upstream release
  404. * Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
  405. - new upstream release
  406. * Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
  407. - new upstream release
  408. - obsolete contrib subpackage, move ssh-copy-id to client subpackage
  409. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
  410. - rebuilt with openssl 1.0.0c
  411. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
  412. - drop x11-askpass, add Obsoletes: openssh-askpass
  413. - add BR: groff
  414. - enable --with-libedit option, add BR: libedit-devel
  415. - remove unrecognized option '--with-rsh'
  416. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
  417. - add BR: xorg-x11-xauth for X11 forwarding support
  418. * Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
  419. - new upstream release
  420. - update patch0,2
  421. - drop patch3,22
  422. * Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
  423. - new upstream release
  424. * Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
  425. - new upstream release
  426. * Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
  427. - rebuild with xorg-x11-7.3
  428. * Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
  429. - new upstream release with security fix (CVE-2008-1483)
  430. - drop patch31 which is included in new release (This was for CVE-2008-1483)
  431. * Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
  432. - new upstream release with security fix ("ForceCommand" Directive)
  433. - turn on daemon restart message
  434. - new versioning policy
  435. * Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
  436. - add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
  437. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
  438. - new upstream release
  439. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
  440. - build with -fpie/-pie by default.
  441. - enable ipv6 by default.
  442. * Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
  443. - new upstream release
  444. * Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
  445. - new upstream release
  446. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
  447. - new upstream release
  448. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
  449. - new upstream release
  450. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
  451. - new upstream release
  452. - remove build6x stuff
  453. - remove libgnome-devel from BuildRequires
  454. - cleanup BuildRequires
  455. - drop Patch200, it is merged in upstream.
  456. - import patches(25-35) from FC-devel
  457. * Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
  458. - SECURITY FIX: CVE-2006-0225
  459. - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
  460. - update BuildPreReq: s/XFree86-devel/XOrg-devel/
  461. - fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
  462. - When GNOME2 is used, using libgnome-devel
  463. - add BuildPreReq: gtk2-devel for GNOME2
  464. * Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
  465. - rebuild with gtk+-2.8 final
  466. * Sun Sep 4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
  467. - new upstream release
  468. - build with gtk+-2.7
  469. * Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
  470. - new upstream release
  471. * Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
  472. - cleanup obsolete patches and added patches from fedora
  473. * Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
  474. - new upstream release
  475. * Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
  476. - new upstream release
  477. * Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
  478. - new upstream release
  479. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
  480. - rebuild with openssl-0.9.7d
  481. * Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
  482. - new upstream release
  483. * Thu Oct 2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
  484. - create contrib package
  485. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
  486. - new upstream release
  487. - fix security issue: http://www.openssh.com/txt/sshpam.adv
  488. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
  489. - new upstream release
  490. - fix security issue: http://www.openssh.com/txt/buffer.adv
  491. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
  492. - new upstream release
  493. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
  494. - rebuild with gtk2
  495. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
  496. - new upstream release
  497. * Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
  498. - rebuild with new tool chain
  499. * Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
  500. - new upstream release
  501. - merge with upstream spec (drop anonymous mmap patch, suid of ssh)
  502. * Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
  503. - change some defines in spec files
  504. * Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
  505. - add patch110 ( 3.4p1 does not include mmap-fallback patch )
  506. * Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
  507. - new upstream release
  508. - security fix
  509. - drop patch10
  510. * Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
  511. - add patch from Solar Designer to make privsep work with a 2.2 kernel.
  512. * Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
  513. - new upstream release
  514. - add {sshd,ssh}_config.5 manpages
  515. - add ssh-keysign
  516. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
  517. - new upstream release
  518. * Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
  519. - new upstream release
  520. - drop patch1
  521. * Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
  522. - new upstream release
  523. - merged with rawhide release.
  524. - drop Patch101 (merged in upstream)
  525. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
  526. - seurity patch for off-by-one bug
  527. * Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
  528. - merged with Rawhide 3.0.2p1-2
  529. * Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
  530. - updated to 3.0.2p1
  531. * Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
  532. - updated to 3.0.1p1
  533. * Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
  534. - updated to 3.0p1
  535. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
  536. - add japanese summery and descriptions.
  537. - update x11-askpass 1.2.5
  538. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
  539. - update to openssh-2.9.9p2
  540. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
  541. - rebuilt with openssl-0.9.6b
  542. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
  543. - do not Permit RootLogin
  544. * Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
  545. - update to openssh-2.5.2p2
  546. * Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
  547. - update to openssh-2.5.2p1
  548. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  549. - update to openssh-2.5.1p2
  550. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  551. - update to openssh-2.5.1p1
  552. * Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
  553. - update to openssh-2.5.1p1
  554. * Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
  555. - remove suid bit from ssh
  556. * Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
  557. - moved man dir to /usr/share/man
  558. * Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
  559. - fixed askpass's link in ssh-add
  560. - partially used rpmmacros
  561. * Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
  562. - update to 2.3.0p1
  563. - update x11-askpass 1.0.3
  564. * Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
  565. - Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
  566. Redhat 7.0 spec file
  567. * Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
  568. - rebuild for Vine Linux
  569. * Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
  570. - Use RPM configure macro
  571. * Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
  572. - Some surgery to sshd.init (generate keys at runtime)
  573. - Cleanup of groups and removal of keygen calls
  574. * Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
  575. - Make building of X11-askpass and gnome-askpass optional
  576. * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
  577. - Glob manpages to catch compressed files
  578. * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
  579. - Updated for new location
  580. - Updated for new gnome-ssh-askpass build
  581. * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
  582. - Added Jim Knoble's <jmknoble@pobox.com> askpass
  583. * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
  584. - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
  585. * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
  586. - Added 'Obsoletes' directives
  587. * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
  588. - Use make install
  589. - Subpackages
  590. * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
  591. - Added links for slogin
  592. - Fixed perms on manpages
  593. * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
  594. - Renamed init script
  595. * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
  596. - Back to old binary names
  597. * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
  598. - Use autoconf
  599. - New binary names
  600. * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
  601. - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.