123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505 |
- %bcond_without ruby
- %bcond_with php
- Summary: Toolkit for broadcasters, video editors, media players, transcoders
- Name: mlt
- Version: 6.2.0
- Release: 4%{?_dist_release}
- # mlt/src/win32/fnmatch.{c,h} are BSD-licensed.
- License: GPLv3 and LGPLv2+ and BSD
- URL: http://www.mltframework.org/twiki/bin/view/MLT/
- Group: System Environment/Libraries
- Vendor: Project Vine
- Distribution: Vine Linux
- Source0: https://github.com/mltframework/mlt/archive/v%{version}/%{name}-%{version}.tar.gz
- BuildRequires: frei0r-devel
- BuildRequires: opencv-devel
- BuildRequires: qt5-qtsvg-devel
- BuildRequires: qt5-qt3d-devel
- BuildRequires: SDL-devel
- BuildRequires: SDL_image-devel
- BuildRequires: gtk2-devel
- BuildRequires: jack-audio-connection-kit-devel
- BuildRequires: libogg-devel
- #Deprecated dv, kino, and vorbis modules are not built.
- #https://github.com/mltframework/mlt/commit/9d082192a4d79157e963fd7f491da0f8abab683f
- #BuildRequires: libdv-devel
- #BuildRequires: libvorbis-devel
- BuildRequires: libsamplerate-devel
- BuildRequires: ladspa-devel
- BuildRequires: libxml2-devel
- BuildRequires: sox
- BuildRequires: sox-devel
- BuildRequires: swig
- BuildRequires: python-devel
- BuildRequires: freetype2-devel
- BuildRequires: libexif-devel
- BuildRequires: fftw3-devel
- BuildRequires: pulseaudio-libs-devel
- BuildRequires: alsa-lib-devel
- %if %{with ruby}
- BuildRequires: ruby-devel ruby
- %else
- Obsoletes: mlt-ruby < 0.8.8-5
- %endif
- %if %{with php}
- BuildRequires: php-devel
- %endif
- Requires: opencv-core
- %if %{with php}
- %global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{php_extdir}/.*\\.so$
- %endif
- %description
- MLT is an open source multimedia framework, designed and developed for
- television broadcasting.
- It provides a toolkit for broadcasters, video editors,media players,
- transcoders, web streamers and many more types of applications. The
- functionality of the system is provided via an assortment of ready to use
- tools, xml authoring components, and an extendible plug-in based API.
- %package devel
- Summary: Libraries, includes to develop applications with %{name}
- License: LGPLv2+
- Group: Development/Libraries
- Requires: pkgconfig
- Requires: %{name}%{?_isa} = %{version}-%{release}
- %package python
- Requires: python
- Requires: %{name}%{?_isa} = %{version}-%{release}
- Summary: Python package to work with MLT
- %package ruby
- Requires: %{name}%{_isa} = %{version}-%{release}
- Summary: Ruby package to work with MLT
- %package php
- Requires: php(zend-abi) = %{php_zend_api}
- Requires: php(api) = %{php_core_api}
- Requires: %{name}%{?_isa} = %{version}-%{release}
- Summary: PHP package to work with MLT
- %description devel
- The %{name}-devel package contains the header files and static libraries for
- building applications which use %{name}.
- %description python
- This module allows to work with MLT using python.
- %description ruby
- This module allows to work with MLT using ruby.
- %description php
- This module allows to work with MLT using PHP.
- %prep
- %setup -q
- chmod 644 src/modules/qt/kdenlivetitle_wrapper.cpp
- chmod 644 src/modules/kdenlive/filter_freeze.c
- chmod -x demo/demo
- # Don't overoptimize (breaks debugging)
- sed -i -e '/fomit-frame-pointer/d' configure
- sed -i -e '/ffast-math/d' configure
- %build
- #export STRIP=/bin/true
- %configure \
- --enable-gpl \
- --enable-gpl3 \
- --enable-motion-est \
- %ifnarch %{ix86} x86_64
- --disable-mmx \
- --disable-sse \
- --disable-xine \
- %endif
- --rename-melt=%{name}-melt \
- --swig-languages="python %{?with_php: php}%{?with_ruby: ruby}"
- make %{?_smp_mflags}
- %install
- make DESTDIR=%{buildroot} install
- # manually do what 'make install' skips
- install -D -pm 0644 src/swig/python/mlt.py %{buildroot}%{python_sitelib}/mlt.py
- install -D -pm 0755 src/swig/python/_mlt.so %{buildroot}%{python_sitearch}/_mlt.so
- %if %{with ruby}
- install -D -pm 0755 src/swig/ruby/play.rb %{buildroot}%{ruby_vendorlibdir}/play.rb
- install -D -pm 0755 src/swig/ruby/thumbs.rb %{buildroot}%{ruby_vendorlibdir}/thumbs.rb
- install -D -pm 0755 src/swig/ruby/mlt.so %{buildroot}%{ruby_vendorarchdir}/mlt.so
- %endif
- %if %{with php}
- install -D -pm 0755 src/swig/php/mlt.so %{buildroot}%{php_extdir}/mlt.so
- install -d %{buildroot}%{_sysconfdir}/php.d
- cat > %{buildroot}%{_sysconfdir}/php.d/mlt.ini << 'EOF'
- ; Enable mlt extension module
- extension=mlt.so
- EOF
- %endif
- mv src/modules/motion_est/README README.motion_est
- %check
- # verify pkg-config version sanity
- export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
- test "$(pkg-config --modversion mlt-framework)" = "%{version}"
- test "$(pkg-config --modversion mlt++)" = "%{version}"
- %post
- /sbin/ldconfig
- %postun
- /sbin/ldconfig
- %files
- %doc AUTHORS ChangeLog NEWS README*
- %license COPYING GPL
- %{_bindir}/mlt-melt
- %{_libdir}/mlt/
- %{_libdir}/libmlt++.so.*
- %{_libdir}/libmlt.so.*
- %{_datadir}/mlt/
- %files python
- %{python_sitelib}/mlt.py*
- %{python_sitearch}/_mlt.so
- %if %{with ruby}
- %files ruby
- %{ruby_vendorlibdir}/play.rb
- %{ruby_vendorlibdir}/thumbs.rb
- %{ruby_vendorarchdir}/mlt.so
- %endif
- %if %{with php}
- %files php
- %config(noreplace) %{_sysconfdir}/php.d/mlt.ini
- %{php_extdir}/mlt.so
- %endif
- %files devel
- %doc docs/* demo/
- %{_libdir}/pkgconfig/mlt-framework.pc
- %{_libdir}/pkgconfig/mlt++.pc
- %{_libdir}/libmlt.so
- %{_libdir}/libmlt++.so
- %{_includedir}/mlt/
- %{_includedir}/mlt++/
- %changelog
- * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 6.2.0-4
- - rebuild under current VineSeed
- * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
- - initial build for Vine Linux.
- * Thu Jun 30 2016 Sérgio Basto <sergio@serjux.com> - 6.2.0-2
- - Disable the php extension, for now, the PHP 7 landed in rawhide
- * Wed May 25 2016 Sérgio Basto <sergio@serjux.com> - 6.2.0-1
- - Initial MLT spec on Fedora.
- * Tue Mar 29 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-3
- - Use upstream patch to compile Ruby bindings
- * Sun Feb 21 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-2
- - Add license tag.
- - More spec modernizations and rpmlint fixes.
- - Configure conditional build for Ruby.
- - Remove old BuilRequires that aren't needed anymore.
- - Remove old config options (avformat-swscale and qimage-libdir) that no longer
- exist in configure.
- - Fix Ruby build.
- * Fri Feb 19 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-1
- - Update 6.0.0 (This is a bugfix and minor enhancement release. Note that our
- release versioning scheme has changed. We were approaching 1.0 but decided to
- synchronize release version with the C library ABI version, which is currently
- at v6)
- - Switch to qt5 to fix rfbz #3810 and copy some BRs from Debian package.
- * Wed Nov 18 2015 Sérgio Basto <sergio@serjux.com> - 0.9.8-1
- - Update MLT to 0.9.8
- * Mon May 11 2015 Sérgio Basto <sergio@serjux.com> - 0.9.6-2
- - Workaround #3523
- * Thu May 07 2015 Sérgio Basto <sergio@serjux.com> - 0.9.6-1
- - Update mlt to 0.9.6 .
- - Added BuildRequires of libexif-devel .
- * Thu May 07 2015 Sérgio Basto <sergio@serjux.com> - 0.9.2-4
- - Added BuildRequires of opencv-devel, rfbz #3523 .
- * Mon Oct 20 2014 Sérgio Basto <sergio@serjux.com> - 0.9.2-3
- - Rebuilt for FFmpeg 2.4.3
- * Fri Sep 26 2014 Nicolas Chauvet <kwizart@gmail.com> - 0.9.2-2
- - Rebuilt for FFmpeg 2.4.x
- * Mon Sep 15 2014 Sérgio Basto <sergio@serjux.com> - 0.9.2-1
- - New upstream release.
- * Thu Aug 07 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-6
- - Rebuilt for ffmpeg-2.3
- * Sat Jul 26 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-5
- - Rebuild for new php, need by mlt-php
- * Sun Mar 30 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-4
- - Rebuilt for ffmpeg-2.2 and fix for freetype2 changes.
- * Wed Dec 04 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-3
- - Update License tag .
- * Wed Nov 20 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-2
- - Enable gplv3 as asked in rfbz #3040
- - Fix a changelog date.
- - Fix Ruby warning with rpmbuild "Use RbConfig instead of obsolete and deprecated Config".
- - Remove obsolete tag %%clean and rm -rf
- * Mon Oct 07 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-1
- - Update to 0.9.0
- * Wed Oct 02 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-7
- - Rebuilt
- * Thu Aug 15 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-6
- - Rebuilt for FFmpeg 2.0.x
- * Mon Jun 10 2013 Rex Dieter <rdieter@fedoraproject.org> 0.8.8-5
- - mlt-ruby FTBFS, omit until fixed (#2816)
- * Sun May 26 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-4
- - Rebuilt for x264/FFmpeg
- * Sun Apr 28 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-3
- - https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Fri Feb 1 2013 Ryan Rix <ry@n.rix.si> - 0.8.8-1
- - Fix ABI requirement to Ruby 1.9
- * Fri Feb 1 2013 Ryan Rix <ry@n.rix.si> - 0.8.8-1
- - Update to 0.8.8
- * Wed Jan 30 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.6-2
- - Rebuilt for ffmpeg
- * Sun Dec 30 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.6-1
- - Update to 0.8.6
- * Sat Nov 24 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.0-3
- - Rebuilt for FFmpeg 1.0
- * Tue Jun 26 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.0-2
- - Rebuilt for FFmpeg
- * Tue Jun 19 2012 Richard Shaw <hobbes1069@gmail.com> - 0.8.0-1
- - Update to latest upstream release.
- * Thu Jun 14 2012 Remi Collet <remi@fedoraproject.org> 0.7.8-3
- - fix filter
- * Thu Jun 14 2012 Remi Collet <remi@fedoraproject.org> 0.7.8-2
- - update PHP requirement for PHP Guildelines
- - add php extension configuration file
- - filter php private shared so
- * Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 0.7.8-1
- - 0.7.8
- * Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-8
- - rebuild (sox)
- * Fri Mar 02 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-7
- - Rebuilt for c++ ABI breakage
- * Tue Feb 28 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-6
- - Rebuilt for x264/FFmpeg
- * Fri Jan 27 2012 Ryan Rix <ry@n.rix.si> 0.7.6-5
- - Include patch to fix building on gcc47 (upstreaming)
- * Wed Jan 25 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Thu Dec 29 2011 Ryan Rix <ry@n.rix.si> 0.7.6-3
- - s/%%[?_isa}/%%{?_isa}
- * Tue Nov 15 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-2
- - rebuild
- * Fri Nov 11 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-1
- - 0.7.6
- - track files/sonames closer
- - tighten subpkg deps via %%{?_isa}
- - drop dup'd %%doc items
- * Mon Sep 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 0.7.4-2
- - Rebuilt for ffmpeg-0.8
- * Thu Jul 21 2011 Ryan Rix <ry@n.rix.si> - 0.7.4-1
- - New upstream
- * Sun Apr 10 2011 Ryan Rix <ry@n.rix.si> - 0.7.0-2
- - Add SDL_image-devel BR per Kdenlive wiki page
- * Thu Apr 7 2011 Ryan Rix <ry@n.rix.si> - 0.7.0-1
- - New upstream
- * Tue Dec 21 2010 Ryan Rix <ry@n.rix.si> - 0.5.4-2
- - Fix build, needed a patch from mlt's git repo.
- * Sat Nov 20 2010 Nicolas Chauvet <kwizart@gmail.com> - 0.5.4-1.1
- - rebuilt - was missing in repo
- * Wed Apr 21 2010 Ryan Rix <ry@n.rix.si> - 0.5.4-1
- - New upstream version to fix reported crashes against Kdenlive
- * Fri Feb 19 2010 Zarko Pintar <zarko.pintar@gmail.com> - 0.5.0-2
- - disabled xine module for PPC arch.
- * Thu Feb 18 2010 Zarko Pintar <zarko.pintar@gmail.com> - 0.5.0-1
- - new version
- * Wed Dec 09 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.10-1
- - new version
- - added subpackage for ruby
- * Wed Oct 07 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.6-1
- - new version
- - added subpackages for: python, PHP
- * Mon Sep 07 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.4-1
- - new version
- - renamed melt binary to mlt-melt
- * Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.2-1
- - new version
- - removed obsolete patches
- * Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-3
- - added linker and license patches
- - set license of MLT devel subpackage to LGPLv2+
- * Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-2
- - some PPC clearing
- * Mon May 18 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-1
- - update to 0.4.0
- * Wed May 13 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.9-2
- - spec cleaning
- * Mon May 11 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.9-1
- - new release
- - MLT++ is now a part of this package
- * Fri May 8 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-3
- - unused-direct-shlib-dependency fix
- * Fri Apr 17 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-2
- - spec clearing
- - added patches for resolving broken lqt-config, lib64 and execstack
- * Wed Apr 15 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-1
- - New release
- * Thu Apr 9 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.6-3
- - Enabled MMX support (not for PPC & PPC64)
- - include demo files
- - some spec cosmetics
- * Thu Mar 12 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.6-2
- - Change URL address
- - devel Requires: pkgconfig
- * Fri Feb 20 2009 Levente Farkas <lfarkas@lfarkas.org> - 0.3.6-1
- - Update to 0.3.6
- * Wed Nov 5 2008 Arkady L. Shane <ashejn@yandex-team.ru> - 0.3.1-0.1.svn1180
- - update to upstream r1180
- - add --avformat-swscale configure option
- * Tue Nov 4 2008 Arkady L. Shane <ashejn@yandex-team.ru> - 0.3.0-5
- - rebuilt with proper qt4 paths
- * Mon Oct 13 2008 jeff <moe@blagblagblag.org> - 0.3.0-4
- - Build without fomit-frame-pointer ffmath
- - Add BuildRequires: prelink
- - clear-execstack libmltgtk2.so
- - Don't strip binaries
- - Group: Development/Libraries
- - Prefix albino, humperdink, and miracle binaries with mlt-
- * Sun Oct 5 2008 jeff <moe@blagblagblag.org> - 0.3.0-3
- - License: GPLv2+ and LGPLv2+
- - Group: Development/Tools
- - ExcludeArch: x86_64 s390 s390x ppc ppc64
- - %%defattr(-,root,root)
- - %%doc docs/
- - %%{_libdir}/%%{name} to main package
- * Sun Aug 24 2008 jeff <moe@blagblagblag.org> - 0.3.0-2
- - Change BuildRoot:
- - Full source URL
- - ExcludeArch: x86_64
- - -devel Requires: pkgconfig, Requires: %%{name} = %%{version}-%%{release}
- * Sun Aug 24 2008 jeff <moe@blagblagblag.org> - 0.3.0-1
- - Update to 0.3.0
- - --enable-gpl
- - mlt-filehandler.patch
- * Tue Jul 8 2008 jeff <moe@blagblagblag.org> - 0.2.5-0.svn1155.0blag.f10
- - Build for blaghead
- * Mon Jul 7 2008 jeff <moe@blagblagblag.org> - 0.2.5-0.svn1155.0blag.f9
- - Update to svn r1155
- - Remove sox-st.h.patch
- - Add configure --disable-sox as it breaks build
- * Sun Nov 11 2007 jeff <moe@blagblagblag.org> - 0.2.4-0blag.f7
- - Update to 0.2.4
- - Clean up spec
- * Sat Jun 23 2007 jeff <moe@blagblagblag.org> - 0.2.3-0blag.f7
- - Update to 0.2.3
- * Sat Dec 30 2006 jeff <moe@blagblagblag.org> - 0.2.2-0blag.fc6
- - Rebuild for 60k
- - Remove --disable-sox
- - Add mlt-0.2.2-sox-st.h.patch
- * Sat Oct 21 2006 jeff <moe@blagblagblag.org> - 0.2.2-0blag.fc5
- - Update to 0.2.2
- * Sat Oct 21 2006 jeff <moe@blagblagblag.org> - 0.2.1-0blag.fc5
- - BLAG'd
- - Removed "olib" from path, name, etc.
- - Add changelog
- - Update summary/description
|