automake-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319
  1. # run "make check" by default
  2. %bcond_without check
  3. Summary: A GNU tool for automatically creating Makefiles.
  4. Summary(ja): Makefile を自動生成するための GNU ツール
  5. Name: automake
  6. Version: 1.16.4
  7. %define api_version %(echo %{version} | cut -d . -f 1-2)
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. License: GPL
  14. URL: http://sources.redhat.com/automake
  15. Source: https://ftp.gnu.org/gnu/automake/automake-%{version}.tar.xz
  16. Source2: http://git.savannah.gnu.org/cgit/config.git/plain/config.sub
  17. Source3: http://git.savannah.gnu.org/cgit/config.git/plain/config.guess
  18. BuildArch: noarch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: autoconf >= 2.58
  21. BuildRequires: texinfo
  22. BuildRequires: coreutils
  23. BuildRequires: findutils
  24. BuildRequires: help2man
  25. BuildRequires: perl(Thread::Queue)
  26. BuildRequires: perl(threads)
  27. Requires: perl, autoconf >= 2.58
  28. # requirements not detected automatically (#919810)
  29. Requires: perl(Thread::Queue)
  30. Requires: perl(threads)
  31. Requires(pre): install-info
  32. # remove bogus Automake perl dependencies and provides
  33. %global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(Automake::
  34. %global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(Automake::
  35. %description
  36. Automake is an experimental Makefile generator. Automake was inspired
  37. by the 4.4BSD make and include files, but aims to be portable and to
  38. conform to the GNU standards for Makefile variables and targets.
  39. You should install Automake if you are developing software and would
  40. like to use its ability to automatically generate GNU standard
  41. Makefiles. If you install Automake, you will also need to install
  42. GNU's Autoconf package.
  43. %prep
  44. %autosetup -p1
  45. #autoreconf -vi
  46. for file in %SOURCE2 %SOURCE3; do
  47. for dest in $(find -name "$(basename "$file")"); do
  48. cp "$file" "$dest"
  49. done
  50. done
  51. sed -i -e '/t\/vala-.*sh/d' t/list-of-tests.mk
  52. %build
  53. ./bootstrap
  54. %configure
  55. %{__make} %{?_smp_mflags}
  56. cp m4/acdir/README README.aclocal
  57. cp contrib/multilib/README README.multilib
  58. %install
  59. rm -rf ${RPM_BUILD_ROOT}
  60. make install DESTDIR=${RPM_BUILD_ROOT}
  61. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
  62. # create this dir empty so we can own it
  63. rm -rf ${RPM_BUILD_ROOT}%{_datadir}/aclocal
  64. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/aclocal
  65. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  66. %check
  67. %if %{with check}
  68. %{__make} -k %{?_smp_mflags} check %{?TESTS_FLAGS: TESTS="%{TESTS_FLAGS}"} \
  69. || ( cat ./test-suite.log && false )
  70. %endif
  71. %clean
  72. rm -rf ${RPM_BUILD_ROOT}
  73. %post
  74. /sbin/install-info %{_infodir}/automake.info.gz %{_infodir}/dir ||:
  75. %preun
  76. if [ $1 = 0 ]; then
  77. /sbin/install-info --delete %{_infodir}/automake.info.gz %{_infodir}/dir ||:
  78. fi
  79. %files
  80. %defattr(-,root,root)
  81. %license COPYING*
  82. %doc AUTHORS NEWS README THANKS
  83. %doc REAME.aclocal README.multilib
  84. %doc %{_pkgdocdir}/amhello-1.0.tar.gz
  85. %{_bindir}/*
  86. %{_infodir}/*.info*
  87. %{_datadir}/automake-%{api_version}
  88. %{_datadir}/aclocal-%{api_version}
  89. %{_mandir}/man1/*
  90. %dir %{_datadir}/aclocal
  91. %changelog
  92. * Fri Jul 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.4-1
  93. - updated to 1.16.4.
  94. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.3-1
  95. - updated to 1.16.3.
  96. - dropped Patch0: got same effect by sed.
  97. - dropped Patch1.
  98. - imported Patch1 from rawhide.
  99. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.1-1
  100. - updated to 1.16.1.
  101. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-2
  102. - added Patch0 for perl-5.26.
  103. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.1-1
  104. - update to 1.14.1
  105. * Sat Sep 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14-1
  106. - update to 1.14
  107. - remove Patch1 (automake-1.12.2-vala-fails.patch)
  108. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.5-1
  109. - update to 1.12.5
  110. * Tue Nov 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
  111. - update to 1.12.2
  112. - add patch1 to skip vala test.
  113. * Sun Sep 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.1-4
  114. - change prereq to Require(pre)
  115. * Sat Aug 11 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.11.1-3
  116. - add patch100 for fix CVE-2012-3386 (world-writable tmp dir)
  117. * Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-2
  118. - rebuild for Vine 6
  119. * Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-1
  120. - new upstream release
  121. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.10.1-2
  122. - spec in utf-8
  123. * Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-1
  124. - new upstream release
  125. * Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.6-0vl1
  126. - new upstream release
  127. * Thu Jun 3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.5-0vl1
  128. - new upstream release
  129. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-0vl1
  130. - new upstream release
  131. * Thu Apr 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  132. - new upstream release
  133. * Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 1.8.2-0vl3
  134. - rebuild
  135. * Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8.2-1vl2
  136. - rebuild
  137. * Thu Feb 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.2-0vl1
  138. - new upstream release
  139. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8-1vl1
  140. - based on 1.8-1 from Rawhide and built for Vine Linux
  141. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.9-0vl1
  142. - new upstream release
  143. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-0vl1
  144. - new upstream release
  145. * Sat Jun 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.5-1vl1
  146. - based on 1.7.5-1 from Rawhide and built for Vine Linux
  147. * Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.3-1vl1
  148. - based on 1.7.3-1 from Rawhide and built for Vine Linux
  149. * Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-1vl2
  150. - based on 1.6.3-1 from Rawhide and built for Vine Linux
  151. * Mon Jul 29 2002 Jens Petersen <petersen@redhat.com> 1.6.3-1
  152. - bug fix release 1.6.3
  153. * Thu Jul 11 2002 Jens Petersen <petersen@redhat.com> 1.6.2-2
  154. - add buildrequires autoconf 2.52 or greater (reported by Edward Avis)
  155. * Wed Jun 19 2002 Jens Petersen <petersen@redhat.com> 1.6.2-1
  156. - 1.6.2 (bug fix release)
  157. - do "make check" after building
  158. * Thu May 23 2002 Tim Powers <timp@redhat.com> 1.6.1-2
  159. - automated rebuild
  160. * Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 1.6.1-1
  161. - 1.6.1
  162. * Tue Mar 12 2002 Jens Petersen <petersen@redhat.com> 1.6-1
  163. - new package based on automake15
  164. - 1.6
  165. * Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-8
  166. - better aclocal versioning
  167. * Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-7
  168. - don't version datadir/automake
  169. * Tue Jan 15 2002 Jens Petersen <petersen@redhat.com> 1.5-6
  170. - version suffix programs and data directories
  171. - own symlinks to programs and /usr/share/aclocal
  172. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.5-5
  173. - automated rebuild
  174. * Wed Jan 9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-4
  175. - Completely back out the fix for #56624 for now, it causes more problems
  176. than it fixes in either form.
  177. * Wed Jan 9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-3
  178. - Don't use AS_DIRNAME, it doesn't work.
  179. * Mon Jan 7 2002 Jens Petersen <petersen@redhat.com> 1.5-2
  180. - Patch depout.m4 to handle makefiles passed to make with "-f" (#56624)
  181. * Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-1
  182. - Update to 1.5 - much better to coexist with autoconf 2.52...
  183. - Fix specfile
  184. - No patches
  185. * Fri Aug 24 2001 Jens Petersen <petersen@redhat.com> - 1.4p5-2
  186. - dont raise error when there is source in a subdirectory (bug #35156).
  187. This was preventing automake from working in binutuls/gas
  188. [patch from HJ Lu <hjl@gnu.org>]
  189. - format long lines of output properly with backslash + newlines as in 1.4
  190. (bug #35259) [patch from HJ Lu <hjl@gnu.org>]
  191. * Sat Jul 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  192. - 1.4-p5, fixes #48788
  193. * Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  194. - add the patch from #20559
  195. - really update to 1.4-p4
  196. * Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  197. - update to 1.4-p4
  198. * Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
  199. - Version 1.4-p1 to work with libtool-1.4
  200. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  201. - automatic rebuild
  202. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  203. - FHS packaging.
  204. * Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
  205. - fix bug #8870
  206. * Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
  207. - revert to pristine automake-1.4.
  208. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  209. - arm netwinder patch
  210. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  211. - Injected new description and group.
  212. * Mon Feb 8 1999 Jeff Johnson <jbj@redhat.com>
  213. - add patches from CVS for 6.0beta1
  214. * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
  215. - update to 1.4.
  216. * Mon Nov 23 1998 Jeff Johnson <jbj@redhat.com>
  217. - update to 1.3b.
  218. - add URL.
  219. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  220. - translations modified for de, fr, tr
  221. * Tue Apr 07 1998 Erik Troan <ewt@redhat.com>
  222. - updated to 1.3
  223. * Tue Oct 28 1997 Cristian Gafton <gafton@redhat.com>
  224. - added BuildRoot; added aclocal files
  225. * Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
  226. - made it a noarch package
  227. * Thu Oct 16 1997 Michael Fulbright <msf@redhat.com>
  228. - Fixed some tag lines to conform to 5.0 guidelines.
  229. * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
  230. - updated to 1.2
  231. * Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
  232. - first version (1.0)