nginx-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.10.1
  26. Release: 2%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.3.5
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. ## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
  51. %define passenger_version 5.0.28
  52. Source1020: passenger-%{passenger_version}.tar.gz
  53. %define upstream_fair_version 2131c73
  54. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  55. %define mod_wsgi_version 6975f0ec7eeb
  56. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  57. # removes -Werror in upstream build scripts. -Werror conflicts with
  58. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  59. Patch0: nginx-auto-cc-gcc.patch
  60. # to fix https://svn.boost.org/trac/boost/ticket/8731
  61. Patch100: boost-changeset_84950.diff
  62. # to fix compile error with C++11.
  63. Patch1000: passenger-5.0.28-boost.patch
  64. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  65. BuildRequires: pcre-devel
  66. BuildRequires: zlib-devel
  67. BuildRequires: openssl-devel
  68. BuildRequires: gd-devel
  69. BuildRequires: perl
  70. BuildRequires: perl(ExtUtils::Embed)
  71. BuildRequires: libxml2-devel
  72. BuildRequires: libxslt-devel
  73. BuildRequires: curl-devel
  74. %if %{with geoip}
  75. BuildRequires: GeoIP-devel
  76. %endif
  77. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  78. # for /usr/sbin/useradd
  79. Requires(pre): shadow-utils
  80. Requires(post): chkconfig
  81. # for /sbin/service
  82. Requires(preun): chkconfig, initscripts
  83. Requires(postun): initscripts
  84. %if "%{_dist_release}" > "vl6"
  85. Requires(pre): www-common
  86. %endif
  87. Provides: webserver
  88. Vendor: Project Vine
  89. Distribution: Vine Linux
  90. Packager: daisuke
  91. %description
  92. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  93. proxy server written by Igor Sysoev.
  94. %description -l ja
  95. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  96. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  97. - HTTP(S) サーバ
  98. - HTTP(S) リバースプロキシサーバ
  99. - IMAP/POP3 プロキシサーバ
  100. %package passenger
  101. Summary: Nginx with mod_passenger support
  102. Summary(ja): Passenger サポート入りの Nginx
  103. Group: System Environment/Daemons
  104. BuildRequires: ruby, rubygem-rake
  105. Requires: ruby, rubygem-rake
  106. %if "%{_dist_release}" >= "vl7"
  107. BuildRequires: ruby-devel, ruby-rubygems
  108. Requires: ruby-rubygems
  109. %else
  110. BuildRequires: rubygems
  111. Requires: rubygems
  112. %endif
  113. Requires: nginx
  114. %description passenger
  115. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  116. This package contains nginx server with passenger support.
  117. %description -l ja passenger
  118. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  119. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  120. - HTTP(S) サーバ
  121. - HTTP(S) リバースプロキシサーバ
  122. - IMAP/POP3 プロキシサーバ
  123. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  124. %prep
  125. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  126. %patch0 -p0
  127. # pushd passenger-%{passenger_version}/ext/
  128. # %patch100 -p2
  129. # popd
  130. pushd passenger-%{passenger_version}
  131. %patch1000 -p1
  132. popd
  133. %build
  134. # nginx does not utilize a standard configure script. It has its own
  135. # and the standard configure options cause the nginx configure script
  136. # to error out. This is is also the reason for the DESTDIR environment
  137. # variable. The configure script(s) have been patched (Patch1 and
  138. # Patch2) in order to support installing into a build environment.
  139. export DESTDIR=%{buildroot}
  140. CONFIGOPTS="\
  141. --user=%{nginx_user} \
  142. --group=%{nginx_group} \
  143. --prefix=%{nginx_datadir} \
  144. --sbin-path=%{_sbindir}/%{name} \
  145. --conf-path=%{nginx_confdir}/%{name}.conf \
  146. --error-log-path=%{nginx_logdir}/error.log \
  147. --http-log-path=%{nginx_logdir}/access.log \
  148. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  149. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  150. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  151. --pid-path=%{_localstatedir}/run/%{name}.pid \
  152. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  153. --with-file-aio \
  154. --with-ipv6 \
  155. --with-http_ssl_module \
  156. --with-http_v2_module \
  157. --with-http_realip_module \
  158. --with-http_addition_module \
  159. --with-http_xslt_module \
  160. --with-http_image_filter_module \
  161. %if %{with geoip}
  162. --with-http_geoip_module \
  163. %endif
  164. --with-http_sub_module \
  165. --with-http_dav_module \
  166. --with-http_flv_module \
  167. --with-http_mp4_module \
  168. --with-http_gunzip_module \
  169. --with-http_gzip_static_module \
  170. --with-http_auth_request_module \
  171. --with-http_random_index_module \
  172. --with-http_secure_link_module \
  173. --with-http_degradation_module \
  174. --with-http_stub_status_module \
  175. --with-http_perl_module \
  176. --with-mail \
  177. --with-mail_ssl_module \
  178. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  179. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  180. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  181. %if %{with wsgi}
  182. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  183. %endif
  184. %ifarch i686
  185. --with-cpu-opt=pentiumpro \
  186. --with-zlib-asm=pentiumpro \
  187. --with-md5-asm \
  188. --with-sha1-asm \
  189. %endif
  190. "
  191. ## build with passenger
  192. ./configure \
  193. $CONFIGOPTS \
  194. --with-cc-opt="%{optflags}" \
  195. --add-module=passenger-%{passenger_version}/src/nginx_module
  196. make %{?_smp_mflags}
  197. mv objs/nginx objs/nginx.passenger
  198. ## build without passenger
  199. ./configure \
  200. $CONFIGOPTS \
  201. --with-cc-opt="%{optflags}"
  202. make %{?_smp_mflags}
  203. %install
  204. rm -rf %{buildroot}
  205. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  206. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  207. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  208. find %{buildroot} -type f -empty -exec rm -f {} \;
  209. find %{buildroot} -type f -exec chmod 0644 {} \;
  210. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  211. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  212. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  213. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  214. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  215. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  216. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  217. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  218. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  219. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  220. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  221. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  222. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  223. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  224. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  225. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  226. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  227. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  228. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  229. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  230. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  231. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  232. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  233. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  234. %if %{with wsgi}
  235. %{__install} -p -m 0644 \
  236. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  237. %{buildroot}%{nginx_confdir}
  238. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  239. %endif
  240. # upstream fair module document
  241. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  242. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  243. # convert to UTF-8 all files that give warnings.
  244. for textfile in CHANGES
  245. do
  246. mv $textfile $textfile.old
  247. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  248. rm -f $textfile.old
  249. done
  250. %clean
  251. rm -rf %{buildroot}
  252. %post
  253. if [ $1 == 1 ]; then
  254. /sbin/chkconfig --add %{name}
  255. fi
  256. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  257. %post passenger
  258. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  259. %preun
  260. if [ $1 = 0 ]; then
  261. /sbin/service %{name} stop >/dev/null 2>&1
  262. /sbin/chkconfig --del %{name}
  263. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  264. fi
  265. %preun passenger
  266. if [ $1 = 0 ]; then
  267. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  268. fi
  269. %postun
  270. if [ $1 == 2 ]; then
  271. /sbin/service %{name} upgrade || :
  272. fi
  273. %files
  274. %defattr(-,root,root,-)
  275. %doc LICENSE CHANGES README
  276. %doc README.upstream_fair
  277. %doc %{?with_wsgi:README.mod_wsgi}
  278. %{nginx_datadir}/
  279. %{_sbindir}/%{name}.normal
  280. %{_mandir}/man3/%{name}.3pm.gz
  281. %{_initrddir}/%{name}
  282. %dir %{nginx_confdir}
  283. %dir %{nginx_confdir}/conf.d
  284. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  285. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  286. %config(noreplace) %{nginx_confdir}/sites.d/*
  287. %config(noreplace) %{nginx_confdir}/win-utf
  288. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  289. %config(noreplace) %{nginx_confdir}/mime.types.default
  290. %config(noreplace) %{nginx_confdir}/fastcgi_params
  291. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  292. %config(noreplace) %{nginx_confdir}/koi-win
  293. %config(noreplace) %{nginx_confdir}/koi-utf
  294. %config(noreplace) %{nginx_confdir}/%{name}.conf
  295. %config(noreplace) %{nginx_confdir}/mime.types
  296. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  297. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  298. %config(noreplace) %{nginx_confdir}/scgi_params
  299. %config(noreplace) %{nginx_confdir}/scgi_params.default
  300. %config(noreplace) %{nginx_confdir}/uwsgi_params
  301. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  302. %if %{with wsgi}
  303. %config(noreplace) %{nginx_confdir}/wsgi_vars
  304. %endif
  305. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  306. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  307. %dir %{perl_vendorarch}/auto/%{name}
  308. %{perl_vendorarch}/%{name}.pm
  309. %{perl_vendorarch}/auto/%{name}/%{name}.so
  310. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  311. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  312. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  313. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  314. %files passenger
  315. %defattr(-,root,root,-)
  316. %doc passenger-%{passenger_version}/doc/*.md
  317. %doc passenger-%{passenger_version}/doc/*.txt
  318. %doc passenger-%{passenger_version}/doc/*.html
  319. %doc passenger-%{passenger_version}/doc/templates
  320. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  321. %doc passenger-%{passenger_version}/doc/images
  322. %{_sbindir}/%{name}.passenger
  323. %changelog
  324. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
  325. - rebuild with gcc-5.4.0
  326. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
  327. - updated to 1.10.1.
  328. - updated passenger to 5.0.28.
  329. * Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
  330. - updated to 1.9.15
  331. * Thu Apr 7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
  332. - updated to 1.9.14
  333. - updated passenger to 5.0.27
  334. * Wed Apr 6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
  335. - new upstream release
  336. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
  337. - updated to 1.9.12.
  338. - updated passenger to 5.0.26.
  339. * Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
  340. - new upstream release
  341. * Wed Feb 3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
  342. - update to 1.9.10
  343. - update passenger to 5.0.24
  344. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
  345. - update passenger to 5.0.23
  346. * Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
  347. - new upstream release
  348. * Sat Dec 5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
  349. - new upstream release
  350. * Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
  351. - new upstream release
  352. * Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
  353. - new upstream release
  354. * Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
  355. - update to 1.9.3
  356. - update passenger to 5.0.11
  357. * Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
  358. - updated Source4 (ssl.conf).
  359. * Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
  360. - update to 1.9.2
  361. - update passenger to 5.0.10
  362. - update ngx-fancyindex to 0.3.5
  363. * Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
  364. - update to 1.6.2
  365. - update passenger to 4.0.52
  366. * Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
  367. - new upstream release
  368. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
  369. - rebuild with new environment
  370. * Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
  371. - update passenger to 4.0.45
  372. * Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  373. - update to 1.6.0 (stable)
  374. * Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
  375. - update fancyindex to 0.3.3
  376. * Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
  377. - update to 1.5.10
  378. - update passenger to 4.0.37
  379. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
  380. - rebuilt with GeoIP-1.6.0.
  381. - added Patch100.
  382. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  383. - update to 1.5.6
  384. - update passenger to 4.0.21
  385. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  386. - rebuilt with gd-2.1.0.
  387. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  388. - update to 1.4.1
  389. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  390. - update to 1.4.0
  391. - enable SPDY module
  392. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  393. - new upstream release
  394. - update passenger to 3.0.19
  395. - update ngx-fancyindex to upstream git master
  396. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  397. - new upstream release
  398. - update passenger to 3.0.17
  399. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  400. - rebuild with pcre-8.31
  401. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  402. - added http_geoip_module.
  403. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  404. - update to 1.2.4
  405. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  406. - update to 1.2.2
  407. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  408. - update to 1.2.1
  409. - change nginx user from nginx to www-data
  410. - R(pre): www-common
  411. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  412. - update to 1.2.0
  413. - update passenger to 3.0.12
  414. - drop http_upstream_keepalive
  415. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  416. - new upstream release
  417. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  418. - update to 1.0.12
  419. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  420. - update to 1.0.11
  421. - update passenger to 3.0.11
  422. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  423. - update to 1.0.10
  424. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  425. - update passenger to 3.0.9
  426. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  427. - update to 1.0.6
  428. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  429. - update to 1.0.4
  430. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  431. - add gnosek-nginx-upstream-fair module
  432. - add ngx_http_upstream_keepalive module
  433. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  434. - add nginx-passenger sub pakckage
  435. - use alternatives to choose nginx with or without passenger
  436. - add BR: ruby, rubygems, rubygem-rake
  437. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  438. - update to 1.0.2
  439. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  440. - update to 1.0.1
  441. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  442. - add bcond_with wsgi for mod_wsgi
  443. - add bcond_with passenger
  444. - you need to install rake.gem to build with this option.
  445. - add Provides: webserver
  446. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  447. - new upstream release 1.0.0!
  448. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  449. - rebuild with perl-5.12.3
  450. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  451. - update to 0.8.54
  452. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  453. - update to 0.8.53
  454. - add nginx_accept_language_module
  455. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  456. - update to 0.8.50
  457. - update ngx-fancyindex to 0.3
  458. - add BR: libxml2-devel, libxslt-devel
  459. - add scgi_params* and uwsgi_params* to %%files
  460. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  461. - update to 0.8.35 (development version)
  462. - add sites.d/ to store vitualhost settings
  463. - split out default server settings to sites.d/default
  464. - add fancyindex module
  465. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  466. - new upstream release
  467. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  468. - update to 0.7.62 (included security fix: VU#180065)
  469. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  470. - fix typo
  471. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  472. - add translated descriptions
  473. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  474. - update 404.html/50x.html to use powered by vine logo.
  475. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  476. - initial build for Vine Linux
  477. - update to 0.7.61
  478. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  479. - init script updates from Gena Makhomed
  480. - remove nginx-upstream-fair
  481. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  482. - update to 0.6.36
  483. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  484. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  485. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  486. - rebuild
  487. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  488. - update to 0.6.35
  489. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  490. - rebuild with new openssl
  491. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  492. - update to 0.6.34
  493. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  494. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  495. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  496. - update to 0.6.33
  497. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  498. - update to 0.6.32
  499. - nginx now supports DESTDIR so removed the patches that enabled it
  500. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  501. - init script fixes
  502. - resolve 'listen 80 default' [#447873]
  503. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  504. - update to 0.6.31
  505. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  506. - upate to new upstream stable branch 0.6
  507. - added 3rd party module nginx-upstream-fair
  508. - added default webpages
  509. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  510. - update init script to match recommended guidelines
  511. - add /etc/nginx/conf.d support [#443280]
  512. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  513. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  514. - add Requires for versioned perl (libperl.so)
  515. - drop silly file Requires
  516. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  517. - Autorebuild for GCC 4.3
  518. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  519. - update to 0.5.35
  520. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  521. - update to 0.5.34
  522. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  523. - Rebuild for deps
  524. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  525. - update to 0.5.33
  526. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  527. - updated to 0.5.32
  528. - fixed rpmlint UTF-8 complaints.
  529. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  530. - added --with-http_stub_status_module build option.
  531. - added --with-http_sub_module build option.
  532. - added use of pcre-config --cflags
  533. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  534. - Update to 0.5.31
  535. - specify license is BSD
  536. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  537. - Add BuildRequires: perl-devel - fixing rawhide build
  538. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  539. - Update to 0.5.30
  540. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  541. - Update to 0.5.29
  542. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  543. - Update to 0.5.28
  544. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  545. - Update to 0.5.27
  546. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  547. - Update to 0.5.26
  548. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  549. - Update to 0.5.19
  550. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  551. - Update to 0.5.17
  552. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  553. - Update to 0.5.16
  554. - add ownership of /usr/share/nginx/html (#233950)
  555. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  556. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  557. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  558. - fixed package review bugs (#233522) given by kevin@tummy.com
  559. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  560. - create patches to assist with building for Fedora
  561. - initial packaging for Fedora