sox-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241
  1. ##
  2. ## disable gsm for Vine Linux
  3. %define nogsm 1
  4. ## disable libmad
  5. %define nomad 1
  6. Summary: A general purpose sound file conversion tool.
  7. Summary(ja): 汎用サウンドファイル変換ツール
  8. Name: sox
  9. Version: 14.4.1
  10. Release: 2%{?_dist_release}
  11. License: LGPL
  12. Group: Applications/Multimedia
  13. Source: http://prdownloads.sourceforge.net/sox/sox-%{version}.tar.bz2
  14. Patch100: sox-14.4.1_CVE-2014-8145.patch
  15. URL: http://sox.sourceforge.net/
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: alsa-lib-devel
  18. BuildRequires: pulseaudio-lib-devel
  19. BuildRequires: flac-devel
  20. BuildRequires: libvorbis-devel
  21. Build%{?nomad:Conflicts}%{!?nomad:Requires}: libmad-devel
  22. Build%{?nogsm:Conflicts}%{!?nogsm:Requires}: gsm-devel
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. %description
  26. SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
  27. and DOS PCs. The 'Swiss Army knife of sound tools,' SoX can convert
  28. between many different digitized sound formats and perform simple
  29. sound manipulation functions, including sound effects.
  30. %description -l ja
  31. SoX (Sound eXchange) は Linux, UNIX, DOS PC 用サウンドファイルフォーマット
  32. 変換ツールです.SoX は「サウンドツール界のスイスアーミーナイフ」で,
  33. 様々なデジタルサウンドフォーマットを相互に変換したり,
  34. 簡単なサウンドエフェクト等の処理も行うことが出来ます.
  35. %package -n sox-devel
  36. Summary: The SoX sound file format converter libraries.
  37. Summary(ja): SoX サウンドファイル変換ライブラリ
  38. Group: Development/Libraries
  39. %description -n sox-devel
  40. This package contains the library needed for compiling applications
  41. which will use the SoX sound file format converter.
  42. Install sox-devel if you want to develop applications which will use
  43. SoX.
  44. %description -n sox-devel -l ja
  45. このパッケージには SoX サウンドファイルフォーマット変換ツールを
  46. 利用するアプリケーションをコンパイルするのに必要なライブラリが
  47. 収められています.
  48. SoX を利用するプログラムを開発する場合は sox-devel パッケージを
  49. インストールして下さい.
  50. %prep
  51. %setup -q
  52. %patch100 -p1 -b .CVE-2014-8145
  53. %build
  54. %configure \
  55. --disable-static \
  56. --includedir=%{_includedir}/sox \
  57. %{!?nogsm: --with-gsm}
  58. make
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  62. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  63. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
  64. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
  65. make install DESTDIR=$RPM_BUILD_ROOT
  66. echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
  67. echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
  68. echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
  69. chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
  70. strip $RPM_BUILD_ROOT%{_bindir}/sox
  71. ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
  72. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
  73. ln -snf play.1 $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
  74. ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1
  75. mkdir -p $RPM_BUILD_ROOT%{_includedir}/sox
  76. install -m 644 src/*.h $RPM_BUILD_ROOT%{_includedir}/sox
  77. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  78. %clean
  79. rm -rf $RPM_BUILD_ROOT
  80. %post -p /sbin/ldconfig
  81. %postun -p /sbin/ldconfig
  82. %files
  83. %defattr(-,root,root)
  84. %doc Changelog README TODO INSTALL
  85. %{_bindir}/*
  86. %{_libdir}/libsox.so.*
  87. %{_mandir}/man1/*
  88. %files -n sox-devel
  89. %defattr(-,root,root)
  90. %{_includedir}/*
  91. %{_libdir}/libsox.so
  92. %{_libdir}/pkgconfig/sox.pc
  93. %{_mandir}/man3/*
  94. %{_mandir}/man7/*
  95. %changelog
  96. * Thu Jan 8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 14.4.1-2
  97. - add patch100 for fix CVE-2014-8145
  98. - add BR: flac-devel, libvorbis-devel
  99. - add Vendor/Distri tags
  100. * Sun Aug 03 2014 Yoji TOYODA <owa@bg.wakwak.com> 14.4.1-1
  101. - update to 14.4.1
  102. * Sat Nov 05 2011 Yoji TOYODA <owa@bg.wakwak.com> 14.3.2-1
  103. - new upstream release
  104. - add BuildRequires: pulseaudio-lib-devel
  105. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 12.18.1-2
  106. - rebuilt with rpm-4.8.1-3
  107. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 12.18.1-1vl5
  108. - applied new versioning policy, spec in utf-8
  109. * Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 12.18.1-0vl3
  110. - fix installing play.1 man page (<BTS:510>)
  111. - add BuildRequires: alsa-lib-devel (alsa stuffs are now in main repo)
  112. * Mon Sep 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 12.18.1-0vl2
  113. - add "%%define nomad 1" to disable libmad dependency
  114. * Fri Aug 25 2006 NAKAMURA Kenta <kenta@vinelinux.org> 12.18.1-0vl1
  115. - new upstream release
  116. - dropped sox-vorberr.patch and sox-CAN-2004-0557.patch
  117. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl2
  118. - add patch for buffer overflow in wav code (CAN-2004-0557, #128158)
  119. - fixed %files section
  120. * Thu Jul 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl1
  121. - based on 12.17.3-12 from Rawhide
  122. - rebuild with new toolchains
  123. - to use License tag instead of Copyright
  124. - fix License (from distributable to LGPL)
  125. * Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  126. - 12.17.1-1vl1
  127. - based on 12.17.1-1 from Rawhide
  128. - use better macros (%%{_bindir}, %%{_libdir}, %%{_includedir})
  129. - added Japanese summary and description
  130. - disable gsm stuff for Vine Linux
  131. * Tue Jan 2 2001 Bill Nottingham <notting@redhat.com>
  132. - re-enable gsm stuff
  133. - update to 12.17.1
  134. * Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
  135. - rebuild because of broken fileutils
  136. * Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
  137. - update to 12.17
  138. - yank out gsm stuff
  139. * Mon Aug 7 2000 Bill Nottingham <notting@redhat.com>
  140. - fix playing of sounds on cards that don't support mono
  141. * Sat Aug 5 2000 Bill Nottingham <notting@redhat.com>
  142. - fix playing of sounds on cards that don't support 8-bit
  143. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  144. - automatic rebuild
  145. * Thu Feb 03 2000 Bill Nottingham <notting@redhat.com>
  146. - fix manpage link the Right Way(tm)
  147. * Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  148. - Fix rec manpage link - now that man pages are compressed, it should point to
  149. play.1.gz, not play.1
  150. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  151. - fix description
  152. * Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
  153. - Grrr. Arrrrgh. Fix link.
  154. * Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
  155. - add some more files to devel
  156. * Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
  157. - fix link
  158. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  159. - update to 12.16
  160. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  161. - auto rebuild in the new build environment (release 4)
  162. * Wed Jan 20 1999 Bill Nottingham <notting@redhat.com>
  163. - allow spaces in filenames for play/rec
  164. * Wed Dec 9 1998 Bill Nottingham <notting@redhat.com>
  165. - fix docs
  166. * Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
  167. - update to 12.15
  168. * Sat Oct 10 1998 Michael Maher <mike@redhat.com>
  169. - fixed broken spec file
  170. * Mon Jul 13 1998 Michael Maher <mike@redhat.com>
  171. - updated source from Chris Bagwell.
  172. * Tue Jun 23 1998 Michael Maher <mike@redhat.com>
  173. - made patch to fix the '-e' option. BUG 580
  174. - added buildroot
  175. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  176. - translations modified for de, fr, tr
  177. * Thu Nov 06 1997 Erik Troan <ewt@redhat.com>
  178. - built against glibc