elfutils-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define eu_version 0.161
  3. %define eu_release 3
  4. %global nocheck true
  5. Summary: A collection of utilities and DSOs to handle compiled objects
  6. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  7. Name: elfutils
  8. Version: %{eu_version}
  9. Release: %{eu_release}%{?_dist_release}
  10. License: GPLv3+ and (GPLv2+ or LGPLv3+)
  11. Group: Development/Tools
  12. URL: https://fedorahosted.org/elfutils/
  13. Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
  14. #Patch1: elfutils-robustify.patch
  15. #Patch2: elfutils-portability.patch
  16. Patch1: elfutils-portability-%{version}.patch
  17. Patch2: elfutils-0.161-ar-long-name.patch
  18. # libdw: fix offset for sig8 lookup in dwarf_formref_die
  19. Patch3: elfutils-0.161-formref-type.patch
  20. # rhbz#1189928 - Consider sh_addralign 0 as 1
  21. Patch4: elfutils-0.161-addralign.patch
  22. ##VINE##
  23. Patch10: elfutils-0.131-readelf_c.patch
  24. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  25. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison >= 1.875
  28. BuildRequires: flex >= 2.5.4a
  29. BuildRequires: bzip2
  30. BuildRequires: bzip2-devel
  31. BuildRequires: zlib-devel
  32. BuildRequires: xz-devel
  33. BuildRequires: gettext
  34. BuildRequires: m4
  35. BuildRequires: gcc >= 3.4
  36. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  37. BuildRequires: glibc-headers >= 2.3.4-11
  38. %define _gnu %{nil}
  39. %define _program_prefix eu-
  40. %description
  41. Elfutils is a collection of utilities, including ld (a linker),
  42. nm (for listing symbols from object files), size (for listing the
  43. section sizes of an object or archive file), strip (for discarding
  44. symbols), readelf (to see the raw ELF file structures), and elflint
  45. (to check for well-formed ELF files).
  46. %package libs
  47. Summary: Libraries to handle compiled objects
  48. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  49. License: GPLv2+ or LGPLv3+
  50. Group: System Environment/Libraries
  51. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  52. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  53. Conflicts: elfutils < %{version}-%{release}
  54. Conflicts: elfutils > %{version}-%{release}
  55. Conflicts: elfutils-devel < %{version}-%{release}
  56. Conflicts: elfutils-devel > %{version}-%{release}
  57. %description libs
  58. The elfutils-libs package contains libraries which implement DWARF, ELF,
  59. and machine-specific ELF handling. These libraries are used by the programs
  60. in the elfutils package. The elfutils-devel package enables building
  61. other programs using these libraries.
  62. %package devel
  63. Summary: Development libraries to handle compiled objects
  64. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  65. License: GPLv2+ or LGPLv3+
  66. Group: Development/Libraries
  67. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  68. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  69. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  70. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  71. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  72. %description devel
  73. The elfutils-devel package contains the libraries to create
  74. applications for handling compiled objects. libebl provides some
  75. higher-level ELF access functionality. libdw provides access to
  76. the DWARF debugging information. libasm provides a programmable
  77. assembler interface.
  78. %package devel-static
  79. Summary: Static archives to handle compiled objects
  80. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  81. License: GPLv2+ or LGPLv3+
  82. Group: Development/Libraries
  83. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  84. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  85. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  86. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  87. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  88. %description devel-static
  89. The elfutils-devel-static package contains the static archives
  90. with the code to handle compiled objects.
  91. %package libelf
  92. Summary: Library to read and write ELF files
  93. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  94. License: GPLv2+ or LGPLv3+
  95. Group: System Environment/Libraries
  96. Provides: libelf = %{version}-%{release}
  97. Obsoletes: libelf <= 0.8.2-2
  98. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  99. Conflicts: elfutils < %{version}-%{release}
  100. Conflicts: elfutils > %{version}-%{release}
  101. Conflicts: elfutils-libs < %{version}-%{release}
  102. Conflicts: elfutils-libs > %{version}-%{release}
  103. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  104. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  105. %description libelf
  106. The elfutils-libelf package provides a DSO which allows reading and
  107. writing ELF files on a high level. Third party programs depend on
  108. this package to read internals of ELF files. The programs of the
  109. elfutils package use it also to generate new ELF files.
  110. %package libelf-devel
  111. Summary: Development support for libelf
  112. Summary(ja): libelf の開発用ライブラリ
  113. License: GPLv2+ or LGPLv3+
  114. Group: Development/Libraries
  115. Provides: libelf-devel = %{version}-%{release}
  116. Obsoletes: libelf-devel <= 0.8.2-2
  117. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  118. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  119. Conflicts: libelf-devel < %{version}-%{release}
  120. %description libelf-devel
  121. The elfutils-libelf-devel package contains the libraries to create
  122. applications for handling compiled objects. libelf allows you to
  123. access the internals of the ELF object file format, so you can see the
  124. different sections of an ELF file.
  125. %package libelf-devel-static
  126. Summary: Static archive of libelf
  127. Summary(ja): libelf の静的ライブラリ
  128. License: GPLv2+ or LGPLv3+
  129. Group: Development/Libraries
  130. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  131. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  132. %description libelf-devel-static
  133. The elfutils-libelf-static package contains the static archive
  134. for libelf.
  135. # compat32
  136. %package -n compat32-%{name}-libelf
  137. Summary: Library to read and write ELF files
  138. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  139. License: GPLv2+ or LGPLv3+
  140. Group: System Environment/Libraries
  141. Provides: compat32-libelf = %{version}-%{release}
  142. %description -n compat32-%{name}-libelf
  143. The elfutils-libelf package provides a DSO which allows reading and
  144. writing ELF files on a high level. Third party programs depend on
  145. this package to read internals of ELF files. The programs of the
  146. elfutils package use it also to generate new ELF files.
  147. %prep
  148. %setup -q
  149. #patch1 -p1 -b .robustify
  150. %patch1 -p1 -b .portability
  151. %patch2 -p1 -b .ar_long_name
  152. %patch3 -p1 -b .formref_type
  153. %patch4 -p1 -b .addralign
  154. %patch10 -p0 -b .readelf_c
  155. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  156. %build
  157. # Remove -Wall from default flags. The makefiles enable enough warnings
  158. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  159. # the makefiles disable some specific warnings for specific code.
  160. RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
  161. %configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
  162. make -s %{?_smp_mflags}
  163. %install
  164. rm -rf ${RPM_BUILD_ROOT}
  165. make -s install DESTDIR=${RPM_BUILD_ROOT}
  166. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  167. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
  168. %find_lang %{name}
  169. # XXX Nuke unpackaged files
  170. { cd ${RPM_BUILD_ROOT}
  171. rm -f .%{_bindir}/eu-ld
  172. }
  173. %check
  174. make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
  175. %clean
  176. rm -rf ${RPM_BUILD_ROOT}
  177. %post libs -p /sbin/ldconfig
  178. %postun libs -p /sbin/ldconfig
  179. %post libelf -p /sbin/ldconfig
  180. %postun libelf -p /sbin/ldconfig
  181. %post -n compat32-%{name}-libelf -p /sbin/ldconfig
  182. %postun -n compat32-%{name}-libelf -p /sbin/ldconfig
  183. %files -f %{name}.lang
  184. %defattr(-,root,root)
  185. %doc README TODO
  186. %{_bindir}/eu-addr2line
  187. %{_bindir}/eu-ar
  188. %{_bindir}/eu-elfcmp
  189. %{_bindir}/eu-elflint
  190. %{_bindir}/eu-findtextrel
  191. %{_bindir}/eu-nm
  192. %{_bindir}/eu-objdump
  193. %{_bindir}/eu-ranlib
  194. %{_bindir}/eu-readelf
  195. %{_bindir}/eu-size
  196. %{_bindir}/eu-stack
  197. %{_bindir}/eu-strings
  198. %{_bindir}/eu-strip
  199. #%{_bindir}/eu-ld
  200. %{_bindir}/eu-unstrip
  201. %{_bindir}/eu-make-debug-archive
  202. %files libs
  203. %defattr(-,root,root)
  204. %{_libdir}/libasm-%{version}.so
  205. %{_libdir}/libasm.so.*
  206. %{_libdir}/libdw-%{version}.so
  207. %{_libdir}/libdw.so.*
  208. %dir %{_libdir}/elfutils
  209. %{_libdir}/elfutils/lib*.so
  210. %files devel
  211. %defattr(-,root,root)
  212. %{_includedir}/dwarf.h
  213. %dir %{_includedir}/elfutils
  214. %{_includedir}/elfutils/elf-knowledge.h
  215. %{_includedir}/elfutils/libasm.h
  216. %{_includedir}/elfutils/libebl.h
  217. %{_includedir}/elfutils/libdw.h
  218. %{_includedir}/elfutils/libdwelf.h
  219. %{_includedir}/elfutils/libdwfl.h
  220. %{_includedir}/elfutils/version.h
  221. %{_libdir}/libebl.a
  222. %{_libdir}/libasm.so
  223. %{_libdir}/libdw.so
  224. %files devel-static
  225. %defattr(-,root,root)
  226. %{_libdir}/libasm.a
  227. %{_libdir}/libdw.a
  228. %files libelf
  229. %defattr(-,root,root)
  230. %{_libdir}/libelf-%{version}.so
  231. %{_libdir}/libelf.so.*
  232. %files libelf-devel
  233. %defattr(-,root,root)
  234. %{_includedir}/libelf.h
  235. %{_includedir}/gelf.h
  236. %{_includedir}/nlist.h
  237. %{_libdir}/libelf.so
  238. %files libelf-devel-static
  239. %defattr(-,root,root)
  240. %{_libdir}/libelf.a
  241. %if %{build_compat32}
  242. %files -n compat32-%{name}-libelf
  243. %defattr(-,root,root)
  244. %{_libdir}/libelf-%{version}.so
  245. %{_libdir}/libelf.so.*
  246. %endif
  247. %changelog
  248. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
  249. - rebuild with gcc-5.4.0
  250. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
  251. - create compat32-elfutils-libelf subpackage
  252. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  253. - update to 0.161
  254. - added Japanese summary
  255. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  256. - update to 0.157
  257. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  258. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  259. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  260. - update to 0.152
  261. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  262. - elfutils-libs: changed Group to System Environment/Libraries
  263. - elfutils-libelf: changed Group to System Environment/Libraries
  264. - elfutils-devel: changed Group to Development/Libraries
  265. - elfutils-devel-static: changed Group to Development/Libraries
  266. - elfutils-libelf-devel: changed Group to Development/Libraries
  267. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  268. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  269. - merged with Fedora 9 0.135-1
  270. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  271. - applied new versioning policy
  272. - added elfutils-0.131-readelf_c.patch
  273. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  274. - new upstream release
  275. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  276. - remove Obsoletes: libelf, libelf-devel from elfutils
  277. - add Obsoletes: libelf to elfutils-libelf
  278. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  279. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  280. - Update to 0.135
  281. - libdwfl: bug fixes
  282. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  283. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  284. - Update to 0.134
  285. - elflint: backend improvements for sparc, alpha (#204170)
  286. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  287. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  288. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  289. - Update to 0.133
  290. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  291. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  292. - libdwfl: bug fixes and optimization in relocation handling
  293. - elfcmp: bug fix for non-allocated section handling
  294. - ld: implement newer features of binutils linker.
  295. - Install eu-objdump and libasm, now has limited disassembler support.
  296. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  297. - Update to 0.132
  298. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  299. - eu-readelf: Fix handling of ET_REL files in archives.
  300. - libcpu: Implement x86 and x86-64 disassembler.
  301. - libasm: Add interface for disassembler.
  302. - all programs: add debugging of branch prediction.
  303. - libelf: new function elf_scnshndx.
  304. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  305. - Update to 0.131
  306. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  307. bug fixes for oddly-formatted DWARF
  308. - libdwfl: bug fixes in offline archive support, symbol table handling;
  309. apply partial relocations for dwfl_module_address_section on ET_REL
  310. - libebl: powerpc backend support for Altivec registers
  311. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  312. - Fix ET_REL support.
  313. - Fix odd indentation in eu-readelf -x output.
  314. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  315. - Update to 0.130
  316. - eu-readelf -p option can take an argument like -x for one section
  317. - eu-readelf --archive-index (or -c)
  318. - eu-readelf -n improved output for core dumps
  319. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  320. - eu-elflint: ditto
  321. - eu-elflint: stricter checks on debug sections
  322. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  323. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  324. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  325. - libebl: backend improvements (#324031)
  326. - libdwfl: build_id support, new functions for it
  327. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  328. - libdwfl offline archive support, new script eu-make-debug-archive
  329. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  330. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  331. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  332. - Update to 0.129
  333. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  334. - addr2line: new option --symbols (or -S)
  335. - libdw: dwarf_getscopes fixes (#230235)
  336. - libdwfl: dwfl_module_addrsym fixes (#249490)
  337. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  338. - Update to 0.128
  339. - new program: unstrip
  340. - elfcmp: new option --hash-inexact
  341. - Replace Conflicts: with Provides/Requires using -arch
  342. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  343. - Update to 0.127
  344. - libdw: new function dwarf_getsrcdirs
  345. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  346. dwfl_module_address_section
  347. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  348. - Update to 0.126
  349. - New program eu-ar.
  350. - libdw: fix missing dwarf_getelf (#227206)
  351. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  352. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  353. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  354. - Fix overeager warn_unused_result build failures.
  355. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  356. - Update to 0.125
  357. - elflint: Compare DT_GNU_HASH tests.
  358. - move archives into -static RPMs
  359. - libelf, elflint: better support for core file handling
  360. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  361. - Resolves: RHBZ #220817, RHBZ #213792
  362. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  363. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  364. - Update to 0.124
  365. - libebl: fix ia64 reloc support (#206981)
  366. - libebl: sparc backend support for return value location
  367. - libebl, libdwfl: backend register name support extended with more info
  368. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  369. - readelf, elflint: trivial bugs fixed
  370. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  371. - Update to 0.123
  372. - libebl: Backend build fixes, thanks to Stepan Kasal.
  373. - libebl: ia64 backend support for register names, return value location
  374. - libdwfl: Handle truncated linux kernel module section names.
  375. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  376. - elflint: Fix checks to permit --hash-style=gnu format.
  377. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  378. - Fix warnings in elflint compilation.
  379. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  380. - Update to 0.122
  381. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  382. - libebl: add function to test for relative relocation
  383. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  384. - elflint, readelf: add support for DT_GNU_HASH
  385. - libelf: add elf_gnu_hash
  386. - elflint, readelf: add support for 64-bit SysV-style hash tables
  387. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  388. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  389. - Update to 0.121
  390. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  391. - make all installed headers usable in C++ code (#193153).
  392. - eu-readelf: better output format.
  393. - eu-elflint: fix tests of dynamic section content.
  394. - libdw, libdwfl: handle files without aranges info.
  395. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  396. - rebuild to pick up -devel deps
  397. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  398. - Update to 0.120
  399. - License changed to GPL, with some exceptions for using
  400. the libelf, libebl, libdw, and libdwfl library interfaces.
  401. Red Hat elfutils is an included package of the Open Invention Network.
  402. - dwarf.h updated for DWARF 3.0 final specification.
  403. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  404. - libdwfl: New function dwfl_version; fixes for offline.
  405. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  406. - bump again for double-long bug on ppc(64)
  407. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  408. - rebuilt for new gcc4.1 snapshot and glibc changes
  409. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  410. - update to 0.119
  411. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  412. - rebuilt
  413. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  414. - update to 0.118
  415. - elflint: more tests.
  416. - libdwfl: New function dwfl_module_register_names.
  417. - libebl: New backend hook for register names.
  418. - Make sure -fexceptions is always in CFLAGS.
  419. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  420. - update to 0.117
  421. - libdwfl: New function dwfl_module_return_value_location (#166118)
  422. - libebl: Backend improvements for several CPUs
  423. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  424. - update to 0.116
  425. - libdw fixes, API changes and additions
  426. - libdwfl fixes (#169672)
  427. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  428. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  429. - Update requires/conflicts for better biarch update behavior.
  430. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  431. - update to 0.115
  432. - New program eu-strings.
  433. - libdw: New function dwarf_getscopes_die.
  434. - libelf: speed-ups of non-mmap reading.
  435. - Implement --enable-gcov option for configure.
  436. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  437. - update to 0.114
  438. - new program eu-ranlib
  439. - libdw: new calls for inlines
  440. - libdwfl: new calls for offline modules
  441. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  442. - update to 0.113
  443. - elflint: relax a bit. Allow version definitions for defined symbols
  444. against DSO versions also for symbols in nobits sections.
  445. Allow .rodata section to have STRINGS and MERGE flag set.
  446. - strip: add some more compatibility with binutils.
  447. - libdwfl: bug fixes.
  448. - Separate libdw et al into elfutils-libs subpackage.
  449. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  450. - update to 0.112
  451. - elfcmp: some more relaxation.
  452. - elflint: many more tests, especially regarding to symbol versioning.
  453. - libelf: Add elfXX_offscn and gelf_offscn.
  454. - libasm: asm_begin interface changes.
  455. - libebl: Add three new interfaces to directly access machine, class,
  456. and data encoding information.
  457. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  458. - update portability patch
  459. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  460. - update to 0.111
  461. - libdwfl library now merged into libdw
  462. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  463. - update to 0.110
  464. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  465. - update to 0.109
  466. - verify that libebl modules are from the same build
  467. - new eu-elflint checks on copy relocations
  468. - new program eu-elfcmp
  469. - new experimental libdwfl library
  470. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  471. - robustification of eu-strip and eu-readelf
  472. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  473. - more robustification
  474. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  475. - robustification
  476. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  477. - update to 0.108
  478. - merge strip fixes
  479. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  480. - update elf.h from glibc
  481. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  482. - fix strip -f byte-swapping bug
  483. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  484. - update to 0.107
  485. - readelf: improve DWARF output format
  486. - elflint: -d option to support checking separate debuginfo files
  487. - strip: fix ET_REL debuginfo files (#156341)
  488. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  489. - fix some bugs in new code, reenable make check
  490. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  491. - disable make check for most arches, for now
  492. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  493. - update to 0.106
  494. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  495. - update to 0.104
  496. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  497. - update to 0.103
  498. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  499. - update to 0.101.
  500. - use %%configure macro to get CFLAGS etc. right
  501. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  502. - upgrade to 0.99.
  503. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  504. - upgrade to 0.97.
  505. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  506. - upgrade to 0.96.
  507. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  508. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  509. warning
  510. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  511. - rebuilt
  512. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  513. - upgrade to 0.95.
  514. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  515. - rebuilt
  516. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  517. - rebuilt
  518. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  519. - upgrade to 0.94
  520. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  521. - upgrade to 0.93
  522. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  523. - full version
  524. - macroized spec file for GPL or OSL builds
  525. - include only libelf under GPL plus wrapper scripts
  526. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  527. - macroized spec file for GPL or OSL builds
  528. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  529. - split elfutils-devel into two packages.
  530. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  531. - include only libelf under GPL plus wrapper scripts
  532. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  533. - readelf, not readline, in %%description (#111214).
  534. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  535. - update to 0.89 (fix eu-strip)
  536. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  537. - update to 0.86 (fix eu-strip on s390x/alpha)
  538. - libebl is an archive now; remove references to DSO
  539. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  540. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  541. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  542. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  543. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  544. - upgrade to 0.82 (strip tests fixed on big-endian).
  545. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  546. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  547. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  548. - upgrade to 0.80 (debugedit changes for kernel in progress).
  549. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  550. - rebuilt
  551. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  552. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  553. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  554. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  555. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  556. - debuginfo rebuild
  557. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  558. - use the correct way of identifying the section via the sh_info link.
  559. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  560. - update to 0.75 (eu-strip -g fix)
  561. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  562. - update to 0.74 (fix for writing with some non-dirty sections)
  563. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  564. - another -0.73 update (with sparc fixes).
  565. - do "make check" in %%check, not %%install, section.
  566. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  567. - update to 0.73 (with s390 fixes).
  568. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  569. - rebuilt
  570. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  571. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  572. - fix other warnings
  573. - reenable checks on s390x
  574. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  575. - temporarily disable checks on s390x, until someone has
  576. time to look at it
  577. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  578. - update to 0.72
  579. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  580. - update to 0.71
  581. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  582. - update to 0.69.
  583. - add "make check" and segfault avoidance patch.
  584. - elfutils-libelf needs to run ldconfig.
  585. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  586. - update to 0.68.
  587. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  588. - update to 0.67.
  589. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  590. - update to 0.65.
  591. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  592. - update to 0.64.
  593. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  594. - split packages further into elfutils-libelf
  595. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  596. - update to 0.63.
  597. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  598. - Adjust for dropping libtool
  599. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  600. - update to 0.59
  601. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  602. - update to 0.56
  603. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  604. - update to 0.54
  605. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  606. - update to 0.53
  607. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  608. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  609. - get beehive to punch a rhpkg generated package.
  610. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  611. - build in 8.0.1.
  612. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  613. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  614. - Add libelf-devel to conflicts for elfutils-devel
  615. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  616. - Split into runtime and devel package
  617. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  618. - integrate into official sources
  619. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  620. - Swaddle.