self-build-x264-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. %define pkgname x264
  2. %define name self-build-%{pkgname}
  3. %define version 0.0.0
  4. %define date 20110322
  5. %define time 2245
  6. %define release 16.%{date}%{?_dist_release}
  7. #define sourceurl0 ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
  8. %define sourceurl0 http://www.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
  9. Summary: Package to automatically build %{pkgname} rpm package
  10. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  11. Name: %{name}
  12. Version: %{version}
  13. Release: %{release}
  14. Source0: %{pkgname}-vl.spec
  15. Source1: %{pkgname}.desktop
  16. Source111: %{pkgname}-shared.patch
  17. Source112: %{pkgname}-nostrip.patch
  18. License: GPLv2+
  19. Group: Restricted Software
  20. Obsoletes: x264 < %{version}
  21. Obsoletes: self-build-x264 < %{version}
  22. Requires(post): self-build-setup >= 0.9.9
  23. # (build)requies of target package.
  24. Requires(post): yasm
  25. Requires(post): self-build-gpac
  26. BuildArch: noarch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. Packager: munepi
  29. %description
  30. x264 is a free library for encoding H264/AVC video streams, written from
  31. scratch.
  32. If you install this package, it automaticaly downloads source
  33. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  34. And the created rpm packages are automatically installed
  35. if installation is executed by apt-get command or synaptic
  36. package manager.
  37. [Note]
  38. This package requires many other packages to compile
  39. targetsoftware. So it consume more disk space than usual.
  40. Also installation takes logner time because of compilation.
  41. (This will take a few minutes to quarter or half of an hour,
  42. depends on building environment)
  43. [About self-build package]
  44. For some kind of software, distributing of binary package
  45. may viorate the patent or law. Therefore we chose self-build
  46. packge, create binary package on your machine, for such kind
  47. of softwares instead of distributing binary package.
  48. Please obey the national law when you use the created binary
  49. packages. And if you want to use the softwares using patented
  50. thechnology, it may be required to get a permission, make an
  51. agreement or purchas a license. Please consider it with your
  52. purpose or way of use and take appropriate action.
  53. %description -l ja
  54. x264 はスクラッチから書かれた H264/AVC ビデオストリームをエン
  55. コードするためのフリーなライブラリです.
  56. このパッケージをインストールすると、自動的にソースコードを
  57. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  58. パッケージを作成します。
  59. また apt-get コマンドや synaptic パッケージマネージャから実行
  60. した場合は、作成された rpm パッケージのインストールも自動的に
  61. 行います。
  62. [注意]
  63. コンパイルに必要な多くの関連パッケージを要求するので通常より
  64. ディスクの領域を多く消費します。
  65. またインストール時にコンパイルを行うため、通常より時間がかか
  66. る場合があります。(環境にもよりますが数分から数十分程度)
  67. [self-build パッケージについて]
  68. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  69. 違反する可能性があるものがあります。その為、このような問題が
  70. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  71. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  72. ジという方法を採っています。
  73. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  74. アのライセンス、および利用する国の各種法令に従ってください。
  75. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  76. センスの購入などが必要となる場合がありますので、利用する目的
  77. や形態に応じて各自で判断し適切な対応を取ってください。
  78. %prep
  79. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  80. %install
  81. %{__rm} -rf ${RPM_BUILD_ROOT}
  82. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  83. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  84. %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  85. %{__install} -m 644 %{SOURCE111} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  86. %{__install} -m 644 %{SOURCE112} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  87. %clean
  88. %{__rm} -rf ${RPM_BUILD_ROOT}
  89. %posttrans
  90. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 19000
  91. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  92. %{pkgname}-devel-%{version}-%{release}
  93. %files
  94. %defattr(-,root,root)
  95. %{_datadir}/%{name}
  96. %changelog
  97. * Thu Sep 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-16.20110322
  98. - changed to depend on %%{version} for Obsoletes: x264
  99. - added BuildArch: noarch
  100. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
  101. - updated source snapshot 20110322
  102. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
  103. - updated source snapshot 20100625
  104. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
  105. - renamed %%{Source0} to x264-vl.spec
  106. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
  107. - updated source snapshot 20100216
  108. - applied to link x264 binary to the shared library from RPM Fusion development
  109. * Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
  110. - changed to download from http://www.videolan.org/pub/videolan/x264/snapshots in %%sourceurl0
  111. - check version between original spec and self-build spec in %%prep
  112. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
  113. - dropped BuildArch: noarch
  114. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
  115. - 20090522 snapshot
  116. - updated x264-vine.patch
  117. - added BuildArch: noarch
  118. - avoided to execute self-build-rpm.sh on RPM transaction
  119. - moved %%post actions to %%posttrans
  120. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
  121. - corrected release number in x264.spec
  122. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.0-7.20090110
  123. - enable asm on x86/x86_64 arch. (fix typo?)
  124. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
  125. - added PreReq: self-build-gpac
  126. * Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
  127. - dropped PreReq: nasm for x86
  128. - added PreReq: yasm for x86
  129. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
  130. - 20090110 snapshot
  131. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
  132. - fixed License: GPLv2+
  133. - added BuildRequires: gettext
  134. - source updated
  135. - fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
  136. and added x264-vine.patch
  137. #- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
  138. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
  139. - spec in utf8
  140. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
  141. - run pre-allocate-rpm.sh in %%post
  142. - set PreReq: self-build-setup >= 0.8
  143. - apply new versioning policy
  144. * Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
  145. - initial build for Vine Linux 4.2
  146. ### end of file