swig-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224
  1. %define tcl 1
  2. %define guile 0
  3. Summary: Connects C/C++/Objective C to some high-level programming languages
  4. Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
  5. Name: swig
  6. Version: 4.0.1
  7. Release: 1%{?_dist_release}
  8. License: GPLv3+ and BSD
  9. Group: Development/Tools
  10. URL: http://swig.sourceforge.net/
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: lua-devel
  16. BuildRequires: pcre-devel
  17. BuildRequires: perl
  18. BuildRequires: python-devel
  19. BuildRequires: python3-devel
  20. BuildRequires: ruby-devel
  21. %if %{tcl}
  22. BuildRequires: tcl-devel
  23. %endif
  24. %if %{guile}
  25. BuildRequires: guile-devel
  26. %endif
  27. BuildRequires: autoconf, automake, gawk, nkf
  28. Obsoletes: swig-runtime
  29. %description
  30. Simplified Wrapper and Interface Generator (SWIG) is a software
  31. development tool for connecting C, C++ and Objective C programs with a
  32. variety of high-level programming languages. SWIG is primarily used
  33. with Perl, Python and Tcl/TK, but it has also been extended to Java,
  34. Eiffel and Guile. SWIG is normally used to create high-level
  35. interpreted programming environments, systems integration, and as a
  36. tool for building user interfaces
  37. %package doc
  38. Summary: Documentation files for SWIG
  39. Summary(ja): SWIG のドキュメント
  40. License: BSD
  41. Group: Documentation
  42. BuildArch: noarch
  43. %description doc
  44. This package contains documentation for SWIG and useful examples
  45. %prep
  46. %setup -q -n swig-%{version}
  47. # as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
  48. # (specific req/prov filtering). Before you remove this hack make sure you don't
  49. # reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
  50. cat << \EOF > %{name}-prov
  51. #!/bin/sh
  52. %{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  53. EOF
  54. %global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
  55. chmod +x %{__perl_provides}
  56. cat << \EOF > %{name}-req
  57. #!/bin/sh
  58. %{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  59. EOF
  60. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  61. chmod +x %{__perl_requires}
  62. for all in CHANGES README; do
  63. iconv -f ISO88591 -t UTF8 < $all > $all.new
  64. touch -r $all $all.new
  65. mv -f $all.new $all
  66. done
  67. %build
  68. ./autogen.sh
  69. %configure
  70. make %{?_smp_mflags}
  71. # Test suite is currently broken
  72. #make check
  73. %install
  74. rm -rf %{buildroot}
  75. make clean-examples
  76. pushd Examples/
  77. # Remove all arch dependent files in Examples/
  78. find -type f -name 'Makefile.in' | xargs rm -f --
  79. # We don't want to ship files below.
  80. rm -rf test-suite
  81. find -type f -name '*.dsp' | xargs rm -f --
  82. find -type f -name '*.dsw' | xargs rm -f --
  83. # Convert files to UNIX format
  84. for all in `find -type f`; do
  85. nkf --unix $all
  86. chmod -x $all
  87. done
  88. popd
  89. make DESTDIR=%{buildroot} install
  90. %clean
  91. rm -rf %{buildroot}
  92. %files
  93. %defattr(-,root,root,-)
  94. %{_bindir}/*
  95. %{_datadir}/swig
  96. %doc ANNOUNCE CHANGES CHANGES.current INSTALL
  97. %doc README TODO
  98. %license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  99. %files doc
  100. %defattr(-,root,root,-)
  101. %doc Doc Examples
  102. %license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  103. %changelog
  104. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.1-1
  105. - new upstream release.
  106. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.12-1
  107. - new upstream release.
  108. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.10-1
  109. - new upstream release.
  110. * Wed Feb 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
  111. - new upstream release
  112. - moved doc subpackage to Documentation Group
  113. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
  114. - update to 3.0.2
  115. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  116. - update to 3.0.0
  117. - add BR: ruby-devel, lua-devel
  118. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  119. - update to 2.0.8
  120. - build with pcre-8.31
  121. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
  122. - rebuild with python-2.7.2
  123. * Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
  124. - update to 2.0.4
  125. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
  126. - add missing man file(s) to the filelist
  127. * Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
  128. - new upstream release
  129. - rebuild with new toolchain
  130. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
  131. - new upstream release
  132. * Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
  133. - new upstream release
  134. - removed php-devel and ruby-devel from BuildPreReq:.
  135. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
  136. - new upstream release
  137. - use %%configure
  138. - remove runtime subpackage
  139. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  140. - 1.3.21-0vl2
  141. - un-libtoolize (tarball have already been libtoolized).
  142. - fix %%clean.
  143. - add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
  144. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  145. - 1.3.21-0vl1
  146. - update version
  147. * Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  148. - 1.3.20-0vl1
  149. - update version
  150. * Tue Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  151. - update version
  152. * Sun Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  153. - update version
  154. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  155. - import to Vine Linux
  156. * Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
  157. - BM.
  158. - Clean up specs.
  159. - 1.3a3.
  160. * Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
  161. - Use makeinstall macros.
  162. * Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
  163. - Provides: swig
  164. * Mon Apr 3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
  165. - rebuild with new perl
  166. - cleanup
  167. * Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
  168. - Rebuilt on kenobi
  169. - Don't use prefix
  170. * Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
  171. - First RPM for Mandrake