galera-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. %bcond_with systemd
  2. %bcond_with python3
  3. %define galera_api_version 26.4
  4. %define mariadb_version 10.4.12
  5. %if %{with python3}
  6. %global scons scons-3
  7. %else
  8. %global scons scons
  9. %endif
  10. Name: galera
  11. Version: %{galera_api_version}.3
  12. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  13. Summary: Synchronous multi-master wsrep provider (replication engine)
  14. License: GPLv2
  15. URL: http://galeracluster.com/
  16. # Actually, the truth is, we do use galera source tarball provided by MariaDB on
  17. # following URL (without macros):
  18. # https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
  19. Source0: https://downloads.mariadb.com/MariaDB/mariadb-%{mariadb_version}/galera-%{version}/src/%{name}-%{version}.tar.gz
  20. Source1: garbd.service
  21. Source2: garbd-wrapper
  22. Source3: garbd.init
  23. Patch0: galera-python3.patch
  24. BuildRequires: libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
  25. %if %{with systemd}
  26. BuildRequires: systemd
  27. %endif
  28. Requires: nmap
  29. Provides: galera(%{galera_api_version})
  30. %if %{with systemd}
  31. Requires(post): systemd
  32. Requires(preun): systemd
  33. Requires(postun): systemd
  34. %else
  35. Requires(post): chkconfig
  36. Requires(preun): chkconfig initscripts
  37. %endif
  38. %description
  39. Galera is a fast synchronous multi-master wsrep provider (replication engine)
  40. for transactional databases and similar applications. For more information
  41. about wsrep API see http://launchpad.net/wsrep. For a description of Galera
  42. replication engine see http://www.codership.com.
  43. %debug_package
  44. %prep
  45. %setup -q
  46. %if %{with python3}
  47. %patch0 -p1
  48. %endif
  49. %build
  50. CPPFLAGS="%{optflags}"
  51. CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
  52. export CPPFLAGS
  53. %{scons} %{?_smp_mflags} strict_build_flags=0
  54. %install
  55. %if %{with systemd}
  56. install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
  57. install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
  58. %else
  59. install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
  60. %endif
  61. install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
  62. install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
  63. install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
  64. install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
  65. install -D -m 644 chromium/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.chromium
  66. install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
  67. install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
  68. install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
  69. install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
  70. %post
  71. /sbin/ldconfig
  72. %if %{with systemd}
  73. %systemd_post garbd.service
  74. %else
  75. /sbin/chkconfig --add garbd
  76. %endif
  77. %preun
  78. %if %{with systemd}
  79. %systemd_preun garbd.service
  80. %else
  81. if [ $1 = 0 ]; then
  82. /sbin/service garbd stop >/dev/null 2>/dev/null ||:
  83. /sbin/chkconfig --del garbd
  84. fi
  85. %endif
  86. %postun
  87. /sbin/ldconfig
  88. %if %{with systemd}
  89. %systemd_postun_with_restart garbd.service
  90. %endif
  91. %files
  92. %config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
  93. %dir %{_docdir}/galera
  94. %dir %{_libdir}/galera
  95. %{_sbindir}/garbd
  96. %if %{with systemd}
  97. %{_sbindir}/garbd-wrapper
  98. %{_unitdir}/garbd.service
  99. %else
  100. %{_initdir}/garbd
  101. %endif
  102. %{_libdir}/galera/libgalera_smm.so
  103. %license %{_docdir}/galera/COPYING
  104. %license %{_docdir}/galera/LICENSE.asio
  105. %license %{_docdir}/galera/LICENSE.crc32
  106. %license %{_docdir}/galera/LICENSE.chromium
  107. %doc %{_docdir}/galera/README
  108. %doc %{_docdir}/galera/README-MySQL
  109. %changelog
  110. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-2
  111. - rebuilt with boost-1.72.0.
  112. * Wed Nov 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.3-1
  113. - new upstream release.
  114. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 26.4.2-1
  115. - updated to 26.4.2 for MariaDB-10.4.
  116. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
  117. - initial build for Vine Linux.
  118. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  120. * Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
  121. - Rebuilt for Boost 1.69
  122. * Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
  123. - Rebase to 25.3.25
  124. * Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
  125. - Require asio also on rhel
  126. * Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
  127. - Add explicit gcc-c++ BR
  128. - Use python3-scons
  129. * Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
  130. - Do not require asio on rhel
  131. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  133. * Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
  134. - Update to 25.3.23
  135. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  137. * Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
  138. - Update to 25.3.22
  139. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  141. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  143. * Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
  144. - Rebuilt for Boost 1.64
  145. * Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
  146. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
  147. * Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
  148. - Use asio-devel instead of bundled asio library
  149. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  151. * Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
  152. - Update to 25.3.16
  153. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  155. * Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
  156. - Rebuilt for Boost 1.60
  157. * Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
  158. - Remove use of -mtune=native which breaks build on secondary architectures
  159. * Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
  160. - Update to 25.3.12.
  161. - Should fix the build on 32 bit ARM (RHBZ#1241164).
  162. - Remove ExcludeArch (should have read the BZ more closely).
  163. * Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
  164. - Rebuilt for Boost 1.59
  165. * Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
  166. - Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
  167. * Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
  168. - rebuild for Boost 1.58
  169. * Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
  170. - Disable ARM builds (#1241164, #1239516)
  171. * Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
  172. - Update to version 25.3.10
  173. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  175. * Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
  176. - Rebuild for boost 1.57.0
  177. * Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
  178. - Add aarch64 support.
  179. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  181. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  183. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
  184. - Rebuild for boost 1.55.0
  185. * Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
  186. - set ExclusiveArch
  187. * Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
  188. - Use strict_build_flags=0 to avoid -Werror
  189. - Remove unnecessary clean section
  190. * Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
  191. - Include galera directories in file list
  192. - Set CPPFLAGS to optflags
  193. * Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
  194. - Fix client certificate verification (#1090604)
  195. * Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
  196. - Update to version 25.3.5
  197. * Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
  198. - Add systemd service
  199. * Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
  200. - Initial build