Field3D-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211
  1. Name: Field3D
  2. Version: 1.7.3
  3. Release: 1%{?_dist_release}
  4. Summary: Library for storing voxel data
  5. Summary(ja): ボクセルデータを蓄積するためのライブラリ
  6. Group: System Environment/Libraries
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: BSD
  10. URL: https://sites.google.com/site/field3d/
  11. # https://github.com/imageworks/Field3D/archive/v1.6.2.tar.gz
  12. Source0: https://github.com/imageworks/Field3D/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cmake doxygen
  15. BuildRequires: hdf5-devel
  16. BuildRequires: ilmbase-devel
  17. BuildRequires: libboost-devel
  18. BuildRequires: libboost-atomic
  19. BuildRequires: libboost-chrono
  20. BuildRequires: libboost-date-time
  21. BuildRequires: libboost-program-options
  22. BuildRequires: libboost-regex
  23. BuildRequires: libboost-system
  24. BuildRequires: libboost-thread
  25. BuildRequires: zlib-devel
  26. Requires: hdf5
  27. %description
  28. Field3D is an open source library for storing voxel data. It provides C++
  29. classes that handle in-memory storage and a file format based on HDF5 that
  30. allows the C++ objects to be written to and read from disk.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Summary(ja): %{name} の開発用ファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. Development headers and documentation for %{name}.
  38. # Need devel-docs subpackage.
  39. %prep
  40. %setup -q
  41. # for OpenEXR (IlmBase) >= 2.4.0
  42. SFX=`pkg-config --variable=libsuffix IlmBase`
  43. sed -i \
  44. -e "s/ Iex / Iex$SFX /" \
  45. -e "s/ Half / Half$SFX /" \
  46. -e "s/ IlmThread / IlmThread$SFX /" \
  47. -e "s/ Imath/ Imath$SFX/" \
  48. CMakeLists.txt
  49. %build
  50. rm -rf build && mkdir build && pushd build
  51. %cmake -DINSTALL_DOCS=OFF \
  52. ../
  53. make %{?_smp_mflags}
  54. popd
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. pushd build
  58. make install DESTDIR=$RPM_BUILD_ROOT
  59. popd
  60. install -D -m 0644 man/f3dinfo.1 $RPM_BUILD_ROOT%{_mandir}/man1/f3dinfo.1
  61. %check
  62. pushd build
  63. LD_LIBRARY_PATH=`pwd` ./unitTest
  64. popd
  65. %clean
  66. rm -rf $RPM_BUILD_ROOT
  67. %post -p /sbin/ldconfig
  68. %postun -p /sbin/ldconfig
  69. %files
  70. %license COPYING
  71. %doc CHANGES README
  72. %{_bindir}/f3dinfo
  73. %{_libdir}/libField3D.so.*
  74. %{_mandir}/man1/f3dinfo.1.gz
  75. %files devel
  76. %doc docs/html/
  77. %{_includedir}/Field3D/
  78. %{_libdir}/libField3D.so
  79. %changelog
  80. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-1
  81. - new upstream release.
  82. - built with boost-1.72.0.
  83. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.2-2
  84. - rebuilt with ilmbase-2.4.0.
  85. * Wed Aug 22 2018 Toshiaki Ara <ara_t@384.jp> - 1.7.2-1
  86. - update to 1.7.2
  87. * Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.2-4
  88. - rebuild with hdf5-1.8.20
  89. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.2-3
  90. - rebuild with libboost-1.66.0
  91. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.2-2
  92. - rebuild with gcc-5.4.0
  93. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.2-1
  94. - new upstream release
  95. - add BuildRequires: libboost-{atomic,chrono,date-time}
  96. * Fri Jan 30 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.3-2
  97. - added Group tag
  98. - added %%clean section
  99. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.3-1
  100. - initial build for Vine Linux
  101. * Wed Jan 07 2015 Orion Poplawski <orion@cora.nwra.com> - 1.4.3-3
  102. - Rebuild for hdf5 1.8.4
  103. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.3-2
  104. - rebuild (ilmbase), add matching/missing popd's
  105. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.3-1
  106. - Update to latest upstream release.
  107. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-19
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  109. * Tue Jun 10 2014 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-18
  110. - Rebuild for hdf 1.8.13
  111. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-17
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  113. * Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 1.3.2-16
  114. - Rebuild for boost 1.55.0
  115. * Fri Dec 27 2013 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-15
  116. - Rebuild for hdf5 1.8.12
  117. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 1.3.2-14
  118. - rebuild (ilmbase)
  119. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.3.2-13
  120. - rebuild (ilmbase)
  121. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-12
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  123. * Sat Jul 27 2013 pmachata@redhat.com - 1.3.2-11
  124. - Rebuild for boost 1.54.0
  125. * Thu May 16 2013 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-10
  126. - Rebuild for hdf5 1.8.11
  127. * Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.3.2-9
  128. - Rebuild for Boost-1.53.0
  129. * Sat Feb 09 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.3.2-8
  130. - Rebuild for Boost-1.53.0
  131. * Mon Dec 3 2012 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-7
  132. - Rebuild for hdf5 1.8.10
  133. * Wed Aug 8 2012 David Malcolm <dmalcolm@redhat.com> - 1.3.2-6
  134. - rebuild against boost-1.50
  135. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-4
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  137. * Tue May 15 2012 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-3
  138. - Rebuild for hdf5 1.8.9
  139. - Explicitly require the version of hdf5 built with
  140. * Fri Mar 23 2012 Richard Shaw <hobbes1069@gmail.com> - 1.3.2-2
  141. - Bump EVR for oops with F17 package to make sure rawhide package is newer.
  142. * Tue Feb 28 2012 Richard Shaw <hobbes1069@gmail.com> - 1.3.2-1
  143. - Update to latest release.
  144. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-4
  145. - Rebuilt for c++ ABI breakage
  146. * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-3
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  148. * Mon Jan 09 2012 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-2
  149. - Fixed building under GCC 4.7.0.
  150. * Sat Nov 12 2011 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  151. - Initial release.