empathy-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386
  1. %define major_ver 2.30
  2. %define minor_ver 0.1
  3. %define rel 2
  4. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  5. ## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
  6. ## respectively.
  7. %global gtk2_min_version 2.14
  8. %global glib2_min_version 2.22.0
  9. %global tp_mc_min_version 5.3.2
  10. %global tp_glib_min_version 0.9.2
  11. #global enchant_version 1.4.0
  12. %global aspell_version 0.50
  13. %global libcanberra_version 0.4
  14. %global gnome_keyring_version 2.22
  15. %global libnotify_version 0.4.4
  16. Summary: GNOME Instant Messaging Client
  17. Summary(ja): GNOME インスタントメッセージクラアイント
  18. Name: empathy
  19. Version: %{major_ver}.%{minor_ver}
  20. Release: %{rel}%{?_dist_release}
  21. Group: Applications/Communications
  22. License: GPLv2+
  23. URL: http://live.gnome.org/Empathy
  24. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.bz2
  25. Source1: %{name}-README.ConnectionManagers
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. #BuildRequires: enchant-devel >= %{enchant_version}
  28. BuildRequires: aspell-devel >= %{aspell_version}
  29. BuildRequires: iso-codes
  30. BuildRequires: desktop-file-utils
  31. BuildRequires: evolution-data-server-devel
  32. BuildRequires: GConf2-devel
  33. BuildRequires: gettext
  34. BuildRequires: glib2-devel >= %{glib2_min_version}
  35. BuildRequires: gnome-doc-utils >= 0.17.3
  36. BuildRequires: gnome-panel
  37. BuildRequires: gtk2-devel >= %{gtk2_min_version}
  38. BuildRequires: intltool
  39. BuildRequires: libxml2-devel
  40. BuildRequires: perl(XML::Parser)
  41. BuildRequires: pygtk2-devel
  42. BuildRequires: telepathy-glib-devel >= %{tp_glib_min_version}
  43. BuildRequires: telepathy-mission-control-devel >= %{tp_mc_min_version}
  44. BuildRequires: farsight2-devel
  45. BuildRequires: telepathy-farsight-devel
  46. BuildRequires: libcanberra-devel >= %{libcanberra_version}
  47. BuildRequires: libgnome-keyring-devel >= %{gnome_keyring_version}
  48. BuildRequires: unique-devel
  49. BuildRequires: libnotify-devel >= %{libnotify_version}
  50. BuildRequires: libtelepathy-devel
  51. BuildRequires: libgnomecanvas-devel
  52. BuildRequires: libbonoboui-devel
  53. Requires: telepathy-filesystem
  54. ## Empathy is useless without a proper Telepathy connection manager installed.
  55. ## We hardcode dependencies on Salut and Gabble to support XMPP on a default
  56. ## install, in both the link-local and Jabber/GoogleTalk incarnations.
  57. ## (RHBZ: 308871 and 334221)
  58. ## TODO: Perhaps we can configure these to be installed "on demand" with
  59. ## PackageKit and friends?
  60. Requires: telepathy-gabble
  61. Requires: telepathy-salut
  62. ## Also hardcode Haze dependency since Empathy is the default IM client in F10+
  63. ## and I'd hate for people to simply disregard it for lack of the "out of the
  64. ## box" protocol support that Pidgin has. (RHBZ: 458935)
  65. BuildRequires: telepathy-haze
  66. # Require this for VOIP support
  67. Requires: telepathy-stream-engine
  68. Requires(pre): GConf2
  69. Requires(post): GConf2
  70. Requires(post): scrollkeeper
  71. Requires(preun): GConf2
  72. Requires(postun): scrollkeeper
  73. ## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
  74. Obsoletes: telepathy-haze-mission-control < 0.2.0-3
  75. Provides: telepathy-haze-mission-control = 0.2.0-3
  76. ## upstream 2.29.1 removed shared libraries: #599086
  77. Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
  78. ## upstream 2.29.1 removed python bindings' #599039
  79. Obsoletes: empathy-python < 2.29.1
  80. %description
  81. Empathy provides a powerful multiple protocol instant messaging
  82. client using the Telepathy framework.
  83. %prep
  84. %setup -q
  85. %build
  86. ## GCC complains about some unused functions, so we forcibly show those as
  87. ## simple warnings instead of build-halting errors.
  88. %configure --with-compile-warnings=yes --disable-static
  89. ## RPATHs are yucky.
  90. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  91. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  92. ##make %{?_smp_mflags}
  93. ## don't use _smp_mflags at empathy-2.18.1
  94. make
  95. install -m 0644 %{SOURCE1} ./README.ConnectionManagers
  96. %install
  97. rm -rf $RPM_BUILD_ROOT
  98. make install DESTDIR=$RPM_BUILD_ROOT
  99. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  100. %find_lang %{name}
  101. desktop-file-install --vendor "" --delete-original \
  102. --dir %{buildroot}%{_datadir}/applications \
  103. %{buildroot}%{_datadir}/applications/%{name}.desktop
  104. %clean
  105. rm -rf %{buildroot}
  106. %pre
  107. if [ "$1" -gt 1 ]; then
  108. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  109. gconftool-2 --makefile-uninstall-rule \
  110. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  111. fi
  112. %post
  113. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  114. ## for empathy =< 2.28.2-1's schemas
  115. if [ -e %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas ]; then
  116. gconftool-2 --makefile-uninstall-rule \
  117. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas > /dev/null ||:
  118. fi
  119. gconftool-2 --makefile-install-rule \
  120. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  121. scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
  122. touch --no-create %{_datadir}/icons/hicolor ||:
  123. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  124. %preun
  125. if [ "$1" -eq 0 ]; then
  126. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  127. gconftool-2 --makefile-uninstall-rule \
  128. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  129. fi
  130. %postun
  131. scrollkeeper-update -q || :
  132. touch --no-create %{_datadir}/icons/hicolor || :
  133. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  134. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  135. fi
  136. %files -f %{name}.lang
  137. %defattr(-,root,root,-)
  138. %doc AUTHORS COPYING README README.ConnectionManagers NEWS
  139. %{_sysconfdir}/gconf/schemas/%{name}.schemas
  140. %{_bindir}/empathy
  141. %{_bindir}/empathy-accounts
  142. %{_bindir}/empathy-debugger
  143. %{_datadir}/dbus-1/services/*
  144. %{_datadir}/empathy
  145. %{_datadir}/applications/*.desktop
  146. %{_datadir}/gnome/help/%{name}/
  147. #{_datadir}/omf/%{name}/
  148. %{_datadir}/icons/hicolor/*/apps/%{name}*
  149. #{_datadir}/mission-control/profiles/*.profile
  150. %{_datadir}/telepathy/clients/Empathy.client
  151. %{_mandir}/man1/empathy*.1*
  152. %changelog
  153. * Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
  154. - add Obsoletes: empathy-python < 2.29.1
  155. * Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
  156. - new upstream release
  157. - add new files: %%{_bindir}/empathy-{accounts,debugger}
  158. - drop -libs, -devel, -python sub packages: upstream removed
  159. - Obsoletes: empathy-{libs,devel} < 2.29.1
  160. - drop BuildRequires: python-devel
  161. - drop %%{_bindir}/empathy-logs in %%files: upstream don not install
  162. - drop applet files in %%files: upstream removed the panel applets
  163. - update %%post, %pre and %%preun
  164. - update BuildRequires version for glib2 and tp_glib
  165. - defined major_ver, minor_ver and rel
  166. - fix BuildRequires for gnome-keyring
  167. * Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  168. - new upstream release
  169. - add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
  170. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
  171. - rebuilt with python-2.6.4
  172. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
  173. - unuse %%{?_smp_mflags} option to make
  174. * Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
  175. - add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
  176. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  177. - new upstream release
  178. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  179. - new upstream release
  180. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  181. - initial build for Vine Linux
  182. * Tue Sep 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
  183. - Update to 2.23.92
  184. * Thu Sep 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
  185. - Update to 2.23.91
  186. * Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
  187. - Now that Empathy will be the default IM client in F10+, hardcode a dependency
  188. on telepathy-haze to keep the same protocol functionality across upgrades,
  189. for a much improved "out of the box" experience.
  190. - Reference: bug 458935.
  191. * Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
  192. - Update to new upstream release (2.23.90)
  193. * Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
  194. - Apply patch from Colin Walters to automagically update profile namings for
  195. the switch to using Empathy's provided profiles.
  196. - Drop the upgrade script (no longer needed since it's automatically done).
  197. - upgrade-haze-profiles.sh
  198. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
  199. - Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
  200. the telepathy-haze-mission-control package. (The Haze-provided ones have grown
  201. horribly stale...). This makes for better automagic functionality (if Haze is
  202. installed, Empathy/MC will autodetect it) and tracks upstream more closely.
  203. + upgrade-haze-profiles.sh
  204. * Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
  205. - Update to new upstream release (2.23.6)
  206. - Use the in-tarball libtool scripts instead of the system copy to workaround
  207. 'make install' errors.
  208. * Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
  209. - Update to 0.23.4.
  210. - Update source url.
  211. * Mon Jun 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
  212. - Update to 0.23.3.
  213. - Remove reference to stream-engine in connections managers readme.
  214. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
  215. - Update to 0.23.2.
  216. - Add man pages.
  217. - Use enchant-devel, instead of aspell-devel.
  218. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
  219. - Rebuild for new e-d-s.
  220. * Sun May 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
  221. - Drop multiple copies of COPYING file.
  222. - Drop BR on gnome-vfs2-devel.
  223. - Require telepathy-stream-engine for VOIP support.
  224. - Add BR on iso-codes-devel, so spell-checking is enabled.
  225. * Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
  226. - Update to new upstream release (0.23.1)
  227. - Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
  228. * Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
  229. - Update to new upstream release (0.22.1)
  230. * Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
  231. - Update to new upstream release (0.22.0)
  232. * Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
  233. - Update to new upstream release (0.21.91)
  234. * Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
  235. - Update to new upstream release (0.21.90)
  236. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
  237. - Autorebuild for GCC 4.3
  238. * Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
  239. - Update to new upstream release (0.21.4)
  240. * Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
  241. - Update to new upstream release (0.21.2)
  242. - Drop backported drag-and-drop patch (fixed upstream):
  243. - svn380-fix-contact-DnD.patch
  244. - Update README.ConnectionManagers: Include Haze package note, remove Galago
  245. note (a feed-only connection manager isn't useful for instant messaging),
  246. and fix some wording.
  247. * Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
  248. - Backport upstream patch to fixes crashes when using drag-and-drop of a
  249. contact from the buddy list to the current conversation window to initiate a
  250. conversation:
  251. + svn380-fix-contact-DnD.patch
  252. - Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
  253. dragged a contact ...)
  254. * Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
  255. - Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
  256. is essentially useless due to the need to install an external connection
  257. manager. Also, add a README.ConnectionManagers to the installed
  258. documentation which lists other possibilities.
  259. - Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
  260. and bug 334221 (Default empathy install is useless).
  261. * Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
  262. - Enable VoIP support for those brave enough to test/break/debug it (F9+
  263. only). Though it is functional, it is still deemed rather unstable by
  264. upstream. Use it at your own risk. :)
  265. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
  266. - Disable VoIP support at this time, since it is deemed unstable by upstream
  267. for now. (Thanks to Brian Pepple for the notice.)
  268. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
  269. - Update to new upstream release (0.14).
  270. * Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
  271. - Update to new upstream release (0.13), which adds a panel applet (Megaphone)
  272. and python bindings.
  273. - Split shared libraries into a libs subpackage for easier handling
  274. in multi-lib environments.
  275. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  276. - Add ldconfig invocations to %%post and %%postun scriptlets.
  277. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  278. - Update to new upstream release (0.12).
  279. - Build against new mission-control stack.
  280. - Update License tag (GPLv2+).
  281. - Alphabetize BuildRequires list (aesthetic-only change).
  282. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
  283. - Rebuild for selinux ppc32 issue.
  284. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  285. - Update to new upstream release (0.11)
  286. * Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
  287. - bump to 0.8
  288. - Now with aspell support (deat to teh speeling mistaks)
  289. * Sat Jun 9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
  290. - bump to 0.7
  291. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
  292. - Add telepathy-filesystem to Requires
  293. - Move .desktop from autostart to applications
  294. - Nasty hackery to make empathy launch from the menu
  295. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
  296. - Add gettext to BuildRequires
  297. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
  298. - Bump to 0.6
  299. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
  300. - Let Empathy own the directory and not just the files in it
  301. * Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
  302. - Initial package