kturtle-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. Name: kturtle
  2. Summary: Logo educational programming environment for KDE
  3. Summary(ja): Logo の教育用プログラミング環境
  4. Version: 4.9.5
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: Applications/Edutainment
  8. URL: http://edu.kde.org/parley/
  9. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
  10. ## upstream patches
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: desktop-file-utils
  13. BuildRequires: kdelibs4-devel >= %{version}
  14. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  15. Conflicts: kdeedu4 < 4.6.50
  16. %description
  17. KTurtle is an educational programming environment which uses the
  18. TurtleScript programming language (inspired by Logo) to make programming
  19. as easy and accessible as possible.
  20. The user issues TurtleScript language commands to control the "turtle",
  21. which draws on the canvas, making KTurtle suitable for teaching elementary
  22. mathematics, geometry and programming.
  23. This package is part of the KDE education module.
  24. %prep
  25. %setup -q
  26. %build
  27. mkdir -p %{_target_platform}
  28. pushd %{_target_platform}
  29. %cmake \
  30. -DCMAKE_BUILD_TYPE=release \
  31. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  32. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  33. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  34. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  35. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  36. ..
  37. popd
  38. make %{?_smp_mflags} -C %{_target_platform}
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  42. %clean
  43. rm -rf $RPM_BUILD_ROOT
  44. %check
  45. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  46. desktop-file-validate $f
  47. done
  48. %post
  49. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  50. %posttrans
  51. update-desktop-database -q &> /dev/null ||:
  52. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  53. %postun
  54. if [ $1 -eq 0 ] ; then
  55. update-desktop-database -q &> /dev/null ||:
  56. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  57. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  58. fi
  59. %files
  60. %defattr(-,root,root)
  61. %doc COPYING COPYING.DOC
  62. %{_bindir}/kturtle
  63. %{_datadir}/applications/kde4/kturtle.desktop
  64. %{_datadir}/config/*.knsrc
  65. %{_datadir}/icons/hicolor/*/*/*
  66. %{_datadir}/kde4/apps/kturtle
  67. %doc %{_docdir}/HTML/en/kturtle/
  68. %changelog
  69. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
  70. - new upstream release
  71. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
  72. - new upstream release
  73. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
  74. - new upstream release
  75. * Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
  76. - new upstream release
  77. * Tue Aug 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
  78. - new upstream release
  79. * Wed Aug 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
  80. - split from kdeedu