kate-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235
  1. Name: kate
  2. Summary: Advanced Text Editor
  3. Summary(ja): 高機能なテキストエディタ
  4. Version: 4.9.5
  5. Release: 1%{?_dist_release}
  6. # kwrite LGPLv2+
  7. # kate: app LGPLv2, plugins, LGPLv2 and LGPLv2+ and GPLv2+
  8. # ktexteditor: LGPLv2
  9. # katepart: LGPLv2
  10. License: LGPLv2 and LGPLv2+ and GPLv2+
  11. Group: Applications/Editors
  12. URL: https://projects.kde.org/projects/kde/kdebase/kate
  13. Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.xz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: kdelibs4-devel >= %{version}
  17. BuildRequires: soprano-devel
  18. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  19. Requires: %{name}-part = %{version}-%{release}
  20. Requires: %{name}-libs = %{version}-%{release}
  21. %description
  22. %{summary}.
  23. %package devel
  24. Summary: Development files for %{name}
  25. Summary(ja): %{name} の開発用ファイル
  26. Group: Development/Libraries
  27. Requires: %{name}-libs = %{version}-%{release}
  28. Requires: kdelibs4-devel
  29. %description devel
  30. %{summary}.
  31. %package libs
  32. Summary: Runtime files for %{name}
  33. Summary(ja): %{name} のランタイムライブラリ
  34. Group: System Environment/Libraries
  35. # when split occurred
  36. Conflicts: kdesdk4-libs < 4.6.95-10
  37. #Requires: %{name} = %{version}-%{release}
  38. %description libs
  39. %{summary}.
  40. %package part
  41. Summary: Kate kpart plugin
  42. Summary(ja): Kate kpart プラグイン
  43. License: LGPLv2
  44. Group: Applications/Editors
  45. # when split occurred
  46. Conflicts: kdelibs4 < 4.6.95-10
  47. %description part
  48. %{summary}.
  49. %package -n kwrite
  50. Summary: Text Editor
  51. Summary(ja): テキストエディタ
  52. License: LGPLv2+
  53. Group: Applications/Editors
  54. # when split occurred
  55. Conflicts: kdebase4 < 4.6.95-10
  56. Requires: %{name}-part = %{version}-%{release}
  57. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  58. %description -n kwrite
  59. %{summary}.
  60. %prep
  61. %setup -q
  62. %build
  63. mkdir -p %{_target_platform}
  64. pushd %{_target_platform}
  65. %cmake \
  66. -DCMAKE_BUILD_TYPE=release \
  67. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  68. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  69. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  70. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  71. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  72. ..
  73. popd
  74. make %{?_smp_mflags} -C %{_target_platform}
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  78. # move devel symlinks (that would otherwise conflict with kdelibs3-devel)
  79. mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
  80. pushd $RPM_BUILD_ROOT%{_libdir}
  81. for i in lib*.so
  82. do
  83. case "$i" in
  84. libkate*interfaces.so)
  85. linktarget=`readlink "$i"`
  86. rm -f "$i"
  87. ln -sf "../../$linktarget" "kde4/devel/$i"
  88. ;;
  89. esac
  90. done
  91. popd
  92. ## unpackaged files
  93. # playground artsticomment -devel bits
  94. rm -fv $RPM_BUILD_ROOT%{_includedir}/kde4/artisticcomment.h
  95. rm -fv $RPM_BUILD_ROOT%{_libdir}/libacomment.a
  96. %check
  97. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  98. desktop-file-validate $f
  99. done
  100. %post
  101. touch --no-create %{_datadir}icons/hicolor &> /dev/null || :
  102. %posttrans
  103. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  104. update-mime-database %{_datadir}/mime >& /dev/null
  105. %postun
  106. if [ $1 -eq 0 ] ; then
  107. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  108. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  109. update-mime-database %{_datadir}/mime >& /dev/null
  110. fi
  111. %post part -p /sbin/ldconfig
  112. %postun part -p /sbin/ldconfig
  113. %files
  114. %doc kate/AUTHORS kate/ChangeLog kate/COPYING.LIB kate/NEWS kate/README kate/TODO
  115. %{_bindir}/kate
  116. %{_libdir}/libkdeinit4_kate.so
  117. %{_datadir}/applications/kde4/kate.desktop
  118. %{_datadir}/kde4/apps/kate/
  119. %{_datadir}/kde4/apps/katexmltools/
  120. %{_datadir}/kde4/apps/kconf_update/kate*.upd
  121. %{_datadir}/icons/hicolor/*/*/*
  122. %{_mandir}/man1/kate.1.gz
  123. %{_datadir}/config/katerc
  124. %{_datadir}/config/katefiletemplates.knsrc
  125. %{_datadir}/kde4/services/kate*.desktop
  126. %{_libdir}/kde4/kate*plugin.so
  127. %{_libdir}/kde4/katefiletemplates.so
  128. %{_datadir}/kde4/apps/katepart/
  129. %{_datadir}/kde4/apps/ktexteditor_*/
  130. %{_datadir}/kde4/services/ktexteditor_*.desktop
  131. %{_libdir}/kde4/ktexteditor_*.so
  132. %{_datadir}/kde4/services/plasma-applet-katesession.desktop
  133. %{_datadir}/kde4/servicetypes/kateplugin.desktop
  134. %{_libdir}/kde4/plasma_applet_katesession.so
  135. %{_libdir}/kde4/kate_kttsd.so
  136. # snippets plugin
  137. %{_bindir}/ktesnippets_editor
  138. %{_datadir}/applications/kde4/ktesnippets_editor.desktop
  139. %{_datadir}/config/ktexteditor_codesnippets_core.knsrc
  140. # these should *probably* be moved to hicolor -- rex
  141. %{_datadir}/icons/oxygen/*/actions/*
  142. %{_datadir}/mime/packages/ktesnippets.xml
  143. %{_datadir}/doc/HTML/en/kate/
  144. %files libs
  145. %{_libdir}/libkateinterfaces.so.4*
  146. %{_libdir}/libktexteditor_codesnippets_core.so.0*
  147. %files devel
  148. %{_libdir}/kde4/devel/libkateinterfaces.so
  149. %{_libdir}/kde4/devel/libkatepartinterfaces.so
  150. %{_libdir}/libktexteditor_codesnippets_core.so
  151. %{_includedir}/kde4/kate_export.h
  152. %{_includedir}/kde4/kate/
  153. %{_includedir}/kde4/ktexteditor_codesnippets_core/
  154. %files part
  155. %doc part/AUTHORS part/ChangeLog part/COPYING.LIB
  156. %doc part/INDENTATION part/NEWS part/README* part/TODO*
  157. %{_libdir}/kde4/katepart.so
  158. %{_libdir}/libkatepartinterfaces.so.4*
  159. %{_datadir}/config/katemoderc
  160. %{_datadir}/config/katepartpluginsrc
  161. %{_datadir}/kde4/services/katepart.desktop
  162. %files -n kwrite
  163. %{_bindir}/kwrite
  164. %{_datadir}/kde4/apps/kwrite
  165. %{_libdir}/libkdeinit4_kwrite.so
  166. %{_datadir}/applications/kde4/kwrite.desktop
  167. %{_datadir}/doc/HTML/en/kwrite/
  168. %changelog
  169. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
  170. - new upstream release
  171. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
  172. - new upstream release
  173. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
  174. - new upstream release
  175. * Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
  176. - new upstream release
  177. * Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
  178. - new upstream release
  179. * Fri Dec 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  180. - new upstream release
  181. * Sat Oct 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
  182. - new upstream release
  183. * Mon Aug 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
  184. - Initial build for Vine Linux
  185. * Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
  186. - 4.7.0
  187. * Mon Jul 18 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
  188. - first try