iksemel-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. Summary: An XML parser library designed for Jabber applications
  2. Summary(ja): Jabber アプリケーションのために設計された XML パーサ
  3. Name: iksemel
  4. Version: 1.4
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://code.google.com/p/iksemel/
  9. Source0: http://iksemel.googlecode.com/files/iksemel-%{version}.tar.gz
  10. Patch0: 0001-Fix-issues-compiling-with-newer-gnutls.patch
  11. Patch1: 0002-Strip-out-internal-SHA-code-and-use-functions-from-g.patch
  12. Patch2: 0003-Fix-alignment-on-architectures-where-doubles-are-64b.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  14. BuildRequires: gnutls-devel > 2
  15. BuildRequires: libgcrypt-devel
  16. BuildRequires: autoconf
  17. BuildRequires: automake
  18. BuildRequires: libtool > 2
  19. BuildRequires: texinfo
  20. %description
  21. An XML parser library designed for Jabber applications. It is coded in
  22. ANSI C for POSIX compatible environments, thus highly portable.
  23. %package devel
  24. Summary: Development files for iksemel
  25. Summary(ja): iksemel の開発ファイル
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: gnutls-devel
  29. Requires: pkgconfig
  30. Requires(post): /sbin/install-info
  31. Requires(preun): /sbin/install-info
  32. %description devel
  33. Development files for iksemel.
  34. %package utils
  35. Summary: Utilities for iksemel
  36. Summary(ja): iksemel 用のユーティリティ
  37. Group: Applications/Internet
  38. Requires: %{name} = %{version}-%{release}
  39. %description utils
  40. Utlity programs for iksemel.
  41. %prep
  42. %setup0 -q
  43. %patch0 -p1
  44. %patch1 -p1
  45. %patch2 -p1
  46. # force rebuilding of the info file
  47. rm doc/iksemel
  48. %build
  49. # We need to re-run the autotools because the patch we apply modifies
  50. # the configure.ac and src/Makefile.am
  51. libtoolize --copy --force --automake
  52. aclocal
  53. autoheader
  54. automake --add-missing --force-missing --gnu --include-deps
  55. autoconf
  56. %configure --disable-static --disable-rpath
  57. make %{?_smp_mflags}
  58. %install
  59. rm -rf %{buildroot}
  60. make install DESTDIR=%{buildroot}
  61. rm -f %{buildroot}%{_libdir}/*.la
  62. mv %{buildroot}%{_infodir}/iksemel %{buildroot}%{_infodir}/iksemel.info
  63. %check
  64. %ifnarch ppc
  65. make check
  66. %endif
  67. %clean
  68. rm -rf %{buildroot}
  69. %postun -p /sbin/ldconfig
  70. %post -p /sbin/ldconfig
  71. %post devel
  72. /sbin/install-info --quiet %{_infodir}/%{name}.info %{_infodir}/dir || :
  73. %preun devel
  74. if [ "$1" = 0 ]; then
  75. /sbin/install-info --quiet --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
  76. fi
  77. %files
  78. %defattr(-,root,root,-)
  79. %doc AUTHORS ChangeLog COPYING HACKING NEWS README TODO
  80. %{_libdir}/libiksemel.so.*
  81. %files devel
  82. %defattr(-,root,root,-)
  83. %doc COPYING
  84. %{_libdir}/libiksemel.so
  85. %{_includedir}/iksemel.h
  86. %{_libdir}/pkgconfig/iksemel.pc
  87. %{_infodir}/iksemel.info*
  88. %files utils
  89. %defattr(-,root,root,-)
  90. %doc COPYING
  91. %{_bindir}/ikslint
  92. %{_bindir}/iksperf
  93. %{_bindir}/iksroster
  94. %changelog
  95. * Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
  96. - update to 1.4
  97. - remove old patches
  98. - add patches from fedora
  99. - Patch0 (0001-Fix-issues-compiling-with-newer-gnutls.patch)
  100. - Patch1 (0002-Strip-out-internal-SHA-code-and-use-functions-from-g.patch)
  101. - Patch2 (0003-Fix-alignment-on-architectures-where-doubles-are-64b.patch)
  102. * Tue May 05 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3-2vl5
  103. - rebuild with gnutls 2.6.6, libtool 2.2.6
  104. * Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.3-1vl5
  105. - applied new versioning policy, spec in utf-8
  106. * Wed Dec 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
  107. - initial build for Vine Linux
  108. * Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-2
  109. - Disable "make check" on PPC again.
  110. * Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-1
  111. - Update to 1.3
  112. - Don't need to BR pkgconfig because gnutls-devel now requires it properly.
  113. - Update license.
  114. - Run "make check" on PPC
  115. - Update patches so that they apply to 1.3
  116. - Update URLs
  117. * Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-13
  118. - ppp != ppc
  119. * Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-12
  120. - Don't run make check on PPC - tests failing.
  121. * Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-11
  122. - Add patch from Hans de Goede that fixes 64 bit issues
  123. - Re-enable "make check".
  124. - Remove tabs from specfile.
  125. * Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-10
  126. - Bump release and rebuild.
  127. * Wed Aug 2 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-6
  128. - Temporarily disable make check until problems with it can be figured out.
  129. * Thu Jul 27 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-5
  130. - Patch to use SHA1 hashing routines from libgcrypt rather than
  131. broken internal code. This means that we need to BR autoools
  132. to regenerate comfigure script and makefiles.
  133. * Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-4
  134. - Don't re-run autotools, fix rpath in a different way.
  135. * Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-3
  136. - Add a %check section.
  137. - Add BR for libtool.
  138. * Tue May 30 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-2
  139. - Add texinfo BR
  140. * Mon May 29 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-1
  141. - First version for Fedora Extras.